Windows Vista Forums

System Restore Is Missing?

  1. #1



    Member
    Join Date : Jan 2011
    Posts : 37
    Vista Home Premium 32bit
    Local Time: 03:44 PM

    System Restore Is Missing?

    Hi,
    HP Desktop with Vista Home Premium x32 with a ton of available HDD space and 4Gb RAM.

    Was about to install a piece of accounting software and wanted to do a restore point first. Clicked shortcut to System Restore and got the following error:
    "Class not registered (0x80040154)" and that was it. Couldn't get to System Restore.

    Rebooted.

    Tried again, didn't work. Went to Backup and Restore center where we saw a message to the effect of "there are no restore points available on this machine". That makes no sense since we had auto restore points turned on and it would create them daily and then at each windows update (automatic).

    Not sure how long ago this may have happened since it's been a little while since I went to install software and needed a restore point.

    I tried going to Start-Computer-Properties-System Protection but it just brings up a System Properties dialog with 4 tabs: Computer Name, Hardware, Advanced, Remote.

    If I'm not mistaken, that's not right.

    If you need logs or anything like that to help me, please provide explicit directions for attaining them since I am not THAT proficient but I'm good at following instructions.

    Thank you.

    <<Incidentally, this machine did not come with any disks. It only has a partition installed by HP. There is no hope of getting actual Windows disks from HP or from MS - I've tried from both.>>

      My System SpecsSystem Spec

  2.   


  3. #2
    richc46's Avatar

    BSOD Squad




    Join Date : Dec 2008
    Fairfield County, CT
    Posts : 19,798
    Windows 7 SP1 x64
    Local Time: 03:44 PM
    usa us connecticut

     

    Re: System Restore Is Missing?

    Welcome
    One of the first things that malware/virus will do is disable SR, to protect itself
    Make a full and updated scan with your anti virus
    Make a full and updated scan with malwarebytes, to start.

    If clean
    Go to services and make sure that volume shadow service is set to automatic

    Many times your software for maintenance etc deltes the points. Such software is not needed with Vista. If you have such software, please disable.

      My System SpecsSystem Spec

  4. #3



    Member
    Join Date : Jan 2011
    Posts : 37
    Vista Home Premium 32bit
    Local Time: 03:44 PM


      Thread Starter

    Re: System Restore Is Missing?

    Quote Originally Posted by richc46 View Post
    Welcome
    One of the first things that malware/virus will do is disable SR, to protect itself
    Make a full and updated scan with your anti virus
    Make a full and updated scan with malwarebytes, to start.

    If clean
    Go to services and make sure that volume shadow service is set to automatic

    Many times your software for maintenance etc deltes the points. Such software is not needed with Vista. If you have such software, please disable.
    Thanks. Installing Malwarebytes now. Will run and run AV.

    I found Services and the only thing there like what you mentioned is: Volume Shadow Copy. The status column is blank and the startup type is Manual. Log On As column shows Local System.

    I don't see a way to set the Volume Shadow Copy to automatic. I right clicked on it and clicked properties and everything is greyed out and there is no "set to automatic" button anyway.

    There is no maintenance software installed on the machine.

    Please let me know about the service and what I should do.
    Thanks.

    P.S.1 I just tried opening services using "run as admin" and it just ran it as normal. It did not ask for my admin pw.

    P.S.2 I already had MWB on the machine but it was out of date and wouldn't update. I checked their site and they recommended uninstall/install so I downloaded an uninstall program for it but after reboot. It doesn't look like it uninstalled. Just tried running the uninstaller "as admin" and it did the same thing as above - didn't ask for admin pw and now after rebooting, I see it did not uninstall MWB.

    Now what?
    <update> Logged into admin user and was able to remove MWB. Now installing new version.

    <update 2> Being actually logged into admin account (as opposed to trying to "run as admin") allowed me to get into services and turn Volume Shadow Copy to automatic and to restart it. I'm rebooting now to see if it stays that way. THEN I will install MWB.

    Last edited by bucks13; 23 Jun 2011 at 05:29 PM. Reason: updated info
      My System SpecsSystem Spec

  5. #4
    richc46's Avatar

    BSOD Squad




    Join Date : Dec 2008
    Fairfield County, CT
    Posts : 19,798
    Windows 7 SP1 x64
    Local Time: 03:44 PM
    usa us connecticut

     

    Re: System Restore Is Missing?

    LOL, you have the right name for the service. Switch to automatic.
    Try to uninstall using the free revo for 32 bit free trial for 64 bit.

      My System SpecsSystem Spec

  6. #5



    Member
    Join Date : Jan 2011
    Posts : 37
    Vista Home Premium 32bit
    Local Time: 03:44 PM


      Thread Starter

    Re: System Restore Is Missing?

    Rebooted and volume shadow copy service has started automatically. So that's a positive.

    MWB uninstalled and reinstalled and updated fine. Now running full scan.

    It's so great that we have these terabyte drives now <said sarcastically> because it just didn't take long enough to scan gigabyte drives in the past. I have no idea how long it will take to scan these drives but I'm sure it will be ridiculous.

      My System SpecsSystem Spec

  7. #6
    richc46's Avatar

    BSOD Squad




    Join Date : Dec 2008
    Fairfield County, CT
    Posts : 19,798
    Windows 7 SP1 x64
    Local Time: 03:44 PM
    usa us connecticut

     

    Re: System Restore Is Missing?

    Im using 10% of a 550gig and it takes me an hour with Security Essentials and 45 minutes with malwarebytes.

      My System SpecsSystem Spec

  8. #7
    ilikefree's Avatar

    Senior Member



    Join Date : Jan 2010
    New Zealand
    Posts : 2,555
    Vista Home Premium 32bit.SP2
    Local Time: 07:44 AM
    newzealand

     

    Re: System Restore Is Missing?

    Note:Some defraggers delete restore points as well.

      My System SpecsSystem Spec

  9. #8



    Member
    Join Date : Jan 2011
    Posts : 37
    Vista Home Premium 32bit
    Local Time: 03:44 PM


      Thread Starter

    Re: System Restore Is Missing?

    Quote Originally Posted by richc46 View Post
    Im using 10% of a 550gig and it takes me an hour with Security Essentials and 45 minutes with malwarebytes.
    Ugh. We have 300+gb on one drive and 200gb on the other.

    A side question for you about the infectious nature of malware...

    Let's say that after doing everything we need to do, we figure out that there is some type of malware on my Vista C drive. If I put another drive in the machine with a fresh install of Win7 for instance and then deactivated Vista on the C: but left it in the machine so that I could copy over files from the old infected drive onto the new one, would that be bad?

    Can one work with a drive that has malware in a way that doesn't spread it? We have everything backed up via Carbonite but if I needed to download hundreds of gigs of files that way it wouldn't be good. I'd much rather move files over via copy/paste and avoid any infected files. Is that possible?

    Thanks

      My System SpecsSystem Spec

  10. #9



    Member
    Join Date : Jan 2011
    Posts : 37
    Vista Home Premium 32bit
    Local Time: 03:44 PM


      Thread Starter

    Re: System Restore Is Missing?

    Quote Originally Posted by ilikefree View Post
    Note:Some defraggers delete restore points as well.
    Have never defragged this drive.

      My System SpecsSystem Spec

  11. #10
    richc46's Avatar

    BSOD Squad




    Join Date : Dec 2008
    Fairfield County, CT
    Posts : 19,798
    Windows 7 SP1 x64
    Local Time: 03:44 PM
    usa us connecticut

     

    Re: System Restore Is Missing?

    In the case of Malware/Virus etc. Always do a clean install which includes format of the drive with the infected OS.

    If you are 100% certain as to the date of the infection, you can do a system restore picking a date before the infection..

    Many do not know this but a restore point is protected from change, after it was created.

      My System SpecsSystem Spec

Page 1 of 6 123 ... LastLast

System Restore Is Missing?
Similar Threads
Thread Forum
System Restore Disk OS (C:) Error, Dell Dock missing, & ATI Catalyst Control Center Vista General
System Restore and Missing Links Vista performance & maintenance
System Restore is MISSING completely from my Vista Ultimate 32bit! General Discussion
System Restore points missing. Vista General
System Restore Checkpoints Missing Vista security