Windows Vista Forums

c&c generals - zero hour - help plz

  1. #1



    Newbie
    Join Date : Jan 2009
    Posts : 1
    x64
    Local Time: 06:06 PM

    c&c generals - zero hour - help plz

    hi, i have recently just bought a new pc, and fancied putting some old times classics on it like zero hour, however i have installed the game fine and can play and get online fine however i can;t connect to people very well, some times i get the odd connection here and there, but general it goes, connecting players > awaiting probe response > connection failed the only other think i noticed as well the start page where the menu is nothing is moving or no sound (normally u have that lil battle between usa and gla in the back ground)

    i am running the visa 64 bit on my new pc , and all my other c&c games run perfectly on the max setting (ra3 / tibern wars e.t.c) i have a bt home hub with the fire wall turned off, and i just use the windows firewall & a anti virus and fire wall called eset smart. but i never had a problem with any other games with it and its all allowed through. i have tried installing it and re installing and checked my settings to make sure there not blocking it.

    plz help

    Last edited by skunksmash; 17 Jan 2009 at 06:11 AM.
      My System SpecsSystem Spec

  2.   


  3. #2


    Repeat64 Guest

    Re: c&c generals - zero hour - help plz


    I'm running Zero Hour without a problem on Vista Ultimate x64 over here.
    I did have some problems with multiplayer where my Windows Firewall
    would block connections and hang the game for all players involved
    (oops, sorry). After I got the firewall sorted, it works like a charm. I
    did notice the into screen not showing an ongoing battle but a still
    instead, as well. Haven't found a way around that though....


    --
    Repeat64
    ------------------------------------------------------------------------
    Repeat64's Profile: http://forums.techarena.in/members/repeat64.htm
    View this thread: http://forums.techarena.in/windows-v...es/1105080.htm

    http://forums.techarena.in


      My System SpecsSystem Spec

  4. #3



    Newbie
    Join Date : Jan 2009
    Posts : 3
    Windows 7 x64
    Local Time: 07:06 PM


     

    Re: c&c generals - zero hour - help plz

    I also have the same issue. I'm Beta Testing Windows 7 64-Bit with this game and I get the same result you guys are getting; a dead screen in the background instead of the Battle that normally goes on in the background. Of coarse that also means that there is no battle sounds either. I am taking it upon myself to figure this out and I will post the solution at that time. The game plays great though so it really is no big deal.

    Regards,

    Rich

      My System SpecsSystem Spec

  5. #4



    Newbie
    Join Date : Jan 2009
    Posts : 3
    Windows 7 x64
    Local Time: 07:06 PM


     

    Re: c&c generals - zero hour - help plz

    Ok guys, I got it to work. So, here is everything I did.

    1. Go to your "C:\Users\{your name}\Documents\Command and Conquer Generals Zero Hour Data" folder and open options.ini. I set the following settings:

    AntiAliasing = 0
    DrawScrollAnchor =
    FirewallBehavior = 0
    GameSpyIPAddress = 192.168.0.1 (make sure you use your own IP)
    Gamma = 50
    IPAddress = 192.168.0.1 (make sure you use your own IP)
    IdealStaticGameLOD = High
    LanguageFilter = false
    MoveScrollAnchor = 0
    MusicVolume = 61
    Resolution = 800 600
    Retaliation = yes
    SFX3DVolume = 58
    SFXVolume = 53
    ScrollFactor = 60
    SendDelay = no
    StaticGameLOD = lOW
    UseAlternateMouse = no
    UseDoubleClickAttackMove = no
    VoiceVolume = 70

    This may or may not matter but do it anyway just to be sure.

    2. right click on the .exe file that launches the game (or the shortcut on your desktop), select "Properties", and set the following:

    -under the "Shortcut" tab set Run: Maximized
    -under the compatibility tab set Compatibility mode for "windows XP service pack 2" but make sure you click it and make the check mark in the box black, not grey.
    -then, after you do the step above, click "Run this program as administrator" and then click "Set these settings for all users" and then apply everything, ok, etc.

    The game should run now and the movie and sounds will play. Please let me know if you have trouble.

    Regards,

    Rich

      My System SpecsSystem Spec

  6. #5


    Repeat64 Guest

    Re: c&c generals - zero hour - help plz


    Your suggestion worked like a charm. I didn't touch the .ini file
    though.


    --
    Repeat64
    ------------------------------------------------------------------------
    Repeat64's Profile: http://forums.techarena.in/members/repeat64.htm
    View this thread: http://forums.techarena.in/windows-v...es/1105080.htm

    http://forums.techarena.in


      My System SpecsSystem Spec

  7. #6



    Newbie
    Join Date : Jan 2009
    Posts : 3
    Windows 7 x64
    Local Time: 07:06 PM


     

    Re: c&c generals - zero hour - help plz

    Cool!!! Glad to hear it Repeat64. So, anyone looking for the solution just needs to do step 2 and all is well.

    Regards,

    Richard

      My System SpecsSystem Spec


c&c generals - zero hour - help plz
Similar Threads
Thread Forum
command and conquer TFD generals ZH problem Gaming
Command & Conquer Generals Zero Hour - Works Great in Vista! Vista Games
c&c generals zero hour not working properly Gaming
C&C The first Decade Generals Zero Hour problem Vista x64 Gaming
Command & Conquer Generals problem Vista Games