Windows Vista Forums

Issues running games from various manufacturers

  1. #1


    Tim Elder Guest

    Issues running games from various manufacturers

    I am using Vista RTM and I am trying to run games such as Quake 4,
    Battlefield 2142, and Call of Duty 2, all of which are by different
    companies, and none of the will run. I get an error that tells me to insert
    the correct CD/DVD. I have upgraded the firmware on my drives and get the
    same issue. I know that they work because they were working under RC2. There
    is also nothing wrong with the drive or the CD's because they will play in
    other machines perfectly fine. What am I missing here?

      My System SpecsSystem Spec

  2. #2


    Colin Barnhorst Guest

    Re: Issues running games from various manufacturers

    Patches from the manufacturers. Anno 1701 ran on Vista x64 for me until
    rtm. Now that driver signing is enforced it won't run because the Copy
    Protection driver is unsigned. Civilization III complete ran also but now
    stops with a font missing error. Different issues to be sure. Probably due
    to workarounds being removed from the final code.

    "Tim Elder" <TimElder@discussions.microsoft.com> wrote in message
    news:40F0868D-0919-42B9-83D0-D5AFE527768D@microsoft.com...
    >I am using Vista RTM and I am trying to run games such as Quake 4,
    > Battlefield 2142, and Call of Duty 2, all of which are by different
    > companies, and none of the will run. I get an error that tells me to
    > insert
    > the correct CD/DVD. I have upgraded the firmware on my drives and get the
    > same issue. I know that they work because they were working under RC2.
    > There
    > is also nothing wrong with the drive or the CD's because they will play in
    > other machines perfectly fine. What am I missing here?



      My System SpecsSystem Spec

  3. #3


    Tim Elder Guest

    RE: Issues running games from various manufacturers

    I figured out what was wrong. I had UAC turned off. Once I uninstalled the
    games, turned UAC on and reinstalled the games everything worked fine. I was
    then able to go in and turn UAC off and everything still worked fine.

      My System SpecsSystem Spec


Issues running games from various manufacturers
Similar Threads
Thread Forum
Problem running games Vista General
Problem running games Vista Games
running old games Vista General
Running Games Designed for XP Vista Games
running games without disks. Vista General