Windows Vista Forums

Windows update causing 0xc0000142 program errors

  1. #1


    Johnny C Guest

    Windows update causing 0xc0000142 program errors

    I downloaded an update for Vista HP 64bit the other day - update KB915597 Def
    1.22.3649.0 - an update for Windows Defender

    When I rebooted I got the initialisation error 0xc0000142 Unable to
    initialise teh application on a lot of programmes - all office apps, WMP11.
    IE7 runs okay but that's about it. I don't have zonealarm or easyCD or
    anthing like that - the PC has mostly MS software on.

    I checked the KB and found one entry for Vista HP and 0xc0000142 and
    although it was a different problem (when windows was shutting down) it says

    "This problem occurs because of a timing issue between the Winlogon.exe
    process and the Atbroker.exe process. This timing issue causes Windows Vista
    to start the Atbroker.exe process on the wrong desktop. If the Atbroker.exe
    process cannot run on this desktop, you may receive the error message"

    I checked the AtBroker program and sure enough it had been created at the
    time when the Windows Update ran - in fact a lot of programmes had been
    updated but it seems to me that the problem with AtBroker was probably caused
    by the update

    I tried to uninstall the update; I can see that it's been installed when I
    check for updates, it's in the log, but when I bring up the list of updates
    to uninstall it's not there. I checked for hidden updates and it said there
    were none.

    How can I get my system back to the pre-update fully working condition?

    Thanks



      My System SpecsSystem Spec

  2.   


  3. #2



    Newbie
    Join Date : Jan 2008
    Posts : 2
    Vista Ultimate 64 bit
    Local Time: 06:10 PM


     

    Re: Windows update causing 0xc0000142 program errors

    Johnny, did you ever figure this out? I'm having the exact same problem... It's the MS apps that are not working and within those, I can still get my IE to work but only the 64 bit one working.

      My System SpecsSystem Spec

  4. #3


    Johnny C Guest

    Re: Windows update causing 0xc0000142 program errors

    I didn't but someone on Planet64 thinks they have. Try it, I didn't because I
    had re-sintalled Vista before I got this reply

    -------------------------------------------------------

    Even if no specific error has been recorded in system events log, trying to
    dig deeper and deeper in application crashes with appropriate monitoring
    tools, finally I've reached the solution: a Winsock corruption, maybe because
    of some kind of malware, and probably already removed from the system.

    So... no need to recover the entire OS, nor to fully reinstall: a simple
    command is just enough!!

    Close all of the running applications, open a command prompt session and
    type NETSH WINSOCK RESET

    You'll be asked for a urgent reboot... let's do it, and your system is fully
    functional once again.

    If this is not enough, and you're still having the same problem, you could
    also try to reset IP Stack with another command: NETSH INT IP RESET
    ---------------------------

    Good luck, let me know if it works

      My System SpecsSystem Spec

  5. #4



    Newbie
    Join Date : Dec 2009
    Malmö
    Posts : 1
    Windows 7 Ultimate 32bit
    Local Time: 01:10 AM
    sweden se skane

     

    Re: Windows update causing 0xc0000142 program errors

    Quote Originally Posted by Johnny C View Post
    I didn't but someone on Planet64 thinks they have. Try it, I didn't because I
    had re-sintalled Vista before I got this reply

    -------------------------------------------------------

    Even if no specific error has been recorded in system events log, trying to
    dig deeper and deeper in application crashes with appropriate monitoring
    tools, finally I've reached the solution: a Winsock corruption, maybe because
    of some kind of malware, and probably already removed from the system.

    So... no need to recover the entire OS, nor to fully reinstall: a simple
    command is just enough!!

    Close all of the running applications, open a command prompt session and
    type NETSH WINSOCK RESET

    You'll be asked for a urgent reboot... let's do it, and your system is fully
    functional once again.

    If this is not enough, and you're still having the same problem, you could
    also try to reset IP Stack with another command: NETSH INT IP RESET
    ---------------------------

    Good luck, let me know if it works
    Hello Johnny and Andy

    I have this problem on my Win7 laptop too, so it's not only related to Vista64.

    It is in fact a widely spread problem without a proper solution for Win7. I do have a few links to info on some solutions that might or might not work on Vista though:

    I’m not the only one with this problem and nobody have found a working solution for Windows 7 yet. I now request the collective wisdom of the blogworld to come up with a workaround for this.

    This error is hindering the start of any console-related programs . Not even cmd.exe will run! That means I can't run the fix you suggested above, Johnny.

    In my case I am trying to run gpg.exe of the GnuPG package for my Enigmail install in Mozilla Thunderbird. I have found two articles that I think are relevant, but I don’t feel confident enough to edit the registry in the way one of the “solutions” suggest and the other is a hotfix that isn’t made for Windows 7.

    These links point to the articles:
    Error message when you call the CreateProcess function to start a process of a console application by using an account other than the current logon account in Windows Server 2003: "The application failed to initialize properly (0xc0000142
    Unexpected behavior occurs when you run many processes on a computer that is running SQL Server

    All solutions suggested by Microsoft themselves for this issue on other OSs mention this file, Winsrv.dll, as the culprit. This reference can also be found in the kb/824422-article above, since that is listed in that particular registry value.

    I will not, ever, use System Restore to fix anything on my computer, so that is never a valid solution. I should be able to fix anything on a current system, with replacing files or editing system settings. There’s no telling what changes has been made since last restore point was saved and will be lost forever if I “go back”. So, please, don’t suggest using system restore. A full reinstall is a much safer way to go, but I’d rather not do that, again (I just installed Win7 to start using during the Christmas holidays).

    I’ve added my findings on several forums to see if I can get some help there:
    Does Anyone Know of a Fix for the 0xc0000142 Problem - Windows 7 Forums
    The application failed to initialize properly (0x0000142). Click OK to terminate the application.

    I added it on my twitter and my own blog too:
    Kim Nilsson (no_substitute) on Twitter
    http://no-substitute.com/

    Somewhere, someone, anyone should be able to come up with something that will work. Maybe someone can get their friend/relative who works at Microsoft to raise attention to the problem.

    Thank you in advance for any and all help you can give.
    /Kim

      My System SpecsSystem Spec


Windows update causing 0xc0000142 program errors
Similar Threads
Thread Forum
Call to WindowsInstaller object causing 80004005 errors VB Script
Event Logg Errors - Causing Computer Freeze Up General Discussion
Windows update KB905866 causing browser issues Windows Updates
explorer errors, program errors, no task manager Vista performance & maintenance
Windows program errors and blue screen Vista performance & maintenance