Windows Vista Forums

Diagnostics Policy Service won't start

  1. #1


    squire Guest

    Diagnostics Policy Service won't start

    I have a problem with Vista Home Premium (surprise!)

    I have a connection to a home wireless network, which works: 2 computers
    running XP can access it. Up until a couple of days ago mine was working too.
    Now everytime I open internet explorer v.7, it won't display the webpage.
    Network Diagnostics won't work because the Diagnostics Policy Service won't
    start (even after trying to manually start as administrator) and I get the
    msg: "Error 5: Access is denied" even though all users have full control and
    read permissions.

    I have also tried:
    * ringing Microsoft tech support: they can't help me
    * system restore: won't work or fails to complete restore
    * run the repair function through bios (the computer just goes back to
    startup with the same problem
    * uninstall the most recent update (KB940510). Strangely, it appear in the
    'update history' folder, but not in the 'installed updates' folder, so I
    can't uninstall it.
    * starting Windows Firewall or the DHCP client service - same problems

    Any ideas short of a complete re-install of vista? I'm beginning to suspect
    there's something wrong with one of the registry keys &/or system files, but
    I'm not computer literate enough to know how/what to change.

    Cheers

      My System SpecsSystem Spec

  2.   


  3. #2


    Mark L. Ferguson Guest

    Re: Diagnostics Policy Service won't start

    I'm sure there are several technical ways to address this security error,
    but perhaps the best way for you is to go at it wholesale. Unless you have
    spent a lot of time with Permissions so far, resetting to defaults may be a
    good solution for you. My thinking is, 'It worked before, so change it
    back".

    HOW TO Reset Security Settings Back to the Defaults:
    http://support.microsoft.com/default...b;en-us;313222

    If this diagnostic problem is just a side issue, you may have luck with IE
    pages by simply clearing the IE cache. IE, tools menu, "Delete Browsing
    History"
    --
    Was this helpful? Then click the "Yes" Ratings button. Voting helps the web
    interface.
    http://www.microsoft.com/wn3/locales....htm#RateAPost

    Mark L. Ferguson

    ..
    "squire" <squire@xxxxxx> wrote in message
    news:73650709-DD34-4D49-9816-450093B7B22B@xxxxxx

    >I have a problem with Vista Home Premium (surprise!)
    >
    > I have a connection to a home wireless network, which works: 2 computers
    > running XP can access it. Up until a couple of days ago mine was working
    > too.
    > Now everytime I open internet explorer v.7, it won't display the webpage.
    > Network Diagnostics won't work because the Diagnostics Policy Service
    > won't
    > start (even after trying to manually start as administrator) and I get the
    > msg: "Error 5: Access is denied" even though all users have full control
    > and
    > read permissions.
    >
    > I have also tried:
    > * ringing Microsoft tech support: they can't help me
    > * system restore: won't work or fails to complete restore
    > * run the repair function through bios (the computer just goes back to
    > startup with the same problem
    > * uninstall the most recent update (KB940510). Strangely, it appear in the
    > 'update history' folder, but not in the 'installed updates' folder, so I
    > can't uninstall it.
    > * starting Windows Firewall or the DHCP client service - same problems
    >
    > Any ideas short of a complete re-install of vista? I'm beginning to
    > suspect
    > there's something wrong with one of the registry keys &/or system files,
    > but
    > I'm not computer literate enough to know how/what to change.
    >
    > Cheers

      My System SpecsSystem Spec

  4. #3


    moabs_my_life Guest

    RE: Diagnostics Policy Service won't start

    squire
    I have the exact same problem word for word.
    mine started on march 8th. I'm starting to think this hos some thing to do
    with windows uptate. I can't do a repair and it won't start my wireless too.
    I hope someone figures this out.
    --
    moabs_my_life


    "squire" wrote:

    > I have a problem with Vista Home Premium (surprise!)
    >
    > I have a connection to a home wireless network, which works: 2 computers
    > running XP can access it. Up until a couple of days ago mine was working too.
    > Now everytime I open internet explorer v.7, it won't display the webpage.
    > Network Diagnostics won't work because the Diagnostics Policy Service won't
    > start (even after trying to manually start as administrator) and I get the
    > msg: "Error 5: Access is denied" even though all users have full control and
    > read permissions.
    >
    > I have also tried:
    > * ringing Microsoft tech support: they can't help me
    > * system restore: won't work or fails to complete restore
    > * run the repair function through bios (the computer just goes back to
    > startup with the same problem
    > * uninstall the most recent update (KB940510). Strangely, it appear in the
    > 'update history' folder, but not in the 'installed updates' folder, so I
    > can't uninstall it.
    > * starting Windows Firewall or the DHCP client service - same problems
    >
    > Any ideas short of a complete re-install of vista? I'm beginning to suspect
    > there's something wrong with one of the registry keys &/or system files, but
    > I'm not computer literate enough to know how/what to change.
    >
    > Cheers

      My System SpecsSystem Spec

  5. #4


    Mary Guest

    RE: Diagnostics Policy Service won't start

    I also have the exact same problem and also am connected wireless but with no
    internet connection, I have a suspision it is also a windows update that
    caused it, please someone help us resolve this.

    "squire" wrote:

    > I have a problem with Vista Home Premium (surprise!)
    >
    > I have a connection to a home wireless network, which works: 2 computers
    > running XP can access it. Up until a couple of days ago mine was working too.
    > Now everytime I open internet explorer v.7, it won't display the webpage.
    > Network Diagnostics won't work because the Diagnostics Policy Service won't
    > start (even after trying to manually start as administrator) and I get the
    > msg: "Error 5: Access is denied" even though all users have full control and
    > read permissions.
    >
    > I have also tried:
    > * ringing Microsoft tech support: they can't help me
    > * system restore: won't work or fails to complete restore
    > * run the repair function through bios (the computer just goes back to
    > startup with the same problem
    > * uninstall the most recent update (KB940510). Strangely, it appear in the
    > 'update history' folder, but not in the 'installed updates' folder, so I
    > can't uninstall it.
    > * starting Windows Firewall or the DHCP client service - same problems
    >
    > Any ideas short of a complete re-install of vista? I'm beginning to suspect
    > there's something wrong with one of the registry keys &/or system files, but
    > I'm not computer literate enough to know how/what to change.
    >
    > Cheers

      My System SpecsSystem Spec

  6. #5



    Newbie
    Join Date : Nov 2008
    Posts : 1
    Vista Home Premium 32bit
    Local Time: 05:38 AM


     

    Re: Diagnostics Policy Service won't start

    I have a solution that worked for me!


    Hopefully it will work for you!



    First, try a System Restore...don't worry, it won't touch your personal files..just the system settings.

    Go to Start, Control Panel.
    Type System Restore into the search box and chose the second option under System.



    It should be:

    Restore System Files and Settings from a Restore Point.



    Choose it and then pick a restore from before the problem started. If that doesn't work...like if a message comes up saying System Restore didn't complete properly, you need to try it again with a different approach.



    You may want to write these instructions down:



    1. Restart your computer.
    2. When it starts up again press F8 repeatedly before it hits the loading screen.
    3. Select the first option.
    4. Log in as your usual user (I am unsure what the Admin pass is)
    5. Select System Restore and select a date before the problem started.
    ~If you cannot see the system restore, move the main box out of the way.~
    6. Let is restore and hopefully the problem should be fixed.

    It feels good to be telling people how to fix it! It took me 5 days to work out the solution...and now, hopefully this solution will work for everyone!



    Oh....this is how I feel right now.....


    (Quote: KingRyan - Diagnostic Policy Service start, stops - TechNet Forums)

      My System SpecsSystem Spec

  7. #6



    Newbie
    Join Date : Aug 2009
    Posts : 1
    Windows 7 RC 7100
    Local Time: 11:38 PM


     

    Re: Diagnostics Policy Service won't start

    I had a slightly different problem; I could start Diagnostics Policy Service, but it would stop abruptly. The course of action that I took (which worked) was to disable the service (services.msc) and then restart the computer. My computer restarted with internet and then I could restart the DPS without any problem. However, this is on my family's desktop which I installed Windows 7 RC 32 bit on. Hopefully it will work for you.

      My System SpecsSystem Spec

  8. #7


    knth Guest

    Re: Diagnostics Policy Service won't start


    And here goes another one with exactly same story....

    Can't connect to the internet. DPS service wont run. Trying to start it
    manually only results in error 1114.

    Looking into other treads, others have been recommened to run a system
    restore.

    But,...
    I don't have a system restore point established.

    Help!!!

    PS
    My girlfried seems to recall that maybe she was interrupting some
    update... - back in mid-December, when this problem occurred out of
    nowhere. Anyhow, don't know how to undo thus online-update, since... -
    yeah, you guessed it, I cannot get online....


    --
    knth
    ------------------------------------------------------------------------
    knth's Profile: http://forums.techarena.in/members/170393.htm
    View this thread: http://forums.techarena.in/vista-help/926312.htm

    http://forums.techarena.in


      My System SpecsSystem Spec

  9. #8



    Newbie
    Join Date : Mar 2010
    Posts : 1
    vista home premium 32 bit
    Local Time: 11:38 PM


     

    Re: Diagnostics Policy Service won't start

    Johannes919's system restore method worked for me as well but only by logining in Safe Mode (the restarting and hitting F8 approach). I have no idea what happened to cause the sudden Diagnostics Policy Service problem though this particular HP laptop with Vista has been trouble lately and been rebuilt numerous times. I was on the verge of reinstalling Vista AGAIN but thankfully this system restore worked!

    Thanks!

      My System SpecsSystem Spec

  10. #9


    bdh48 Guest

    Re: Diagnostics Policy Service won't start


    I have done all these things except the last - which I couldn't as the
    device had a problem so it had no resources


    --
    bdh48
    ------------------------------------------------------------------------
    bdh48's Profile: http://forums.techarena.in/members/216337.htm
    View this thread: http://forums.techarena.in/vista-help/926312.htm

    http://forums.techarena.in


      My System SpecsSystem Spec


Diagnostics Policy Service won't start
Similar Threads
Thread Forum
Cannot start the Diagnostic Policy Service Vista performance & maintenance
"Dependency service or group failed to start" and unable to start Diagnostic Policy Service manually Vista General
Diagnostics Policy Service not running + wireless connection problem Vista networking & sharing
Diagnostics Policy Service not running + wireless connection probl Vista networking & sharing
Cannot start Diagnostic Policy Service Vista security