Windows Vista Forums

MSMQ unattended installation randomly fails with Vista 64 SP1 usin

  1. #1


    WB Guest

    MSMQ unattended installation randomly fails with Vista 64 SP1 usin

    We have ~200 systems in our test pool. We're using the following command and
    unattend file to install MSMQ in unattended mode for Vista 64:

    ocsetup.exe MSMQ-Server /unattendfile:"MSMQ_Vista64.xml"

    MSMQ_Vista64.xml:
    <?xml version="1.0"?>
    <unattend>
    <servicing>
    <package action="configure">
    <assemblyIdentity name="Microsoft-Windows-Foundation-Package"
    version="6.0.6000.16386" language="neutral" processorArchitecture="amd64"
    publicKeyToken="31bf3856ad364e35" versionScope="nonSxS"/>
    <selection name="MSMQ-Container" state="true"/>
    <selection name="MSMQ-Server" state="true"/>
    </package>
    </servicing>
    </unattend>

    This usually works fine, but on random systems it fails. I don't know
    if/where anything gets logged for the failure. ProcessExplorer shows ocsetup
    running with a PkgMrg child, but it's stuck (no activity). There is a
    TrustedInstaller process running, but it seems to run forever (I've let it
    run for over 30 minutes and it doesn't go away). I've also tried the
    following command, but no log ever appears:

    ocsetup.exe MSMQ-Server /log:"c:\msmq.log"

    This is only occurring on Vista 64 SP1 (I'll try Vista 64 with no SP next),
    and only on random systems.

    Any ideas?
    --
    Bill Baker

      My System SpecsSystem Spec

  2. #2


    WB Guest

    RE: MSMQ unattended installation randomly fails with Vista 64 SP1 usin

    Turns out that it does install, but it takes over 45 minutes!
    --
    Bill Baker


    "WB" wrote:

    > We have ~200 systems in our test pool. We're using the following command and
    > unattend file to install MSMQ in unattended mode for Vista 64:
    >
    > ocsetup.exe MSMQ-Server /unattendfile:"MSMQ_Vista64.xml"
    >
    > MSMQ_Vista64.xml:
    > <?xml version="1.0"?>
    > <unattend>
    > <servicing>
    > <package action="configure">
    > <assemblyIdentity name="Microsoft-Windows-Foundation-Package"
    > version="6.0.6000.16386" language="neutral" processorArchitecture="amd64"
    > publicKeyToken="31bf3856ad364e35" versionScope="nonSxS"/>
    > <selection name="MSMQ-Container" state="true"/>
    > <selection name="MSMQ-Server" state="true"/>
    > </package>
    > </servicing>
    > </unattend>
    >
    > This usually works fine, but on random systems it fails. I don't know
    > if/where anything gets logged for the failure. ProcessExplorer shows ocsetup
    > running with a PkgMrg child, but it's stuck (no activity). There is a
    > TrustedInstaller process running, but it seems to run forever (I've let it
    > run for over 30 minutes and it doesn't go away). I've also tried the
    > following command, but no log ever appears:
    >
    > ocsetup.exe MSMQ-Server /log:"c:\msmq.log"
    >
    > This is only occurring on Vista 64 SP1 (I'll try Vista 64 with no SP next),
    > and only on random systems.
    >
    > Any ideas?
    > --
    > Bill Baker



      My System SpecsSystem Spec


MSMQ unattended installation randomly fails with Vista 64 SP1 usin
Similar Threads
Thread Forum
unattended vista ulti x32 installation probs!!! Vista installation & setup
[MSMQ]Shell for basic opeartions with MSMQ ? PowerShell
Windows Vista unattended installation / regional settings Vista installation & setup
unattended installation over the network? Vista installation & setup
Unattended installation of MSMQ Vista installation & setup