1.    17 Jun 2009 #1
    Join Date : Jun 2009
    Posts : 2
    Vista x64
    Local Time: 08:52

    High CPU usage - svchost.exe, DcomLaunch and Plug & Play


    Hey guys,

    I'm running into a problem with my install of Vista Home Premium x64. The usual solutions I'm finding online aren't helping me very much, so I thought I'd post what I've done so far.

    Problem synopsis: Computer uses 40-60% of processor while idling with no startup programs. The bulk of this comes from svchost.exe; specifically, the one that's hosting DcomLaunch and Plug & Play.

    Attempted solutions: The first thing I found was this, which suggested it to be a sound problem. I attempted the fix listed there on all my available sound interfaces. No dice. I then tried uninstalling my Tascam 122-L since it's notoriously finicky with Vista. Again, no dice. I tried various combinations of suspending services, along with all startup programs, but wasn't able to find an acceptable setup which fixed the problem.

    I downloaded Process Explorer and looked into exactly which threads are using up my processor. The culprits are "RPCRT4.dll!NdrComplexArrayMarshall+0x610" and three other variants. As far as I can tell, it's a legitimate process, but it's malfunctioning in some way. Suspending these threads returns my processor to an idle of <5%.

    Any ideas on what could be causing this problem? I suppose I could suspend these threads on startup, but I haven't verified if it comes with a functionality cost.
      My System SpecsSystem Spec

  2.    17 Jun 2009 #2
    Join Date : Jun 2009
    Posts : 2
    Vista x64
    Local Time: 08:52


      Thread Starter

    Re: High CPU usage - svchost.exe, DcomLaunch and Plug & Play


    Oh, cool - I ended up finding a solution. Turned out, the issue was my ATI HDMI Audio drivers. Disabling those immediately fixed the issue.

    Thanks anyway!
      My System SpecsSystem Spec


Similar Threads
Thread Forum
DComLaunch and WmiPrvSE.exe, DComLaunch and WmiPrvSE.exe makes CPU running high
My laptop's, with Vista 64-bit business, CPU is running high constant. And when I analyzed this with ProcessExplorer I see that its the SvcHost...
Software
DCOMLAUNCH SVCHOST Plug & Play, Hi CPU Usage
I noticed every time I boot up I hear my computer fan speed up (as if the computer were working extra hard). When I check Task Mgr I notice SVCHOST...
Vista General
High CPU utilization with svchost.exe / dwm.exe
Been running Vista Enterprise for almost a year, with no issues. This problem just began last night. When booting my computer, I have about 1...
Vista performance & maintenance
svchost.exe and Sound + CPU usage...
Hello, in Front sorry for my English - so be patient with me. My Desktop had a funny spleen - it makes some Noise like 'ding dong dong ding'...
Vista performance & maintenance
High CPU SVCHOST
We have a high powered notebook and in the last few days it has been so un-responsive that it is un-usable. The system: -- System Information...
Vista performance & maintenance
svchost.exe memory usage
Hello, I have Windows Vista Ultimate 64-bit installed with all the important updates. My hardware is as follow: Intel Pentium D 2.8GHZ 2GB DDR2...
Vista performance & maintenance
100% Processor usage - svchost.exe
My machine runs with 100% processor used up by svchost.exe I have read other posts suggesting to disable Windows Update, but having done this, I...
Vista performance & maintenance

Our Sites
  • Ten Forums
  • Eight Forums
  • Seven Forums
  • PC Help Forum
  • Help Me Bake
  • Site Links
  • Contact Us
  • Privacy and Cookies
  • About Us
    Windows Vista Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 07:52.
    .