Windows Vista Forums

WebDAV support

  1. #1


    Join Date : Mar 2007
    Posts : 4
    Local Time: 18:29

    WebDAV support

    Hello, I have implemented a webdav server, and it's no problem to use it from Windows XP. With Windows Vista all connection attempts fail:

    - Internet Explorer: Open Page as Webfolder; result: error mesage offering me the normal page view
    - Windows Explorer: Add the webdav site as network resource; error message telling me that the folder is not correct
    - Word 2007: when entering the address of a folder (http://mwebdavserver/folder1/folder2/) Word just does HEAD and GET requests, and finally openes the GET response as document in word... no OPTION/PROPFIND request

    What I have done already, after reading different discussion boards:

    - set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters "BasicAuthLevel" to value 2 (see Error message when you open a Web site by using Basic authentication in Expression Web on a computer that is running Windows Vista: “The folder name is not valid”)

    - added support for requests to OPTIONS/PROPFIND requests to
    /
    /core/
    (normally my webdav application can be called with http://myserver/core/webdav/*)

    I am testing with Vista Business, and have Office Ultimate installed

    For me it seems like WebDAV would be 100% switched off at my client. How can I activate it?? If it helps, I can offer Fiddler logs for the Word test. Currently fiddler and my test server did not show me any requests for the Internet Explorer/Windows Explorer access tests. This was different at another Vista installation (Vista Ultimate), there I could see PROPFIND/OPTIONS requests, but finally it did not work there, too...

    I could use DriveOnWeb at Vista, it worked. But I would prefer to use Windows Explorer and Office as WebDAV clients, as it offers better support for the user (for example LOCK behavior, or storage of files).

    Kind Regards,
    Konstantin Breu

      My System SpecsSystem Spec

  2. #2


    Join Date : Mar 2007
    Posts : 4
    Local Time: 18:29


      Thread Starter
    I've done the test now also with Apache Tomcat webdav function (instead of my webdav server). It's 100% the same. It works when the client is running on Windows XP, it's not working with my vista clients. I'm now testing with Vista Ultimate and Vista Business (I have MSDN subscription). As I could not find any workarounds or solutions in this forum so far (I tested all what I've found, net use *,....), I will try to get into contact with Microsoft support. When I've got further information, I will post it here.

      My System SpecsSystem Spec

  3. #3


    Join Date : Jun 2007
    Posts : 1
    Local Time: 11:29


     

    WebFolder into Windows Vista

    Hi

    If you want to set up a web folder into Windows Vista, follow this link
    Access to your files with a Web Folder


    Thomas

      My System SpecsSystem Spec

WebDAV support

Similar Threads
Thread Forum
WebDAV (mini-redirector): double-click in an SSL-enabled WebDAV-folder to open an Office 2003 file does not work
Operating system: Vista Office: 2003 WebDAV client: Microsoft Vista Mini-Redirector 6.00.0xx WebDAV server: ...
Vista General
WebDAV for Vista x64
After downloading the update at Download details: Software Update for Web Folders (KB907306) I was able to successfully use WebDAV on my 32 bit...
Windows Updates
WebDAV Vista64
I am having trouble accessing WebDav from our 64bit Vista Business client PCs. I can access it fine in IE7, but adding a network location says...
Vista General
Vista and WebDAV
I am currntly running Vista with SP1. I can connect to my WebDAV folders but when I try to double click on a folder inside the Explorer window it...
Vista General
WEBDAV
I can't seem to access remote sites via WEBDAV from Vista. I have found the command to add a Network place -- but no matter what format or site...
Vista General
WebDav question
I've tried connecting to our WebDAV server as I had in XP through adding a network place, but after I enter the URL I get an error that states "the...
Vista General
WebDav
I just installed Windows Vista Business N. With my previous XP installation, I could easily connect to a https-webdav location using Add Network...
Vista General