Windows Vista Forums

External Hard Drive (USB MassStorage Device missing?)

  1. #11


    jw93 Guest

    RE: External Hard Drive (USB MassStorage Device missing?)

    I am having the same trouble with my WD external hard drive. It works great
    on my XP desktop. I recently bought a new laptop with Vista. I had to install
    drivers and updates several times for it to finally see my 1GB thumb drive.
    Then after all I had to manually direct the computer to the driver for the
    thumb drive. Every once in awhile it will see my external hard drive but more
    times than not it won't. Who knows if my Vista machine will see either my
    thumb drive or my WD drive next time I start it up.
    If anyone has any ideas on how to deal with this issue please let me know.

    "Kev50027" wrote:

    > I am having the same problem, It worked fine on XP, and even on Vista using
    > my laptop, but it cannot find any drivers (it shouldn't need any anyway) on
    > Vista Ultimate on my desktop. This is a serious issue, and either Microsoft
    > or Western Digital needs to fix it soon, because this is frankly absurd, and
    > I'm frustrated.
    >
    > I've tried contacting Western Digital, and they have not responded.
    >
    > "Lincoln 6 Echo" wrote:
    >
    > > Hi,
    > >
    > > I am trying to connect my Western Digital external hard drive over USB port
    > > and it seems vista cannot find the Usb MassStorage Device Driver
    > >
    > > Any thoughts? Even scanning my other partition with XP is not of use (it
    > > says file not found).
    > >
    > > I thought MS would include at least these trivial drivers???
    > >
    > > Petar
    > >


      My System SpecsSystem Spec

  2.   


  3. #12


    Don Guest

    Re: External Hard Drive (USB MassStorage Device missing?)

    jw93 wrote:
    > I am having the same trouble with my WD external hard drive. It works great
    > on my XP desktop. I recently bought a new laptop with Vista. I had to install
    > drivers and updates several times for it to finally see my 1GB thumb drive.
    > Then after all I had to manually direct the computer to the driver for the
    > thumb drive...


    Well, you may have more than one problem. The problem of not finding
    USB drivers sounds like your C:\windows\inf\INFCACHE.1 is corrupted and
    needs to be deleted. (You will need to edit its file permissions to
    give Full Control to the Users group before you can delete it.)

    If you are also seeing "...One of the devices attached to this computer
    has malfunctioned and Windows does not recognize it..." then the fix
    I gave you above may not work, but I'd like to know.


      My System SpecsSystem Spec

  4. #13


    jw93 Guest

    Re: External Hard Drive (USB MassStorage Device missing?)

    I deleted the INFCACHE.1 file and that didn't help. I don't want to do any
    drastic measures because it is reading my thumb drive and my printer,
    keyboard and mouse just fine. With my WD external hard drive I am still
    getting the window that says "...One of the devices attached to this computer
    has malfunctioned and Windows does not recognize it..." I am beyond knowing
    what to do. I tried going to the store where I bought the ext. hard drive and
    they don't know anything about the troubles Vista is having with reading USB
    devices. Thanks for you response and I really hope someone comes up with
    something soon.

    "Don" wrote:

    > jw93 wrote:
    > > I am having the same trouble with my WD external hard drive. It works great
    > > on my XP desktop. I recently bought a new laptop with Vista. I had to install
    > > drivers and updates several times for it to finally see my 1GB thumb drive.
    > > Then after all I had to manually direct the computer to the driver for the
    > > thumb drive...

    >
    > Well, you may have more than one problem. The problem of not finding
    > USB drivers sounds like your C:\windows\inf\INFCACHE.1 is corrupted and
    > needs to be deleted. (You will need to edit its file permissions to
    > give Full Control to the Users group before you can delete it.)
    >
    > If you are also seeing "...One of the devices attached to this computer
    > has malfunctioned and Windows does not recognize it..." then the fix
    > I gave you above may not work, but I'd like to know.
    >
    >


      My System SpecsSystem Spec

  5. #14


    marcrinnyc510 Guest

    RE: External Hard Drive (USB MassStorage Device missing?)

    has anyone gotten a fix for this yet? i'm having the same frustrating
    problem with vista and an external hard drive enclosure going thru a usb 2
    port. it actually worked the very first time then crashed. after rebooting
    nothing. first it says can't find the usb drivers then when i point it to
    the system directory it says loading but still fails, and the enclosure shows
    as not working in the device manager. not sure how to get this to work but
    i'm fairly certain it's a vista specific problem as i didn't have this
    problem with xp. any ideas would be appreciated. thanks.

    "Kev50027" wrote:

    > I fixed the issue by installing updated motherboard drivers, and I could find
    > and use the drive, then I restarted and got a BSOD (blue screen of death) and
    > perpetual re-starting before Vista even started.
    >
    > I did a repair install, then restarted and the same thing happened. I got
    > sick of it, and formatted and re-installed XP. I'm done with Vista for now,
    > until Nvidia releases some finalized drivers for my 8800 GTX, and motherboard
    > (nForce 680i). I'm really frustrated with Nvidia and Creative over driver
    > issues with Vista, it's really absurd.


      My System SpecsSystem Spec

  6. #15


    alx6 Guest

    Re: External Hard Drive (USB MassStorage Device missing?)


    Hi, useless message I know, but I have the same problem...

    Vista Ultimate OEM (all legit and paid for with hard earned money...),
    everything up to date... At first my external USB2 harddrive worked
    like a charm (it's a LaCie Brick) but now Vista always asks for
    drivers.

    Same problem with my IPod :/

    All work fine under XP or MacOSX...


    --
    alx6
    ------------------------------------------------------------------------
    alx6's Profile: http://forums.techarena.in/member.php?userid=27830
    View this thread: http://forums.techarena.in/showthread.php?t=591047

    http://forums.techarena.in


      My System SpecsSystem Spec

  7. #16


    alx6 Guest

    Re: External Hard Drive (USB MassStorage Device missing?)


    Hi again, replying to myself... Posting this in case people stumble on
    this thread while looking for information on this damn external USB
    drive / iPod problem with Vista...

    After trying everything listed here I found a more complete solution
    and it's now working 100%

    Turns out it *was* a corrupted driver database problem, but deleting
    the infamouse infcache file was not enough.

    I just unplugged all USB drives, deleted all the files mentionned in
    the link, rebooted, plugged again, when vista asked for drivers I
    pointed it to c:\windows\system32 and this time it worked! I only add
    to do it once per peripheral. The whole hardware process seemed faster
    and less sluggish too, I guess cleaning this driver database really
    helped. It didn't do a thing to my other otherwise functionning
    peripherals too, so it doesn't seem dangerous.

    Here's the link to the instructions on how to totally delete the driver
    database :

    http://forums.logitech.com/rss/messa...essage.id=3755


    If you're desesperate like I was, try it, it worked for me

    (also no need to boot on install CD to delete the files... just use the
    same method as explained for infcache : right click, properties,
    security, and change permissions so that user as total access)


    Enjoy Vista USB freedom!!!

    (yeah I'm really happy after spending hours rebooting...)

    HTH


    --
    alx6
    ------------------------------------------------------------------------
    alx6's Profile: http://forums.techarena.in/member.php?userid=27830
    View this thread: http://forums.techarena.in/showthread.php?t=591047

    http://forums.techarena.in


      My System SpecsSystem Spec

  8. #17


    JUICY LUCY and PIGLY FIGGLY Guest

    RE: External Hard Drive (USB MassStorage Device missing?)

    Ha! Ha! Ha! Ha! Ha! Ha!

    It's never going to see it until you go buy the Ultimate edition.

    The so called cheaper editions, (Home Premium, etc.) won't recognize a
    dynamic drive.

    Sure, their might not be anything in the documentation, or other usual
    information sources that will tell you this, (before you make your purchase).
    It's not only a fact, but a pretty well kept secret as evidenced by the fact
    that I've posted this information already and MS pulled it off the board.

    So, unless you're ready to drop some more bucks, you're SOL gringo.

    But hey, this is America, the greatest country in the world, for making a
    fast, dishonest buck (that is).

    It's called conservitive free enterprize and If you don't like it, you can
    leave and go to Iraq, or Cuba.

    Brought to you by . . . The Republicans and yes the beloved party of the
    working people . . . The lay me down and bend me over DEMOCRATS.



    "Lincoln 6 Echo" wrote:

    > Hi,
    >
    > I am trying to connect my Western Digital external hard drive over USB port
    > and it seems vista cannot find the Usb MassStorage Device Driver
    >
    > Any thoughts? Even scanning my other partition with XP is not of use (it
    > says file not found).
    >
    > I thought MS would include at least these trivial drivers???
    >
    > Petar
    >


      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12

External Hard Drive (USB MassStorage Device missing?)
Similar Threads
Thread Forum
External Hard Drive doesn't show up in "my computer" but does in "device manager" General Discussion
Complete PC Backup to external hard drive: share the drive? Vista General
External Hard Drive Goes Missing Vista hardware & devices
Converting my external USB FAT external hard drive to NFTS Vista hardware & devices
External DVD Drive / Hard Drive Vista Install Vista General