Windows Vista Forums

Error code 0x80070017

  1. #1


    Viv Guest

    Error code 0x80070017

    I am trying to install Vista Business, 32 bit, on my computer. The
    installation was successful using this DVD on my original MoBo but then I
    decided to flash the BIOS and destroyed it. I now have an MSI K9N SLI board
    with the latest BIOS, a 160Gb HDD as secondary master on the IDE cable and an
    8x MSI DVD RW as primary master and 1st boot device. There is 1024Mb of RAM
    and an AMD Athlon 64x2 Dual Core Processor 4800+.

    Installation starts successfully then when it gets to expanding files the
    first 1% takes about 15 minutes, the next 1% over 30 minutes and I get this
    message :-
    Windows cannot install required files. The file may be corrupt or missing.
    Make sure all files required for installation are available, and restart the
    installation. Error code 0x80070017

    There is no indication what file is missing, (and as installing from this
    DVD worked once I cannot believe that there are missing files).

    Can anyone advise what the problem is, and how to overcome it? All advice
    gratefully received.
    Viv

      My System SpecsSystem Spec

  2.   


  3. #2


    Richard G. Harper Guest

    Re: Error code 0x80070017

    Have you checked for damage to the DVD and/or cleaned the drive that reports
    the error condition?

    --
    Richard G. Harper [MVP Shell/User] rgharper@xxxxxx
    * NEW! Catch my blog ... http://msmvps.com/blogs/rgharper/
    * PLEASE post all messages and replies in the newsgroups
    * The Website - http://rgharper.mvps.org/
    * HELP us help YOU ... http://www.dts-l.org/goodpost.htm


    "Viv" <Viv@xxxxxx> wrote in message
    news:03A3ACFB-C00C-4C2C-A898-3878C3955AE2@xxxxxx

    >I am trying to install Vista Business, 32 bit, on my computer. The
    > installation was successful using this DVD on my original MoBo but then I
    > decided to flash the BIOS and destroyed it. I now have an MSI K9N SLI
    > board
    > with the latest BIOS, a 160Gb HDD as secondary master on the IDE cable and
    > an
    > 8x MSI DVD RW as primary master and 1st boot device. There is 1024Mb of
    > RAM
    > and an AMD Athlon 64x2 Dual Core Processor 4800+.
    >
    > Installation starts successfully then when it gets to expanding files the
    > first 1% takes about 15 minutes, the next 1% over 30 minutes and I get
    > this
    > message :-
    > Windows cannot install required files. The file may be corrupt or
    > missing.
    > Make sure all files required for installation are available, and restart
    > the
    > installation. Error code 0x80070017
    >
    > There is no indication what file is missing, (and as installing from this
    > DVD worked once I cannot believe that there are missing files).
    >
    > Can anyone advise what the problem is, and how to overcome it? All advice
    > gratefully received.
    > Viv

      My System SpecsSystem Spec

  4. #3


    Mike Hall - MVP Guest

    Re: Error code 0x80070017

    First, recable your DVD and hard drive, ensuring that the hard drive is
    master. Then run either Memtest 86, Windows Memory Diagnostic, or use the
    memory test in BIOS if there is one available.

    Also, set your BIOS to 'optimal' settings..

    --
    Mike Hall - MVP
    http://msmvps.com/blogs/mikehall/default.aspx
    Posting Productively.. http://www.dts-l.org/goodpost.htm



    "Viv" <Viv@xxxxxx> wrote in message
    news:03A3ACFB-C00C-4C2C-A898-3878C3955AE2@xxxxxx

    >I am trying to install Vista Business, 32 bit, on my computer. The
    > installation was successful using this DVD on my original MoBo but then I
    > decided to flash the BIOS and destroyed it. I now have an MSI K9N SLI
    > board
    > with the latest BIOS, a 160Gb HDD as secondary master on the IDE cable and
    > an
    > 8x MSI DVD RW as primary master and 1st boot device. There is 1024Mb of
    > RAM
    > and an AMD Athlon 64x2 Dual Core Processor 4800+.
    >
    > Installation starts successfully then when it gets to expanding files the
    > first 1% takes about 15 minutes, the next 1% over 30 minutes and I get
    > this
    > message :-
    > Windows cannot install required files. The file may be corrupt or
    > missing.
    > Make sure all files required for installation are available, and restart
    > the
    > installation. Error code 0x80070017
    >
    > There is no indication what file is missing, (and as installing from this
    > DVD worked once I cannot believe that there are missing files).
    >
    > Can anyone advise what the problem is, and how to overcome it? All advice
    > gratefully received.
    > Viv

      My System SpecsSystem Spec

  5. #4


    Viv Guest

    Re: Error code 0x80070017

    Thanks, Mike.

    I have changed the HDD to be master and the DVD to be slave, reset the BIOS
    to optimal settings, ensuring that the DVD is the first boot device.

    There does not seem to be a method to check the memory using BIOS so I tried
    the other options you mentioned. Neither the Windows Memory Diagnostic nor
    Memtest86 will run as they both give a message 'Bootmgr is missing'.

    However I decided to try the installation again and it seems to be working
    as expanding files is up to 85% and zipping through quite quickly. It looks
    as if changing the HDD to master has solved the problem.

    Viv



    "Mike Hall - MVP" wrote:

    > First, recable your DVD and hard drive, ensuring that the hard drive is
    > master. Then run either Memtest 86, Windows Memory Diagnostic, or use the
    > memory test in BIOS if there is one available.
    >
    > Also, set your BIOS to 'optimal' settings..
    >
    > --
    > Mike Hall - MVP
    > http://msmvps.com/blogs/mikehall/default.aspx
    > Posting Productively.. http://www.dts-l.org/goodpost.htm
    >
    >
    >
    > "Viv" <Viv@xxxxxx> wrote in message
    > news:03A3ACFB-C00C-4C2C-A898-3878C3955AE2@xxxxxx

    > >I am trying to install Vista Business, 32 bit, on my computer. The
    > > installation was successful using this DVD on my original MoBo but then I
    > > decided to flash the BIOS and destroyed it. I now have an MSI K9N SLI
    > > board
    > > with the latest BIOS, a 160Gb HDD as secondary master on the IDE cable and
    > > an
    > > 8x MSI DVD RW as primary master and 1st boot device. There is 1024Mb of
    > > RAM
    > > and an AMD Athlon 64x2 Dual Core Processor 4800+.
    > >
    > > Installation starts successfully then when it gets to expanding files the
    > > first 1% takes about 15 minutes, the next 1% over 30 minutes and I get
    > > this
    > > message :-
    > > Windows cannot install required files. The file may be corrupt or
    > > missing.
    > > Make sure all files required for installation are available, and restart
    > > the
    > > installation. Error code 0x80070017
    > >
    > > There is no indication what file is missing, (and as installing from this
    > > DVD worked once I cannot believe that there are missing files).
    > >
    > > Can anyone advise what the problem is, and how to overcome it? All advice
    > > gratefully received.
    > > Viv
    >
    >

      My System SpecsSystem Spec

  6. #5


    Viv Guest

    Re: Error code 0x80070017


    Thanks for the suggestion Richard. The DVD does not appear to be damaged
    and I do not have a drive cleaner but it looks as if Mike's suggestion has
    solved the problem.

    Viv


    "Richard G. Harper" wrote:

    > Have you checked for damage to the DVD and/or cleaned the drive that reports
    > the error condition?
    >
    > --
    > Richard G. Harper [MVP Shell/User] rgharper@xxxxxx
    > * NEW! Catch my blog ... http://msmvps.com/blogs/rgharper/
    > * PLEASE post all messages and replies in the newsgroups
    > * The Website - http://rgharper.mvps.org/
    > * HELP us help YOU ... http://www.dts-l.org/goodpost.htm
    >
    >
    > "Viv" <Viv@xxxxxx> wrote in message
    > news:03A3ACFB-C00C-4C2C-A898-3878C3955AE2@xxxxxx

    > >I am trying to install Vista Business, 32 bit, on my computer. The
    > > installation was successful using this DVD on my original MoBo but then I
    > > decided to flash the BIOS and destroyed it. I now have an MSI K9N SLI
    > > board
    > > with the latest BIOS, a 160Gb HDD as secondary master on the IDE cable and
    > > an
    > > 8x MSI DVD RW as primary master and 1st boot device. There is 1024Mb of
    > > RAM
    > > and an AMD Athlon 64x2 Dual Core Processor 4800+.
    > >
    > > Installation starts successfully then when it gets to expanding files the
    > > first 1% takes about 15 minutes, the next 1% over 30 minutes and I get
    > > this
    > > message :-
    > > Windows cannot install required files. The file may be corrupt or
    > > missing.
    > > Make sure all files required for installation are available, and restart
    > > the
    > > installation. Error code 0x80070017
    > >
    > > There is no indication what file is missing, (and as installing from this
    > > DVD worked once I cannot believe that there are missing files).
    > >
    > > Can anyone advise what the problem is, and how to overcome it? All advice
    > > gratefully received.
    > > Viv
    >

      My System SpecsSystem Spec

  7. #6



    Newbie
    Join Date : Feb 2009
    Posts : 2
    Windows Vista Ultimate
    Local Time: 12:07 PM


     

    Re: Error code 0x80070017

    Hello,
    I had the same problem, after running setup 5 times, using 3 different dvds, (which I had used before with no problems), and reading this post, I realised it was the dvd drive, Solution: take the hard drive out and install it in another machine, run setup completely, until you are in the desktop, take the hard drive out and put it back in the original machine, voila!!, you have windows!!, or replace the dvd drive..... as a quick solution, if you have another one....

      My System SpecsSystem Spec

  8. #7



    Newbie
    Join Date : Feb 2009
    Posts : 2
    Windows Vista Ultimate
    Local Time: 12:07 PM


     

    Re: Error code 0x80070017

    [/quote]
    Quote Originally Posted by oldwizard View Post
    Hello,
    I had the same problem, after running setup 5 times, using 3 different dvds, (which I had used before with no problems), and reading this post, I realised it was the dvd drive, Solution: take the hard drive out and install it in another machine, run setup completely, until you are in the desktop, take the hard drive out and put it back in the original machine, voila!!, you have windows!!, or replace the dvd drive..... as a quick solution, if you have another one....

      My System SpecsSystem Spec

  9. #8



    Newbie
    Join Date : Feb 2009
    Posts : 1
    32bit
    Local Time: 12:07 PM


     

    Re: Error code 0x80070017

    This site truly helped me upgrade to Windows 7 Beta. First I downloaded Beta on a dvd and tried installing it however did it not respond and kept on giving me the "Error code 0x80070017" I burned a second copy of the upgrade and it worked!! This upgrade is amazing!! For the first time since I have my laptop is it actually functioning with no problems. Its way faster and user friendly!! Dont give up. Keep on trying. Vista sucked but Microsoft came around and fixed it!! Thanks

      My System SpecsSystem Spec

  10. #9



    Newbie
    Join Date : Jun 2009
    Posts : 1
    Vista 32bit
    Local Time: 12:07 PM


     

    Re: Error code 0x80070017

    guys, i was having same problem with same error code...i just wanted to know how to make my HDD slave to master? i am kind of new to this

      My System SpecsSystem Spec


Error code 0x80070017
Similar Threads
Thread Forum
Installation error code 0x80070017 General Discussion
error code 0x80070017 with retail vista version Vista installation & setup
Error Code 0X80070017 Vista General
Error Code: 0x80070017 Vista installation & setup
Error 0x80070017 Vista installation & setup