Windows Vista Forums

USB messed up

  1. #1


    AlexT Guest

    USB messed up

    Folks

    I have somehow managed to mess up the USB "stack" in Vista.

    Everything else seems to work fine except that if I attach an USB
    device (no matter what device, even a simple hub will do) I get a "new
    device found" wizard, then a prompt for the install CD and finally an
    error to the effect that no valid driver was provided. This happens
    both for devices that do need a specific driver and devices that
    should work out of the box (such as generic USB keys).

    The irritating thing is that I am pretty sure that USB was working
    "out of the box", ie after the initial Vista setup. It's just that I
    have somehow managed to break it... Any idea before I reformat my
    HD ?!

    Any pointer / help / remark appreciated.

    Regards

    --alexT


      My System SpecsSystem Spec

  2. #2


    MICHAEL Guest

    Re: USB messed up

    http://support.microsoft.com/kb/925528

    This article discusses an update that resolves a variety of issues that occur with specific USB
    hardware devices and controllers in Windows Vista.


    "AlexT" <google@atc.ch> wrote in message
    news:1170705037.100932.164090@h3g2000cwc.googlegroups.com...
    > Folks
    >
    > I have somehow managed to mess up the USB "stack" in Vista.
    >
    > Everything else seems to work fine except that if I attach an USB
    > device (no matter what device, even a simple hub will do) I get a "new
    > device found" wizard, then a prompt for the install CD and finally an
    > error to the effect that no valid driver was provided. This happens
    > both for devices that do need a specific driver and devices that
    > should work out of the box (such as generic USB keys).
    >
    > The irritating thing is that I am pretty sure that USB was working
    > "out of the box", ie after the initial Vista setup. It's just that I
    > have somehow managed to break it... Any idea before I reformat my
    > HD ?!
    >
    > Any pointer / help / remark appreciated.
    >
    > Regards
    >
    > --alexT
    >



      My System SpecsSystem Spec

  3. #3


    Wegie Guest

    Re: USB messed up

    In article <1170705037.100932.164090@h3g2000cwc.googlegroups.com>,
    "AlexT" <google@atc.ch> wrote:

    > Folks
    >
    > I have somehow managed to mess up the USB "stack" in Vista.
    >
    > Everything else seems to work fine except that if I attach an USB
    > device (no matter what device, even a simple hub will do) I get a "new
    > device found" wizard, then a prompt for the install CD and finally an
    > error to the effect that no valid driver was provided. This happens
    > both for devices that do need a specific driver and devices that
    > should work out of the box (such as generic USB keys).
    >
    > The irritating thing is that I am pretty sure that USB was working
    > "out of the box", ie after the initial Vista setup. It's just that I
    > have somehow managed to break it... Any idea before I reformat my
    > HD ?!
    >
    > Any pointer / help / remark appreciated.


    this one is easy, get a Mac... and you'll never have to deal with
    messing up a USB Stack... too funny! why you even posted this is
    embarrassing!

    Get a Mac!

    --
    ..

      My System SpecsSystem Spec

  4. #4


    AlexT Guest

    Re: USB messed up

    On Feb 5, 11:06 pm, Wegie <h...@northere.com> wrote:
    > In article <1170705037.100932.164...@h3g2000cwc.googlegroups.com>,
    >
    >
    >
    >
    >
    > "AlexT" <goo...@atc.ch> wrote:
    > > Folks

    >
    > > I have somehow managed to mess up the USB "stack" in Vista.

    >
    > > Everything else seems to work fine except that if I attach an USB
    > > device (no matter what device, even a simple hub will do) I get a "new
    > > device found" wizard, then a prompt for the install CD and finally an
    > > error to the effect that no valid driver was provided. This happens
    > > both for devices that do need a specific driver and devices that
    > > should work out of the box (such as generic USB keys).

    >
    > > The irritating thing is that I am pretty sure that USB was working
    > > "out of the box", ie after the initial Vista setup. It's just that I
    > > have somehow managed to break it... Any idea before I reformat my
    > > HD ?!

    >
    > > Any pointer / help / remark appreciated.

    >
    > this one is easy, get a Mac... and you'll never have to deal with
    > messing up a USB Stack... too funny! why you even posted this is
    > embarrassing!
    >
    > Get a Mac!
    >
    > --
    > .- Hide quoted text -
    >
    > - Show quoted text -


    errr... this is happening on a dual boot Macbook... )


      My System SpecsSystem Spec

USB messed up

Similar Threads
Thread Forum
My computer is messed up.
The other day my compter was working just fine, until the battery died and it shut off. Ever since then, when I start it up McAfee doesn't open at...
General Discussion
I think I must have messed something up--Really bad. Help?
PLEASE HELP! A few months ago, I had that lovely virus called Antivirus 2010. It got so bad that eventually, whenever I turned my Intel Pentium...
General Discussion
icons are all messed up
hi guys i just signed up to post this question which is a real headache for me and ill try to be as detailed about it as i can be so here it goes. ...
General Discussion
Re: keyboard is messed up
Yeah, it dried over night and it works now. Thank goodness. I don't think I would have been able to dish out the money to get a new one. --...
Vista General
I messed up my display i think.
To start off I'd like to say i just came here because i have a problem. I have no clue where this belongs, so i just thought I'd set with the...
Vista General
i think i messed something up...
i can't seem to toggle back and forth between open windows, anymore. when i try to move from one program to another on the toolbar, the button for...
Vista General
Messed Up big time
Well I was playing with a registry fix tool on my home Vista machine and not thinking, I ran it on my work XP machine. Stupid me .... I have a few...
Vista General