Windows Vista Forums

Windows Movie Maker Vids - Audio but Black Screen

  1. #1



    Newbie
    Join Date : Apr 2009
    Posts : 2
    Vista Home Premium 32Bit
    Local Time: 02:50 AM

    Windows Movie Maker Vids - Audio but Black Screen

    Hey, I'm really confused and have googled for hours on a solution but I'm so tired I decided to just make a post on it hoping somebody would help me.

    I was asking one of my friends and they recommended this place for me, so here I am.


    The problem seems to be with my .avi videos when I put them on Windows Movie Maker. They're videos i spend days downloading for an AMV that I downloaded from Vuze recently, and they seem to work fine with anything apart from WMM and Windows DVD Maker (But windows DVD maker is a diff issue anyway that I wont address here).

    I've tried all sorts of things. I unticked "AVI DVD Compressor" because when I left it ticked, whenever I tried moving .AVI vids to the timeline it would just say "Windows Movie Maker Has Stopped Working" and close the whole thing. But unticking it got me atleast somewhere, but now I face yet another problem.

    When I try to play my videos (timelines or not), the audio only comes and the video is replaced with a transfixed black screen. I've tried all sorts of codecs and what not, and I'm totally lost now. I dont know what's wrong, but was wondering if anyone could help me.

    Im not too good with Compressors, Decompressors and Codecs and what have you, but given the instructions I'm good at following them, and hope to be able to make videos properly soon with my .avi videos.

    Oh, and I dont want to convert them because that just makes the quality worse, as .AVI videos give the best playback quality for me.

    Thanks alot,
    _xShafski

      My System SpecsSystem Spec

  2.   


  3. #2



    Vista Fan
    Join Date : Dec 2007
    Posts : 551
    Vista Home Premium 64bit
    Local Time: 07:50 PM
    australia au new south wales

     

    Re: Windows Movie Maker Vids - Audio but Black Screen

    Quote Originally Posted by Shafski View Post
    Hey, I'm really confused and have googled for hours on a solution but I'm so tired I decided to just make a post on it hoping somebody would help me.

    I was asking one of my friends and they recommended this place for me, so here I am.


    The problem seems to be with my .avi videos when I put them on Windows Movie Maker. They're videos i spend days downloading for an AMV that I downloaded from Vuze recently, and they seem to work fine with anything apart from WMM and Windows DVD Maker (But windows DVD maker is a diff issue anyway that I wont address here).

    I've tried all sorts of things. I unticked "AVI DVD Compressor" because when I left it ticked, whenever I tried moving .AVI vids to the timeline it would just say "Windows Movie Maker Has Stopped Working" and close the whole thing. But unticking it got me atleast somewhere, but now I face yet another problem.

    When I try to play my videos (timelines or not), the audio only comes and the video is replaced with a transfixed black screen. I've tried all sorts of codecs and what not, and I'm totally lost now. I dont know what's wrong, but was wondering if anyone could help me.

    Im not too good with Compressors, Decompressors and Codecs and what have you, but given the instructions I'm good at following them, and hope to be able to make videos properly soon with my .avi videos.

    Oh, and I dont want to convert them because that just makes the quality worse, as .AVI videos give the best playback quality for me.

    Thanks alot,
    _xShafski

    It sounds to me like you have symptoms of too many codecs installed. People tend to throw codec packs into PC's and hope that one of them will work....instead the codecs cause conflicts.

    .AVI is a container wrapper...it's an extension that can be given to any video compressed with any of the codecs in use today....so AVI can be any of the 800+ flavours.

    The trick is to find out which codec was used for the video you downloaded off the net... I'm not going to try and guess which it is but there are programs available to work it out.

    Once you have worked it out, install only the codec needed and everything should work.

      My System SpecsSystem Spec

  4. #3



    Newbie
    Join Date : Apr 2009
    Posts : 2
    Vista Home Premium 32Bit
    Local Time: 02:50 AM


      Thread Starter

    Re: Windows Movie Maker Vids - Audio but Black Screen

    Quote Originally Posted by Clevo View Post
    Quote Originally Posted by Shafski View Post
    Hey, I'm really confused and have googled for hours on a solution but I'm so tired I decided to just make a post on it hoping somebody would help me.

    I was asking one of my friends and they recommended this place for me, so here I am.


    The problem seems to be with my .avi videos when I put them on Windows Movie Maker. They're videos i spend days downloading for an AMV that I downloaded from Vuze recently, and they seem to work fine with anything apart from WMM and Windows DVD Maker (But windows DVD maker is a diff issue anyway that I wont address here).

    I've tried all sorts of things. I unticked "AVI DVD Compressor" because when I left it ticked, whenever I tried moving .AVI vids to the timeline it would just say "Windows Movie Maker Has Stopped Working" and close the whole thing. But unticking it got me atleast somewhere, but now I face yet another problem.

    When I try to play my videos (timelines or not), the audio only comes and the video is replaced with a transfixed black screen. I've tried all sorts of codecs and what not, and I'm totally lost now. I dont know what's wrong, but was wondering if anyone could help me.

    Im not too good with Compressors, Decompressors and Codecs and what have you, but given the instructions I'm good at following them, and hope to be able to make videos properly soon with my .avi videos.

    Oh, and I dont want to convert them because that just makes the quality worse, as .AVI videos give the best playback quality for me.

    Thanks alot,
    _xShafski

    It sounds to me like you have symptoms of too many codecs installed. People tend to throw codec packs into PC's and hope that one of them will work....instead the codecs cause conflicts.

    .AVI is a container wrapper...it's an extension that can be given to any video compressed with any of the codecs in use today....so AVI can be any of the 800+ flavours.

    The trick is to find out which codec was used for the video you downloaded off the net... I'm not going to try and guess which it is but there are programs available to work it out.

    Once you have worked it out, install only the codec needed and everything should work.


    Hm, are you sure? Because why will they play on windows media play but not WMM; isn't the same codecs used with both? Apart from AVI Decompressor which I unfiltered as stated before.

    My vid was downloaded from Azureus Vuze, a torrent downloaded, but im finding it hard to find which codec is right and I'm getting confused

    Anybody got any suggestions or help?

      My System SpecsSystem Spec

  5. #4



    Junior Member
    Join Date : Apr 2009
    Posts : 10
    Vista Home Premium x64
    Local Time: 04:50 AM


     

    Re: Windows Movie Maker Vids - Audio but Black Screen

    This is what i use for codec's. all most every movie on torrents sites uses one of these formats

    heres the links for dl.


    Mpeg-4 ~ http://www.koepi.info/Xvid-1.2.1-04122008.exe


    Divx ~ http://www.divx.com/downloads/divx

    ac3 ~ SourceForge.net: AC3Filter: Downloading ...

    Last edited by KoRnKoB; 29 Apr 2009 at 05:09 PM.
      My System SpecsSystem Spec

  6. #5


    Pingo Guest

    Re: Windows Movie Maker Vids - Audio but Black Screen


    i am having the same problem, BUT i _did_not_ download any codecs.
    heck, i don't even know what those are. anyhoo, none of my videos from
    my Flip Camcorder will show up on ANY movie maker. it's just a blank
    screen with just audio. help ppl!!!!!


    --
    Pingo
    ------------------------------------------------------------------------
    Pingo's Profile: http://forums.techarena.in/members/128466.htm
    View this thread: http://forums.techarena.in/vista-mus...eo/1169531.htm

    http://forums.techarena.in


      My System SpecsSystem Spec

  7. #6



    Vista Fan
    Join Date : Dec 2007
    Posts : 551
    Vista Home Premium 64bit
    Local Time: 07:50 PM
    australia au new south wales

     
    Quote Originally Posted by Shafski View Post
    Quote Originally Posted by Clevo View Post
    Quote Originally Posted by Shafski View Post
    Hey, I'm really confused and have googled for hours on a solution but I'm so tired I decided to just make a post on it hoping somebody would help me.

    I was asking one of my friends and they recommended this place for me, so here I am.


    The problem seems to be with my .avi videos when I put them on Windows Movie Maker. They're videos i spend days downloading for an AMV that I downloaded from Vuze recently, and they seem to work fine with anything apart from WMM and Windows DVD Maker (But windows DVD maker is a diff issue anyway that I wont address here).

    I've tried all sorts of things. I unticked "AVI DVD Compressor" because when I left it ticked, whenever I tried moving .AVI vids to the timeline it would just say "Windows Movie Maker Has Stopped Working" and close the whole thing. But unticking it got me atleast somewhere, but now I face yet another problem.

    When I try to play my videos (timelines or not), the audio only comes and the video is replaced with a transfixed black screen. I've tried all sorts of codecs and what not, and I'm totally lost now. I dont know what's wrong, but was wondering if anyone could help me.

    Im not too good with Compressors, Decompressors and Codecs and what have you, but given the instructions I'm good at following them, and hope to be able to make videos properly soon with my .avi videos.

    Oh, and I dont want to convert them because that just makes the quality worse, as .AVI videos give the best playback quality for me.

    Thanks alot,
    _xShafski

    It sounds to me like you have symptoms of too many codecs installed. People tend to throw codec packs into PC's and hope that one of them will work....instead the codecs cause conflicts.

    .AVI is a container wrapper...it's an extension that can be given to any video compressed with any of the codecs in use today....so AVI can be any of the 800+ flavours.

    The trick is to find out which codec was used for the video you downloaded off the net... I'm not going to try and guess which it is but there are programs available to work it out.

    Once you have worked it out, install only the codec needed and everything should work.


    Hm, are you sure? Because why will they play on windows media play but not WMM; isn't the same codecs used with both? Apart from AVI Decompressor which I unfiltered as stated before.

    My vid was downloaded from Azureus Vuze, a torrent downloaded, but im finding it hard to find which codec is right and I'm getting confused

    Anybody got any suggestions or help?
    One is a player and the other is an editor...different beasts.

    Even on my pro-sumer editor I occasionally come across similar situations...plays in WINDVD or WMC but put it in an editor and it won't play.

    Just to be on the safe side though make sure you have the latest MS DirectX (march 2009) installed....this might help

      My System SpecsSystem Spec

  8. #7
    whs's Avatar
    whs

    Senior Member




    Join Date : May 2008
    Germany/Florida
    Posts : 1,986
    Vista home premium 32bit
    Local Time: 10:50 AM
    germany us florida

     

    Re: Windows Movie Maker Vids - Audio but Black Screen

    I think the easiest would be to convert the video format to .wmv using the free Format Factory ( Format Factory - Free media file format converter ). Since .wmv is the "native" Vista format, you avoid all problems.

      My System SpecsSystem Spec

  9. #8


    Pingo Guest

    Re: Windows Movie Maker Vids - Audio but Black Screen

    whs;4586814 Wrote:
    I think the easiest would be to convert the video format to .wmv using
    the free Format Factory ( 'Format Factory - Free media file format
    converter' Since .wmv is the "native"
    Vista format, you avoid all problems.
    yeah but i tried using format factory and changing it to .wmv--does not
    work. well it worked for the first one but all the other ones? nope.

      My System SpecsSystem Spec

  10. #9


    Sai-Jackal Guest

    Re: Windows Movie Maker Vids - Audio but Black Screen

    I hope I'm not kicking around a dead topic here. But I am basically
    having the exact same problem.

    I had no codecs installed as my computer was brand new. The file
    imported without any problems, but try and play a clip and you get the
    audio but no picture. I did eventually download a "K-lite" codec pack
    which allowed me to play .avi on windows media player. But it didn't
    effect Windows movie maker at all.

    Is there another video editing program that anyone can recommend that
    will perhaps not have this problem?

      My System SpecsSystem Spec

  11. #10
    whs's Avatar
    whs

    Senior Member




    Join Date : May 2008
    Germany/Florida
    Posts : 1,986
    Vista home premium 32bit
    Local Time: 10:50 AM
    germany us florida

     

    Re: Windows Movie Maker Vids - Audio but Black Screen

    Quote Originally Posted by Sai-Jackal View Post
    I hope I'm not kicking around a dead topic here. But I am basically
    having the exact same problem.

    I had no codecs installed as my computer was brand new. The file
    imported without any problems, but try and play a clip and you get the
    audio but no picture. I did eventually download a "K-lite" codec pack
    which allowed me to play .avi on windows media player. But it didn't
    effect Windows movie maker at all.

    Is there another video editing program that anyone can recommend that
    will perhaps not have this problem?


    Windows Movie Maker works best with the .wmv filetype. The easiest is to use Format Factory ( Format Factory - Free media file format converter ) and convert your clips. Format Factory does a high quality job and it is free and easy to use.
    You should be aware that you have a considerable loss of quality when you edit with WMM. That is why I use Machete ( Lossless Video and Audio Editor (splitter,joiner) for AVI,FLV,WMV,WMA,ASF,MP3 files ) which sell for $19.95 (lifetime license). There the output is exactly like the input. You can try it for free for 2 weeks and see whether you like it.

      My System SpecsSystem Spec


Windows Movie Maker Vids - Audio but Black Screen
Similar Threads
Thread Forum
windows movie maker:black preview screen Vista music pictures video
Windows Movie Maker ~ Preview screen black Vista General
Windows Vista Movie Maker Video displaying black with no audio. Vista music pictures video
black preview screen on windows movie maker Vista music pictures video
Black display screen in windows movie maker...... Vista music pictures video