Windows Vista Forums

Lost internet connection.

  1. #1


    olyd Guest

    Lost internet connection.

    A couple of hours ago I lost my connection and thought it was caused by the
    ISP (this happens once in a while) but then I noticed that all programs and
    some games that try to connect to internet crashes sooner or later. Firefox
    is showing a blank page and crashes when I close it down, IE7 crashes when I
    hit F5 a few times and after the first crash I can't even get it to start up.
    World of Warcraft and BF2 reports there's problem with connecting or creating
    a socket. I'm writing this through a virtual machine with WinXP on the same
    system so the connection problem obviously isn't on the ISP side. Any ideas?

    PS
    I'm running Vista Ultimate x64

      My System SpecsSystem Spec

  2. #2


    rwbta Guest

    RE: Lost internet connection.

    I also have Vista Ultimate 64-bit and am having a similar problem. Vista
    basically forgets that is connected to my home network and the internet. It
    works for awhile then suddenly nothing. There are three computers on the
    network: Vista Home Premium, XP and Ultimate. Only Ultimate is failing to
    recognize (the previously recognized) network. It tells me to reset the
    router which I did but rarely helps. Also, even tho Ultimate can't access the
    network or internet, the other two computers can. So, I'm resetting the ADSL
    modem and router just to satisfy Ultimate and it doesn't seem to care. I'm
    heartbroken and frustrated.

    "olyd" wrote:

    > A couple of hours ago I lost my connection and thought it was caused by the
    > ISP (this happens once in a while) but then I noticed that all programs and
    > some games that try to connect to internet crashes sooner or later. Firefox
    > is showing a blank page and crashes when I close it down, IE7 crashes when I
    > hit F5 a few times and after the first crash I can't even get it to start up.
    > World of Warcraft and BF2 reports there's problem with connecting or creating
    > a socket. I'm writing this through a virtual machine with WinXP on the same
    > system so the connection problem obviously isn't on the ISP side. Any ideas?
    >
    > PS
    > I'm running Vista Ultimate x64


      My System SpecsSystem Spec

  3. #3


    olyd Guest

    RE: Lost internet connection.

    I fixed it by opening a command prompt as administrator and typing: netsh
    winsock reset After that I just rebooted and everything was back to normal.

    "rwbta" wrote:

    > I also have Vista Ultimate 64-bit and am having a similar problem. Vista
    > basically forgets that is connected to my home network and the internet. It
    > works for awhile then suddenly nothing. There are three computers on the
    > network: Vista Home Premium, XP and Ultimate. Only Ultimate is failing to
    > recognize (the previously recognized) network. It tells me to reset the
    > router which I did but rarely helps. Also, even tho Ultimate can't access the
    > network or internet, the other two computers can. So, I'm resetting the ADSL
    > modem and router just to satisfy Ultimate and it doesn't seem to care. I'm
    > heartbroken and frustrated.


      My System SpecsSystem Spec

  4. #4


    rwbta Guest

    RE: Lost internet connection.

    I am logged in on an adminstrator account. When I tried your suggestion, I
    was told I needed to be an administrator. Perhaps this is related to my
    problem.

    "olyd" wrote:

    > I fixed it by opening a command prompt as administrator and typing: netsh
    > winsock reset After that I just rebooted and everything was back to normal.
    >
    > "rwbta" wrote:
    >
    > > I also have Vista Ultimate 64-bit and am having a similar problem. Vista
    > > basically forgets that is connected to my home network and the internet. It
    > > works for awhile then suddenly nothing. There are three computers on the
    > > network: Vista Home Premium, XP and Ultimate. Only Ultimate is failing to
    > > recognize (the previously recognized) network. It tells me to reset the
    > > router which I did but rarely helps. Also, even tho Ultimate can't access the
    > > network or internet, the other two computers can. So, I'm resetting the ADSL
    > > modem and router just to satisfy Ultimate and it doesn't seem to care. I'm
    > > heartbroken and frustrated.


      My System SpecsSystem Spec

  5. #5


    Robert L [MVP - Networking] Guest

    Re: Lost internet connection.

    Thank you for the update.

    Bob Lin, MS-MVP, MCSE & CNE
    Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
    How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
    "olyd" <olyd@discussions.microsoft.com> wrote in message news:EF039CF2-93D3-4872-8472-EFAB7F6C3E90@microsoft.com...
    I fixed it by opening a command prompt as administrator and typing: netsh
    winsock reset After that I just rebooted and everything was back to normal.

    "rwbta" wrote:

    > I also have Vista Ultimate 64-bit and am having a similar problem. Vista
    > basically forgets that is connected to my home network and the internet. It
    > works for awhile then suddenly nothing. There are three computers on the
    > network: Vista Home Premium, XP and Ultimate. Only Ultimate is failing to
    > recognize (the previously recognized) network. It tells me to reset the
    > router which I did but rarely helps. Also, even tho Ultimate can't access the
    > network or internet, the other two computers can. So, I'm resetting the ADSL
    > modem and router just to satisfy Ultimate and it doesn't seem to care. I'm
    > heartbroken and frustrated.


      My System SpecsSystem Spec


Lost internet connection.
Similar Threads
Thread Forum
Solved Lost internet connection Network & Sharing
Lost connection to Internet Virtual PC
RE: Lost Internet Connection Vista General
Re: Lost Internet Connection Vista General
Lost internet connection. Vista General