Windows Vista Forums

Add Printer Not Working - Vista Home Premium

  1. #1


    Rick_Hugh Guest

    Add Printer Not Working - Vista Home Premium

    I have an Epson Stylus c84 Inkjet that, according to the Epson support page,
    should already have drivers in Vista (I should just be able to plug in the
    printer, Vista will see it and load the appropriate driver, etc). However,
    Vista cannot find the correct driver and asks for the original driver CD, to
    which I try anyway and it still does not work.
    I contacted Epson who suggested I try and use the Add Printer feature.
    However, upon trying this, an error came up as soon as I pressed the icon:
    "Windows Cannot Open Add Printer. Operation could not be completed (error
    0x000000c1)."
    I did not receive the original install disc from eMachines, and they have
    been aggravating when attempting to get service from them. Any ideas? Thanks

      My System SpecsSystem Spec

  2.   


  3. #2


    Bob Guest

    Re: Add Printer Not Working - Vista Home Premium

    Uninstall the printer.
    Go to the eMachines or the Epson website. Download and install the latest
    driver.
    Reinstall the printer.
    -------
    *Report back, please*

    "Rick_Hugh" <Rick_Hugh@xxxxxx> wrote in message
    news:2263F5DE-69AB-4F4D-8926-58D719A05E76@xxxxxx

    >I have an Epson Stylus c84 Inkjet that, according to the Epson support
    >page,
    > should already have drivers in Vista (I should just be able to plug in the
    > printer, Vista will see it and load the appropriate driver, etc). However,
    > Vista cannot find the correct driver and asks for the original driver CD,
    > to
    > which I try anyway and it still does not work.
    > I contacted Epson who suggested I try and use the Add Printer feature.
    > However, upon trying this, an error came up as soon as I pressed the icon:
    > "Windows Cannot Open Add Printer. Operation could not be completed (error
    > 0x000000c1)."
    > I did not receive the original install disc from eMachines, and they have
    > been aggravating when attempting to get service from them. Any ideas?
    > Thanks

      My System SpecsSystem Spec

  4. #3


    Rick_Hugh Guest

    Re: Add Printer Not Working - Vista Home Premium

    *Sigh* Ok....let me try this again:

    The driver for the printer is not the issue. Again, according to Epson.com,
    a compatible printer driver for my C84 should already be on Vista.

    The issue is: When I try to use the Add Printer option, I receive an error
    that says "Windows Cannot Open Add Printer. Operation could not be completed
    (error 0x000000c1)." Why is it doing this, and what can I do to correct it?


    "Bob" wrote:

    > Uninstall the printer.
    > Go to the eMachines or the Epson website. Download and install the latest
    > driver.
    > Reinstall the printer.
    > -------
    > *Report back, please*
    >
    > "Rick_Hugh" <Rick_Hugh@xxxxxx> wrote in message
    > news:2263F5DE-69AB-4F4D-8926-58D719A05E76@xxxxxx

    > >I have an Epson Stylus c84 Inkjet that, according to the Epson support
    > >page,
    > > should already have drivers in Vista (I should just be able to plug in the
    > > printer, Vista will see it and load the appropriate driver, etc). However,
    > > Vista cannot find the correct driver and asks for the original driver CD,
    > > to
    > > which I try anyway and it still does not work.
    > > I contacted Epson who suggested I try and use the Add Printer feature.
    > > However, upon trying this, an error came up as soon as I pressed the icon:
    > > "Windows Cannot Open Add Printer. Operation could not be completed (error
    > > 0x000000c1)."
    > > I did not receive the original install disc from eMachines, and they have
    > > been aggravating when attempting to get service from them. Any ideas?
    > > Thanks
    >
    >

      My System SpecsSystem Spec

  5. #4


    Bob Guest

    Re: Add Printer Not Working - Vista Home Premium


    In between sighs...Uninstall the printer. Go to the eMachines or the Epson
    website. Download and install the latest driver. Reinstall the printer
    whether or not you find a newer driver.

    Which firewall, anti-virus or security suite is installed?

    "Rick_Hugh" <RickHugh@xxxxxx> wrote in message
    news:755D0AA9-8F0A-4B2D-8607-62E64EB49057@xxxxxx

    > *Sigh* Ok....let me try this again:
    >
    > The driver for the printer is not the issue. Again, according to
    > Epson.com,
    > a compatible printer driver for my C84 should already be on Vista.
    >
    > The issue is: When I try to use the Add Printer option, I receive an error
    > that says "Windows Cannot Open Add Printer. Operation could not be
    > completed
    > (error 0x000000c1)." Why is it doing this, and what can I do to correct
    > it?
    >
    >
    > "Bob" wrote:
    >

    >> Uninstall the printer.
    >> Go to the eMachines or the Epson website. Download and install the latest
    >> driver.
    >> Reinstall the printer.
    >> -------
    >> *Report back, please*
    >>
    >> "Rick_Hugh" <Rick_Hugh@xxxxxx> wrote in message
    >> news:2263F5DE-69AB-4F4D-8926-58D719A05E76@xxxxxx

    >> >I have an Epson Stylus c84 Inkjet that, according to the Epson support
    >> >page,
    >> > should already have drivers in Vista (I should just be able to plug in
    >> > the
    >> > printer, Vista will see it and load the appropriate driver, etc).
    >> > However,
    >> > Vista cannot find the correct driver and asks for the original driver
    >> > CD,
    >> > to
    >> > which I try anyway and it still does not work.
    >> > I contacted Epson who suggested I try and use the Add Printer feature.
    >> > However, upon trying this, an error came up as soon as I pressed the
    >> > icon:
    >> > "Windows Cannot Open Add Printer. Operation could not be completed
    >> > (error
    >> > 0x000000c1)."
    >> > I did not receive the original install disc from eMachines, and they
    >> > have
    >> > been aggravating when attempting to get service from them. Any ideas?
    >> > Thanks
    >>
    >>

      My System SpecsSystem Spec

  6. #5


    Rick_Hugh Guest

    Re: Add Printer Not Working - Vista Home Premium

    Ok...so, not to sound sarcastic (because this question is going to come off
    as sounding that way), but how do I uninstall a printer that I haven't
    installed? Vista does not see it, the original driver disc doesn't work (when
    it's attempting to install the drivers, the install program just sits there),
    and the current drivers I found for my printer at Epson were for XP.

    If you're referring to the driver that Vista has for it, I don't know which
    driver Vista would use to install my printer.

    And again, why is my Add Printer command not working?

    "Bob" wrote:

    >
    > In between sighs...Uninstall the printer. Go to the eMachines or the Epson
    > website. Download and install the latest driver. Reinstall the printer
    > whether or not you find a newer driver.
    >
    > Which firewall, anti-virus or security suite is installed?
    >
    > "Rick_Hugh" <RickHugh@xxxxxx> wrote in message
    > news:755D0AA9-8F0A-4B2D-8607-62E64EB49057@xxxxxx

    > > *Sigh* Ok....let me try this again:
    > >
    > > The driver for the printer is not the issue. Again, according to
    > > Epson.com,
    > > a compatible printer driver for my C84 should already be on Vista.
    > >
    > > The issue is: When I try to use the Add Printer option, I receive an error
    > > that says "Windows Cannot Open Add Printer. Operation could not be
    > > completed
    > > (error 0x000000c1)." Why is it doing this, and what can I do to correct
    > > it?
    > >
    > >
    > > "Bob" wrote:
    > >

    > >> Uninstall the printer.
    > >> Go to the eMachines or the Epson website. Download and install the latest
    > >> driver.
    > >> Reinstall the printer.
    > >> -------
    > >> *Report back, please*
    > >>
    > >> "Rick_Hugh" <Rick_Hugh@xxxxxx> wrote in message
    > >> news:2263F5DE-69AB-4F4D-8926-58D719A05E76@xxxxxx
    > >> >I have an Epson Stylus c84 Inkjet that, according to the Epson support
    > >> >page,
    > >> > should already have drivers in Vista (I should just be able to plug in
    > >> > the
    > >> > printer, Vista will see it and load the appropriate driver, etc).
    > >> > However,
    > >> > Vista cannot find the correct driver and asks for the original driver
    > >> > CD,
    > >> > to
    > >> > which I try anyway and it still does not work.
    > >> > I contacted Epson who suggested I try and use the Add Printer feature.
    > >> > However, upon trying this, an error came up as soon as I pressed the
    > >> > icon:
    > >> > "Windows Cannot Open Add Printer. Operation could not be completed
    > >> > (error
    > >> > 0x000000c1)."
    > >> > I did not receive the original install disc from eMachines, and they
    > >> > have
    > >> > been aggravating when attempting to get service from them. Any ideas?
    > >> > Thanks
    > >>
    > >>
    >
    >

      My System SpecsSystem Spec

  7. #6


    Bob Guest

    Re: Add Printer Not Working - Vista Home Premium


    Do you see the printer in Device Manager?
    -------
    *Report back, please*


    "Rick_Hugh" <RickHugh@xxxxxx> wrote in message
    news:8DC28A95-9907-4ACA-ABC3-26BB3083A9EC@xxxxxx

    > Ok...so, not to sound sarcastic (because this question is going to come
    > off
    > as sounding that way), but how do I uninstall a printer that I haven't
    > installed? Vista does not see it, the original driver disc doesn't work
    > (when
    > it's attempting to install the drivers, the install program just sits
    > there),
    > and the current drivers I found for my printer at Epson were for XP.
    >
    > If you're referring to the driver that Vista has for it, I don't know
    > which
    > driver Vista would use to install my printer.
    >
    > And again, why is my Add Printer command not working?
    >
    > "Bob" wrote:
    >

    >>
    >> In between sighs...Uninstall the printer. Go to the eMachines or the
    >> Epson
    >> website. Download and install the latest driver. Reinstall the printer
    >> whether or not you find a newer driver.
    >>
    >> Which firewall, anti-virus or security suite is installed?
    >>
    >> "Rick_Hugh" <RickHugh@xxxxxx> wrote in message
    >> news:755D0AA9-8F0A-4B2D-8607-62E64EB49057@xxxxxx

    >> > *Sigh* Ok....let me try this again:
    >> >
    >> > The driver for the printer is not the issue. Again, according to
    >> > Epson.com,
    >> > a compatible printer driver for my C84 should already be on Vista.
    >> >
    >> > The issue is: When I try to use the Add Printer option, I receive an
    >> > error
    >> > that says "Windows Cannot Open Add Printer. Operation could not be
    >> > completed
    >> > (error 0x000000c1)." Why is it doing this, and what can I do to correct
    >> > it?
    >> >
    >> >
    >> > "Bob" wrote:
    >> >
    >> >> Uninstall the printer.
    >> >> Go to the eMachines or the Epson website. Download and install the
    >> >> latest
    >> >> driver.
    >> >> Reinstall the printer.
    >> >> -------
    >> >> *Report back, please*
    >> >>
    >> >> "Rick_Hugh" <Rick_Hugh@xxxxxx> wrote in message
    >> >> news:2263F5DE-69AB-4F4D-8926-58D719A05E76@xxxxxx
    >> >> >I have an Epson Stylus c84 Inkjet that, according to the Epson
    >> >> >support
    >> >> >page,
    >> >> > should already have drivers in Vista (I should just be able to plug
    >> >> > in
    >> >> > the
    >> >> > printer, Vista will see it and load the appropriate driver, etc).
    >> >> > However,
    >> >> > Vista cannot find the correct driver and asks for the original
    >> >> > driver
    >> >> > CD,
    >> >> > to
    >> >> > which I try anyway and it still does not work.
    >> >> > I contacted Epson who suggested I try and use the Add Printer
    >> >> > feature.
    >> >> > However, upon trying this, an error came up as soon as I pressed the
    >> >> > icon:
    >> >> > "Windows Cannot Open Add Printer. Operation could not be completed
    >> >> > (error
    >> >> > 0x000000c1)."
    >> >> > I did not receive the original install disc from eMachines, and they
    >> >> > have
    >> >> > been aggravating when attempting to get service from them. Any
    >> >> > ideas?
    >> >> > Thanks
    >> >>
    >> >>
    >>
    >>

      My System SpecsSystem Spec

  8. #7


    Rick_Hugh Guest

    Re: Add Printer Not Working - Vista Home Premium

    No.

    "Bob" wrote:

    >
    > Do you see the printer in Device Manager?
    > -------
    > *Report back, please*
    >
    >

      My System SpecsSystem Spec

  9. #8


    Alan Morris [MSFT] Guest

    Re: Add Printer Not Working - Vista Home Premium

    the error the UI component is reporting is bad exe format. This will also
    apply to dlls. Is sounds like x86 binaries are loading on x64 or x64
    binaries are loading on x86.

    E:\>winerror 0x000000c1
    193 ERROR_BAD_EXE_FORMAT <--> 0xc000000a STATUS_BAD_INITIAL_PC

    --
    Alan Morris
    Windows Printing Team
    Search the Microsoft Knowledge Base here:
    http://support.microsoft.com/search/?adv=1

    This posting is provided "AS IS" with no warranties, and confers no rights.

    "Rick_Hugh" <RickHugh@xxxxxx> wrote in message
    news:5CBBCF77-B4E1-4206-894A-1B40B3FFCC64@xxxxxx

    > No.
    >
    > "Bob" wrote:
    >

    >>
    >> Do you see the printer in Device Manager?
    >> -------
    >> *Report back, please*
    >>
    >>
    >


      My System SpecsSystem Spec

  10. #9


    Rick_Hugh Guest

    Re: Add Printer Not Working - Vista Home Premium

    Ok.....so, how would I got about attempting to correct this?

    Thanks

    "Alan Morris [MSFT]" wrote:

    > the error the UI component is reporting is bad exe format. This will also
    > apply to dlls. Is sounds like x86 binaries are loading on x64 or x64
    > binaries are loading on x86.
    >
    > E:\>winerror 0x000000c1
    > 193 ERROR_BAD_EXE_FORMAT <--> 0xc000000a STATUS_BAD_INITIAL_PC
    >
    > --
    > Alan Morris
    > Windows Printing Team
    > Search the Microsoft Knowledge Base here:
    > http://support.microsoft.com/search/?adv=1
    >
    > This posting is provided "AS IS" with no warranties, and confers no rights.
    >
    > "Rick_Hugh" <RickHugh@xxxxxx> wrote in message
    > news:5CBBCF77-B4E1-4206-894A-1B40B3FFCC64@xxxxxx

    > > No.
    > >
    > > "Bob" wrote:
    > >

    > >>
    > >> Do you see the printer in Device Manager?
    > >> -------
    > >> *Report back, please*
    > >>
    > >>
    > >
    >
    >
    >

      My System SpecsSystem Spec

  11. #10


    Alan Morris [MSFT] Guest

    Re: Add Printer Not Working - Vista Home Premium

    Unsure. I ran into a different issue but got this error. It turns out
    there was a x64 print driver living in the x86 driver location so when a new
    x86 client connected it failed with the 0x000000c1 error.


    Is this 64bit or 32bit?

    I assume you hit this error almost immediately

    the explorer process will load printui.dll which drives Add Printer

    You can launch Add Printer without explorer by opening a command prompt and
    typing

    rundll32 printui.dll,PrintUIEntry /il

    or for Network Add Printer
    rundll32 printui.dll,PrintUIEntry /ip

    Here is the list of files loaded and referenced by other files when starting
    Add Printer using rundll32. Any one could be the issue but I sorted the
    spooler components and placed them at the top of the list.

    spooler
    ModLoad: 71670000 716b2000 C:\Windows\system32\WINSPOOL.DRV
    ModLoad: 73860000 73938000 C:\Windows\system32\printui.dll
    ModLoad: 740a0000 740cc000 C:\Windows\system32\puiapi.dll
    ModLoad: 740f0000 74127000 C:\Windows\system32\ntprint.dll
    ModLoad: 70fd0000 70fe2000 C:\Windows\system32\tcpmonui.dll

    other stuff
    ModLoad: 004b0000 004be000 rundll32.exe
    ModLoad: 76f40000 77067000 ntdll.dll
    ModLoad: 76cb0000 76d8b000 C:\Windows\system32\kernel32.dll
    ModLoad: 77100000 7719d000 C:\Windows\system32\USER32.dll
    ModLoad: 770b0000 770fb000 C:\Windows\system32\GDI32.dll
    ModLoad: 76a90000 76b56000 C:\Windows\system32\ADVAPI32.dll
    ModLoad: 76970000 76a33000 C:\Windows\system32\RPCRT4.dll
    ModLoad: 759b0000 75a5a000 C:\Windows\system32\msvcrt.dll
    ModLoad: 76790000 767b9000 C:\Windows\system32\imagehlp.dll
    ModLoad: 72f30000 72f4e000 C:\Windows\system32\ShimEng.dll
    ModLoad: 755c0000 755ec000 C:\Windows\system32\apphelp.dll
    ModLoad: 6cbd0000 6cc58000 C:\Windows\AppPatch\AcLayers.DLL
    ModLoad: 75c70000 7677f000 C:\Windows\system32\SHELL32.dll
    ModLoad: 757c0000 75818000 C:\Windows\system32\SHLWAPI.dll
    ModLoad: 76b60000 76ca4000 C:\Windows\system32\ole32.dll
    ModLoad: 75af0000 75b7d000 C:\Windows\system32\OLEAUT32.dll
    ModLoad: 75670000 7568e000 C:\Windows\system32\USERENV.dll
    ModLoad: 75650000 75664000 C:\Windows\system32\Secur32.dll
    ModLoad: 751c0000 751d4000 C:\Windows\system32\MPR.dll
    ModLoad: 75c50000 75c6e000 C:\Windows\system32\IMM32.DLL
    ModLoad: 76820000 768e8000 C:\Windows\system32\MSCTF.dll
    ModLoad: 77070000 77079000 C:\Windows\system32\LPK.DLL
    ModLoad: 768f0000 7696d000 C:\Windows\system32\USP10.dll
    ModLoad: 743c0000 7455e000
    C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.6001.18000_none_5cdbaa5a083979cc\comctl32.dll
    ModLoad: 71a80000 71ab5000 C:\Windows\system32\ACTIVEDS.dll
    ModLoad: 71a40000 71a73000 C:\Windows\system32\adsldpc.dll
    ModLoad: 75340000 753b5000 C:\Windows\system32\NETAPI32.dll
    ModLoad: 75720000 75727000 C:\Windows\system32\PSAPI.DLL
    ModLoad: 767c0000 7680a000 C:\Windows\system32\WLDAP32.dll
    ModLoad: 77080000 770ad000 C:\Windows\system32\WS2_32.dll
    ModLoad: 76780000 76786000 C:\Windows\system32\NSI.dll
    ModLoad: 71a10000 71a3e000 C:\Windows\system32\credui.dll
    ModLoad: 74890000 748a4000 C:\Windows\system32\ATL.DLL
    ModLoad: 723e0000 723e8000 C:\Windows\system32\CFGMGR32.dll
    ModLoad: 75820000 759aa000 C:\Windows\system32\setupapi.DLL
    ModLoad: 73d00000 73d32000 C:\Windows\system32\WINMM.dll
    ModLoad: 739b0000 739e9000 C:\Windows\system32\OLEACC.dll
    ModLoad: 74930000 7493a000 C:\Windows\system32\WTSAPI32.dll
    ModLoad: 75080000 750ba000 C:\Windows\system32\slc.dll
    ModLoad: 74f40000 74f48000 C:\Windows\system32\VERSION.dll
    ModLoad: 75020000 75039000 C:\Windows\system32\IPHLPAPI.DLL
    ModLoad: 74fe0000 75015000 C:\Windows\system32\dhcpcsvc.DLL
    ModLoad: 75260000 7528c000 C:\Windows\system32\DNSAPI.dll
    ModLoad: 74fd0000 74fd7000 C:\Windows\system32\WINNSI.DLL
    ModLoad: 74fa0000 74fc1000 C:\Windows\system32\dhcpcsvc6.DLL
    ModLoad: 73940000 739a2000 C:\Windows\system32\mscms.dll
    ModLoad: 6cc80000 6cce9000 C:\Windows\system32\irprops.cpl
    ModLoad: 72a20000 72a27000 C:\Windows\system32\WSOCK32.dll
    ModLoad: 74940000 7494f000 C:\Windows\system32\nlaapi.dll
    ModLoad: 75200000 75218000 C:\Windows\system32\ntdsapi.dll
    ModLoad: 74db0000 74deb000 C:\Windows\system32\mswsock.dll
    ModLoad: 749e0000 749e5000 C:\Windows\System32\wshtcpip.dll
    ModLoad: 74f50000 74f55000 C:\Windows\System32\wship6.dll
    ModLoad: 74940000 7494f000 C:\Windows\system32\NLAapi.dll
    ModLoad: 73b20000 73b28000 C:\Windows\System32\winrnr.dll
    ModLoad: 73b30000 73b3f000 C:\Windows\system32\napinsp.dll
    ModLoad: 73a00000 73a06000 C:\Windows\system32\rasadhlp.dll
    ModLoad: 74f70000 74f77000 C:\Windows\system32\credssp.dll
    ModLoad: 750c0000 751b1000 C:\Windows\system32\CRYPT32.dll
    ModLoad: 75220000 75232000 C:\Windows\system32\MSASN1.dll
    ModLoad: 74bc0000 74c04000 C:\Windows\system32\schannel.dll
    ModLoad: 74e30000 74eac000 C:\Windows\system32\kerberos.dll
    ModLoad: 75290000 752a1000 C:\Windows\system32\cryptdll.dll
    ModLoad: 74eb0000 74ef5000 C:\Windows\system32\bcrypt.dll
    ModLoad: 75a60000 75ae4000 C:\Windows\system32\CLBCatQ.DLL
    ModLoad: 6fb60000 6fb74000 C:\Windows\system32\shgina.dll
    ModLoad: 75240000 75251000 C:\Windows\system32\SAMLIB.dll
    ModLoad: 73750000 737d5000
    C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_5.82.6001.18000_none_886786f450a74a05\comctl32.dll
    ModLoad: 74860000 74890000 C:\Windows\system32\DUser.dll
    ModLoad: 748b0000 748ef000 C:\Windows\system32\UxTheme.dll
    ModLoad: 74130000 7415f000 C:\Windows\system32\xmllite.dll
    ModLoad: 6cfd0000 6d0c9000 C:\Windows\system32\bthprops.cpl
    ModLoad: 74300000 7432d000 C:\Windows\system32\WINTRUST.dll





    --
    Alan Morris
    Windows Printing Team
    Search the Microsoft Knowledge Base here:
    http://support.microsoft.com/search/?adv=1

    This posting is provided "AS IS" with no warranties, and confers no rights.

    "Rick_Hugh" <RickHugh@xxxxxx> wrote in message
    news:B85F535F-3455-448F-A96B-10911B438A30@xxxxxx

    > Ok.....so, how would I got about attempting to correct this?
    >
    > Thanks
    >
    > "Alan Morris [MSFT]" wrote:
    >

    >> the error the UI component is reporting is bad exe format. This will
    >> also
    >> apply to dlls. Is sounds like x86 binaries are loading on x64 or x64
    >> binaries are loading on x86.
    >>
    >> E:\>winerror 0x000000c1
    >> 193 ERROR_BAD_EXE_FORMAT <--> 0xc000000a STATUS_BAD_INITIAL_PC
    >>
    >> --
    >> Alan Morris
    >> Windows Printing Team
    >> Search the Microsoft Knowledge Base here:
    >> http://support.microsoft.com/search/?adv=1
    >>
    >> This posting is provided "AS IS" with no warranties, and confers no
    >> rights.
    >>
    >> "Rick_Hugh" <RickHugh@xxxxxx> wrote in message
    >> news:5CBBCF77-B4E1-4206-894A-1B40B3FFCC64@xxxxxx

    >> > No.
    >> >
    >> > "Bob" wrote:
    >> >
    >> >>
    >> >> Do you see the printer in Device Manager?
    >> >> -------
    >> >> *Report back, please*
    >> >>
    >> >>
    >> >
    >>
    >>
    >>


      My System SpecsSystem Spec

Page 1 of 2 12 LastLast

Add Printer Not Working - Vista Home Premium
Similar Threads
Thread Forum
All in one printer 4 vista home premium Vista print fax & scan
Shared printer on XP Home inaccessibel from Vista Home Premium Vista networking & sharing
___%$# Shared printer on XP Home inaccessibel from Vista Home Premium Vista General
Printer sharing Vista Home Premium Vista print fax & scan
Vista Home Premium and XP Home printer sharing Vista networking & sharing