• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Access 2003 database inconsistent behaviour between Vista and XP

#1
Hi Groupies:

I'm not sure which newsgroup this question belongs to, sorry.

I have an Access 2003 database that was built on my Vista laptop. This
laptop also has Access 2007 installed but that version has not been used at
all to work with this database. My other computer has Windows XP and only
has Access 2003 installed.

In a couple of forms I have combo boxes that are used for searches. On my
Vista machine, these searches work fine, on my XP machine, the searches
work, but no data is "visible" when you push the down arrow. The list still
shows the correct number of rows as if the data was there, but no words show
up so you have to guess at what you are selecting.

The query behind the search boxes works fine and if you try the query by
itself all of the data shows up properly.

Not realizing what was going on, I spent a couple of hours trying to fix the
searches on my XP machine. I changed formatting, rebuilt the query,
everything I could think of. There was no way that I could make this thing
work on XP yet no problems on Vista.

What is the deal????
Any insight?......Anybody.......

--
Thanks for taking the time!

CJ
---------------------------------------------------------
Know thyself, know thy limits....know thy newsgroups!
 
M

Mark L. Ferguson

#2
The 'common controls' dll for that in Access 07 is probably different from
the one in 03. I would locate the comctl32.dll used by Access 07, and put it
in the path for your search dialog in XP (not system32, but the Access .exe
folder.) You might also accomplish this by installing the Runtime files for
Access 07.
Access 2007 Download: Access Runtime:
http://www.microsoft.com/downloads/...d9-9dc6-4b38-9fa6-2c745a175aed&DisplayLang=en
--
Was this helpful? Then click the Ratings button. Voting helps the web
interface.
http://www.microsoft.com/wn3/locales/help/help_en-us.htm#RateAPostAsAnswer
Mark L. Ferguson
..

"CJ" <private@xxxxxx> wrote in message
news:20B7A98C-2758-4183-B504-EE43AA9132EC@xxxxxx

> Hi Groupies:
>
> I'm not sure which newsgroup this question belongs to, sorry.
>
> I have an Access 2003 database that was built on my Vista laptop. This
> laptop also has Access 2007 installed but that version has not been used
> at all to work with this database. My other computer has Windows XP and
> only has Access 2003 installed.
>
> In a couple of forms I have combo boxes that are used for searches. On my
> Vista machine, these searches work fine, on my XP machine, the searches
> work, but no data is "visible" when you push the down arrow. The list
> still shows the correct number of rows as if the data was there, but no
> words show up so you have to guess at what you are selecting.
>
> The query behind the search boxes works fine and if you try the query by
> itself all of the data shows up properly.
>
> Not realizing what was going on, I spent a couple of hours trying to fix
> the searches on my XP machine. I changed formatting, rebuilt the query,
> everything I could think of. There was no way that I could make this thing
> work on XP yet no problems on Vista.
>
> What is the deal????
> Any insight?......Anybody.......
>
> --
> Thanks for taking the time!
>
> CJ
> ---------------------------------------------------------
> Know thyself, know thy limits....know thy newsgroups!
 
G

George Nicholson

#3
Check Microsoft/Office Update. I bet your XP machine has Office 2003 SP3
installed but not the hotfix (and your Vista machine has either both or
neither).

What you describe was a problem created by SP3 and subsequently "fixed".
http://support.microsoft.com/kb/945674/en-us

--
HTH,
George


"Mark L. Ferguson" <MarkLFerguson@xxxxxx> wrote in
message news:3A397E3E-0E8A-483C-8178-0313CC51363D@xxxxxx

> The 'common controls' dll for that in Access 07 is probably different from
> the one in 03. I would locate the comctl32.dll used by Access 07, and put
> it in the path for your search dialog in XP (not system32, but the Access
> .exe folder.) You might also accomplish this by installing the Runtime
> files for Access 07.
> Access 2007 Download: Access Runtime:
> http://www.microsoft.com/downloads/...d9-9dc6-4b38-9fa6-2c745a175aed&DisplayLang=en
> --
> Was this helpful? Then click the Ratings button. Voting helps the web
> interface.
> http://www.microsoft.com/wn3/locales/help/help_en-us.htm#RateAPostAsAnswer
> Mark L. Ferguson
> .
>
> "CJ" <private@xxxxxx> wrote in message
> news:20B7A98C-2758-4183-B504-EE43AA9132EC@xxxxxx

>> Hi Groupies:
>>
>> I'm not sure which newsgroup this question belongs to, sorry.
>>
>> I have an Access 2003 database that was built on my Vista laptop. This
>> laptop also has Access 2007 installed but that version has not been used
>> at all to work with this database. My other computer has Windows XP and
>> only has Access 2003 installed.
>>
>> In a couple of forms I have combo boxes that are used for searches. On my
>> Vista machine, these searches work fine, on my XP machine, the searches
>> work, but no data is "visible" when you push the down arrow. The list
>> still shows the correct number of rows as if the data was there, but no
>> words show up so you have to guess at what you are selecting.
>>
>> The query behind the search boxes works fine and if you try the query by
>> itself all of the data shows up properly.
>>
>> Not realizing what was going on, I spent a couple of hours trying to fix
>> the searches on my XP machine. I changed formatting, rebuilt the query,
>> everything I could think of. There was no way that I could make this
>> thing work on XP yet no problems on Vista.
>>
>> What is the deal????
>> Any insight?......Anybody.......
>>
>> --
>> Thanks for taking the time!
>>
>> CJ
>> ---------------------------------------------------------
>> Know thyself, know thy limits....know thy newsgroups!
>
 
#4
Fantastic, that was it!

I had SP3 on both machines but neither had the HotFix. I don't have updates
auto installed but I don't recall seeing anything about this fix from MS.
Or, there may have been so many that I quit paying attention to them.

Have a great weekend.
--
Thanks for taking the time!

CJ
---------------------------------------------------------
Know thyself, know thy limits....know thy newsgroups!

"George Nicholson" <GeorgeNJunk@xxxxxx> wrote in message
news:u8qLubfsIHA.5872@xxxxxx

>
> Check Microsoft/Office Update. I bet your XP machine has Office 2003 SP3
> installed but not the hotfix (and your Vista machine has either both or
> neither).
>
> What you describe was a problem created by SP3 and subsequently "fixed".
> http://support.microsoft.com/kb/945674/en-us
>
> --
> HTH,
> George
>
>
> "Mark L. Ferguson" <MarkLFerguson@xxxxxx> wrote in
> message news:3A397E3E-0E8A-483C-8178-0313CC51363D@xxxxxx

>> The 'common controls' dll for that in Access 07 is probably different
>> from the one in 03. I would locate the comctl32.dll used by Access 07,
>> and put it in the path for your search dialog in XP (not system32, but
>> the Access .exe folder.) You might also accomplish this by installing the
>> Runtime files for Access 07.
>> Access 2007 Download: Access Runtime:
>> http://www.microsoft.com/downloads/...d9-9dc6-4b38-9fa6-2c745a175aed&DisplayLang=en
>> --
>> Was this helpful? Then click the Ratings button. Voting helps the web
>> interface.
>> http://www.microsoft.com/wn3/locales/help/help_en-us.htm#RateAPostAsAnswer
>> Mark L. Ferguson
>> .
>>
>> "CJ" <private@xxxxxx> wrote in message
>> news:20B7A98C-2758-4183-B504-EE43AA9132EC@xxxxxx

>>> Hi Groupies:
>>>
>>> I'm not sure which newsgroup this question belongs to, sorry.
>>>
>>> I have an Access 2003 database that was built on my Vista laptop. This
>>> laptop also has Access 2007 installed but that version has not been used
>>> at all to work with this database. My other computer has Windows XP and
>>> only has Access 2003 installed.
>>>
>>> In a couple of forms I have combo boxes that are used for searches. On
>>> my Vista machine, these searches work fine, on my XP machine, the
>>> searches work, but no data is "visible" when you push the down arrow.
>>> The list still shows the correct number of rows as if the data was
>>> there, but no words show up so you have to guess at what you are
>>> selecting.
>>>
>>> The query behind the search boxes works fine and if you try the query by
>>> itself all of the data shows up properly.
>>>
>>> Not realizing what was going on, I spent a couple of hours trying to fix
>>> the searches on my XP machine. I changed formatting, rebuilt the query,
>>> everything I could think of. There was no way that I could make this
>>> thing work on XP yet no problems on Vista.
>>>
>>> What is the deal????
>>> Any insight?......Anybody.......
>>>
>>> --
>>> Thanks for taking the time!
>>>
>>> CJ
>>> ---------------------------------------------------------
>>> Know thyself, know thy limits....know thy newsgroups!
>>
>
>
 
P

pcbins

#5
Re: Access 2003 database inconsistent behaviour between Vista and

I need this hotfix also. I have downloaded it and extracted the files. Now
what? How do i install this hotfix?

"CJ" wrote:

> Fantastic, that was it!
>
> I had SP3 on both machines but neither had the HotFix. I don't have updates
> auto installed but I don't recall seeing anything about this fix from MS.
> Or, there may have been so many that I quit paying attention to them.
>
> Have a great weekend.
> --
> Thanks for taking the time!
>
> CJ
> ---------------------------------------------------------
> Know thyself, know thy limits....know thy newsgroups!
>
> "George Nicholson" <GeorgeNJunk@xxxxxx> wrote in message
> news:u8qLubfsIHA.5872@xxxxxx

> >
> > Check Microsoft/Office Update. I bet your XP machine has Office 2003 SP3
> > installed but not the hotfix (and your Vista machine has either both or
> > neither).
> >
> > What you describe was a problem created by SP3 and subsequently "fixed".
> > http://support.microsoft.com/kb/945674/en-us
> >
> > --
> > HTH,
> > George
> >
> >
> > "Mark L. Ferguson" <MarkLFerguson@xxxxxx> wrote in
> > message news:3A397E3E-0E8A-483C-8178-0313CC51363D@xxxxxx

> >> The 'common controls' dll for that in Access 07 is probably different
> >> from the one in 03. I would locate the comctl32.dll used by Access 07,
> >> and put it in the path for your search dialog in XP (not system32, but
> >> the Access .exe folder.) You might also accomplish this by installing the
> >> Runtime files for Access 07.
> >> Access 2007 Download: Access Runtime:
> >> http://www.microsoft.com/downloads/...d9-9dc6-4b38-9fa6-2c745a175aed&DisplayLang=en
> >> --
> >> Was this helpful? Then click the Ratings button. Voting helps the web
> >> interface.
> >> http://www.microsoft.com/wn3/locales/help/help_en-us.htm#RateAPostAsAnswer
> >> Mark L. Ferguson
> >> .
> >>
> >> "CJ" <private@xxxxxx> wrote in message
> >> news:20B7A98C-2758-4183-B504-EE43AA9132EC@xxxxxx
> >>> Hi Groupies:
> >>>
> >>> I'm not sure which newsgroup this question belongs to, sorry.
> >>>
> >>> I have an Access 2003 database that was built on my Vista laptop. This
> >>> laptop also has Access 2007 installed but that version has not been used
> >>> at all to work with this database. My other computer has Windows XP and
> >>> only has Access 2003 installed.
> >>>
> >>> In a couple of forms I have combo boxes that are used for searches. On
> >>> my Vista machine, these searches work fine, on my XP machine, the
> >>> searches work, but no data is "visible" when you push the down arrow.
> >>> The list still shows the correct number of rows as if the data was
> >>> there, but no words show up so you have to guess at what you are
> >>> selecting.
> >>>
> >>> The query behind the search boxes works fine and if you try the query by
> >>> itself all of the data shows up properly.
> >>>
> >>> Not realizing what was going on, I spent a couple of hours trying to fix
> >>> the searches on my XP machine. I changed formatting, rebuilt the query,
> >>> everything I could think of. There was no way that I could make this
> >>> thing work on XP yet no problems on Vista.
> >>>
> >>> What is the deal????
> >>> Any insight?......Anybody.......
> >>>
> >>> --
> >>> Thanks for taking the time!
> >>>
> >>> CJ
> >>> ---------------------------------------------------------
> >>> Know thyself, know thy limits....know thy newsgroups!
> >>
> >
> >
>
 
B

Bob Larson

#6
Re: Access 2003 database inconsistent behaviour between Vista and

It should be an exe file which you just run.

--

Thanks,

Bob Larson
Access MVP
Administrator, Access World Forums
Utter Access VIP

Free Access Tutorials and Resources: http://www.btabdevelopment.com


"pcbins" <pcbins@xxxxxx> wrote in message
news:75E2F678-47ED-4423-A17F-28E44AD2DCB8@xxxxxx

>I need this hotfix also. I have downloaded it and extracted the files. Now
> what? How do i install this hotfix?
>
> "CJ" wrote:
>

>> Fantastic, that was it!
>>
>> I had SP3 on both machines but neither had the HotFix. I don't have
>> updates
>> auto installed but I don't recall seeing anything about this fix from MS.
>> Or, there may have been so many that I quit paying attention to them.
>>
>> Have a great weekend.
>> --
>> Thanks for taking the time!
>>
>> CJ
>> ---------------------------------------------------------
>> Know thyself, know thy limits....know thy newsgroups!
>>
>> "George Nicholson" <GeorgeNJunk@xxxxxx> wrote in message
>> news:u8qLubfsIHA.5872@xxxxxx

>> >
>> > Check Microsoft/Office Update. I bet your XP machine has Office 2003
>> > SP3
>> > installed but not the hotfix (and your Vista machine has either both or
>> > neither).
>> >
>> > What you describe was a problem created by SP3 and subsequently
>> > "fixed".
>> > http://support.microsoft.com/kb/945674/en-us
>> >
>> > --
>> > HTH,
>> > George
>> >
>> >
>> > "Mark L. Ferguson" <MarkLFerguson@xxxxxx> wrote in
>> > message news:3A397E3E-0E8A-483C-8178-0313CC51363D@xxxxxx
>> >> The 'common controls' dll for that in Access 07 is probably different
>> >> from the one in 03. I would locate the comctl32.dll used by Access 07,
>> >> and put it in the path for your search dialog in XP (not system32, but
>> >> the Access .exe folder.) You might also accomplish this by installing
>> >> the
>> >> Runtime files for Access 07.
>> >> Access 2007 Download: Access Runtime:
>> >> http://www.microsoft.com/downloads/...d9-9dc6-4b38-9fa6-2c745a175aed&DisplayLang=en
>> >> --
>> >> Was this helpful? Then click the Ratings button. Voting helps the web
>> >> interface.
>> >> http://www.microsoft.com/wn3/locales/help/help_en-us.htm#RateAPostAsAnswer
>> >> Mark L. Ferguson
>> >> .
>> >>
>> >> "CJ" <private@xxxxxx> wrote in message
>> >> news:20B7A98C-2758-4183-B504-EE43AA9132EC@xxxxxx
>> >>> Hi Groupies:
>> >>>
>> >>> I'm not sure which newsgroup this question belongs to, sorry.
>> >>>
>> >>> I have an Access 2003 database that was built on my Vista laptop.
>> >>> This
>> >>> laptop also has Access 2007 installed but that version has not been
>> >>> used
>> >>> at all to work with this database. My other computer has Windows XP
>> >>> and
>> >>> only has Access 2003 installed.
>> >>>
>> >>> In a couple of forms I have combo boxes that are used for searches.
>> >>> On
>> >>> my Vista machine, these searches work fine, on my XP machine, the
>> >>> searches work, but no data is "visible" when you push the down arrow.
>> >>> The list still shows the correct number of rows as if the data was
>> >>> there, but no words show up so you have to guess at what you are
>> >>> selecting.
>> >>>
>> >>> The query behind the search boxes works fine and if you try the query
>> >>> by
>> >>> itself all of the data shows up properly.
>> >>>
>> >>> Not realizing what was going on, I spent a couple of hours trying to
>> >>> fix
>> >>> the searches on my XP machine. I changed formatting, rebuilt the
>> >>> query,
>> >>> everything I could think of. There was no way that I could make this
>> >>> thing work on XP yet no problems on Vista.
>> >>>
>> >>> What is the deal????
>> >>> Any insight?......Anybody.......
>> >>>
>> >>> --
>> >>> Thanks for taking the time!
>> >>>
>> >>> CJ
>> >>> ---------------------------------------------------------
>> >>> Know thyself, know thy limits....know thy newsgroups!
>> >>
>> >
>> >
>>