• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Anyone know how to turn off the ON-Screen keyboard

#1
For some reason the on-screen keyboard as started poping up on by
desktop everytime I log on. Does anyone know how to prevent it from
opening ?
 

My Computer

Brink

Staff member
mvp
Messages
32,206
Location
Oklahoma, USA
#2

My Computers

System One System Two

  • Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    PSU
    Seasonic Prime Titanium 850W
    Case
    Corsair Air 740
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master
    Keyboard
    Logitech wireless K800
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Creative F200 webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD
A

Andrew McLaren

#3
"bp" <6ball@xxxxxx> wrote ...

> For some reason the on-screen keyboard as started poping up on by
> desktop everytime I log on. Does anyone know how to prevent it from
Hi,

The short answer: I dunno :-) But here are a few things to check ...

First, go to Control Panel, Ease of Access. Then click on the link "Use the
computer without a mouse or keyboard". Make sure the checkbox marked "Use On
screen keyboard" is UNchecked (ie, clear).

That's your first and most important place to check. After that, it gets a
bit more obscure. The On Screen Keyboard program is "osk.exe". Presumably
something is causing osk.exe to be run, every time you log in.

In the Start menu, look in the Startup folder. Make sure there are no
shortcuts there pointing towards osk.exe. If there are, move the shortcut to
another location, or just delete it.

Next, run the command "msconfig". If prompted for admin credentials, enter
them. Then, look under the Startup tab. Look for any entries which appear to
run osk.exe. If you see one, uncheck teh entry, and then press Apply.

Next, run Regedit. If prompted for credentials, enter your own, current
username and password. Then navigate to the registry key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run

If you see a value under there which runs osk.exe, delete that value.

If you've looked at Ease of Access, the Startup folder, the MSConfig
startups, and the HKEY Current User Run key, and you don't find the osk.exe
Onscreen keyboard anywhere in any of them, then ... sorry, I really don't
know. Maybe someone else will know. Or else, learn to enjoy having an On
screen keyboard! :-)

Hope this helps a bit,

--
Andrew McLaren
amclar (at) optusnet dot com dot au
 

My Computer

#4
On Tue, 2 Oct 2007 15:10:31 +1000, "Andrew McLaren"
<andrew@xxxxxx> wrote:

>"bp" <6ball@xxxxxx> wrote ...

>> For some reason the on-screen keyboard as started poping up on by
>> desktop everytime I log on. Does anyone know how to prevent it from
>
>Hi,
>
>The short answer: I dunno :-) But here are a few things to check ...
>
>First, go to Control Panel, Ease of Access. Then click on the link "Use the
>computer without a mouse or keyboard". Make sure the checkbox marked "Use On
>screen keyboard" is UNchecked (ie, clear).
>
>That's your first and most important place to check. After that, it gets a
>bit more obscure. The On Screen Keyboard program is "osk.exe". Presumably
>something is causing osk.exe to be run, every time you log in.
>
>In the Start menu, look in the Startup folder. Make sure there are no
>shortcuts there pointing towards osk.exe. If there are, move the shortcut to
>another location, or just delete it.
done that, nothing there

>
>Next, run the command "msconfig". If prompted for admin credentials, enter
>them. Then, look under the Startup tab. Look for any entries which appear to
>run osk.exe. If you see one, uncheck teh entry, and then press Apply.
Done that, nothing there.

>
>Next, run Regedit. If prompted for credentials, enter your own, current
>username and password. Then navigate to the registry key:
>
> HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run
>
>If you see a value under there which runs osk.exe, delete that value.
Nope nothing there.

I also have an app that can look at all startup app for all users and
nothing there either. ;(

>
>If you've looked at Ease of Access, the Startup folder, the MSConfig
>startups, and the HKEY Current User Run key, and you don't find the osk.exe
>Onscreen keyboard anywhere in any of them, then ... sorry, I really don't
>know. Maybe someone else will know. Or else, learn to enjoy having an On
>screen keyboard! :-)
That's where I'm at. No where can I find how or why it is starting and
the settings in the OSK don't have an option to start at boot up so I
have no idea how to turn it off. ;(

>
>Hope this helps a bit,
Thanks for trying.
NEXT!? ;-)
 

My Computer

S

Synapse Syndrome

#5
"bp" <6ball@xxxxxx> wrote in message
news:adb3g3dt9eo4msapq8ip8jn9rmjurhu6g9@xxxxxx

> For some reason the on-screen keyboard as started poping up on by
> desktop everytime I log on. Does anyone know how to prevent it from
> opening ?

There are two different keyboards. One is the Accessibility one, and the
other is the slicker looking TabletPC one, which has tabs for handwriting
input as well.

Which one have you got? The TabletPC keyboard appears on the logging in
screen when you have a graphics tablet plugged in.

ss.
 

My Computer

Brink

Staff member
mvp
Messages
32,206
Location
Oklahoma, USA
#6
On Tue, 2 Oct 2007 15:10:31 +1000, "Andrew McLaren"
<andrew@xxxxxx> wrote:


done that, nothing there

Done that, nothing there.

Nope nothing there.

I also have an app that can look at all startup app for all users and
nothing there either. ;(

That's where I'm at. No where can I find how or why it is starting and
the settings in the OSK don't have an option to start at boot up so I
have no idea how to turn it off. ;(

Thanks for trying.
NEXT!? ;-)
BP,

Have you looked at this tutorial yet? It will show you how to turn off the on-screen keyboard.

On-Screen Keyboard

Shawn
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    PSU
    Seasonic Prime Titanium 850W
    Case
    Corsair Air 740
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master
    Keyboard
    Logitech wireless K800
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Creative F200 webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD
A

Andrew McLaren

#7
"brink" <brink.2xu482@xxxxxx-mx.forums.net> wrote...

> Have you looked at this tutorial yet? It will show you how to turn off
> the on-screen keyboard.
> 'On-Screen Keyboard'
> (http://www.vistax64.com/tutorials/72733-screen-keyboard.html)
In fairness to myself :-) that's the same as my first suggestion: go to
Control panel, Ease of Access, Use computer wthout mouse or keyboard. Still,
good to have it double-checked.


bp, if you have checked all those things and nothing works, I have 2 further
suggestions:

1) download and run the "autoruns" utility:
http://www.microsoft.com/technet/sysinternals/utilities/Autoruns.mspx
Autoruns will show you *everything* that is configured to run automatically
on your machine.

2) As Synapse suggested: on a Tablet PC, having an onscreen keyboard is
normal. In Vista, the Tablet PC extensions will be installed by default,
whether you have a Tablet PC or not. If you have a graphics tablet or
similar device, the Tablet extensions will think they are on a Tablet PC and
cause the Tablet Keyboard to become active. If you don't actually want to
use any of the Windows Tablet extensions, you can simply remove them. Go to
Control Panel, Programs and Features, Turn Windows Features on or Off. The
"Turn Windows Features on or off" window will appear. Scroll down the list
to find "Tablet PC Optional Components". Uncheck the checkbox and click OK.
This will remove all the Tablet components including the Tablet keyboard.
The normal OSK.EXE Onscree keyboard will be unaffected; likewise, your
graphics tablet should continue to work fine.

BTW you can look in Task Maanger to see if you have a process called
"osk.exe" running - that will show whether the keyboard is the "normal"
Windows Onscreen keyboard, or the Tablet keyboard. If osk - normal keyboard.
If no osk in Tasklist, but you see a keyboard on screen, it must be the
Tablet keyboard, as Synapse suggested.

If after all that, you still haven't found the cause of the keyboard
appearing, then .. I really dunno. In this case you may have overlooked one
of the above steps. Repeat the whole process again, slowly and carefully.

Good luck, hope you find it.
--
Andrew McLaren
amclar (at) optusnet dot com dot au
 

My Computer

#8
On Tue, 2 Oct 2007 11:22:26 -0500, brink
<brink.2xu482@xxxxxx-mx.forums.net> wrote:

>
>bp;469347 Wrote:

>> On Tue, 2 Oct 2007 15:10:31 +1000, "Andrew McLaren"
>> <andrew@xxxxxx> wrote:
>>
>>
>> done that, nothing there
>>
>> Done that, nothing there.
>>
>> Nope nothing there.
>>
>> I also have an app that can look at all startup app for all users and
>> nothing there either. ;(
>>
>> That's where I'm at. No where can I find how or why it is starting and
>> the settings in the OSK don't have an option to start at boot up so I
>> have no idea how to turn it off. ;(
>>
>> Thanks for trying.
>> NEXT!? ;-)
>
>BP,
>
>Have you looked at this tutorial yet? It will show you how to turn off
>the on-screen keyboard.
>
>'On-Screen Keyboard'
>(http://www.vistax64.com/tutorials/72733-screen-keyboard.html)
>
>Shawn
Thank you!
 

My Computer

#9
On Wed, 3 Oct 2007 09:24:58 +1000, "Andrew McLaren"
<andrew@xxxxxx> wrote:

>"brink" <brink.2xu482@xxxxxx-mx.forums.net> wrote...

>> Have you looked at this tutorial yet? It will show you how to turn off
>> the on-screen keyboard.
>> 'On-Screen Keyboard'
>> (http://www.vistax64.com/tutorials/72733-screen-keyboard.html)
>
>In fairness to myself :-) that's the same as my first suggestion: go to
>Control panel, Ease of Access, Use computer wthout mouse or keyboard. Still,
>good to have it double-checked.
>
Opps I looked in "ease of access" but didn't look under' 'Use computer
wthout mouse or keyboard." Because I figured you would need the mouse
to use the on-screen keyboard and instead got focussed on the
on-screen keyboard options on the front.

Thanks all
 

My Computer

Brink

Staff member
mvp
Messages
32,206
Location
Oklahoma, USA
#10
Thank you!
--------------
Brink wrote:
BP,
>
>Have you looked at this tutorial yet? It will show you how to turn off
>the on-screen keyboard.
>
>'On-Screen Keyboard'
>(
On-Screen Keyboard)
>
>Shawn
Your welcome BP,

Glad to hear you have it sorted, and thanks to Andrew also.

Shawn
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    PSU
    Seasonic Prime Titanium 850W
    Case
    Corsair Air 740
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master
    Keyboard
    Logitech wireless K800
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Creative F200 webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD
N

Norm >> >@discussions.microsoft.com>

#11
If you ever went into the East of Access center icon on the logon screen,
lower left hand corner of the screen, and selected the on-screen keyboard to
run, it will set the Ease of Access panel in the control panel to run the OSK
everytime you logon. As the previous poster stated, if you uncheck the OSK
selection under the "Use the computer without a mouse or keyboard" screen and
select Apply of Save, and then close the window. Then next time that you
logon, the OSK shouldn't start back up.



"Synapse Syndrome" wrote:

> "bp" <6ball@xxxxxx> wrote in message
> news:adb3g3dt9eo4msapq8ip8jn9rmjurhu6g9@xxxxxx

> > For some reason the on-screen keyboard as started poping up on by
> > desktop everytime I log on. Does anyone know how to prevent it from
> > opening ?
>
>
> There are two different keyboards. One is the Accessibility one, and the
> other is the slicker looking TabletPC one, which has tabs for handwriting
> input as well.
>
> Which one have you got? The TabletPC keyboard appears on the logging in
> screen when you have a graphics tablet plugged in.
>
> ss.
>
>
>
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)