• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Broadcom Wireless Card stopped working.

Messages
11
#1
Hello. Well, a couple weeks ago my wireless started acting buggy. It wouldn't work, but if I restarted my laptop it would usually start again. Now it's not working at all. I've tried reinstalling the drivers with the disc that came with my computer and downloading the drivers from the dell website. The device does show up in my device manager. I've tried deleting it, so it reinstalls, didn't work. It is enabled in BIOS. I have tried the little wireless switch and the hotkey.

I have a Dell Inspiron 1521
Broadcom 440x 10/100 Intergrated Controller
 

My Computer

System One

  • CPU
    Dell Inspiron 1521
    Graphics Card(s)
    ATI Radeon X1270
    Sound Card
    SigmaTel High Definition Audio
Messages
2,456
Location
NY USA
#2
Hello. Well, a couple weeks ago my wireless started acting buggy. It wouldn't work, but if I restarted my laptop it would usually start again. Now it's not working at all. I've tried reinstalling the drivers with the disc that came with my computer and downloading the drivers from the dell website. The device does show up in my device manager. I've tried deleting it, so it reinstalls, didn't work. It is enabled in BIOS. I have tried the little wireless switch and the hotkey.

I have a Dell Inspiron 1521
Broadcom 440x 10/100 Intergrated Controller
Jibby

I have the same computer and my wifi card is the dell 1390. the broadcom is the wired device. could you go into device manager (type device manager in search) and see if there is an "unknown" device? that might be your wifi.

Ken

Edit Im 32bit you 32 or 64?
 

My Computer

System One

  • Manufacturer/Model
    Dell Inspiron E 1405
    CPU
    2@2.0
    Memory
    4 gigs
    Graphics Card(s)
    integrated intel 945
    Sound Card
    integrated
    Screen Resolution
    1440x900
    Hard Drives
    300 gig internal
    Internet Speed
    10 down 1.5 up
Messages
11
#3
Jibby

I have the same computer and my wifi card is the dell 1390. the broadcom is the wired device. could you go into device manager (type device manager in search) and see if there is an "unknown" device? that might be your wifi.

Ken

Edit Im 32bit you 32 or 64?
Thanks for replying Ken.

I'm 32 bit. Nope there is no unknown device at all. So I take it that my wifi isn't there then :confused:. But I did download drivers for the 1390, because I seen it somewhere on the disc or website I think that it was on my computer.

-Jibby
 
Last edited:

My Computer

System One

  • CPU
    Dell Inspiron 1521
    Graphics Card(s)
    ATI Radeon X1270
    Sound Card
    SigmaTel High Definition Audio
Messages
2,456
Location
NY USA
#4
jibby

so in device manager you have the broadcom, and a wifi under network?

Ken
 

My Computer

System One

  • Manufacturer/Model
    Dell Inspiron E 1405
    CPU
    2@2.0
    Memory
    4 gigs
    Graphics Card(s)
    integrated intel 945
    Sound Card
    integrated
    Screen Resolution
    1440x900
    Hard Drives
    300 gig internal
    Internet Speed
    10 down 1.5 up
Messages
11
#5
Well there is the Broadcom Controller and there's:
Intel(R) PRO/Wireless 2200BG Network Connection
Intel(R) PRO/Wireless 2915ABG Network Connection
Intel(R) PRO/Wireless 3945ABG Network Connection
Intel(R) PRO/Wireless 3945BG Network Connection

And all those have a /!\ on them.
 

My Computer

System One

  • CPU
    Dell Inspiron 1521
    Graphics Card(s)
    ATI Radeon X1270
    Sound Card
    SigmaTel High Definition Audio
Messages
11
#7
Okay I just tried that and ran the windows network diagnostics. Before it said that it couldn't find any drivers associated with the Intel(R) PRO/Wireless...(even though I did download those too) now it says "Install wireless networking hardware, and verify the correct drivers are loaded."
 

My Computer

System One

  • CPU
    Dell Inspiron 1521
    Graphics Card(s)
    ATI Radeon X1270
    Sound Card
    SigmaTel High Definition Audio
Messages
9
#8
Do you know for what the network adapter is? Does the device manager see the wireless NIC but with bangs!... if removed them from device manager from pervious step and then it repopulated, then at least the OS is seeing something.

Rt.click the network device under network adapters and select update driver software
 

My Computer

Messages
11
#9
The only thing under network adapters now is the Broadcom 440x 10/100 Integrated Controller and it says the driver information for that is up to date.
 

My Computer

System One

  • CPU
    Dell Inspiron 1521
    Graphics Card(s)
    ATI Radeon X1270
    Sound Card
    SigmaTel High Definition Audio
Messages
9
#10
do you have a recovery CD.. with the driver install. I have seen some nic's that dont even show up until the install is complete

Another thing to try is to use the system restore
 

My Computer

Messages
11
#11
Sorry I couldn't reply sooner. Couldn't get online. I tried the system restore yesterday, no change, wireless still won't work. I tried install all the network drivers on the driver CD again. Still nothing.
 

My Computer

System One

  • CPU
    Dell Inspiron 1521
    Graphics Card(s)
    ATI Radeon X1270
    Sound Card
    SigmaTel High Definition Audio
Messages
2,456
Location
NY USA
#12
Sorry I couldn't reply sooner. Couldn't get online. I tried the system restore yesterday, no change, wireless still won't work. I tried install all the network drivers on the driver CD again. Still nothing.
Jibby

In vista there is a utility called snipping tool (type snip in search). Could you take a snip of device manager with the network adapter tab open and upload it for us to see.

TIA

Ken
 

My Computer

System One

  • Manufacturer/Model
    Dell Inspiron E 1405
    CPU
    2@2.0
    Memory
    4 gigs
    Graphics Card(s)
    integrated intel 945
    Sound Card
    integrated
    Screen Resolution
    1440x900
    Hard Drives
    300 gig internal
    Internet Speed
    10 down 1.5 up
Messages
11
#13
Huh that's nifty. Is there any certain section other than network adapters you want to see? Also, the Intel Network Connections restored themselves.
 

My Computer

System One

  • CPU
    Dell Inspiron 1521
    Graphics Card(s)
    ATI Radeon X1270
    Sound Card
    SigmaTel High Definition Audio
Messages
9
#14
From what you have checked so far, it almost sounds like the NIC died or got fried somehow.

ZIGZAG3143:
I have no recollection of a snipping tool Search turned up nothing with snip, Vista business version. I just us alt+Print Scrn and paste
 

My Computer

Messages
2,456
Location
NY USA
#15
From what you have checked so far, it almost sounds like the NIC died or got fried somehow.

ZIGZAG3143:
I have no recollection of a snipping tool Search turned up nothing with snip, Vista business version. I just us alt+Print Scrn and paste
My bad prtscr is fine. Im not working on a vista machine right now so I just guessed. I thought it was in vista, but is a great help in win 7

Ken
 

My Computer

System One

  • Manufacturer/Model
    Dell Inspiron E 1405
    CPU
    2@2.0
    Memory
    4 gigs
    Graphics Card(s)
    integrated intel 945
    Sound Card
    integrated
    Screen Resolution
    1440x900
    Hard Drives
    300 gig internal
    Internet Speed
    10 down 1.5 up
Messages
11
#16
I have it in my version of vista.
Here's just the network adapters open
 

My Computer

System One

  • CPU
    Dell Inspiron 1521
    Graphics Card(s)
    ATI Radeon X1270
    Sound Card
    SigmaTel High Definition Audio
Messages
11
#17
Well my laptop has been getting really warm. like it's overheating. So maybe it did get fried.
 

My Computer

System One

  • CPU
    Dell Inspiron 1521
    Graphics Card(s)
    ATI Radeon X1270
    Sound Card
    SigmaTel High Definition Audio
Messages
2,456
Location
NY USA
#18
I have it in my version of vista.
Here's just the network adapters open
Cool Now we have it. ALL of the intel drivers are not installed correctly (hence the yellow triangles on them). Un-install all of them. if windows cant find a driver for you try support.dell.com (they are somewhat useless in 64bit), but its definately a dell 1390. Just double click on the picture I uploaded.
 

My Computer

System One

  • Manufacturer/Model
    Dell Inspiron E 1405
    CPU
    2@2.0
    Memory
    4 gigs
    Graphics Card(s)
    integrated intel 945
    Sound Card
    integrated
    Screen Resolution
    1440x900
    Hard Drives
    300 gig internal
    Internet Speed
    10 down 1.5 up
Messages
11
#19
So uninstall all the Intel ones and download the driver for the 1390?
 

My Computer

System One

  • CPU
    Dell Inspiron 1521
    Graphics Card(s)
    ATI Radeon X1270
    Sound Card
    SigmaTel High Definition Audio
Messages
2,456
Location
NY USA
#20
The only thing under network adapters now is the Broadcom 440x 10/100 Integrated Controller and it says the driver information for that is up to date.

Jibby have you rebooted? if there still is no driver for the 1390, cant you just go to dells support and put in your express number and it will find all the drivers for you.?

Ley me know if you still need help

Ken
 

My Computer

System One

  • Manufacturer/Model
    Dell Inspiron E 1405
    CPU
    2@2.0
    Memory
    4 gigs
    Graphics Card(s)
    integrated intel 945
    Sound Card
    integrated
    Screen Resolution
    1440x900
    Hard Drives
    300 gig internal
    Internet Speed
    10 down 1.5 up

Users Who Are Viewing This Thread (Users: 1, Guests: 0)