Can COM Be Reinstalled?

S

SCAdmin

Trying to get a stupid app to work (WhatsUp) so it can send e-mail alerts
when Event Log stuff happens.

Kept getting Access Denied error, did some testing with WMI test.

Some article I ran across suggested changing the permissions inside Control
Panel / Admin Tools / Component Services. I added myself in there, and
domain admins, and a couple of other accounts I needed to work with all
this.

Long story short -- changing the permissions didn't make any difference. So
I tried to put everything back the way I found it. However, the securtity
tab inside the dcomcnfg.msc would NOT let me put it back to blank, or empty,
or null, or whatever you want to call it, which is how it was when I first
started. So I tried deleting all the accounts. Stupid, I admit, but
certainly no more stupid than whoever designed this stupid interface.

Anyway, now I can't get com services to work on this server. When I open
the dcomconfig snap-in, My Computer has a red down arrow next to it.
Whenever I try to do anything, it says I don't have permission.

I just got finished REINSTALLING WINDOWS SERVER 2003 AND APPLYING THE
SERVICE PACKS. Still no good. (Sorry for the all caps, but I'm getting a
little frustrated here.).

Anyway, how the hell can I uninstall / reinstall com, or get it back to how
it used to be?

Thanks.
 

My Computer

S

Special Access

On Thu, 27 May 2010 14:44:37 -0500, "SCAdmin"
<[email protected]> wrote:

>Trying to get a stupid app to work (WhatsUp) so it can send e-mail alerts
>when Event Log stuff happens.
>
>Kept getting Access Denied error, did some testing with WMI test.
>
>Some article I ran across suggested changing the permissions inside Control
>Panel / Admin Tools / Component Services. I added myself in there, and
>domain admins, and a couple of other accounts I needed to work with all
>this.
>
>Long story short -- changing the permissions didn't make any difference. So
>I tried to put everything back the way I found it. However, the securtity
>tab inside the dcomcnfg.msc would NOT let me put it back to blank, or empty,
>or null, or whatever you want to call it, which is how it was when I first
>started. So I tried deleting all the accounts. Stupid, I admit, but
>certainly no more stupid than whoever designed this stupid interface.
>
>Anyway, now I can't get com services to work on this server. When I open
>the dcomconfig snap-in, My Computer has a red down arrow next to it.
>Whenever I try to do anything, it says I don't have permission.
>
>I just got finished REINSTALLING WINDOWS SERVER 2003 AND APPLYING THE
>SERVICE PACKS. Still no good. (Sorry for the all caps, but I'm getting a
>little frustrated here.).
>
>Anyway, how the hell can I uninstall / reinstall com, or get it back to how
>it used to be?
>
>Thanks.
>
Try this KB:
http://support.microsoft.com/kb/315296
it worked for us, but our problem may have been different.

This one http://support.microsoft.com/kb/892500 is referencing SP1
install with COM+ failure

good luck!
Mike
 

My Computer

Top