"Cannot write to file" on OS X

M

Matt J

I've got the new sync client on my Mac, and it seems to be working more or
less. However, I keep getting pop-ups from it saying it "cannot write to
file" and that I need to move "any of my files that have a .p2p extension out
of this folder." This is at best annoying and at worst unusable -
Foldershare put those p2p files there and ths is supposed to be a seamless
upgrade, right? On my machine there were dozens of these p2p files left over.

The UI for this is also pretty bad - the options on the pop-up are "OK" and
"Exit." A "go ahead and delete this file" button would help a lot (often
times the full path isn't visible in the popup, and clicking OK just causes
it to pop up again if I haven't deleted the .p2p file). The pop-ups are also
modal, but only for WLS, so the only way to find them is to close all the
other windows one by one and hunt around. They don't show up in expose and
clicking on the WLS icon doesn't pull them up. Annoying.

Even after deleting all the leftover .p2p files, I'm still getting the same
error for a particular folder "~/Documents/foo/" (that's it - no filename,
just the path to the folder). There are definitely *no* p2p files in that
folder. I tried exiting and restarting Sync, to no avail. The whole sync
process seems to be blocked on this modal dialog that doesn't make sense.
How can I get it working?

Thanks,
Matt
 

My Computer

C

Christoph Zelazowski [MSFT]

It sounds like you have write only access to that folder (kind of like
~/Public/Drop Box). Could you verify your permissions? Did you troubleshoot
the problem by creating a shared folder in a different location?

Thanks,
Christoph

"Matt J" wrote:

> I've got the new sync client on my Mac, and it seems to be working more or
> less. However, I keep getting pop-ups from it saying it "cannot write to
> file" and that I need to move "any of my files that have a .p2p extension out
> of this folder." This is at best annoying and at worst unusable -
> Foldershare put those p2p files there and ths is supposed to be a seamless
> upgrade, right? On my machine there were dozens of these p2p files left over.
>
> The UI for this is also pretty bad - the options on the pop-up are "OK" and
> "Exit." A "go ahead and delete this file" button would help a lot (often
> times the full path isn't visible in the popup, and clicking OK just causes
> it to pop up again if I haven't deleted the .p2p file). The pop-ups are also
> modal, but only for WLS, so the only way to find them is to close all the
> other windows one by one and hunt around. They don't show up in expose and
> clicking on the WLS icon doesn't pull them up. Annoying.
>
> Even after deleting all the leftover .p2p files, I'm still getting the same
> error for a particular folder "~/Documents/foo/" (that's it - no filename,
> just the path to the folder). There are definitely *no* p2p files in that
> folder. I tried exiting and restarting Sync, to no avail. The whole sync
> process seems to be blocked on this modal dialog that doesn't make sense.
> How can I get it working?
>
> Thanks,
> Matt
 

My Computer

M

Matt J

"Christoph Zelazowski [MSFT]" wrote:

> It sounds like you have write only access to that folder (kind of like
> ~/Public/Drop Box). Could you verify your permissions? Did you troubleshoot
> the problem by creating a shared folder in a different location?
Nope, I definitely have full access to the folder, and WLS is running as me.

MBP-2:foo me$ echo 'hello!' > hi.txt
MBP-2:foo me$ cat hi.txt
hello!
MBP-2:foo me$ pwd
/Users/mkjones/Documents/bar/foo
MBP-2:cs198 me$ whoami
me

I'm not sure what you mean by "creating a shared folder in a different
location." I've got close to 10k files in this folder, (both on this machine
and in its synced analogue on an XP box halfway across the country), and
would rather not create an empty folder to fill with the same stuff.

Thanks,
Matt
 

My Computer

Top