• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

cant open files from old hard-drive

#1
i recently got new computer with vista home premium x64. i attached the harddrive from my old xp computer (w/external case) so i can get all the files from it, but when i try to open the files it says i dont have permission. ive managed to use the security tab to "replace owner and subcontainers on objects" while changing the owner, for some of the files (mostly mp3's) but this is very tedious. is there anyway i can disable the 'owner' from my old computer?
 

My Computer

M

Malke

#2
aaronofyo wrote:

>
> i recently got new computer with vista home premium x64. i attached the
> harddrive from my old xp computer (w/external case) so i can get all the
> files from it, but when i try to open the files it says i dont have
> permission. ive managed to use the security tab to "replace owner and
> subcontainers on objects" while changing the owner, for some of the
> files (mostly mp3's) but this is very tedious. is there anyway i can
> disable the 'owner' from my old computer?
Run this at an elevated Command Prompt:

cacls c:\ /t /e /g Administrators:f [enter]

This will give full rights to all the files and folders on drive C: to the
Administrators group, any member to this group will then have full rights
to the files.

To grant full rights to a specific user issue the command with the user's
name:

cacls c:\ /t /e /g Steve:f [enter]

will grant Steve full rights to all the files and folders on C:. If the
user name has spaces you must surround it with quotation marks:

cacls c:\ /t /e /g "Some User":f [enter]

Obviously you will substitute your desired owner user name on Vista for
"Steve".

Malke
--
MS-MVP
Elephant Boy Computers - Don't Panic!
FAQ - http://www.elephantboycomputers.com/#FAQ
 

My Computer

#3
when i enter that command it displays a list of "processed file : L:_____(various files)"
but when it gets to "processed dir:L: Documents and Settings" it says "access is denied".
 

My Computer

G

Gordon

#4
"aaronofyo" <guest@xxxxxx-email.com> wrote in message
news:880c25deba1baf68a3b675fd7d7b5711@xxxxxx-gateway.com...

>
> when i enter that command it displays a list of "processed file :
> L:_____(various files)"
> but when it gets to "processed dir:L: Documents and Settings" it says
> "access is denied".
>

To whom are you talking? Please QUOTE the post you are replying to.
Thank you

--
Asking a question?
Please tell us the version of the application you are asking about,
your OS, Service Pack level
and the FULL contents of any error message(s)
 

My Computer

Z

Zaphod Beeblebrox

#5
"aaronofyo" <guest@xxxxxx-email.com> wrote in message
news:880c25deba1baf68a3b675fd7d7b5711@xxxxxx-gateway.com...

>
> when i enter that command it displays a list of "processed file :
> L:_____(various files)"
> but when it gets to "processed dir:L: Documents and Settings" it says
> "access is denied".
>
>
I don't think that the CACLS command handles ownership issues, so you
probably need to take ownership of the files and folders first. Rather
than doing so one file/folder at a time, you can use the TAKEOWN command
to do so, like this:

TAKEOWN /F L:\* /R /D

That should give ownership of all files and folders on L: to the current
user. To give ownership to the Administrators group instead of the
current user, add /A.

Hope this helps.

--
Zaphod

No matter where you go, there you are!
 

My Computer

#6
Perhaps this may help

Step by step instruction on how to take ownership of a folder



- Right-click the file/folder you want to own, click properties

- Click Security Tab

- Click Advanced

- Click the Owner Tab

- Click Edit

- Select the Administrators group from the list

- Click OK

- Click OK

- Click OK

You have now taken 'Ownership' of the file and you can close the property

Windows



Now again



1) Right-click on the file

2) Select Properties

3) Go to the Security tab again, click the Advanced button

4) Now Press Edit, then double-click 'Administrators' in the list and tick

the 'allow' box for 'Full control'



You have now taken 'Full control' of file


--
Leo

'Whoever said the pen is mightier than the sword
obviously never encountered automatic weapons.'
General MacArthur






"Zaphod Beeblebrox" <Zaphod.Arisztid.Beeblebrox@xxxxxx> wrote in message
news:gie66m$a6h$1@xxxxxx

>
> "aaronofyo" <guest@xxxxxx-email.com> wrote in message
> news:880c25deba1baf68a3b675fd7d7b5711@xxxxxx-gateway.com...

>>
>> when i enter that command it displays a list of "processed file :
>> L:_____(various files)"
>> but when it gets to "processed dir:L: Documents and Settings" it says
>> "access is denied".
>>
>>
>
> I don't think that the CACLS command handles ownership issues, so you probably
> need to take ownership of the files and folders first. Rather than doing so
> one file/folder at a time, you can use the TAKEOWN command to do so, like
> this:
>
> TAKEOWN /F L:\* /R /D
>
> That should give ownership of all files and folders on L: to the current user.
> To give ownership to the Administrators group instead of the current user, add
> /A.
>
> Hope this helps.
>
> --
> Zaphod
>
> No matter where you go, there you are!
>
 

My Computer

#7
that worked leo. thanks for the help.



- Right-click the file/folder you want to own, click properties
- Click Security Tab
- Click Advanced
- Click the Owner Tab
- Click Edit
- Select the Administrators group from the list
- Click OK
- Click OK
- Click OK
You have now taken 'Ownership' of the file and you can close the property
Windows
Now again
1) Right-click on the file
2) Select Properties
3) Go to the Security tab again, click the Advanced button
4) Now Press Edit, then double-click 'Administrators' in the list and tick
the 'allow' box for 'Full control'
 

My Computer

#8
YW, glad the problem has been fixed.

--
Leo

'Whoever said the pen is mightier than the sword
obviously never encountered automatic weapons.'
General MacArthur






"aaronofyo" <guest@xxxxxx-email.com> wrote in message
news:923f4e7ce34736ff0b908acd839ec6a6@xxxxxx-gateway.com...

>
> that worked leo. thanks for the help.
>
>
>

>> - Right-click the file/folder you want to own, click properties
>> - Click Security Tab
>> - Click Advanced
>> - Click the Owner Tab
>> - Click Edit
>> - Select the Administrators group from the list
>> - Click OK
>> - Click OK
>> - Click OK
>> You have now taken 'Ownership' of the file and you can close the
>> property
>> Windows
>> Now again
>> 1) Right-click on the file
>> 2) Select Properties
>> 3) Go to the Security tab again, click the Advanced button
>> 4) Now Press Edit, then double-click 'Administrators' in the list and
>> tick
>> the 'allow' box for 'Full control'
>
>
> --
> aaronofyo
 

My Computer