• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Defender Failed 0x800106ba-0x80092003

graydog7

New Member
Messages
3
#1
I turned on my Vista64 PC today to find that Defender has decided to stop working!

It pops up a message with error number 0x800106ba.

A search of the knowledgebase advises removing Defender and re-installing with Run>appwiz.cpl but when I do this "Defender" isn't in the list of installed programs.

It isn't in the "Turn Windows features on or off" section either.

Running the WindowsDefender installer package just says it's already installed and doesn't offer Repair/Uninstall options.

Starting the Defender service through "Computer Management" fails and produces an 0x80092003 error which is an error relating to reading or writing to a file.


I feel this problem has been introduced by an Automatic Update as nothing else has changed since yesterday.

Anyone else having this problem?

Thanks GH
 

My Computer

E

Engel

#2
You might try this. Go to the main Windows Update window and
click on "Installed Updates" (on the left-hand side of the window, at the
bottom), and then remove "Update for Microsoft Windows (KB931099)" (only).
Reboot. Reboot again. Go back to Windows Update, and re-install the same
update, by clicking on the Check for Updates button.


This should essentially re-install Windows Defender on Vista.
 

My Computer

graydog7

New Member
Messages
3
#3
Hi Engel

I saw your advice here in an earlier Post. Gave it a go, but It hasn't fixed the problem.

Also tried a system restore, but the earliest resotre point now seems to be immediately after the offending update!

GH
 

My Computer

graydog7

New Member
Messages
3
#5
Tried many things. Your link above mainly relates to XP as most of the steps don't apply to Vista64 and those that do have no effect.

I'm getting this error now:

"application failed to initialize: 0x800106ba. The RPC server is unavailable."

What a Crock! I've wasted the whole day trying to resolve this issue that seems to be the result of an Automatic Update!

All I can do now is disable Defender in MSCONFIG and wait.....ZZZZzzzzzzz
 

My Computer

Mvgratz

New Member
Messages
1
#7
I had the same problem after upgradeing from Vista32 bit to Vista64 bit. Here's what I did to fix mine;
1. Click start
2. Type Run MsConfig
3. On the System Config Window Click on the Services Tag
4. Click on the "hide all Microsoft Services" option.
5. Click on the Start Up Tab at the top.
6. Scroll down to the Windows Defender box and Uncheck it.
7. Go back to the Services Tab and Uncheck "hide all Microsoft Services".
8. Click on Apply, and OK.
9. Restart Computer
This took care of my problems. Hope it helps you too!
 

My Computer

Messages
2
#9
Use the admin settings to check the manuel or auto run settings and fix the error in windows defender by changing the way it runs. Auto or manuel and then reset back to run atuomatic at startup of system start.
 
Last edited:

My Computer

System One

  • CPU
    3.4 p4 HT
    Motherboard
    ABIT AS8-V
    Memory
    4 GIG
    Graphics Card(s)
    Nividia Gforce FX5700LE
    Sound Card
    On board Realtek
    Monitor(s) Displays
    Hansol H750
    Screen Resolution
    1024 by 768
    Hard Drives
    Two Sata 250 GB
    PSU
    850 ANTEC TurePower Quatro
    Case
    Antec 10 bay
    Cooling
    9 fans on Termo take contrls
    Mouse
    Logitech
    Keyboard
    Logitech
    Internet Speed
    DSL
    Other Info
    Found a way to fix 0x800106ba windows defender error by looking at the event log and tell it run manuely two times and the trying it. IT worked great after that.
Messages
1
Location
colchester, england
#10
mvgrats.....thank you soooo much!!!:D
 

My Computer

System One

  • Manufacturer/Model
    Toshiba Satellite L350
    CPU
    Intel Pentium T3400
    Memory
    2 gig
    Graphics Card(s)
    Intel GMA 4500M
    Screen Resolution
    1440 by 900
    Hard Drives
    2 75 gig internal HDD's and one 1 terabyte external HDD.
Messages
2
#11
"Update to another fix"

You may also look at McAfee for the Site Advisor fix if you use McAfee Site Advisor.
There is a fix there but you have to save the .ini file to your desktop and reboot,
Then copy and past it back in the folder it beongs in to fix the problem!!!!!
 
Last edited:

My Computer

System One

  • CPU
    3.4 p4 HT
    Motherboard
    ABIT AS8-V
    Memory
    4 GIG
    Graphics Card(s)
    Nividia Gforce FX5700LE
    Sound Card
    On board Realtek
    Monitor(s) Displays
    Hansol H750
    Screen Resolution
    1024 by 768
    Hard Drives
    Two Sata 250 GB
    PSU
    850 ANTEC TurePower Quatro
    Case
    Antec 10 bay
    Cooling
    9 fans on Termo take contrls
    Mouse
    Logitech
    Keyboard
    Logitech
    Internet Speed
    DSL
    Other Info
    Found a way to fix 0x800106ba windows defender error by looking at the event log and tell it run manuely two times and the trying it. IT worked great after that.

neednonerd

New Member
Messages
9
#14
I tried the regcure, but you have to pay for it and I believe that this is a Windows Vista Problem that should be fix by Microsoft. However, try the following steps and do it yourself without paying for it.

1 Go to control Panel and click on Administrative tools.
2 Click on services and a new windows will appear.
3 Look up for windows defender and right click on it, click on properties and select automatic, it should be on manual, change it to automatic and click apply then o.k. and will take you back to the services windows.
4 Windows Defender should be highlighted and on the left hand side of the services windows, should be 2 links, click restart.
5 Close all windows and open Windows Defender, it should work without a problem and your popup window at start up will not be display any longer.

Hope this helps you.
 

My Computer

neednonerd

New Member
Messages
9
#15
I tried the regcure, but you have to pay for it and I believe that this is a Windows Vista Problem that should be fix by Microsoft. However, try the following steps and do it yourself without paying for it.

1 Go to control Panel and click on Administrative tools.
2 Click on services and a new windows will appear.
3 Look up for windows defender and right click on it, click on properties and select automatic, it should be on manual, change it to automatic and click apply then o.k. and will take you back to the services windows.
4 Windows Defender should be highlighted and on the left hand side of the services windows, should be 2 links, click restart.
5 Close all windows and open Windows Defender, it should work without a problem and your popup window at start up will not be display any longer.
Hope this helps you.
 

My Computer

Messages
1
#17
I had the same problem after upgradeing from Vista32 bit to Vista64 bit. Here's what I did to fix mine;
1. Click start
2. Type Run MsConfig
3. On the System Config Window Click on the Services Tag
4. Click on the "hide all Microsoft Services" option.
5. Click on the Start Up Tab at the top.
6. Scroll down to the Windows Defender box and Uncheck it.
7. Go back to the Services Tab and Uncheck "hide all Microsoft Services".
8. Click on Apply, and OK.
9. Restart Computer
This took care of my problems. Hope it helps you too!
thanks man 4 real!
 

My Computer

Farr

New Member
Messages
2
#19
I tied many hours to fix this problem, and the following suggestion from the Forum finally worked. Thanks.

Go to the main Update window and
click on "Installed Updates" (on the left-hand side of the window, at the
bottom), and then remove "Update for Microsoft Windows (KB931099)" (only).
Reboot. Reboot again. Go back to Windows Update, and re-install the same
update, by clicking on the Check for Updates button.
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)