• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

error 0x00000057

tkahrs

New Member
Messages
3
Location
Gardner, KS
#1
I installed Vista Home Premium a few days ago and now I can't get my (USB) Epson Stylus PHOTO 820 to print. The driver installs but when I start to print I get the 0x00000057 error code. Called Epson for help but they said it is Windows problem. Purchased RegCure and ran it but printer still does not print. I read several articles that pointed to the spooler or the registry as a problem but didn't find a workable solution. Any Fix solutions?
 

My Computer

System One

  • Manufacturer/Model
    Power Spec
A

Alan Morris [MSFT]

#2
this error is invalid parameter. I'm assuming the machine is not 64 bit and
you are using drivers from Epson's website. Do the basic drivers Epson
included with the OS allow you to print? If you are using Epson's XP
drivers, you will need to go back to Epson.


E:\>winerror 0x00000057
87 ERROR_INVALID_PARAMETER <--> 0x40000002
STATUS_WORKING_SET_LIMIT_RANGE


--
Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:
http://support.microsoft.com/search/?adv=1

This posting is provided "AS IS" with no warranties, and confers no rights.

"tkahrs" <guest@xxxxxx-email.com> wrote in message
news:b78401b95239248565a48c5d73abda6f@xxxxxx-gateway.com...

>
> I installed Vista Home Premium a few days ago and now I can't get my
> (USB) Epson Stylus PHOTO 820 to print. The driver installs but when I
> start to print I get the 0x00000057 error code. Called Epson for help
> but they said it is Windows problem. Purchased RegCure and ran it but
> printer still does not print. I read several articles that pointed to
> the spooler or the registry as a problem but didn't find a workable
> solution. Any Fix solutions?
>
>
> --
> tkahrs
 

My Computer

tkahrs

New Member
Messages
3
Location
Gardner, KS
#3
I am on a 32 bit machine but am using the driver from the Vista OS. Here is some additional information .... when I attempt to print, I get a box that says "EPIBSR30 has stopped working." I did go to the Epson download site for this printer but they show it as In-Box which means "Drivers are included with Windows Vista." Still no fix yet.
 

My Computer

System One

  • Manufacturer/Model
    Power Spec
B

Brothertech

#4
Hello, I am a technician for brother. I have had several clients call
with the same issue.
They are all using Vista 32 bit.
They have the MFC4800 using USB cable.
The driver for this model is built in with Vista.
They are not able to print, the print job seems to disappear.
We set the drivers to print directly to printer (by passing the print
spooler) and then the error 0X00000057.
Is there a problem with these drivers?


--
Brothertech
------------------------------------------------------------------------
Brothertech's Profile: http://forums.techarena.in/members/brothertech.htm
View this thread: http://forums.techarena.in/vista-print-fax/1110567.htm

http://forums.techarena.in
 

My Computer

A

Alan Morris [MSFT]

#5
the file name the other user posted was not one that ships with the Vista
OS.

If you are with Brother, there are driver developers who periodically reside
in Redmond working to checkin and fix print drivers. Follow your channel
back to development.

--
Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:
http://support.microsoft.com/search/?adv=1

This posting is provided "AS IS" with no warranties, and confers no rights.

"Brothertech" <Brothertech.3n8ube@xxxxxx> wrote in message
news:Brothertech.3n8ube@xxxxxx

>
> Hello, I am a technician for brother. I have had several clients call
> with the same issue.
> They are all using Vista 32 bit.
> They have the MFC4800 using USB cable.
> The driver for this model is built in with Vista.
> They are not able to print, the print job seems to disappear.
> We set the drivers to print directly to printer (by passing the print
> spooler) and then the error 0X00000057.
> Is there a problem with these drivers?
>
>
> --
> Brothertech
> ------------------------------------------------------------------------
> Brothertech's Profile: http://forums.techarena.in/members/brothertech.htm
> View this thread: http://forums.techarena.in/vista-print-fax/1110567.htm
>
> http://forums.techarena.in
>
 

My Computer

A
#6

My Computer

anco

New Member
Messages
11
Location
Suva, Fiji
#7
I am trying to connect to a network printer and there is an error message that comes up, it goes, "Winows cannot conect to the printer. Operation could not be completed (error 0x00000057) Can someone please help me out with this. I have been working on this connection for two days now, but there is no progress
 

My Computer

A

Alan Morris [MSFT]

#8
Invalid parameter error. There's too many reasons for this.

The first thing I would check is weather the vendor has a Vista specific
print driver. If you are connecting to Server 2003 or XP, the print driver
installed on the "server" may not be able to run in Vista.

E:\>winerror 0x00000057
87 ERROR_INVALID_PARAMETER <--> 0x40000002
STATUS_WORKING_SET_LIMIT_RANGE
87 ERROR_INVALID_PARAMETER <--> 0x80090308 No Symbolic Name
87 ERROR_INVALID_PARAMETER <--> 0x80090309 No Symbolic Name
87 ERROR_INVALID_PARAMETER <--> 0x8009030d No Symbolic Name
87 ERROR_INVALID_PARAMETER <--> 0xc0000003 STATUS_INVALID_INFO_CLASS
87 ERROR_INVALID_PARAMETER <--> 0xc000000b STATUS_INVALID_CID
87 ERROR_INVALID_PARAMETER <--> 0xc000000d STATUS_INVALID_PARAMETER
87 ERROR_INVALID_PARAMETER <--> 0xc000001a STATUS_UNABLE_TO_FREE_VM
87 ERROR_INVALID_PARAMETER <--> 0xc000001b
STATUS_UNABLE_TO_DELETE_SECTION
87 ERROR_INVALID_PARAMETER <--> 0xc0000030 STATUS_INVALID_PARAMETER_MIX
87 ERROR_INVALID_PARAMETER <--> 0xc0000045
STATUS_INVALID_PAGE_PROTECTION
87 ERROR_INVALID_PARAMETER <--> 0xc0000048 STATUS_PORT_ALREADY_SET

--
Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:
http://support.microsoft.com/search/?adv=1

This posting is provided "AS IS" with no warranties, and confers no rights.

"anco" <guest@xxxxxx-email.com> wrote in message
news:ed3602872f23e05885233b599bdfe655@xxxxxx-gateway.com...

>
> I am trying to connect to a network printer and there is an error
> message that comes up, it goes, "Winows cannot conect to the printer.
> Operation could not be completed (error 0x00000057) Can someone please
> help me out with this. I have been working on this connection for two
> days now, but there is no progress
>
>
> --
> anco
 

My Computer

anco

New Member
Messages
11
Location
Suva, Fiji
#9
thank you for the solution, yes, the server is running on 2003 and if the vendor has a vista driver, that would mean that I would have to install it into the server, would it affect the other PCs running on XP ?
 

My Computer

A

Alan Morris [MSFT]

#10
It can.

I'd set this up on another machine first and confirm there will not be any
conflicts. Normally the Vista driver will work on XP when it's just the
print driver. If it's a multifunction device , anything goes.

--
Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:
http://support.microsoft.com/search/?adv=1

This posting is provided "AS IS" with no warranties, and confers no rights.

"anco" <guest@xxxxxx-email.com> wrote in message
news:849586e6efc492fcb3d63ac3db2fa580@xxxxxx-gateway.com...

>
> thank you for the solution, yes, the server is running on 2003 and if
> the vendor has a vista driver, that would mean that I would have to
> install it into the server, would it affect the other PCs running on XP
> ?
>
>
> --
> anco
 

My Computer

anco

New Member
Messages
11
Location
Suva, Fiji
#11
Thanx for the advice, I really appreciate that

Alan Morris [MSFT];966113 said:
It can.

I'd set this up on another machine first and confirm there will not be any
conflicts. Normally the Vista driver will work on XP when it's just the
print driver. If it's a multifunction device , anything goes.

--
Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:
Advanced Search

This posting is provided "AS IS" with no warranties, and confers no rights.

"anco" <guest@xxxxxx-email.com> wrote in message
news:849586e6efc492fcb3d63ac3db2fa580@xxxxxx-gateway.com...

>
> thank you for the solution, yes, the server is running on 2003 and if
> the vendor has a vista driver, that would mean that I would have to
> install it into the server, would it affect the other PCs running on XP
> ?
>
>
> --
> anco
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)