• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Error: Could not find endpoint element...

  • Thread starter Alhambra-Eidos Kiquenet
  • Start date
A

Alhambra-Eidos Kiquenet

#1
Hi misters, I'm a newbie to WCF and I am trying to run an application web
that calls to a service WCF and I am having a bit of trouble with
configuration. The client of service WCF is an application web.

I finally got my service up and running and it is hosted on IIS.

I get WDSL like this
http://localhost:2121/TINSA.MaquinaEstados/service.svc?wsdl, and it's right.

Aftwer I got my service up and running I proceeded to create my proxy
classes with svcutil.exe

svcutil.exe http://localhost:2121/TINSA.MaquinaEstados/service.svc?wsdl

and that created the proxy class and another config file which I copied
into application web (rename output.config to web.config).

I created my client class and when I try to initialize the proxy I am
getting the following error:

Could not find endpoint element with name 'WSHttpBinding_ITareasEngine' and
contract 'TINSA.WCF.MaquinaEstados.Contrato.ITareasEngine' in the
ServiceModel client configuration section. This might be because no
configuration file was found for your application, or because no endpoint
element matching this name could be found in the client element


Config in client (Application web)

<client>
<!-- SERVICIO MAQUINA ESTADOS -->
<endpoint address="http://localhost:2121/TINSA.MaquinaEstados/service.svc"
binding="wsHttpBinding"
bindingConfiguration="WSHttpBinding_ITareasEngine"
contract="TINSA.WCF.MaquinaEstados.Contrato.ITareasEngine"
name="AgenteMaquinaEstados">
<identity>
<userPrincipalName value="xxxxx@grupo.zzz.sa" />
</identity>
</endpoint>
</client>


<!-- SERVICIO MAQUINA ESTADOS -->
<binding name="WSHttpBinding_ITareasEngine"
closeTimeout="00:01:00"
openTimeout="00:01:00" receiveTimeout="00:10:00"
sendTimeout="00:01:00"
bypassProxyOnLocal="false" transactionFlow="false"
hostNameComparisonMode="StrongWildcard"
maxBufferPoolSize="524288" maxReceivedMessageSize="65536"
messageEncoding="Text" textEncoding="utf-8"
useDefaultWebProxy="true"
allowCookies="false">
<readerQuotas maxDepth="32"
maxStringContentLength="8192" maxArrayLength="16384"
maxBytesPerRead="4096" maxNameTableCharCount="16384"
/>
<reliableSession ordered="true"
inactivityTimeout="00:10:00" enabled="false" />
<security mode="Message">
<transport clientCredentialType="Windows"
proxyCredentialType="None"
realm="" />
<message clientCredentialType="Windows"
negotiateServiceCredential="true"
algorithmSuite="Default"
establishSecurityContext="true" />
</security>
</binding>



Config for Service WCF

<services>
<service name="TINSA.WCF.MaquinaEstados.Adaptador.TareasEngine"
behaviorConfiguration="TareasEngineBehavior">
<endpoint address=""
binding="wsHttpBinding"
bindingConfiguration="TINSAConfiguracion"
contract="TINSA.WCF.MaquinaEstados.Contrato.ITareasEngine"
/>
</service>
</services>

<bindings>
<wsHttpBinding>

<binding name="TINSAConfiguracion" maxReceivedMessageSize="100000000">
<security mode="Message">
<message clientCredentialType="Windows" />
</security>
</binding>
</wsHttpBinding>
</bindings>

<behaviors>
<serviceBehaviors>
<behavior name="TareasEngineBehavior">
<serviceThrottling maxConcurrentCalls="50"
maxConcurrentSessions="50"
maxConcurrentInstances="2147483647" />
<serviceMetadata httpGetEnabled="true" />
<serviceDebug includeExceptionDetailInFaults="true" />
</behavior>
</serviceBehaviors>
</behaviors>


--
http://www.alhambra-eidos.es/web2005/index.html
www.kiquenet.net
 

My Computer

D

Dwight@QuickLearn

#2
I'm not quite sure if I totally understand you but it sounds like you're
copying the "client" config from your svcutil output, over your "Server"
service config file. If this is what you're trying to do, then you need not
overwrite it but merge the two together.

-Dwightg@quicklearn

"Alhambra-Eidos Kiquenet" wrote:

> Hi misters, I'm a newbie to WCF and I am trying to run an application web
> that calls to a service WCF and I am having a bit of trouble with
> configuration. The client of service WCF is an application web.
>
> I finally got my service up and running and it is hosted on IIS.
>
> I get WDSL like this
> http://localhost:2121/TINSA.MaquinaEstados/service.svc?wsdl, and it's right.
>
> Aftwer I got my service up and running I proceeded to create my proxy
> classes with svcutil.exe
>
> svcutil.exe http://localhost:2121/TINSA.MaquinaEstados/service.svc?wsdl
>
> and that created the proxy class and another config file which I copied
> into application web (rename output.config to web.config).
>
> I created my client class and when I try to initialize the proxy I am
> getting the following error:
>
> Could not find endpoint element with name 'WSHttpBinding_ITareasEngine' and
> contract 'TINSA.WCF.MaquinaEstados.Contrato.ITareasEngine' in the
> ServiceModel client configuration section. This might be because no
> configuration file was found for your application, or because no endpoint
> element matching this name could be found in the client element
>
>
> Config in client (Application web)
>
> <client>
> <!-- SERVICIO MAQUINA ESTADOS -->
> <endpoint address="http://localhost:2121/TINSA.MaquinaEstados/service.svc"
> binding="wsHttpBinding"
> bindingConfiguration="WSHttpBinding_ITareasEngine"
> contract="TINSA.WCF.MaquinaEstados.Contrato.ITareasEngine"
> name="AgenteMaquinaEstados">
> <identity>
> <userPrincipalName value="xxxxx@grupo.zzz.sa" />
> </identity>
> </endpoint>
> </client>
>
>
> <!-- SERVICIO MAQUINA ESTADOS -->
> <binding name="WSHttpBinding_ITareasEngine"
> closeTimeout="00:01:00"
> openTimeout="00:01:00" receiveTimeout="00:10:00"
> sendTimeout="00:01:00"
> bypassProxyOnLocal="false" transactionFlow="false"
> hostNameComparisonMode="StrongWildcard"
> maxBufferPoolSize="524288" maxReceivedMessageSize="65536"
> messageEncoding="Text" textEncoding="utf-8"
> useDefaultWebProxy="true"
> allowCookies="false">
> <readerQuotas maxDepth="32"
> maxStringContentLength="8192" maxArrayLength="16384"
> maxBytesPerRead="4096" maxNameTableCharCount="16384"
> />
> <reliableSession ordered="true"
> inactivityTimeout="00:10:00" enabled="false" />
> <security mode="Message">
> <transport clientCredentialType="Windows"
> proxyCredentialType="None"
> realm="" />
> <message clientCredentialType="Windows"
> negotiateServiceCredential="true"
> algorithmSuite="Default"
> establishSecurityContext="true" />
> </security>
> </binding>
>
>
>
> Config for Service WCF
>
> <services>
> <service name="TINSA.WCF.MaquinaEstados.Adaptador.TareasEngine"
> behaviorConfiguration="TareasEngineBehavior">
> <endpoint address=""
> binding="wsHttpBinding"
> bindingConfiguration="TINSAConfiguracion"
> contract="TINSA.WCF.MaquinaEstados.Contrato.ITareasEngine"
> />
> </service>
> </services>
>
> <bindings>
> <wsHttpBinding>
>
> <binding name="TINSAConfiguracion" maxReceivedMessageSize="100000000">
> <security mode="Message">
> <message clientCredentialType="Windows" />
> </security>
> </binding>
> </wsHttpBinding>
> </bindings>
>
> <behaviors>
> <serviceBehaviors>
> <behavior name="TareasEngineBehavior">
> <serviceThrottling maxConcurrentCalls="50"
> maxConcurrentSessions="50"
> maxConcurrentInstances="2147483647" />
> <serviceMetadata httpGetEnabled="true" />
> <serviceDebug includeExceptionDetailInFaults="true" />
> </behavior>
> </serviceBehaviors>
> </behaviors>
>
>
> --
> http://www.alhambra-eidos.es/web2005/index.html
> www.kiquenet.net
>
 

My Computer

K

kfrost

#3
The initial problem I see is the name of the binding you are using in your
config file. The name in the config file is:
<client>
name="AgenteMaquinaEstados"
</client>

However your exception is looking for a name of
'WSHttpBinding_ITareasEngine'

Check your the line where you are initializing the proxy in code. It
appears you are passing a value of 'WSHttpBinding_ITareasEngine' into the
constructor and you should be passing in AgenteMaquinaEstados.

That or you need to change the names of your bindings in your .config file.

Your 2nd config file looks like it's probably correct.
--
kris@n-sv.com.<Remove This Before Emailing>

Network & Software Integration
www.n-sv.com

"Helping put the pieces of your IT puzzle together"


"Alhambra-Eidos Kiquenet" wrote:

> Hi misters, I'm a newbie to WCF and I am trying to run an application web
> that calls to a service WCF and I am having a bit of trouble with
> configuration. The client of service WCF is an application web.
>
> I finally got my service up and running and it is hosted on IIS.
>
> I get WDSL like this
> http://localhost:2121/TINSA.MaquinaEstados/service.svc?wsdl, and it's right.
>
> Aftwer I got my service up and running I proceeded to create my proxy
> classes with svcutil.exe
>
> svcutil.exe http://localhost:2121/TINSA.MaquinaEstados/service.svc?wsdl
>
> and that created the proxy class and another config file which I copied
> into application web (rename output.config to web.config).
>
> I created my client class and when I try to initialize the proxy I am
> getting the following error:
>
> Could not find endpoint element with name 'WSHttpBinding_ITareasEngine' and
> contract 'TINSA.WCF.MaquinaEstados.Contrato.ITareasEngine' in the
> ServiceModel client configuration section. This might be because no
> configuration file was found for your application, or because no endpoint
> element matching this name could be found in the client element
>
>
> Config in client (Application web)
>
> <client>
> <!-- SERVICIO MAQUINA ESTADOS -->
> <endpoint address="http://localhost:2121/TINSA.MaquinaEstados/service.svc"
> binding="wsHttpBinding"
> bindingConfiguration="WSHttpBinding_ITareasEngine"
> contract="TINSA.WCF.MaquinaEstados.Contrato.ITareasEngine"
> name="AgenteMaquinaEstados">
> <identity>
> <userPrincipalName value="xxxxx@grupo.zzz.sa" />
> </identity>
> </endpoint>
> </client>
>
>
> <!-- SERVICIO MAQUINA ESTADOS -->
> <binding name="WSHttpBinding_ITareasEngine"
> closeTimeout="00:01:00"
> openTimeout="00:01:00" receiveTimeout="00:10:00"
> sendTimeout="00:01:00"
> bypassProxyOnLocal="false" transactionFlow="false"
> hostNameComparisonMode="StrongWildcard"
> maxBufferPoolSize="524288" maxReceivedMessageSize="65536"
> messageEncoding="Text" textEncoding="utf-8"
> useDefaultWebProxy="true"
> allowCookies="false">
> <readerQuotas maxDepth="32"
> maxStringContentLength="8192" maxArrayLength="16384"
> maxBytesPerRead="4096" maxNameTableCharCount="16384"
> />
> <reliableSession ordered="true"
> inactivityTimeout="00:10:00" enabled="false" />
> <security mode="Message">
> <transport clientCredentialType="Windows"
> proxyCredentialType="None"
> realm="" />
> <message clientCredentialType="Windows"
> negotiateServiceCredential="true"
> algorithmSuite="Default"
> establishSecurityContext="true" />
> </security>
> </binding>
>
>
>
> Config for Service WCF
>
> <services>
> <service name="TINSA.WCF.MaquinaEstados.Adaptador.TareasEngine"
> behaviorConfiguration="TareasEngineBehavior">
> <endpoint address=""
> binding="wsHttpBinding"
> bindingConfiguration="TINSAConfiguracion"
> contract="TINSA.WCF.MaquinaEstados.Contrato.ITareasEngine"
> />
> </service>
> </services>
>
> <bindings>
> <wsHttpBinding>
>
> <binding name="TINSAConfiguracion" maxReceivedMessageSize="100000000">
> <security mode="Message">
> <message clientCredentialType="Windows" />
> </security>
> </binding>
> </wsHttpBinding>
> </bindings>
>
> <behaviors>
> <serviceBehaviors>
> <behavior name="TareasEngineBehavior">
> <serviceThrottling maxConcurrentCalls="50"
> maxConcurrentSessions="50"
> maxConcurrentInstances="2147483647" />
> <serviceMetadata httpGetEnabled="true" />
> <serviceDebug includeExceptionDetailInFaults="true" />
> </behavior>
> </serviceBehaviors>
> </behaviors>
>
>
> --
> http://www.alhambra-eidos.es/web2005/index.html
> www.kiquenet.net
>
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)