• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Error installing Vista SP2 Update - 0x8007000D

Messages
29
#1
I have been having problems installing Service Pack 2 on Vista. I have downloaded SP2 Update from Microsoft Windows Update Site. I have been getting an error saying that I should download and run the "Check for System Update Readiness" tool at Description of the System Update Readiness Tool for Windows Vista and for Windows Server 2008.



So, I opened the link, downloaded and ran the program. I have downloaded and installed all windows updates available but still I'm getting the same error. Is there a solution available?
 

My Computer

b12blib

New Member
Messages
20
Location
In a box next to yours
#2
Well, looking at the fact that your are wanting to install SP2 which is in beta I'd say you probably have more Beta software installed. Henceforth Vista is having trouble as it is all untested beta rubbish. No use installing it unless you are a developer or just have too much time at hand to resolve and report bugs.

Sounds though like the download corrupted. Try downloading on another PC, chuck it on a stick or CD, and install from there.
Other possible reasons could be corrupted windows OS files (Not unusual with beta's) bad HDD (Run a check disk, and please do not use reg fixes) or bad lan connection if installing from network share.
 
Last edited:

My Computer

System One

  • CPU
    CPU = Can't Power Up!!
    Motherboard
    You mean my mothership?
    Memory
    I had amnesia for as long as I can remember...
    Graphics Card(s)
    Nah, Braille bro!
    Sound Card
    Yeah! Very sound!
    Monitor(s) Displays
    Yes, the monitor(s) display indeed! Very good my youn padawan!
    Screen Resolution
    Resolution for gettin a display is pushing "on" for power...
    Hard Drives
    Pretty darn hard! Nearly broke my darn tooth!
    PSU
    PSU = Pimping Sick Undies!
    Case
    Gues I'm a bit of a nut case yup
    Cooling
    Cool me with a beer!
    Mouse
    Eeeek!
    Keyboard
    No, mine has razors on the board to prevent me smashing it.
    Internet Speed
    Dunno, modem doesn't seem to move with a great deal of speed
    Other Info
    Aha! Now this is making more sense to me!

    Operating System: Windows Vista™ Business (6.0, Build 6001) Service Pack 1 (6001.vistasp1_gdr.080917-1612)
    System Model: OptiPlex 755
    BIOS: Phoenix ROM BIOS PLUS Version 1.10 A12
    Processor: Intel(R) Core(TM)2 Duo CPU E6850 @ 3.40GHz (2 CPUs), ~3.4GHz
    Memory: 3324MB RAM (Strange one, I really got 4GB, but it claims 3324... Not u

Kernel

Vista User
Power User
Messages
130
Location
India
#3
if you are installing via "automatic updates" then try renaming Softwaredistribution folder (there is a way to get via "automatic updates").
Follow Method 10 from the following Article.

also make sure that you have updated all your hardware device drivers
 

My Computer

System One

  • Manufacturer/Model
    Custom
    CPU
    AMD
    Motherboard
    ASUS
    Memory
    2GB
    Graphics Card(s)
    Nvidia 256MB
    Sound Card
    Creative 7.1
    Monitor(s) Displays
    19" Viewsonic and Sony 26" S Series TV
    Screen Resolution
    1920x1080
    Hard Drives
    Sata (1 TB) and IDE (350GB)
    Mouse
    Optical (Wireless)
    Keyboard
    Multimedia (Wireless)
    Internet Speed
    2MB

Users Who Are Viewing This Thread (Users: 1, Guests: 0)