• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

file sharing

T

Tiffany

#1
Hi,

All my office laptops are using window vista. i want to create sharing
folders for my office. I want to assign permission to access each folder e.g.
A can access folder 1, 2 and 3; B can access folder 1 and 2 and C can access
only folder 1. Is it possible to do these without a server. If yes, could you
also show me steps to create the sharing folder.

Thank you
 
#2
How about the users logged in?? Are they logged into the domain or is it just a local workgroup??


If it is domain, it is pretty easy as ABCD

If it is a workgroup, try adding the users of other computers in format of COMPUTERNAME\USERNAME and that would probably work. Granting permissions to user are still the same and ensure that all computers are in same netwkr! ;)
 
M

Malke

#3
Tiffany wrote:

> Hi,
>
> All my office laptops are using window vista. i want to create sharing
> folders for my office. I want to assign permission to access each folder
> e.g. A can access folder 1, 2 and 3; B can access folder 1 and 2 and C can
> access only folder 1. Is it possible to do these without a server. If yes,
> could you also show me steps to create the sharing folder.
You will need Vista Business or Ultimate. Create users and passwords. Create
groups is desired and put users into groups, too. Set permissions on shared
resources as desired.

Excellent, thorough, yet easy to understand article about File/Printer
Sharing in Vista. Includes details about sharing printers as well as files
and folders:

http://technet.microsoft.com/en-us/library/bb727037.aspx

Deployment:
http://technet.microsoft.com/en-us/windows/bb887300.aspx

Management:
http://technet.microsoft.com/en-us/windows/aa905063.aspx

Malke
--
MS-MVP
Elephant Boy Computers - Don't Panic!
FAQ - http://www.elephantboycomputers.com/#FAQ
 
T

Tiffany

#5
Hi Malke,

I have done the followings

1) Use the same Workgroup Name for all the laptops and desktops in my office
2) set network type to Private
3) enabled filing sharing, public folder sharing and printer sharing under
the Sharing and Discovery section

I try to share a folder by right-click the folder that I want to share and
then click share. The file sharing window is displayed. I want only selected
people to be able to access this folder. Hence, i put in the names of those
who are permitted to access this folder. I typed e.g. AMIN and click Add in
the Choose people to share with's dialog box. the error msg pop up saying
unable to locate user AMIN. Nothing wrong with the computer name. What could
be the problems? Kindly advise

Thank you very much for your support

"Malke" wrote:

> Tiffany wrote:
>

> > Hi,
> >
> > All my office laptops are using window vista. i want to create sharing
> > folders for my office. I want to assign permission to access each folder
> > e.g. A can access folder 1, 2 and 3; B can access folder 1 and 2 and C can
> > access only folder 1. Is it possible to do these without a server. If yes,
> > could you also show me steps to create the sharing folder.
>
> You will need Vista Business or Ultimate. Create users and passwords. Create
> groups is desired and put users into groups, too. Set permissions on shared
> resources as desired.
>
> Excellent, thorough, yet easy to understand article about File/Printer
> Sharing in Vista. Includes details about sharing printers as well as files
> and folders:
>
> http://technet.microsoft.com/en-us/library/bb727037.aspx
>
> Deployment:
> http://technet.microsoft.com/en-us/windows/bb887300.aspx
>
> Management:
> http://technet.microsoft.com/en-us/windows/aa905063.aspx
>
> Malke
> --
> MS-MVP
> Elephant Boy Computers - Don't Panic!
> FAQ - http://www.elephantboycomputers.com/#FAQ
>
>
 
M

Malke

#6
Tiffany wrote:

> Hi Malke,
>
> I have done the followings
>
> 1) Use the same Workgroup Name for all the laptops and desktops in my
> office 2) set network type to Private
> 3) enabled filing sharing, public folder sharing and printer sharing under
> the Sharing and Discovery section
>
> I try to share a folder by right-click the folder that I want to share and
> then click share. The file sharing window is displayed. I want only
> selected people to be able to access this folder. Hence, i put in the
> names of those who are permitted to access this folder. I typed e.g. AMIN
> and click Add in the Choose people to share with's dialog box. the error
> msg pop up saying unable to locate user AMIN. Nothing wrong with the
> computer name. What could be the problems? Kindly advise
1. Do you have Windows Vista Business or Ultimate?
2. Did you create the matching user accounts and passwords on all machines?
It sounds like you didn't.

Malke
--
MS-MVP
Elephant Boy Computers - Don't Panic!
FAQ - http://www.elephantboycomputers.com/#FAQ
 
T

Tiffany

#7
Hi Malke,

All the laptops or desktop are Window Vista Business.

How to create the matching user accounts and passwords on all machines?
Kindly help.

Thanks!



"Malke" wrote:

> Tiffany wrote:
>

> > Hi Malke,
> >
> > I have done the followings
> >
> > 1) Use the same Workgroup Name for all the laptops and desktops in my
> > office 2) set network type to Private
> > 3) enabled filing sharing, public folder sharing and printer sharing under
> > the Sharing and Discovery section
> >
> > I try to share a folder by right-click the folder that I want to share and
> > then click share. The file sharing window is displayed. I want only
> > selected people to be able to access this folder. Hence, i put in the
> > names of those who are permitted to access this folder. I typed e.g. AMIN
> > and click Add in the Choose people to share with's dialog box. the error
> > msg pop up saying unable to locate user AMIN. Nothing wrong with the
> > computer name. What could be the problems? Kindly advise
>
> 1. Do you have Windows Vista Business or Ultimate?
> 2. Did you create the matching user accounts and passwords on all machines?
> It sounds like you didn't.
>
> Malke
> --
> MS-MVP
> Elephant Boy Computers - Don't Panic!
> FAQ - http://www.elephantboycomputers.com/#FAQ
>
>
 
M

Malke

#8
Tiffany wrote:

> Hi Malke,
>
> All the laptops or desktop are Window Vista Business.
>
> How to create the matching user accounts and passwords on all machines?
> Kindly help.
Assuming this is a Workgroup and not a domain, go to each computer and
Control Panel>Users and create new users. Just the way you always create
users! All the users and passwords must match those on the other computers
if you want to share resources among them.

*****
Create matching user accounts and passwords on all machines. You do not need
to be logged into the same account on all machines and the passwords
assigned to each user account can be different; the accounts/passwords just
need to exist and match on all machines. DO NOT NEGLECT TO CREATE
PASSWORDS, EVEN IF ONLY SIMPLE ONES. If you wish a machine to boot directly
to the Desktop (into one particular user's account) for convenience, you
can do this. The instructions at this link work for both XP and Vista:

Configure Windows to Automatically Login (MVP Ramesh) -
http://windowsxp.mvps.org/Autologon.htm

Malke
--
MS-MVP
Elephant Boy Computers - Don't Panic!
FAQ - http://www.elephantboycomputers.com/#FAQ
 
T

Tiffany

#9
Hi Malke,

I use 2 PCs (one laptop and one desktop, both using Window Vista Business)
in my office for file sharing testing.

I discover the desktop network connection is

ABC (computer name) ----> multiple networks -----> internet

I have created the same workgroup name on both the desktop and the laptop

For the laptop network connection, it is

DEF ----> KK ----> internet

KK is the workgroup name for both PCs.

I have added ABC as standard user on the laptop and DEF on the desktop. have
also assigned password to the user. But still the file sharing does not work.
The error message is the user has no rights to access the folder.

Kindly help.

Thank you!
"Malke" wrote:

> Tiffany wrote:
>

> > Hi Malke,
> >
> > All the laptops or desktop are Window Vista Business.
> >
> > How to create the matching user accounts and passwords on all machines?
> > Kindly help.
>
> Assuming this is a Workgroup and not a domain, go to each computer and
> Control Panel>Users and create new users. Just the way you always create
> users! All the users and passwords must match those on the other computers
> if you want to share resources among them.
>
> *****
> Create matching user accounts and passwords on all machines. You do not need
> to be logged into the same account on all machines and the passwords
> assigned to each user account can be different; the accounts/passwords just
> need to exist and match on all machines. DO NOT NEGLECT TO CREATE
> PASSWORDS, EVEN IF ONLY SIMPLE ONES. If you wish a machine to boot directly
> to the Desktop (into one particular user's account) for convenience, you
> can do this. The instructions at this link work for both XP and Vista:
>
> Configure Windows to Automatically Login (MVP Ramesh) -
> http://windowsxp.mvps.org/Autologon.htm
>
> Malke
> --
> MS-MVP
> Elephant Boy Computers - Don't Panic!
> FAQ - http://www.elephantboycomputers.com/#FAQ
>
>
 
M

Malke

#10
Tiffany wrote:

> Hi Malke,
>
> I use 2 PCs (one laptop and one desktop, both using Window Vista Business)
> in my office for file sharing testing.
>
> I discover the desktop network connection is
>
> ABC (computer name) ----> multiple networks -----> internet
>
> I have created the same workgroup name on both the desktop and the laptop
>
> For the laptop network connection, it is
>
> DEF ----> KK ----> internet
>
> KK is the workgroup name for both PCs.
>
> I have added ABC as standard user on the laptop and DEF on the desktop.
> have also assigned password to the user. But still the file sharing does
> not work. The error message is the user has no rights to access the
> folder.
Then you have permissions set incorrectly on the folder. Since I can't see
what you're doing, I have no idea what you're doing incorrectly. Where is
the folder?

Please refer to this link about Vista sharing to see if you've covered all
the bases:

http://technet.microsoft.com/en-us/library/bb727037.aspx

Malke
--
MS-MVP
Elephant Boy Computers - Don't Panic!
FAQ - http://www.elephantboycomputers.com/#FAQ
 
#11
Tiffany wrote:

> Hi Malke,
>
> I use 2 PCs (one laptop and one desktop, both using Window Vista Business)
> in my office for file sharing testing.
>
> I discover the desktop network connection is
>
> ABC (computer name) ----> multiple networks -----> internet
>
> I have created the same workgroup name on both the desktop and the laptop
>
> For the laptop network connection, it is
>
> DEF ----> KK ----> internet
>
> KK is the workgroup name for both PCs.
>
> I have added ABC as standard user on the laptop and DEF on the desktop.
> have also assigned password to the user. But still the file sharing does
> not work. The error message is the user has no rights to access the
> folder.
Then you have permissions set incorrectly on the folder. Since I can't see
what you're doing, I have no idea what you're doing incorrectly. Where is
the folder?

Please refer to this link about Vista sharing to see if you've covered all
the bases:

File and Printer Sharing in Windows Vista

Malke
--
MS-MVP
Elephant Boy Computers - Don't Panic!
FAQ - index
I believe that the users are created locally and she is trying to add a local user of another computer to access folders on computer 2.

If that's the case tiffany, let's consider you want the user1 of computer1 wants to access folder created by User2 on computer2, then you can try adding the user on the folder computer1 name/user1 name to access folders...

Hope this helps!! ;)