• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

file types for desktop background

S

safyrejet

#1
I change my wallpaper frequently and I usually just go to the file where I
keep my wallpaper, right click on one and select "set as desktop background"
Now that I have Vista this only works with jpg type files. I do not get this
option for my bmp type files. (ironic because isn't bmp for windows
graphics?) I can set the bmp files but I have to go the long way. I need to
open the 'personalize' window for the desktop, select 'desktop background',
and then browse through the files to find the one I want again. Does anyone
else have this problem? It seems to me that Vista has made several things
(there are other areas besides the desktop settings) more difficult to do. I
really don't want to go through all my bmp files and save them as jpg files
to circumvent this problem. That would take alot of time and give me doubles
on many files.

----------------
This post is a suggestion for Microsoft, and Microsoft responds to the
suggestions with the most votes. To vote for this suggestion, click the "I
Agree" button in the message pane. If you do not see the button, follow this
link to open the suggestion in the Microsoft Web-based Newsreader and then
click "I Agree" in the message pane.

http://windowshelp.microsoft.com/co...oft.public.windows.vista.music_pictures_video
 

My Computer

R

Ramesh, MS-MVP

#2
The "Set as Desktop Background" function works fine here for .BMP files as well. There may be due to a missing registry key/value for the BMP file class, or incorrect file association settings for .BMP in your system.

See if applying the .BMP file association fix from here helps.

File association fixes for Windows Vista:
http://www.winhelponline.com/articles/105/1/

--
Regards,

Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
Windows® Troubleshooting http://www.winhelponline.com


"safyrejet" <safyrejet@discussions.microsoft.com> wrote in message news:20E0542A-AE52-4FBD-B1C8-324846E683EE@microsoft.com...
I change my wallpaper frequently and I usually just go to the file where I
keep my wallpaper, right click on one and select "set as desktop background"
Now that I have Vista this only works with jpg type files. I do not get this
option for my bmp type files. (ironic because isn't bmp for windows
graphics?) I can set the bmp files but I have to go the long way. I need to
open the 'personalize' window for the desktop, select 'desktop background',
and then browse through the files to find the one I want again. Does anyone
else have this problem? It seems to me that Vista has made several things
(there are other areas besides the desktop settings) more difficult to do. I
really don't want to go through all my bmp files and save them as jpg files
to circumvent this problem. That would take alot of time and give me doubles
on many files.

----------------
This post is a suggestion for Microsoft, and Microsoft responds to the
suggestions with the most votes. To vote for this suggestion, click the "I
Agree" button in the message pane. If you do not see the button, follow this
link to open the suggestion in the Microsoft Web-based Newsreader and then
click "I Agree" in the message pane.

http://windowshelp.microsoft.com/co...oft.public.windows.vista.music_pictures_video
 

My Computer

S

safyrejet

#3
Wow, that worked. Thanks for showing me how to fix this. I'm not savy
enough on computers to mess with registry fixes and stuff. I'm gonna
bookmark that site in case I end up with problems on other file types. :)

"Ramesh, MS-MVP" wrote:

> The "Set as Desktop Background" function works fine here for .BMP files as well. There may be due to a missing registry key/value for the BMP file class, or incorrect file association settings for .BMP in your system.
>
> See if applying the .BMP file association fix from here helps.
>
> File association fixes for Windows Vista:
> http://www.winhelponline.com/articles/105/1/
>
> --
> Regards,
>
> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
> Windows® Troubleshooting http://www.winhelponline.com
>
>
> "safyrejet" <safyrejet@discussions.microsoft.com> wrote in message news:20E0542A-AE52-4FBD-B1C8-324846E683EE@microsoft.com...
> I change my wallpaper frequently and I usually just go to the file where I
> keep my wallpaper, right click on one and select "set as desktop background"
> Now that I have Vista this only works with jpg type files. I do not get this
> option for my bmp type files. (ironic because isn't bmp for windows
> graphics?) I can set the bmp files but I have to go the long way. I need to
> open the 'personalize' window for the desktop, select 'desktop background',
> and then browse through the files to find the one I want again. Does anyone
> else have this problem? It seems to me that Vista has made several things
> (there are other areas besides the desktop settings) more difficult to do. I
> really don't want to go through all my bmp files and save them as jpg files
> to circumvent this problem. That would take alot of time and give me doubles
> on many files.
>
> ----------------
> This post is a suggestion for Microsoft, and Microsoft responds to the
> suggestions with the most votes. To vote for this suggestion, click the "I
> Agree" button in the message pane. If you do not see the button, follow this
> link to open the suggestion in the Microsoft Web-based Newsreader and then
> click "I Agree" in the message pane.
>
> http://windowshelp.microsoft.com/co...oft.public.windows.vista.music_pictures_video
>
 

My Computer

R

Ramesh, MS-MVP

#4
You're welcome!

--
Regards,

Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
Windows® Troubleshooting http://www.winhelponline.com


"safyrejet" <safyrejet@discussions.microsoft.com> wrote in message news:DA0D86DB-61CE-41C7-A932-A444CE7D004B@microsoft.com...
Wow, that worked. Thanks for showing me how to fix this. I'm not savy
enough on computers to mess with registry fixes and stuff. I'm gonna
bookmark that site in case I end up with problems on other file types. :)

"Ramesh, MS-MVP" wrote:

> The "Set as Desktop Background" function works fine here for .BMP files as well. There may be due to a missing registry key/value for the BMP file class, or incorrect file association settings for .BMP in your system.
>
> See if applying the .BMP file association fix from here helps.
>
> File association fixes for Windows Vista:
> http://www.winhelponline.com/articles/105/1/
>
> --
> Regards,
>
> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
> Windows® Troubleshooting http://www.winhelponline.com
>
>
> "safyrejet" <safyrejet@discussions.microsoft.com> wrote in message news:20E0542A-AE52-4FBD-B1C8-324846E683EE@microsoft.com...
> I change my wallpaper frequently and I usually just go to the file where I
> keep my wallpaper, right click on one and select "set as desktop background"
> Now that I have Vista this only works with jpg type files. I do not get this
> option for my bmp type files. (ironic because isn't bmp for windows
> graphics?) I can set the bmp files but I have to go the long way. I need to
> open the 'personalize' window for the desktop, select 'desktop background',
> and then browse through the files to find the one I want again. Does anyone
> else have this problem? It seems to me that Vista has made several things
> (there are other areas besides the desktop settings) more difficult to do. I
> really don't want to go through all my bmp files and save them as jpg files
> to circumvent this problem. That would take alot of time and give me doubles
> on many files.
>
> ----------------
> This post is a suggestion for Microsoft, and Microsoft responds to the
> suggestions with the most votes. To vote for this suggestion, click the "I
> Agree" button in the message pane. If you do not see the button, follow this
> link to open the suggestion in the Microsoft Web-based Newsreader and then
> click "I Agree" in the message pane.
>
> http://windowshelp.microsoft.com/co...oft.public.windows.vista.music_pictures_video
>
 

My Computer

R

Ramesh, MS-MVP

#5
"Set as Desktop Background" context menu entry missing for .BMP file type:
http://www.winhelponline.com/articles/193/1/

--
Regards,

Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
Windows® Troubleshooting http://www.winhelponline.com


"Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message news:udT6z9BjHHA.392@TK2MSFTNGP06.phx.gbl...
You're welcome!

--
Regards,

Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
Windows® Troubleshooting http://www.winhelponline.com


"safyrejet" <safyrejet@discussions.microsoft.com> wrote in message news:DA0D86DB-61CE-41C7-A932-A444CE7D004B@microsoft.com...
Wow, that worked. Thanks for showing me how to fix this. I'm not savy
enough on computers to mess with registry fixes and stuff. I'm gonna
bookmark that site in case I end up with problems on other file types. :)

"Ramesh, MS-MVP" wrote:

> The "Set as Desktop Background" function works fine here for .BMP files as well. There may be due to a missing registry key/value for the BMP file class, or incorrect file association settings for .BMP in your system.
>
> See if applying the .BMP file association fix from here helps.
>
> File association fixes for Windows Vista:
> http://www.winhelponline.com/articles/105/1/
>
> --
> Regards,
>
> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
> Windows® Troubleshooting http://www.winhelponline.com
>
>
> "safyrejet" <safyrejet@discussions.microsoft.com> wrote in message news:20E0542A-AE52-4FBD-B1C8-324846E683EE@microsoft.com...
> I change my wallpaper frequently and I usually just go to the file where I
> keep my wallpaper, right click on one and select "set as desktop background"
> Now that I have Vista this only works with jpg type files. I do not get this
> option for my bmp type files. (ironic because isn't bmp for windows
> graphics?) I can set the bmp files but I have to go the long way. I need to
> open the 'personalize' window for the desktop, select 'desktop background',
> and then browse through the files to find the one I want again. Does anyone
> else have this problem? It seems to me that Vista has made several things
> (there are other areas besides the desktop settings) more difficult to do. I
> really don't want to go through all my bmp files and save them as jpg files
> to circumvent this problem. That would take alot of time and give me doubles
> on many files.
>
> ----------------
> This post is a suggestion for Microsoft, and Microsoft responds to the
> suggestions with the most votes. To vote for this suggestion, click the "I
> Agree" button in the message pane. If you do not see the button, follow this
> link to open the suggestion in the Microsoft Web-based Newsreader and then
> click "I Agree" in the message pane.
>
> http://windowshelp.microsoft.com/co...oft.public.windows.vista.music_pictures_video
>
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)