• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Games not working.

T

TwoTone

#1
This has happened to a number of games now, most recently Fable.
I have installed them, and when i try to run them it tells me "protection
stub has stopped working"
I am really getting frustrated with vista now.
any recommendations?
 

My Computer

P

Pooh-Man

#2
"TwoTone" <TwoTone@discussions.microsoft.com> wrote in message
news:0B881881-3C91-4BD2-B59C-ED27C31BB462@microsoft.com...
> This has happened to a number of games now, most recently Fable.
> I have installed them, and when i try to run them it tells me "protection
> stub has stopped working"
> I am really getting frustrated with vista now.
> any recommendations?



Try this. Right click the shortcut and select to run them in administrator
mode.
 

My Computer

T

Torbjörn Nyström / Pharoe Islands :)

#3
I've tried that a large number of times. The run as administrator thing.
And also run as XP2.
Still not working.
Not even Microsofts own games, like Rise of Nation and Rise of Legends

Have to admit that Vista have not convinced me yet.
1. My games don't work.
2. My computer has two speeds: slow and very slow.
3. So search-minded, I can't find what I'm looking for.

No, if I can't get it fixed soon, I'll just have too admit my money is lost.
Buying Vista was a mistake.
I'm nothing but a guinea-pig for the Giant who produced and marketed such a
crappy OS.




"Pooh-Man" wrote:

> "TwoTone" <TwoTone@discussions.microsoft.com> wrote in message
> news:0B881881-3C91-4BD2-B59C-ED27C31BB462@microsoft.com...
> > This has happened to a number of games now, most recently Fable.
> > I have installed them, and when i try to run them it tells me "protection
> > stub has stopped working"
> > I am really getting frustrated with vista now.
> > any recommendations?

>
>
> Try this. Right click the shortcut and select to run them in administrator
> mode.
>
>
 

My Computer

V

Vroya

#4
Found the fix!...here's what worked for me finally:


Control Panel ->System-> Advanced System Settings -> Advanced Tab ->
Performance -> Settings ->Data Execution Prevention tab -> Activate
only "Turn on DEP for essential Windows programs and services only"

Apply...restart computer.

Alternatively - you can also check "Turn on DEP for all programs and
services except those I select:" -> Click on Add... and browse for the
game program that is giving you the protection stub error.

This problem really confused me as my computer gave me no problems at
all installing and running many of the problem games. My wife's laptop
tho gave me all kinds of difficulties. Both running Vista, equal RAM,
comparable video and CPU.

Looked for hours before I finally figured this out. Funny thing is
no-one has posted it for others except in one spot. Will be posting
this all over the net so others don't have to go through as much
frustration in the future.


--
Vroya
------------------------------------------------------------------------
Vroya's Profile: http://forums.techarena.in/member.php?userid=31931
View this thread: http://forums.techarena.in/showthread.php?t=793959

http://forums.techarena.in
 

My Computer

A

Andy [YaYa]

#5
"Vroya" <Vroya.2xmjjd@xxxxxx> wrote in message
news:Vroya.2xmjjd@xxxxxx

>
> Found the fix!...here's what worked for me finally:
>
>
> Control Panel ->System-> Advanced System Settings -> Advanced Tab ->
> Performance -> Settings ->Data Execution Prevention tab -> Activate
> only "Turn on DEP for essential Windows programs and services only"
>
> Apply...restart computer.
>
> Alternatively - you can also check "Turn on DEP for all programs and
> services except those I select:" -> Click on Add... and browse for the
> game program that is giving you the protection stub error.
>
> This problem really confused me as my computer gave me no problems at
> all installing and running many of the problem games. My wife's laptop
> tho gave me all kinds of difficulties. Both running Vista, equal RAM,
> comparable video and CPU.
>
> Looked for hours before I finally figured this out. Funny thing is
> no-one has posted it for others except in one spot. Will be posting
> this all over the net so others don't have to go through as much
> frustration in the future.
>
Reason no one posts it, is because as I understand it DEP prevents rootkits
and other nastyness from installing on your computer. It does more than
that, but from what some people have told me, you only want to turn this off
as a last resort, and only turn it off for programs you trust.

I had issues with some Steam games recently and where DEP helped some
people, it did not help my situation. You might also want to run a memory
test on your system (google: Memtest86).

Maybe an MVP can chime in here. Don't get me wrong, i'm glad this fixed your
problem, but for everyone else, only do this as a last resort. Check with
the software manufacturer first to make sure they don't have software fixes
for your program before you open up holes in your OS.

-A.
 

My Computer

D

Dave Angel

#6
Yeah temporarily turning it off to troubleshoot certain applications may be
necessary at times but I'd reenable it as soon as you are done testing
certain game and just add it to the list of exceptions.
Well I personally learned about this issue thanks to HL2 and steam not
liking it on my Vista computer.
I"m seeing alot more articles about in on the net now so I guess others are
starting to find out about it and yeah I think it gives Vista a bad game
since the few games I have had it on HL2,FEAR,AOE3 are some of the most
popular games so when someone trys to play them on Vista and they don't run
people automatically think Vista+games don't mix!

http://windowssecrets.com/2007/05/03/01-How-DEP-can-protect-your-PC

Although the DEP is supposed to display a message indicating when it has
shut down an errant program, some sources claim that the messages don't
always appear, and that DEP can sometimes even prevent programs (especially
installers) from launching. These sources go so far as to recommend turning
off DEP entirely.

Such advice is like throwing out the proverbial baby with the bathwater. If
you do have problems with applications that end abnormally or won't run, you
can always return to the Performance Options dialog to turn off DEP
temporarily as a test. This can help you get your software installed, for
example, if an installer won't run.

Overall, you're much better off making exceptions for a few problem programs
(and reporting the difficulty to the manufacturer) than shutting down DEP
entirely.

Finally, you should look at DEP as only one weapon in your security arsenal.
DEP adds an important layer of protection, but it isn't a reason to give up
your other security tools.


"Andy [YaYa]" <android8675@xxxxxx> wrote in message
news:02511F66-7436-4810-8D93-D00D2BBD83A2@xxxxxx

> "Vroya" <Vroya.2xmjjd@xxxxxx> wrote in message
> news:Vroya.2xmjjd@xxxxxx

>>
>> Found the fix!...here's what worked for me finally:
>>
>>
>> Control Panel ->System-> Advanced System Settings -> Advanced Tab ->
>> Performance -> Settings ->Data Execution Prevention tab -> Activate
>> only "Turn on DEP for essential Windows programs and services only"
>>
>> Apply...restart computer.
>>
>> Alternatively - you can also check "Turn on DEP for all programs and
>> services except those I select:" -> Click on Add... and browse for the
>> game program that is giving you the protection stub error.
>>
>> This problem really confused me as my computer gave me no problems at
>> all installing and running many of the problem games. My wife's laptop
>> tho gave me all kinds of difficulties. Both running Vista, equal RAM,
>> comparable video and CPU.
>>
>> Looked for hours before I finally figured this out. Funny thing is
>> no-one has posted it for others except in one spot. Will be posting
>> this all over the net so others don't have to go through as much
>> frustration in the future.
>>
>
> Reason no one posts it, is because as I understand it DEP prevents
> rootkits and other nastyness from installing on your computer. It does
> more than that, but from what some people have told me, you only want to
> turn this off as a last resort, and only turn it off for programs you
> trust.
>
> I had issues with some Steam games recently and where DEP helped some
> people, it did not help my situation. You might also want to run a memory
> test on your system (google: Memtest86).
>
> Maybe an MVP can chime in here. Don't get me wrong, i'm glad this fixed
> your problem, but for everyone else, only do this as a last resort. Check
> with the software manufacturer first to make sure they don't have software
> fixes for your program before you open up holes in your OS.
>
> -A.
 

My Computer