• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

How to turn off wake up on USB in Vista

A

Andrew

#1
Hello!

When my computer is in sleep mode it wakes up, when I'm pluging or unpluging
USB device, otherwise in XP it continues to sleep. How could I turn automatic
wake up off? I don't want to install XP again. It is very important to me,
because I charge my cell phone using USB cable, and autowakeup I don't need.

My motherboard is ASUS P5LD2 with 945P Chipset, BIOS version 1804, sleep
mode is S3 (maybe).

THX for reading.


From Russia with love, Andrew. :-)
 
F

freddy

#2
Andrew,

The following is a copy of a Microsoft article (copied most of it):

The computer wakes when you remove a device from a computer that is running
Windows Vista.

View products that this article applies to. Article ID : 935267 Last Review
: April 3, 2007 Revision : 1.0\

SYMPTOMS
When you remove a device from a Windows Vista-based computer that is asleep,
the computer wakes. For example, the computer wakes when you remove a USB
keyboard or a USB mouse.

You may not notice when a portable computer that has its lid closed has
awakened. Therefore, battery power may be consumed.
Back to the top

CAUSE
This problem occurs because the default configuration of a device in Windows
Vista lets it wake the computer.
Back to the top

WORKAROUND
To work around this problem, use Device Manager to prevent the device from
waking the computer. To do this, follow these steps:1. Click Start, type
devmgmt.msc in the Start Search box, and then click devmgmt.msc in the
Programs list.

If you are prompted for an administrator password or for confirmation, type
your password, or click Continue.
2. In Device Manager, right-click the device, and then click Properties.

Note To find a USB keyboard or a USB mouse, expand Human Interface Devices.
3. Click the Power Management tab.
4. Click to clear the Allow this device to wake the computer check box.
5. Click OK.

Back to the top

STATUS
Microsoft has confirmed that this is a problem in the Microsoft products
that are listed in the "Applies to" section.
Back to the top


--------------------------------------------------------------------------------

APPLIES TO
• Windows Vista Home Basic
• Windows Vista Home Premium
• Windows Vista Ultimate
• Windows Vista Business
• Windows Vista Enterprise
• Windows Vista Starter
• Windows Vista Home Basic 64-bit edition
• Windows Vista Home Premium 64-bit edition
• Windows Vista Ultimate 64-bit edition
• Windows Vista Business 64-bit edition
• Windows Vista Enterprise 64-bit edition
--
freddy


"Andrew" wrote:

> Hello!
>
> When my computer is in sleep mode it wakes up, when I'm pluging or unpluging
> USB device, otherwise in XP it continues to sleep. How could I turn automatic
> wake up off? I don't want to install XP again. It is very important to me,
> because I charge my cell phone using USB cable, and autowakeup I don't need.
>
> My motherboard is ASUS P5LD2 with 945P Chipset, BIOS version 1804, sleep
> mode is S3 (maybe).
>
> THX for reading.
>
>
> From Russia with love, Andrew. :-)
 
F

freddy

#4
Andrew,

Yes, not all devices have a power option in its Properties, but some do, and
I was hoping that your device did. for instance, on my system, the NIC
(under Network adapters) also has such a tab for power settings, so there are
more possibilities than keyboard and mouse.

In Device Manager, under Universal Serial Bus Controllers, all the USB Root
Hubs have a Power tab. I don't know whether your issue can be addressed by
checking how those are set, but you can look it over to see what happens.

Off hand, I don't know of any updates specifically for addressing your
problem, but make sure you have downloaded all the updates available on the
Microsoft update site. You can try using google to search the Internet. You
never know whether someone has posted a solution. Anyone else?
--
freddy


"Andrew" wrote:

> freddy,
>
> There is no such option for all of the devices, only for mouse, keyboard,
> build-in modem. Here is screehshot:
> http://img505.imageshack.us/img505/1483/usbsettingsuu8.png
>
> Maybe there is an update? :)
 
A

Andrew

#5
freddy,

I found the same problem here:
http://windowshelp.microsoft.com/co...b9606c2&cat=&lang=en&cr=US&sloc=en-us&m=1&p=1 , but there were no solution too.
I tried Google.ru, yandex.ru (in Russian), but search returned little
results and they contained information like you game me. :(

USB Root Hubs have a Power tab, but "Allow this device to wake the computer"
is unchecked there and it is grey, so i can't change it.

Additionaly I tried look through registry and discovered, that dword
"WaitWakeEnabled" controls exactly this function. But by default it is
located only in keys, where this function is available in Device Manager,
adding it to other devices keys changed nothing.

Maybe I should contact developers? How can I do it?

Thanks for answering.
 
F

freddy

#7
Andrew,

I'm sorry you can't configure your computer to get the behavior you desire.
I'm out of ideas, so I can't provide any more guidance. My last word: If I
had this problem, I would only plug/unplug USB devices while the computer was
awake. Can you do your work that way. I give up.
--
freddy


"Andrew" wrote:

> Some updates concerning USB I downloaded, but they did nothing.
 
F

freddy

#9
Andrew,

Sometimes I have an idea after I say I have no more ideas: For example,
review your BIOS settings for any configuration that enables "wake on"
situations. If you have any such situations, disable them.

In addition, review your settings in Control Panel > Power. If you find any
event configured to wake your computer, deselect that setting.

If you need to refresh your knowledge about power management, use Windows
Help and Support under Start. Launch that and search on Power Settings, or
something similar. You'll find plenty of information about power management
in Vista.

Updating BIOS to the most recent version should also be considered. Updated
BIOS is important to be able to interface with the demanding Vista
requirements.

If you have already completed any of these suggestions, please disregard
those comments that don't apply.
--
freddy


"Andrew" wrote:

> Does somebody else have such problem?
 
A

Andrew

#10
freddy,

> review your BIOS settings for any configuration that enables "wake on"
> situations. If you have any such situations, disable them.

There is only power up options, and all of them are disabled. I reviewed
every USB and Power setting, but I didn't find anything helpfull.

> In addition, review your settings in Control Panel > Power. If you find any
> event configured to wake your computer, deselect that setting.

There is nothing conserning wake up by USB.

> If you need to refresh your knowledge about power management, use Windows
> Help and Support under Start. Launch that and search on Power Settings, or
> something similar. You'll find plenty of information about power management
> in Vista.

I looked it though several times...

> Updating BIOS to the most recent version should also be considered. Updated
> BIOS is important to be able to interface with the demanding Vista
> requirements.

Updated to the latest vesrion. :(


It's Windows Vista problem!
 
F

freddy

#11
Andrew,

I'm trying to help by working on eliminating any variables that could impact
on your situation. It's hard to be certain as to what the problem is, so
sometimes one needs to think outside the box. If I have any more
suggestions, I'll post them. What you do about them is up to you.
--
freddy


"Andrew" wrote:

> freddy,
>
> > review your BIOS settings for any configuration that enables "wake on"
> > situations. If you have any such situations, disable them.

> There is only power up options, and all of them are disabled. I reviewed
> every USB and Power setting, but I didn't find anything helpfull.
>
> > In addition, review your settings in Control Panel > Power. If you find any
> > event configured to wake your computer, deselect that setting.

> There is nothing conserning wake up by USB.
>
> > If you need to refresh your knowledge about power management, use Windows
> > Help and Support under Start. Launch that and search on Power Settings, or
> > something similar. You'll find plenty of information about power management
> > in Vista.

> I looked it though several times...
>
> > Updating BIOS to the most recent version should also be considered. Updated
> > BIOS is important to be able to interface with the demanding Vista
> > requirements.

> Updated to the latest vesrion. :(
>
>
> It's Windows Vista problem!
 
F

freddy

#12
Andrew,

If you are still looking here, please post you question again using a
current date. I may have found an answer for your question, but I don't know
how to get in touch with you. Perhaps you have resolved your problem, in
which case ignore this post.
--
freddy


"Andrew" wrote:

> Hello!
>
> When my computer is in sleep mode it wakes up, when I'm pluging or unpluging
> USB device, otherwise in XP it continues to sleep. How could I turn automatic
> wake up off? I don't want to install XP again. It is very important to me,
> because I charge my cell phone using USB cable, and autowakeup I don't need.
>
> My motherboard is ASUS P5LD2 with 945P Chipset, BIOS version 1804, sleep
> mode is S3 (maybe).
>
> THX for reading.
>
>
> From Russia with love, Andrew. :-)
 
D

Draunkin@gmail.com

#13
On Jun 14, 2:21 am, freddy <fkirsc...@tidalwave.net> wrote:
> Andrew,
>
> The following is a copy of a Microsoft article (copied most of it):
>
> The computerwakeswhen you remove a device from a computer that is running
> WindowsVista.
>
> View products that this article applies to. Article ID : 935267 Last Review
> : April 3, 2007 Revision : 1.0\
>
> SYMPTOMS
> When you remove a device from a WindowsVista-based computer that is asleep,
> the computerwakes. For example, the computerwakeswhen you remove a USB
> keyboard or a USB mouse.
>
> You may not notice when a portable computer that has its lid closed has
> awakened. Therefore, battery power may be consumed.
> Back to the top
>
> CAUSE
> This problem occurs because the default configuration of a device in WindowsVistalets it wake the computer.
> Back to the top
>
> WORKAROUND
> To work around this problem, use Device Manager to prevent the device from
> waking the computer. To do this, follow these steps:1. Click Start, type
> devmgmt.msc in the Start Search box, and then click devmgmt.msc in the
> Programs list.
>
> If you are prompted for an administrator password or for confirmation, type
> your password, or click Continue.
> 2. In Device Manager, right-click the device, and then click Properties.
>
> Note To find a USB keyboard or a USB mouse, expand Human Interface Devices.
> 3. Click the Power Management tab.
> 4. Click to clear the Allow this device to wake the computer check box.
> 5. Click OK.





freddy,

Thank you muchly, this has fixed my problem. I saw that the USB root
hub woke my pc up all the time, found that both my keyboard and mouse
were set to wake up the pc in their power management tab under the
device manager. Changed them to not wake and have no more problems.

Cheers mate,
Draunkin.