IE7, JavaScript, Information Bar

P

Puppy Breath

I created a simple page with some simple JavaScript which I'd only run from
my own computer. But even so, the IE7 Information Bar pops up the "To help
protect you security, IE has restricted this webpage from running scripts or
ActiveX controls that could access your computer...".

Ugh, I'd really rather not have to see and click that every time I open this
page. But even though I keep tweaking back the security settings, I still
get the warning. What, if anything, can I do in IE 7 to be able to run
JavaScript code in pages on my own computer?

(If I run the page from Visual Studio and its built-in Web server, I don't
get the into bar. But I'd like to open this page from a desktop icon and
Windows).

TIA
 

My Computer

P

Puppy Breath

Sorry, this is not the newgroup I intended to post this to.

"Puppy Breath" <[email protected]> wrote in message
news:%[email protected]
>I created a simple page with some simple JavaScript which I'd only run from
>my own computer. But even so, the IE7 Information Bar pops up the "To help
>protect you security, IE has restricted this webpage from running scripts
>or ActiveX controls that could access your computer...".
>
> Ugh, I'd really rather not have to see and click that every time I open
> this page. But even though I keep tweaking back the security settings, I
> still get the warning. What, if anything, can I do in IE 7 to be able to
> run JavaScript code in pages on my own computer?
>
> (If I run the page from Visual Studio and its built-in Web server, I don't
> get the into bar. But I'd like to open this page from a desktop icon and
> Windows).
>
> TIA
>
>
>
 

My Computer

D

dean-dean

IE7 > Tools >internet Options, on the Advanced tab, under the heading
"Security", check "Allow active content to run in files on My Computer".

"Puppy Breath" <[email protected]> wrote in message
news:%[email protected]
>I created a simple page with some simple JavaScript which I'd only run from
>my own computer. But even so, the IE7 Information Bar pops up the "To help
>protect you security, IE has restricted this webpage from running scripts
>or ActiveX controls that could access your computer...".
>
> Ugh, I'd really rather not have to see and click that every time I open
> this page. But even though I keep tweaking back the security settings, I
> still get the warning. What, if anything, can I do in IE 7 to be able to
> run JavaScript code in pages on my own computer?
>
> (If I run the page from Visual Studio and its built-in Web server, I don't
> get the into bar. But I'd like to open this page from a desktop icon and
> Windows).
>
> TIA
>
>
>
 

My Computer

P

Puppy Breath

Sheesh, thanks. Figures it was right in front of my face and a scrolled
right past it.


"dean-dean" <[email protected]> wrote in message
news:[email protected]
> IE7 > Tools >internet Options, on the Advanced tab, under the heading
> "Security", check "Allow active content to run in files on My Computer".
>
> "Puppy Breath" <[email protected]> wrote in message
> news:%[email protected]
>>I created a simple page with some simple JavaScript which I'd only run
>>from my own computer. But even so, the IE7 Information Bar pops up the "To
>>help protect you security, IE has restricted this webpage from running
>>scripts or ActiveX controls that could access your computer...".
>>
>> Ugh, I'd really rather not have to see and click that every time I open
>> this page. But even though I keep tweaking back the security settings, I
>> still get the warning. What, if anything, can I do in IE 7 to be able to
>> run JavaScript code in pages on my own computer?
>>
>> (If I run the page from Visual Studio and its built-in Web server, I
>> don't get the into bar. But I'd like to open this page from a desktop
>> icon and Windows).
>>
>> TIA
>>
>>
>>

>
 

My Computer

Top