IE8 bug: default accelerator for translations Live Search in arabic-english

hexaae

Member
I've just upgraded from IE7/Vista SP1, x86, ITA to IE8.
Everything works fine except one thing: IE8's Live Search accelerator to tranlsate text is in arabic-english as default instead of the expected english-italian. If I change to english-italian settings won't be saved.

If I use InPrivate browsing or disable Protected mode it's ok instead.

This problems has been already reported by other users some months ago with the betas: Microsoft Translator Official Team Blog : IE8 Beta 2 - Translation Accelerator
 

My Computer

System One

  • Manufacturer/Model
    HP Pavilion dv5-1110el
    CPU
    Intel T5800 Core 2 Duo 2GHz
    Motherboard
    Quanta 3603
    Memory
    4GB
    Graphics Card(s)
    GeForce 9600M GT (Forceware 189.06)
    Screen Resolution
    1280x800
    Hard Drives
    Hitachi 2,5" 5400RPM

hexaae

Member
Solved!
Have had to delete EVERYTHING from Tools/Delete Browsing History, EXcluding only first checkmark option!
Deleting cookies more and more times was not enough!
 

My Computer

System One

  • Manufacturer/Model
    HP Pavilion dv5-1110el
    CPU
    Intel T5800 Core 2 Duo 2GHz
    Motherboard
    Quanta 3603
    Memory
    4GB
    Graphics Card(s)
    GeForce 9600M GT (Forceware 189.06)
    Screen Resolution
    1280x800
    Hard Drives
    Hitachi 2,5" 5400RPM
Top