• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Internet links will not open in Windows Mail

kito

New Member
#1
My problem is that I can't open IE7 links from within WinMail anymore. I've looked here and elsewhere for a solution ('Windows cannot find 'http -/- html'. Make sure you typed the name correctly, and then try again'). From this and other events, I suspect this is a permissions issue. Any ideas?


George
 

kito

New Member
#3
Re: TrustedInstaller - Restore as Owner

Thanks for your reply.
I tried the IE default program settings, but it doesn't seem to have made WinMail 'communicate' with it. For example, I get Windows cannot find 'http://www.vistax64.com/showthread.php?t=159360&goto=newpost'. Make sure you typed the name correctly, and then try again from your message.

I also tried resetting WinMail, via your excellent guide, still with no 'linking' result.

The problem seemed to start after I had to install an ActiveX item to download a GeForce driver from nVidia's official site -- 'seemed' because I was also updating Creative SB X-Fi driver / utilities at around the same time.

Since then, there seem to be more '(a program) has stopped working
Windows is checking for a solution to the problem...' alerts than before.

So I wonder if something in IE7 has become corrupted, or whether this was a system-wide problem (e.g. permissions).

So, a couple of questions:
(i) Can IE be removed from the registry and 'reset'/restored as with the WinMail guide?
(ii) Have you (or any other Vista users) noticed this problem in relation to ActiveX or driver installation?

Any help appreciated before I resort to repairing Vista :cry:
George
 

Brink

Staff member
mvp
#4
Re: TrustedInstaller - Restore as Owner

George,

Double check your settings in Windows Mail (Tools - Options), in the Security tab to make sure that Internet Zone is dotted and to uncheck Do not allow attachments.... and Block images and other .....

Are you able to copy the link from Windows Mail and manually paste it in the Internet Explorer address bar and it opens that page then?

This will show you how to reset IE7 if needed.

http://www.vistax64.com/tutorials/114310-internet-explorer-reset.html

Hope this helps,
Shawn
 

kito

New Member
#5
Yes, copying the link works; however, relaxing WinMail security settings gives the same result.

Tried resetting IE7, no difference.
Installed and tried IE8, same story.

I note that trying to open internet shortcut (.url) files directly from the Favorites folder produces the same 'Windows cannot find...' message. But will open .xps files, so doubt it's a file association/extension issue - maybe a Windows Explorer problem?
 

Brink

Staff member
mvp
#6
I would leave your WinMail security settings relaxed to be able to open links when you click on them.

Does opening Favorites from within IE7 work fine? Have you doublechecked the links that you get this message on to make sure that they are valid addresses?
 

kito

New Member
#7
Sorry, maybe my answer wasn't too clear - I still can't open (any) links from WinMail, even with relaxed security settings.

Favorites from within IE7 work as normal. Links checked; all valid urls.

A bit of a Vista mystery...
 

Brink

Staff member
mvp
#8
You might check your antivirus and other security program to see if they have any sort of Windows Mail filtering feature turned on. If they do, try disabling that setting and/or the program itself temporarily to see if it is interfering.
 

kito

New Member
#9
Hello again. I've found the cause, but not a complete solution.
The problem appears to be related to User Account Control.

[-] Disabling UAC allows direct opening of .url links from (a) within WinMail, (b) the Favorites folder on the Start Menu, and (c) the Favorites folder in Windows Explorer.

[+] Enabling UAC prevents these actions.

I'm sure it didn't always behave this way. Does this happen to anyone else?
My feeling is that something has become corrupted.

I've also tried:
1 Checking antivirus/security settings: they don't seem to affect this.
2 Elevating Administrator Privilege
3 Enable Hidden Built-In Administrator Account
4 Uninstalling SP1 (didn't complete).

So, while disabling UAC - or 3, above - fixes the problem, it's not the most secure solution.

Many thanks for your dedicated help, anyway, Shawn. Good luck to anyone who encounters this problem or finds a fix for it!

George
 

Brink

Staff member
mvp
#10
Thank you George for posting back the results you have found. I'm not sure what else to try either. Hopefully someone will know if a better solution for you.