• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Internet Security Warning - "The server you are connected to is ..

P
#1
As of last month I have been getting the following message on all accounts
that use SSL in Windows Live Mail Desktop:

"The server you are connected to is using a security certificate that could
not be verified.
A certificate chain processed, but terminated in a root certificate which is
not trusted by the trust provider.
Do you want to continue using this server?"

This happened on three accounts:
1) Gmail
POP3: pop.gmail.com - Port 995
SMTP: smtp.gmail.com - Port 465
2) Oxford Nexus
IMAP: imap.nexus.ox.ac.uk - Port 993
SMTP: smtp.ox.ac.uk - Port 587
3) Mail from a shared hosting server
POP3: renat.x10hosting.com - Port 995
SMTP: renat.x10hosting.com - Port 465

All the above accounts stopped working on the same day last month. If I
click "Yes", then the mail is downloaded as it should be, and I can sync mail
from that server for the rest of the session.
Since then I have set up forwarding from each of my e-mail accounts to my
hotmail address, which is less than ideal as this requires me to use the web
interface for each of the other services to reply to e-mails sent to them.
 

My Computer

I

Ildhund

#2
"Paul" <Paul@newsgroup> wrote in message news:9D29CF57-182D-4701-906C-55579926C730@newsgroup

> As of last month I have been getting the following message on all accounts that use SSL in Windows Live Mail Desktop:
>
> "The server you are connected to is using a security certificate that could not be verified.
> A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider.
> Do you want to continue using this server?"
>
> This happened on three accounts:
> 1) Gmail
> POP3: pop.gmail.com - Port 995
> SMTP: smtp.gmail.com - Port 465
> 2) Oxford Nexus
> IMAP: imap.nexus.ox.ac.uk - Port 993
> SMTP: smtp.ox.ac.uk - Port 587
> 3) Mail from a shared hosting server
> POP3: renat.x10hosting.com - Port 995
> SMTP: renat.x10hosting.com - Port 465
>
> All the above accounts stopped working on the same day last month. If I click "Yes", then the mail is downloaded as it should be, and I can
> sync mail from that server for the rest of the session.
> Since then I have set up forwarding from each of my e-mail accounts to my hotmail address, which is less than ideal as this requires me to use
> the web interface for each of the other services to reply to e-mails sent to them.
Is your computer clock accurate, date and time?
--
Noel
 

My Computer

P
#3
Re: Internet Security Warning - "The server you are connected to ...

"Ildhund" wrote:

> Is your computer clock accurate, date and time?
> --
> Noel
>
> .
Thanks for the response Noel,

I checked with all servers available in the Date and Time settings, and
various other sources, and am confident that the computer clock / date and
time is accurate.

I also tried one of the above accounts on a different machine (Windows XP
(x86) Service Pack 3, my machine is Windows 7 (x64)) and had the same error
message.
 

My Computer

G

Gary VanderMolen [MVP]

#4
Re: Internet Security Warning - "The server you are connected to ...

Verify your time zone setting. I believe your time zone should be
GMT 0000 (England).

Also, look under Tools, Safety Options, Security, make sure neither of the last
two boxes is checked, then click on Digital IDs and make sure none are listed.

--
Gary VanderMolen, Microsoft MVP (Mail)
Microsoft MVP Program: http://mvp.support.microsoft.com


"Paul" <Paul@newsgroup> wrote in message news:DD1260BC-1E83-486E-BDA8-8F7E2C8E02E6@newsgroup

> "Ildhund" wrote:

>> Is your computer clock accurate, date and time?
>> --
>> Noel
>>
>> .
>
> Thanks for the response Noel,
>
> I checked with all servers available in the Date and Time settings, and
> various other sources, and am confident that the computer clock / date and
> time is accurate.
>
> I also tried one of the above accounts on a different machine (Windows XP
> (x86) Service Pack 3, my machine is Windows 7 (x64)) and had the same error
> message.
 

My Computer

P
#5
Re: Internet Security Warning - "The server you are connected to .

"Gary VanderMolen [MVP]" wrote:

> Verify your time zone setting. I believe your time zone should be
> GMT 0000 (England).
>
> Also, look under Tools, Safety Options, Security, make sure neither of the last
> two boxes is checked, then click on Digital IDs and make sure none are listed.
>
> --
> Gary VanderMolen, Microsoft MVP (Mail)
> Microsoft MVP Program: http://mvp.support.microsoft.com
My timezone is (UTC) Dublin, Edinburgh, Lisbon, London.

Neither "Encrypt contents and attachments ..." or "Digitally sign all
outgoing messages" is checked, and there are no Digital IDs listed under the
"Personal" and "Other People" tabs. There are a number listed under the
"Intermediate Certification Authorities", "Trusted Root Certification
Authorities", and one listed under "Trusted Publishers".
 

My Computer

I

Ildhund

#6
Re: Internet Security Warning - "The server you are connected to ...

"Paul" <Paul@newsgroup> wrote in message news:DD1260BC-1E83-486E-BDA8-8F7E2C8E02E6@newsgroup

> "Ildhund" wrote:

>> Is your computer clock accurate, date and time?

> Thanks for the response Noel,
>
> I checked with all servers available in the Date and Time settings, and various other sources, and am confident that the computer clock / date and time is accurate.
>
> I also tried one of the above accounts on a different machine (Windows XP (x86) Service Pack 3, my machine is Windows 7 (x64)) and had the same error message.
OK. I don't pretend to know the first thing about certification, but if your computer date is awry, a certificate which hasn't yet expired might look as if it has and you would probably get the error you describe. So that's a first troubleshooting step.

Root certificates (stored on your computer) are usually updated automatically as required; i.e. Windows calls home to check whether a certificate is still valid. This process can be disabled through Group Policy, though, and may have been if, say, the machines you're using have been configured by some institutional IT tech (OU?). So that's another thing to check. In XP, this would involve
* Start > Run > gpedit.msc
* Computer Configuration > Administrative Templates > System > Internet Communication Management > Internet Communication settings.
Turn off Automatic Root Certificates Update would be Enabled if that's your problem. I've no idea whether there's anything similar in W7.

And the last thing to check: Windows Update regularly offers an optional Root Certificates Update. If you have Automatic Updates configured, you won't see it - only by visiting the WU site. The last was in November 2009, I think.

That should keep you busy for a bit. You could try googling windows root certificate update to get lots of reading material.
--
Noel
 

My Computer

P
#7
Re: Internet Security Warning - "The server you are connected to .

"Ildhund" wrote:

> OK. I don't pretend to know the first thing about certification, but if your computer date is awry, a certificate which hasn't yet expired might look as if it has and you would probably get the error you describe. So that's a first troubleshooting step.
>
> Root certificates (stored on your computer) are usually updated automatically as required; i.e. Windows calls home to check whether a certificate is still valid. This process can be disabled through Group Policy, though, and may have been if, say, the machines you're using have been configured by some institutional IT tech (OU?). So that's another thing to check. In XP, this would involve
> * Start > Run > gpedit.msc
> * Computer Configuration > Administrative Templates > System > Internet Communication Management > Internet Communication settings.
> Turn off Automatic Root Certificates Update would be Enabled if that's your problem. I've no idea whether there's anything similar in W7.
>
> And the last thing to check: Windows Update regularly offers an optional Root Certificates Update. If you have Automatic Updates configured, you won't see it - only by visiting the WU site. The last was in November 2009, I think.
>
> That should keep you busy for a bit. You could try googling windows root certificate update to get lots of reading material.
> --
> Noel
Thanks again Noel.

The problem seems to be fixed now.

The step which seemed to fix it was to go to gpedit.msc (this does exist in
Windows 7) and check the "Turn off Automatic Root Certificates Update." The
option was previously on "Not configured," and I changed it to "Disabled."

The problem still exists on my shared hosting server, but I imagine that
that is a problem with their certificate given that the other accounts have
started working again.

Many thanks again to you both, Gary and Neil.

Paul
 

My Computer

G

Gary VanderMolen [MVP]

#8
Re: Internet Security Warning - "The server you are connected to .

Well, you've got me stumped then. Sorry, no further ideas.

--
Gary VanderMolen, Microsoft MVP (Mail)
Microsoft MVP Program: http://mvp.support.microsoft.com


"Paul" <Paul@newsgroup> wrote in message news:32624A2A-293A-4BDA-AD69-CE31131195A9@newsgroup

> "Gary VanderMolen [MVP]" wrote:

>> Verify your time zone setting. I believe your time zone should be
>> GMT 0000 (England).
>>
>> Also, look under Tools, Safety Options, Security, make sure neither of the last
>> two boxes is checked, then click on Digital IDs and make sure none are listed.
>>
>> --
>> Gary VanderMolen, Microsoft MVP (Mail)
>> Microsoft MVP Program: http://mvp.support.microsoft.com
>
> My timezone is (UTC) Dublin, Edinburgh, Lisbon, London.
>
> Neither "Encrypt contents and attachments ..." or "Digitally sign all
> outgoing messages" is checked, and there are no Digital IDs listed under the
> "Personal" and "Other People" tabs. There are a number listed under the
> "Intermediate Certification Authorities", "Trusted Root Certification
> Authorities", and one listed under "Trusted Publishers".
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)