• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

JIT Debugger

S

Stumped

#1
Hi All,
I'm trying to run MS WW Telescope but keep receiving the following error
message:

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

How do I enable the JIT Debugger? Simple language for a simple person
please...
 
C

Charlie42

#2
"Stumped" <batus8370@xxxxxx> wrote:

> I'm trying to run MS WW Telescope but keep receiving the following
> error message:
>
> When JIT debugging is enabled, any unhandled exception
> will be sent to the JIT debugger registered on the computer
> rather than be handled by this dialog box.
>
> How do I enable the JIT Debugger? Simple language for a simple person
I believe you have to install the .NET Framework SDK (Software Developer
Kit), this debugger does not come with Vista. Fetch it from MS Download
Center:

http://www.microsoft.com/downloads/

You must enable the debugger in the machine.config file in the .NET 2.0
CONFIG folder in %WinDir%\Microsoft.NET. Adding this line in the
<configuration> section should enable it:

<system.windows.forms jitDebugging="true" />

Charlie42
 
#3
;)I did the windows.systems .forms trick in the .net 2.0 folder. I used notepad to add the line in the machine config folder and it seems to be working. I am using a Meade LPI camera on a Meade telescope with Envisage software. It has been a trip. I had to edit the resgistry in Vista also to make it work. Envisage in Vista did not recognize Meade LPI. When I plugged the Meade LPI into USB, Vista loaded drivers and called it Trust Webcam 14823. I went into the registry and renamed all the instances of Trust Webcam 14823 to Meade LPI. Envisage then recognized the Meade LPI, and that is when the "unhandled exception" box popped up. Thanks to Charlie 42, Meade LPI seems to be working, however the.png picture format does not work. Meade has no solution for LPI and Vista.
 
C

Charlie42

#4
"cdo10" <guest@xxxxxx-email.com> wrote:

> ;)I did the windows.systems .forms trick in the .net 2.0 folder. I used
> notepad to add the line in the machine config folder and it seems to be
> working. I am using a Meade LPI camera on a Meade telescope with
> Envisage software. It has been a trip. I had to edit the resgistry in
> Vista also to make it work. Envisage in Vista did not recognize
> Meade LPI. When I plugged the Meade LPI into USB, Vista loaded
> drivers and called it Trust Webcam 14823. I went into the registry
> and renamed all the instances of Trust Webcam 14823 to Meade
> LPI. Envisage then recognized the Meade LPI, and that is when the
> "unhandled exception" box popped up. Thanks to Charlie 42, Meade
> LPI seems to be working, however the.png picture format does not
> work. Meade has no solution for LPI and Vista.
Glad to be of assistance. I am surprised Meade has not developed Vista
compatible software yet. They are great scopes, and I guess lots of people
hook the cameras up to their Vista computers as well. I hope you enjoy
managing your astro photos in Vista.

Charlie42
 
E

ellessu

#5
I read this discussion since I am getting the same error message with Net TV
2.0. I downloaded .NET 2.0. The machine.config default for the jit Debugging
is false. When I try to add it to the config folder as true, it will not let
me save the change. Is there something I can do?

Thanks!
--
ellessu


"Charlie42" wrote:

> "cdo10" <guest@xxxxxx-email.com> wrote:
>

> > ;)I did the windows.systems .forms trick in the .net 2.0 folder. I used
> > notepad to add the line in the machine config folder and it seems to be
> > working. I am using a Meade LPI camera on a Meade telescope with
> > Envisage software. It has been a trip. I had to edit the resgistry in
> > Vista also to make it work. Envisage in Vista did not recognize
> > Meade LPI. When I plugged the Meade LPI into USB, Vista loaded
> > drivers and called it Trust Webcam 14823. I went into the registry
> > and renamed all the instances of Trust Webcam 14823 to Meade
> > LPI. Envisage then recognized the Meade LPI, and that is when the
> > "unhandled exception" box popped up. Thanks to Charlie 42, Meade
> > LPI seems to be working, however the.png picture format does not
> > work. Meade has no solution for LPI and Vista.
>
> Glad to be of assistance. I am surprised Meade has not developed Vista
> compatible software yet. They are great scopes, and I guess lots of people
> hook the cameras up to their Vista computers as well. I hope you enjoy
> managing your astro photos in Vista.
>
> Charlie42
>
>
 
C

Charlie42

#6
"ellessu" <ellessu@xxxxxx> wrote:

> I read this discussion since I am getting the same error message
> with Net TV 2.0. I downloaded .NET 2.0. The machine.config
> default for the jit Debugging is false. When I try to add it to the
> config folder as true, it will not let me save the change. Is there
> something I can do?
First of all, modify the machine.config file and temporarily store it in one
of your personal folders. Next, cut and paste it into the correct directory.
You will most likely be prompted for administrator confirmation. (Enter your
credentials and) ok it.

Charlie42
 
E

ellessu

#7
Thank You - That did the trick!!
--
ellessu


"Charlie42" wrote:

> "ellessu" <ellessu@xxxxxx> wrote:
>

> > I read this discussion since I am getting the same error message
> > with Net TV 2.0. I downloaded .NET 2.0. The machine.config
> > default for the jit Debugging is false. When I try to add it to the
> > config folder as true, it will not let me save the change. Is there
> > something I can do?
>
> First of all, modify the machine.config file and temporarily store it in one
> of your personal folders. Next, cut and paste it into the correct directory.
> You will most likely be prompted for administrator confirmation. (Enter your
> credentials and) ok it.
>
> Charlie42
>
>
 
#8
i've read this topic and have the same Problem i get this message:

To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.
and i just cant find the Folder with the machine.config. file in it
 
#9
Hi, read the posts here, and I have the same problem. I tried many ways, I've edited the machine.config files at least 50 times so far. I need to know something more: in the Microsoft.Net folder I have 2 Framework folders (Framework and Framework x64). In these 2 framework folders, I have 3 machine.config files (machine - xml configuration; machine.config - default; machine.config - comments). Please let me know which one I should edit. I found the jitDebugging option only in the machine.config - comments, and it was like this <!--
<system.windows.forms
jitDebugging = "false" [true|false]
/>
-->
<system.windows.forms jitDebugging="false" />

Then I changed it to <!--
<system.windows.forms
jitDebugging = "true" [true|false]
/>
-->
<system.windows.forms jitDebugging="true" />

Be aware that I changed, added, and modified in every possible way, even in the both Framework folders. Clearly, I am doing something wrong.

Thanks for helping me!
 
Last edited:
#10
I cannot find the config. files for .NET to change the JIT

I got .Net version 3

I also installed the SDK, it downloaded and installed itself, I could not locate it. Will it be harmful or how can I get rid of it if I wanted tio.

Below is the error the error that I tried to solve evryway I can think of:

Im gona try this method, but >NET config folder??????:confused: Im abit stupid.
Im running Vista Extreme x64 SP1

Microsoft .Net Framework

Unhandled exceptiom has occurred in your application. If you click contibue, the application will ignore this error and attempt to continue. If you click quit, the application will close immediately

The remore server retirned an error: (404) Not Found.

Details:
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.Net.WebException: The remote server returned an error: (404) Not Found.
at System.Net.HttpWebRequest.GetResponse()
at groupmanager.frmMain.WebConnect(String Server)
at groupmanager.frmMain.PollServer()
at groupmanager.frmMain.frmMain_Load(Object sender, EventArgs e)
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
groupmanager
Assembly Version: 1.0.0.5
Win32 Version: 1.0.0.5
CodeBase: file:///C:/Windows/msiUpdate.exe
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 8.0.0.0
Win32 Version: 8.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Management
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Management/2.0.0.0__b03f5f7f11d50a3a/System.Management.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.