Losing Internet connection when resuming from sleep-mode

S

Squint0241

Whenever I come out of sleep-mode, I loose my Internet connection. Happens
everytime? If I reboot, my connection is reestablished, that is until I use
sleep mode again??? Anyone seen this or have a suggestion? Thanks...
 

My Computer

S

Steve

I have this problem also.

- BT Home hub linked via ethernet cable. I've turned sleep off for the time
being.

"Squint0241" <[email protected]> wrote in message
news:[email protected]
> Whenever I come out of sleep-mode, I loose my Internet connection.
> Happens
> everytime? If I reboot, my connection is reestablished, that is until I
> use
> sleep mode again??? Anyone seen this or have a suggestion? Thanks...
 

My Computer

S

Steve Rose

Hi

I also have this problem and, like you, have a BT Home Hub.

When I resume from sleep the network itself is fine (one PC connected
wirelessly and one via Ethernet) but the internet has gone (along with the
little globe symbol on the network activity icon).

To fix it I right click on the activity icon and select "diagnose and
repair" and select the reset network adapter option which has always worked.
Each time I do it I send the info to Microsoft.

It's a pain but it seems to work OK - wonder if it is a problem with the hub
itself which an update to the firmware from BT might fix?

Steve


"Steve" <.> wrote in message news:%[email protected]
>I have this problem also.
>
> - BT Home hub linked via ethernet cable. I've turned sleep off for the
> time being.
>
> "Squint0241" <[email protected]> wrote in message
> news:[email protected]
>> Whenever I come out of sleep-mode, I loose my Internet connection.
>> Happens
>> everytime? If I reboot, my connection is reestablished, that is until I
>> use
>> sleep mode again??? Anyone seen this or have a suggestion? Thanks...

>
 

My Computer

S

Squint0241

Steve, thanks for the info. I tried your solution and it allows me to
reconnect without having tho reboot... Thanks so much..

"Squint0241" wrote:

> Whenever I come out of sleep-mode, I loose my Internet connection. Happens
> everytime? If I reboot, my connection is reestablished, that is until I use
> sleep mode again??? Anyone seen this or have a suggestion? Thanks...
 

My Computer

J

Jake

As Steve says, although this workaround works it is a pain in the butt to
have to go through the whole routine each time the computer wakes up. Any
thoughts on a permanent fix for this problem or, alternatively, a keystroke
shortcut to automate the process?

"Steve Rose" wrote:

> Hi
>
> I also have this problem and, like you, have a BT Home Hub.
>
> When I resume from sleep the network itself is fine (one PC connected
> wirelessly and one via Ethernet) but the internet has gone (along with the
> little globe symbol on the network activity icon).
>
> To fix it I right click on the activity icon and select "diagnose and
> repair" and select the reset network adapter option which has always worked.
> Each time I do it I send the info to Microsoft.
>
> It's a pain but it seems to work OK - wonder if it is a problem with the hub
> itself which an update to the firmware from BT might fix?
>
> Steve
>
 

My Computer

J

Jake

Tim, thanks for your comments and the interim fix. There are a lot of folk
who will be looking forward to a permanent fix. Thanks for your input on
this.

Regards, Ian


"mace242" wrote:

>
> I am in the middle of all kinds of support calls with bt in india about
> this. I have a kind of solution. It works 99% of the time on our two
> laptops.
>
> I downloaded a program called Hibernate Trigger from 'Hibernate
> Trigger' (http://www.rpi.edu/~desimn/suspendtrigger/)
>
> This allows you to run a command on suspend and another on resume.
>
> I created two batch files called susppend.bat and resume.bat.
>
> Suspend.bat contains the line
>
> ipconfig /release w*
>
> Resume.bat contains the line
>
> ipconfig /renew
>
> This will basically redo the ip addresses for your wireless
> connection.
>
> I then put these into the suspend and resume options for Hibernate
> Trigger and got it to run at Windows start up.
>
> ** UPDATE **
>
> Whilst I was writing this post BT have decided to send me another home
> hub and have asked me to speak to their r&d department to see if we can
> get to the bottom of this.
>
> I'll keep you posted.
>
> Tim B.
>
>
> --
> mace242
>
 

My Computer

Yes, after nearly two hours with HP on a brand new, clean system what we
discovered worked perfectly is to reinstall the network card driver. I have
had no problems since then. Here is what they sent to me via email with
additional options.

I understand that the HP Pavilion d4790y PC fails to connect to internet
after coming out sleep mode.

This issue might be due to various reasons. In this case please follow the
steps below to resolve this issue:

Msconfig helps Windows control software that automatically loads while
Windows is starting. For troubleshooting purposes, use the following steps
to prevent all software programs from automatically opening when Windows
starts.

CAUTION: Use the following steps to prevent all startup items
from opening, including antivirus software and other
software that provides important functions. Follow
these steps for troubleshooting purposes only.

1. Click Start.
2. In the Start Search field, type the following:

msconfig

3. Press Enter. The System Configuration window opens.

4. In the General tab view, select Selective Startup, and remove the
checkmark next to Load startup items.
5. Click the Services tab, select Hide all Microsoft services, and
click the Disable all button.
6. Restart the computer for the changes to take effect.
After the computer restarts, a message appears confirming some
startup programs have been blocked from opening.

For a description of the tab views and their contents in the System
Configuration window along with graphics, visit the following HP Web
Site:

http://h10025.www1.hp.com/ewfrf/wc/document?cc=us&docname=c00819747

Reinstalling Network Card driver
---------------------------------------

1. Start the Computer.
2. Press the F8 key when the blue HP logo appears. The Windows Advanced
Options menu will appear.
3. Use the arrow keys to select "Safe mode" and then press Enter.
4. Log on to Windows as Administrator.
5. When you are able to view the desktop, click on Start 6. Type Device
Manager in the Start Search box 7. Click on Device Manager 8. Click the
plus (+) sign next to Network Adapetr to list the Network drivers.
9. Select one driver and select uninstall. In the "Confirm Device
Uninstall" dialog box, click OK.
10. Repeat this process until there is no listing for Network card 11.
Close all windows and restart the computer.

Please do feel free to get back to us if you need further assistance. We
will be available here round the clock and will be glad to assist you further.

http://www.hp.com/go/totalcare


"Cromptons" wrote:

>
> Hi people, does anyone have a update / soloution on this yet as I have
> exacly the same problem.....
>
> Cheers
> James
>
>
> --
> Cromptons
> ------------------------------------------------------------------------
> Cromptons's Profile: http://www.vista64.net/forums/member.php?userid=1754
> View this thread: http://www.vista64.net/forums/showthread.php?t=35663
>
>
 

My Computer

A

ap1

I am using Windows Vista Home Premium on a HP Pavilion Notebook and have
the same issue: Losing Internet connection when resuming from
sleep/hybernate mode.

A temporary fix: Before I Hiybernate or go to Sleep Mode, I go to
Control Panel -> Device manager -> Network Adapters, disable the
adapter/modem

When I come out of sleep-mode I 'enable' it. this seems to work but is
not an elegant fix. Can anyone help?


--
ap1
------------------------------------------------------------------------
ap1's Profile: http://forums.techarena.in/member.php?userid=33795
View this thread: http://forums.techarena.in/showthread.php?t=674038

http://forums.techarena.in
 

My Computer

T

Tobi

Jack wrote:

>I don't know if this is applicable to your problem but I was having
similar

>problems with my Vista Ultimate constantly telling me I was offline
and >attempting to dial a connection.

>After contacting everyone I could think of and going to different
Vista

>forums for an answer, I found out my problem was with Adobe.. The
Adobe >Updater was the culprit. After I made some changes in Preference
in Adobe >Reader the problems quit.

I too am having these issues and I'm wondering if you could specify the
changes that you made in the Adobe Preferences. I had not had these
problems until quite recently, and I think I DID recently update my
version of Adobe Reader. Thanks!


--
Tobi
------------------------------------------------------------------------
Tobi's Profile: http://forums.techarena.in/member.php?userid=40800
View this thread: http://forums.techarena.in/showthread.php?t=674038

http://forums.techarena.in
 

My Computer

T

Twinson

My machine never had this problem until around the time I installed SP1,
which I initially suspected was the problem. I also upgraded the firmware on
my Linksys wireless G router, which could also have been the culprit. But
after reading many threads someone mentioned they had an issue with McAfee,
which has caused other problems for me in the past. So I uninstalled McAfee
and reinstalled it again and voila, the problem went away. There are several
reasons that can cause you to loose connectivity after returning from sleep
but I would definitely recommend if you're running McAfee to uninstall and
reinstall it again to ensure that this is not the cause of the problem.

"Steve Rose" wrote:

> Hi
>
> I also have this problem and, like you, have a BT Home Hub.
>
> When I resume from sleep the network itself is fine (one PC connected
> wirelessly and one via Ethernet) but the internet has gone (along with the
> little globe symbol on the network activity icon).
>
> To fix it I right click on the activity icon and select "diagnose and
> repair" and select the reset network adapter option which has always worked.
> Each time I do it I send the info to Microsoft.
>
> It's a pain but it seems to work OK - wonder if it is a problem with the hub
> itself which an update to the firmware from BT might fix?
>
> Steve
>
>
> "Steve" <.> wrote in message news:%[email protected]

> >I have this problem also.
> >
> > - BT Home hub linked via ethernet cable. I've turned sleep off for the
> > time being.
> >
> > "Squint0241" <[email protected]> wrote in message
> > news:[email protected]

> >> Whenever I come out of sleep-mode, I loose my Internet connection.
> >> Happens
> >> everytime? If I reboot, my connection is reestablished, that is until I
> >> use
> >> sleep mode again??? Anyone seen this or have a suggestion? Thanks...
> >
>
>
 

My Computer

N

Not Me

Make sure the NIC is set to NOT 'allow windows to turn off this device to
save energy' or such.

"Twinson" <[email protected]> wrote in message
news:[email protected]

> My machine never had this problem until around the time I installed SP1,
> which I initially suspected was the problem. I also upgraded the firmware
> on
> my Linksys wireless G router, which could also have been the culprit. But
> after reading many threads someone mentioned they had an issue with
> McAfee,
> which has caused other problems for me in the past. So I uninstalled
> McAfee
> and reinstalled it again and voila, the problem went away. There are
> several
> reasons that can cause you to loose connectivity after returning from
> sleep
> but I would definitely recommend if you're running McAfee to uninstall and
> reinstall it again to ensure that this is not the cause of the problem.
>
> "Steve Rose" wrote:
>

>> Hi
>>
>> I also have this problem and, like you, have a BT Home Hub.
>>
>> When I resume from sleep the network itself is fine (one PC connected
>> wirelessly and one via Ethernet) but the internet has gone (along with
>> the
>> little globe symbol on the network activity icon).
>>
>> To fix it I right click on the activity icon and select "diagnose and
>> repair" and select the reset network adapter option which has always
>> worked.
>> Each time I do it I send the info to Microsoft.
>>
>> It's a pain but it seems to work OK - wonder if it is a problem with the
>> hub
>> itself which an update to the firmware from BT might fix?
>>
>> Steve
>>
>>
>> "Steve" <.> wrote in message
>> news:%[email protected]

>> >I have this problem also.
>> >
>> > - BT Home hub linked via ethernet cable. I've turned sleep off for the
>> > time being.
>> >
>> > "Squint0241" <[email protected]> wrote in message
>> > news:[email protected]
>> >> Whenever I come out of sleep-mode, I loose my Internet connection.
>> >> Happens
>> >> everytime? If I reboot, my connection is reestablished, that is until
>> >> I
>> >> use
>> >> sleep mode again??? Anyone seen this or have a suggestion? Thanks...
>> >
>>
>>
 

My Computer

T

Twinson

UPDATE - So after reinstalling McAfee and having no problem for the past few
days, the next time my computer came back from sleep after I posted the note
below, no internet - how ironic! However I noticed that Outlook downloaded
my new emails so there was a connection but I couldn't connect to any web
pages and Skype couldn't connect so I suspected it may be the firwall. I
disabled the McAfee firewell and voila, I could connect again. I then
re-enabled the firewall again and all was fine. So for some reason, every so
often McAfee firewall will block you when returning from sleep. At least
I've found a way to reconnect to the Internet without having to reboot the
computer all the time. As a side note, Windows never found a problem with
the network when I used the 'Diagnose and Repair' option, because there
wasn't a problem with the network, the problem was with the firewall.

So I called McAfee and they got me to do the following, I haven't yet tested
the changes long enough to know whether it will fix the problem but thought I
would post this info anyway. I'll make another post in a week to let
everyone know whether or not this worked.

Step 1: Click on windows start.
Step 2: Click on Run.
Step 3: Type %temp%.
Step 4: Click Ok.
Step 5: Delete all the files and folders. Please leave the files that
cannot be deleted; delete the rest.

Step 1: Click on windows start.
Step 2: Click on Run.
Step 3: Type prefetch.
Step 4: Click Ok.
Step 5: Delete all the files and folders.

Step 1: Open your Internet Explorer.
Step 2: Click on 'Tools' and select 'Internet Options'.
Step 3: Click on 'Delete cookies' and then click 'Ok'.
Step 4: Click on Delete Files.

Now click on "advanced" tab on the top and click "reset" on the bottom, this
will reset IE.

"Not Me" wrote:

> Make sure the NIC is set to NOT 'allow windows to turn off this device to
> save energy' or such.
>
> "Twinson" <[email protected]> wrote in message
> news:[email protected]

> > My machine never had this problem until around the time I installed SP1,
> > which I initially suspected was the problem. I also upgraded the firmware
> > on
> > my Linksys wireless G router, which could also have been the culprit. But
> > after reading many threads someone mentioned they had an issue with
> > McAfee,
> > which has caused other problems for me in the past. So I uninstalled
> > McAfee
> > and reinstalled it again and voila, the problem went away. There are
> > several
> > reasons that can cause you to loose connectivity after returning from
> > sleep
> > but I would definitely recommend if you're running McAfee to uninstall and
> > reinstall it again to ensure that this is not the cause of the problem.
> >
> > "Steve Rose" wrote:
> >

> >> Hi
> >>
> >> I also have this problem and, like you, have a BT Home Hub.
> >>
> >> When I resume from sleep the network itself is fine (one PC connected
> >> wirelessly and one via Ethernet) but the internet has gone (along with
> >> the
> >> little globe symbol on the network activity icon).
> >>
> >> To fix it I right click on the activity icon and select "diagnose and
> >> repair" and select the reset network adapter option which has always
> >> worked.
> >> Each time I do it I send the info to Microsoft.
> >>
> >> It's a pain but it seems to work OK - wonder if it is a problem with the
> >> hub
> >> itself which an update to the firmware from BT might fix?
> >>
> >> Steve
> >>
> >>
> >> "Steve" <.> wrote in message
> >> news:%[email protected]
> >> >I have this problem also.
> >> >
> >> > - BT Home hub linked via ethernet cable. I've turned sleep off for the
> >> > time being.
> >> >
> >> > "Squint0241" <[email protected]> wrote in message
> >> > news:[email protected]
> >> >> Whenever I come out of sleep-mode, I loose my Internet connection.
> >> >> Happens
> >> >> everytime? If I reboot, my connection is reestablished, that is until
> >> >> I
> >> >> use
> >> >> sleep mode again??? Anyone seen this or have a suggestion? Thanks...
> >> >
> >>
> >>
 

My Computer

Top