• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Medal of Honor Airborne - Problems

#1
I've just received my copy of this game in the post from Amazon but I cannot get it installed on my system. Has anyone else tried it yet? According to the back of the DVD case it is Vista compatible.

About 3/4 of the way through the installation it quits saying it's ended prematurely and to try again later.

I've temporarily disabled my anti-virus (Avast) and run the setup.exe on the dvd as an administrator but not had any success. The installation runs incredibly slowly, by far the slowest installation of any game I've ever bought.

Is there anything else I can try before I email EA?
 

My Computer

#2
Try using a program like Nero, ImgBurn, PowerISO, etc. to make an ISO file of the DVD and then use Daemon Tools to mount the ISO file and try installing from it. You will still have to use the original DVD in your drive to play the game.

I don't have the full game yet, but I tried the demo and it works just fine for me on Vista 32bit.
 

My Computer

#3
OK it's worth a try, but why would that make a difference?

I've already tried copying the contents of the DVD to a secondary hard drive and installing from there but that didn't help. I only have 1 DVD drive too so I guess I'll have to copy them to this hard drive again...
 

My Computer

#4
For anyone else experiencing this problem it's a bug in the installer related to Windows Firewall. You must have it on and the associated service started for it to install correctly.
 

My Computer

#6
I bought it and it runs on my 64.bits,,,But i feel it has a bit of problem with what i call "mouse-lagg". You dont really have control of your mouse, its a bit like walking on ice.I tride to disconnect my wheel and gamepad, the same. Even trid to go really really low on the setting, but the same mouselagg.I know its not 100 percent compatible with Vista64, but i hope a patch will solve this cause its a good game and its very fun.
Why should we who have the 64 bits be standing in the cold when the 32 bits can run it??
I hope in the future that the games they say will run on vista without a problem its not just for the 32bits owner.
 

My Computer

#7
I use a Death Adder, and its funny how Razers drivers and firmware not working in Vista,,For an example: BF2142 runs awsome without the Razer drives and i can use all buttons with the default windows drivers. When using razers i cannot map the 2 thumbs and the mousewheel to click.
i was reserving my problem with mouselagg to the drivers for the mouse, but with razers drivers its even more of the thing i called mouselagg.
I even tried a copperhead, the same.
So if ya having trouble with a mouse dont go Razer with vista, razer sucks!!!

But to my earlier post above: Is there anyone else that have the mouselagg in Airborne,?? its the only game i have that feeling.
 

My Computer

#8
I bought it and it runs on my 64.bits,,,But i feel it has a bit of problem with what i call "mouse-lagg". You dont really have control of your mouse, its a bit like walking on ice.I tride to disconnect my wheel and gamepad, the same. Even trid to go really really low on the setting, but the same mouselagg.I know its not 100 percent compatible with Vista64, but i hope a patch will solve this cause its a good game and its very fun.
Why should we who have the 64 bits be standing in the cold when the 32 bits can run it??
I hope in the future that the games they say will run on vista without a problem its not just for the 32bits owner.
I don't have any mouse problems - it sounds like you have quite a few controllers plugged in there! How about if you disconnect them all (apart from the mouse) restart and try then?
 

My Computer

#9
I use a Death Adder, and its funny how Razers drivers and firmware not working in Vista,,For an example: BF2142 runs awsome without the Razer drives and i can use all buttons with the default windows drivers. When using razers i cannot map the 2 thumbs and the mousewheel to click.
i was reserving my problem with mouselagg to the drivers for the mouse, but with razers drivers its even more of the thing i called mouselagg.
I even tried a copperhead, the same.
So if ya having trouble with a mouse dont go Razer with vista, razer sucks!!!

But to my earlier post above: Is there anyone else that have the mouselagg in Airborne,?? its the only game i have that feeling.
I can't map both of the 2 thumb buttons on my Logitech mouse independantly either. Also I can't get the scroll wheel working - I have it set to change weapon if scrolled up or down. Up works fine but down just keeps reselecting the current weapon.

I haven't tried installing any logitech drivers yet as they come embedded in lots of bloatware - can't find just the drivers alone anywhere :(
 

My Computer

#10
Yepp,,The first thing i did was disconnecting my Saitek wheel and Logitech rumblepad.
Death Adder mouse, i use the defaultwindows mouse drivers because when trying the Razer drivers i cant mapp any button on the mouse however i try, even in the controllsetting for the Razer, Its the same in BF2142.
I think its strange how it works, but i hope a patch will resolve the issue with the mouse lagg..OH GOD PLEASEEEEEEEEEE;;hehehehe,,
I thinh Airborne its excellent but i wont go online with the mouselagg so i keep playing the missions.
Thanks for responding njparton.
If i ever found a solution i will post it here, maybe it will help others.
I had a mate over yesterday, thinking he could resolve the issue. But he was as surprised as me founding out that the Razer drivers and i was doing something wrong. But he couldnt even resolve the problem thinking that i couldnt mapp the settings in the Razer firmware and software. but it wasnt that.
I even tried going very low on the graphics but NO. Still the mouse issue.
Yaya,,i will patiently wait for a 64 support.

I have that problem with Razer drivers in all the game in my 64Vista. but with windowsdefault drivers it works mapping.


I keep thinking on the EA answer to you that the game wasnt designed for 64 bits, and that the problem occurs to that, and that finnally they will release a patch with 64bits support.
keep hoping, keep the faith.
 
Last edited:

My Computer

#11
I had a mate over yesterday, thinking he could resolve the issue. But he was as surprised as me founding out that the Razer drivers and i was doing something wrong. But he couldnt even resolve the problem thinking that i couldnt mapp the settings in the Razer firmware and software. but it wasnt that.
I even tried going very low on the graphics but NO. Still the mouse issue.
Yaya,,i will patiently wait for a 64 support.
 

My Computer

#13
I had a mate over yesterday, thinking he could resolve the issue. But he was as surprised as me founding out that the Razer drivers and i was doing something wrong. But he couldnt even resolve the problem thinking that i couldnt mapp the settings in the Razer firmware and software. but it wasnt that.
I even tried going very low on the graphics but NO. Still the mouse issue.
Yaya,,i will patiently wait for a 64 support.
Its got to be a razer driver issue with that model I use a razer copperhead and I have no mouselagg and I can map all my buttons i have no issues with it
 

My Computer

#15
For anyone else experiencing this problem it's a bug in the installer related to Windows Firewall. You must have it on and the associated service started for it to install correctly.
Hi, i have the exact same problem, but how do i add it to associated service? I tried disabling the firewall, but still wont intall. Any help is appreciated, thanks.
 

My Computer

#16
Hey.

I don't know if this is your problem, but I found a solution to one: Installation aborts (without messages) at PhysX driver installation.
Solution: Copy all files from the DVD to a harddrive. Rename PhysX_7.07.09_SystemSoftware.exe to something else. If you need to install this, run it manually. Make a copy of an exe file, any one that will execute successfully, put it in the PhysX folder and name it PhysX_7.07.09_SystemSoftware.exe. Run the installation program for Airborne (on the harddrive). When it gets to the PhysX part, it just skips and installs without problems.


Good luck.

First and last post here.. with this account. Hope it helped.

/L
 

My Computer

#17
Hey,

Thanks for the reply, i tired it, but still doesn't work. When i get to the PhysX driver it does install, but when it finishes it just quits and the game wont install.

I also tried disabling the firewall permanently, but it's still the same. I heard that there is other problems with the game and it wont load into a specific mission, so even if i do get it installed, there might be other problems in the game :(. I might just have to wait until theres support for Vista 64 in an upcoming patch.
 

My Computer

#18
I'm having the same problem and I've tried all the suggestions on this board as well as my own ideas and no luck as of yet. I'm not really sure how a patch would help as most patches requrie the game to atleast be installed first.

I know it isn't the physx installation either, as I have other games that use physx and they all installed fine.
 

My Computer

#19
I've got Vista home premium 32 bit, and have had the exact same install problem. Just uninstalled Physx drivers and MOHA re-installed it followed swiftly by the game. Is it me or is Vista just a big pain in the arse when it comes to any game???
 

My Computer