• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Networking & File sharing problem

#1
I am new to networking so please bear with me if I am asking for help on
something relatively simple.

I have 3 Vista machine in a home network belonging to the same workgroup.
On all the machines Network discovery, File sharing and Public folder
sharing are turned on (Printer sharing, password protected sharing and media
sharing are turned off). Each machine can see the other two machines in
Explorer>Network.

On one of the machines, I have shared a couple of folders in the C drive and
added Everyone in Choose people to share with, giving Co-owner permission
level. This works fine and I can see these folders and all the files they
contain on the other machines. However, if I share files and/or a folder &
files in the Documents folder with similar permission level these do not
show on the other machines.

If I click on "Show me all the files and folders I am sharing" in Network
and Sharing Center only those that are shared in the Documents folders show
(but not the shared folders outside the Documents folder) whereas "Show me
all the shared network folders on this computer" comes up with only the
shared folders which are not in the Documents folder plus Public and
Printers folders.

I have tried sharing the Documents folder but again this does not appear on
networked computers.

What do I need to do to give access to files and folders in the Documents
folder to other computers?

JP
 

My Computer

M

Malke

#2
JP wrote:

> I am new to networking so please bear with me if I am asking for help on
> something relatively simple.
>
> I have 3 Vista machine in a home network belonging to the same workgroup.
> On all the machines Network discovery, File sharing and Public folder
> sharing are turned on (Printer sharing, password protected sharing and
> media
> sharing are turned off). Each machine can see the other two machines in
> Explorer>Network.
>
> On one of the machines, I have shared a couple of folders in the C drive
> and added Everyone in Choose people to share with, giving Co-owner
> permission level. This works fine and I can see these folders and all the
> files they
> contain on the other machines. However, if I share files and/or a folder
> & files in the Documents folder with similar permission level these do not
> show on the other machines.
>
> If I click on "Show me all the files and folders I am sharing" in Network
> and Sharing Center only those that are shared in the Documents folders
> show (but not the shared folders outside the Documents folder) whereas
> "Show me all the shared network folders on this computer" comes up with
> only the shared folders which are not in the Documents folder plus Public
> and Printers folders.
>
> I have tried sharing the Documents folder but again this does not appear
> on networked computers.
>
> What do I need to do to give access to files and folders in the Documents
> folder to other computers?
The issue is clearly not your firewalls or antivirus as the other poster
suggested. In order to share the personal user directories (Documents,
Music, etc.) you need to create the same user accounts/passwords on all
three machines.

Create matching user accounts and passwords on all machines. You do not need
to be logged into the same account on all machines and the passwords
assigned to each user account can be different; the accounts/passwords just
need to exist and match on all machines. DO NOT NEGLECT TO CREATE
PASSWORDS, EVEN IF ONLY SIMPLE ONES. If you wish a machine to boot directly
to the Desktop (into one particular user's account) for convenience, you
can do this:

Vista - Start Orb>Search box>type: netplwiz [enter]
Click on Continue (or supply an administrator's password) when prompted by
UAC

Uncheck the option "Users must enter a user name and password to use this
computer". Select a user account to automatically log on by clicking on the
desired account to highlight it and then hit OK. Enter the correct password
for that user account (if there is one) when prompted. Leave it blank if
there is no password (null).

Malke
--
MS-MVP
Elephant Boy Computers - Don't Panic!
http://www.elephantboycomputers.com/#FAQ
 

My Computer

#3
firewalls and a.v.'s
"can" inhibit file
sharing,

especially if they are
not microsoft versions.

--------

clearly, you should not
degrade the responses
of others.

it only degrades your
own crediability.
--

db·´¯`·...¸><)))º>
DatabaseBen, Retired Professional
- Systems Analyst
- Database Developer
- Accountancy
- Veteran of the Armed Forces
- Microsoft Partner
- @hotmail.com
~~~~~~~~~~"share the nirvana" - dbZen
"Malke" <malke@xxxxxx> wrote in message news:OUDyqsm9JHA.1336@xxxxxx

> JP wrote:
>

>> I am new to networking so please bear with me if I am asking for help on
>> something relatively simple.
>>
>> I have 3 Vista machine in a home network belonging to the same workgroup.
>> On all the machines Network discovery, File sharing and Public folder
>> sharing are turned on (Printer sharing, password protected sharing and
>> media
>> sharing are turned off). Each machine can see the other two machines in
>> Explorer>Network.
>>
>> On one of the machines, I have shared a couple of folders in the C drive
>> and added Everyone in Choose people to share with, giving Co-owner
>> permission level. This works fine and I can see these folders and all the
>> files they
>> contain on the other machines. However, if I share files and/or a folder
>> & files in the Documents folder with similar permission level these do not
>> show on the other machines.
>>
>> If I click on "Show me all the files and folders I am sharing" in Network
>> and Sharing Center only those that are shared in the Documents folders
>> show (but not the shared folders outside the Documents folder) whereas
>> "Show me all the shared network folders on this computer" comes up with
>> only the shared folders which are not in the Documents folder plus Public
>> and Printers folders.
>>
>> I have tried sharing the Documents folder but again this does not appear
>> on networked computers.
>>
>> What do I need to do to give access to files and folders in the Documents
>> folder to other computers?
>
> The issue is clearly not your firewalls or antivirus as the other poster
> suggested. In order to share the personal user directories (Documents,
> Music, etc.) you need to create the same user accounts/passwords on all
> three machines.
>
> Create matching user accounts and passwords on all machines. You do not need
> to be logged into the same account on all machines and the passwords
> assigned to each user account can be different; the accounts/passwords just
> need to exist and match on all machines. DO NOT NEGLECT TO CREATE
> PASSWORDS, EVEN IF ONLY SIMPLE ONES. If you wish a machine to boot directly
> to the Desktop (into one particular user's account) for convenience, you
> can do this:
>
> Vista - Start Orb>Search box>type: netplwiz [enter]
> Click on Continue (or supply an administrator's password) when prompted by
> UAC
>
> Uncheck the option "Users must enter a user name and password to use this
> computer". Select a user account to automatically log on by clicking on the
> desired account to highlight it and then hit OK. Enter the correct password
> for that user account (if there is one) when prompted. Leave it blank if
> there is no password (null).
>
> Malke
> --
> MS-MVP
> Elephant Boy Computers - Don't Panic!
> http://www.elephantboycomputers.com/#FAQ
>
 

My Computer

#4
Thank you for the information Malke. What you say does work provided you
log in using the same username on the machine from where you want to access
the files. Clearly it is not possible for any other user to access these
files. Don't understand why Vista restricts access to Documents folder like
this.

JP

"Malke" <malke@xxxxxx> wrote in message
news:OUDyqsm9JHA.1336@xxxxxx

> JP wrote:
>

>> I am new to networking so please bear with me if I am asking for help on
>> something relatively simple.
>>
>> I have 3 Vista machine in a home network belonging to the same workgroup.
>> On all the machines Network discovery, File sharing and Public folder
>> sharing are turned on (Printer sharing, password protected sharing and
>> media
>> sharing are turned off). Each machine can see the other two machines in
>> Explorer>Network.
>>
>> On one of the machines, I have shared a couple of folders in the C drive
>> and added Everyone in Choose people to share with, giving Co-owner
>> permission level. This works fine and I can see these folders and all the
>> files they
>> contain on the other machines. However, if I share files and/or a folder
>> & files in the Documents folder with similar permission level these do
>> not
>> show on the other machines.
>>
>> If I click on "Show me all the files and folders I am sharing" in Network
>> and Sharing Center only those that are shared in the Documents folders
>> show (but not the shared folders outside the Documents folder) whereas
>> "Show me all the shared network folders on this computer" comes up with
>> only the shared folders which are not in the Documents folder plus Public
>> and Printers folders.
>>
>> I have tried sharing the Documents folder but again this does not appear
>> on networked computers.
>>
>> What do I need to do to give access to files and folders in the Documents
>> folder to other computers?
>
> The issue is clearly not your firewalls or antivirus as the other poster
> suggested. In order to share the personal user directories (Documents,
> Music, etc.) you need to create the same user accounts/passwords on all
> three machines.
>
> Create matching user accounts and passwords on all machines. You do not
> need
> to be logged into the same account on all machines and the passwords
> assigned to each user account can be different; the accounts/passwords
> just
> need to exist and match on all machines. DO NOT NEGLECT TO CREATE
> PASSWORDS, EVEN IF ONLY SIMPLE ONES. If you wish a machine to boot
> directly
> to the Desktop (into one particular user's account) for convenience, you
> can do this:
>
> Vista - Start Orb>Search box>type: netplwiz [enter]
> Click on Continue (or supply an administrator's password) when prompted by
> UAC
>
> Uncheck the option "Users must enter a user name and password to use this
> computer". Select a user account to automatically log on by clicking on
> the
> desired account to highlight it and then hit OK. Enter the correct
> password
> for that user account (if there is one) when prompted. Leave it blank if
> there is no password (null).
>
> Malke
> --
> MS-MVP
> Elephant Boy Computers - Don't Panic!
> http://www.elephantboycomputers.com/#FAQ
>
 

My Computer

M

Malke

#5
JP wrote:

> Thank you for the information Malke. What you say does work provided you
> log in using the same username on the machine from where you want to
> access
> the files. Clearly it is not possible for any other user to access these
> files. Don't understand why Vista restricts access to Documents folder
> like this.
You don't need to log in using the same username. I can access my son's
desktop on his XP box from my Win7 and Vista machines. He's logged into his
account and I'm logged into mine. But I have a user account on his system.
And vice versa. Make sure you've added "Everyone" to the advanced sharing
on those shares.

Malke
--
MS-MVP
Elephant Boy Computers - Don't Panic!
http://www.elephantboycomputers.com/#FAQ
 

My Computer