New nVIDIA drivers

larryk

Member
Vista Pro
I am. As you mentioned in the other thread, it doesn't say it's for Vista, but it's working for me. My frame rate in Guild Wars went back to 62 from the 49 it dropped to with the previous beta.
 

My Computer

alltheway

Lord of War
Power User
I am. As you mentioned in the other thread, it doesn't say it's for Vista, but it's working for me. My frame rate in Guild Wars went back to 62 from the 49 it dropped to with the previous beta.
What version of the previous beta were you running 163.44 or 163.67
 

My Computer

larryk

Member
Vista Pro
I was running 67. I saw a performance drop going from 44 to 67, but seem to have recovered with 69.

69 came out pretty quickly after 67 so I was figuring it was because of a flood of complaints about a performance hit.
 

My Computer

alltheway

Lord of War
Power User
I was running 67. I saw a performance drop going from 44 to 67, but seem to have recovered with 69.

69 came out pretty quickly after 67 so I was figuring it was because of a flood of complaints about a performance hit.
I don't know for some reason I thought on my machine the 67 drivers worked better than the 64. It was also curious to see that supported drivers are coming out soon for Vista. I will install these drivers and see how they run for me. I have heard problem from users on guru3d stating they can't enable SLI when downloading them though. I am a little weary of using them but I can always just re-install
 

My Computer

bob_c_b

Banned
I got all hyped when I saw the title, thought new official drivers finally shipped, might have to break down and try these...
 

My Computer

System One

  • CPU
    Intel Core 2 Duo [email protected]
    Motherboard
    eVGA 750i FTW
    Memory
    2x2GB G.Skill DDR2-800
    Graphics Card(s)
    2x eVGA 9600GT
    Hard Drives
    500GB Seagate 7200.10

alltheway

Lord of War
Power User
BOOOIIIINNNGGGG!!!! The list of bug fixes in the last BETAs make these a must grab.

Yeah I just downloaded and installed these drivers last night...still didn't fix my problem with Medieval 2 Total war but oh well. Can't be perfect I guess.
 

My Computer

bob_c_b

Banned
Finally got 'em installed this morning, no obvious issues but I still havnen't tried to game on this box yet (maybe this weekend).
 

My Computer

System One

  • CPU
    Intel Core 2 Duo [email protected]
    Motherboard
    eVGA 750i FTW
    Memory
    2x2GB G.Skill DDR2-800
    Graphics Card(s)
    2x eVGA 9600GT
    Hard Drives
    500GB Seagate 7200.10
Top