Solved Numeric lock on: keyboard only partial!

Hi I have a problem with an Advent Laptop 7113 running Vista.

I loaned this spare laptop to my 36 year old son whilst his Dell was away being repaired, now he has returned the laptop back to me with what to me seems to be an unusual problem: the numeric lock is permanently on, most of the toggles, F pads, enter and scroll are not functioning. It is impossible to get into the bios via F2 as this is also not functioning. I note that during the boot the numeric lock is off, and only comes on when current user is selected for windows. I have been into regedit, current user, control panel and keyboard and the keyboard setting is set to 2, and I have then reset it to 0, however when the machine is rebooted and you go back via regedit to check the setting for the current user, the keyboard has reset itself every time to 2!!!

I have also gone to default under regedit default, control panel, keyboard, and reset the default from the long numeric string to 0, and this remains constant, however, when I try to log back on as my normal password and current user, the numeric via Regedit is seen to have reset itself again to 2!

The entire keyboard was replaced about 5 months ago as it had a broken key pad.
I suppose the moral of the story is to not loan spare machines to sons, who seem to treat laptops like mobile phones: i.e. little respect and throw them all around the room!
I should also add that the combination Fn Numeric is also not functioning.

Using a mouse I am able to get into the front end screen and all of my files are intact, but with the numeric locked and no enter pad, then programs such as word are inoperable

Any thoughts appreciated, (hardware software problem?) before I kick laptop and older son into a tidy bin!! :)
 

My Computer

System One

  • Manufacturer/Model
    Advent 7113 Laptop
    CPU
    Celeron
    Motherboard
    Advent
    Memory
    2 M

Yard Dog

Vista Guru
Gold Member

My Computer

System One

  • Manufacturer/Model
    Emachine ET 1161-05
    CPU
    AMD Athlon 64 LE-1640
    Motherboard
    eMachines MCP61PM-GM (Socket AM2 )
    Memory
    2.00 GB Dual-Channel DDR2 @ 387MHz (6-6-6-18)
    Graphics Card(s)
    Acer E181H ([email protected]) 128MB GeForce 6150SE nForce 430 (
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    Name Acer E181H on NVIDIA GeForce 6150SE nForce 430
    Screen Resolution
    1280x768 pixels
    Hard Drives
    ST316081 5AS SCSI Disk Device
    PSU
    MCP61PM-GM 9000 NVIDIA Chipset Model MCP61 Chipset Revisio
    Case
    Tower
    Cooling
    Fan Speed 1247 RPM
    Mouse
    PS/2 Compatible Mouse
    Keyboard
    Standard PS/2 Keyboard
    Internet Speed
    http://www.speedtest.net/result/1538974261.png
Hi

And thank you for your valued response. I'm struggling a bit as the laptop is not easily accessible with only a partial keyboard, so am having to transfer info from the laptop onto the network via my desktop via a 'peg'!

I have just uploaded the results from the system Ap, which hopefully will assist in any evaluation:

Enc:

Will await your response, and again many thanks for your valued assistance!

Ragamuffin
 

Attachments

My Computer

System One

  • Manufacturer/Model
    Advent 7113 Laptop
    CPU
    Celeron
    Motherboard
    Advent
    Memory
    2 M

Yard Dog

Vista Guru
Gold Member
Go to your services, and on this one. Name: Human Interface Device Access , highlight it and make it start, then go and see if the keyboard will work. Post back. type “services.msc” in the Run box without quotes, if you can do any typing at all. There is another way to access that, in control panel, in admin tools, if you open it, you will see the services icon, and you can get there that way. Give this a shot and post back.
 

My Computer

System One

  • Manufacturer/Model
    Emachine ET 1161-05
    CPU
    AMD Athlon 64 LE-1640
    Motherboard
    eMachines MCP61PM-GM (Socket AM2 )
    Memory
    2.00 GB Dual-Channel DDR2 @ 387MHz (6-6-6-18)
    Graphics Card(s)
    Acer E181H ([email protected]) 128MB GeForce 6150SE nForce 430 (
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    Name Acer E181H on NVIDIA GeForce 6150SE nForce 430
    Screen Resolution
    1280x768 pixels
    Hard Drives
    ST316081 5AS SCSI Disk Device
    PSU
    MCP61PM-GM 9000 NVIDIA Chipset Model MCP61 Chipset Revisio
    Case
    Tower
    Cooling
    Fan Speed 1247 RPM
    Mouse
    PS/2 Compatible Mouse
    Keyboard
    Standard PS/2 Keyboard
    Internet Speed
    http://www.speedtest.net/result/1538974261.png
Hi

Tried that option, but keyboard remains only partially functional & numeric lock still on all the time.

Just about to hit the sack as here it is close midnight, but will log back on in the morning with a fresh mind and look at other options

Again: thanks for your effort.

Very much appreciated.

Ragamufin :sleepy:
 

My Computer

System One

  • Manufacturer/Model
    Advent 7113 Laptop
    CPU
    Celeron
    Motherboard
    Advent
    Memory
    2 M

Yard Dog

Vista Guru
Gold Member
K, gonna see what else is available to fix you, check email in morn. as someone else may post a fix .
 

My Computer

System One

  • Manufacturer/Model
    Emachine ET 1161-05
    CPU
    AMD Athlon 64 LE-1640
    Motherboard
    eMachines MCP61PM-GM (Socket AM2 )
    Memory
    2.00 GB Dual-Channel DDR2 @ 387MHz (6-6-6-18)
    Graphics Card(s)
    Acer E181H ([email protected]) 128MB GeForce 6150SE nForce 430 (
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    Name Acer E181H on NVIDIA GeForce 6150SE nForce 430
    Screen Resolution
    1280x768 pixels
    Hard Drives
    ST316081 5AS SCSI Disk Device
    PSU
    MCP61PM-GM 9000 NVIDIA Chipset Model MCP61 Chipset Revisio
    Case
    Tower
    Cooling
    Fan Speed 1247 RPM
    Mouse
    PS/2 Compatible Mouse
    Keyboard
    Standard PS/2 Keyboard
    Internet Speed
    http://www.speedtest.net/result/1538974261.png

townsbg

~~тσωηsвg~~
Vista Guru
Gold Member
This this registry key: HKEY_CURRENT_USER\Control Panel\Keyboard\
 

My Computers

System One System Two

  • Operating System
    Windows 7 Pro x64
    Manufacturer/Model
    Mid 2010 iMac
    CPU
    Quad core 3.2 Ghz Intel I3
    Memory
    8 gb
    Graphics Card(s)
    ATI Radeon HD 5670 512 mb ram
    Screen Resolution
    1920x1080 and 1440x900
    Hard Drives
    1 TB
    Other Info
    N/A
  • Operating System
    Windows 2008 R2 Enterprise
    Manufacturer/Model
    Compaq Presario SR5350F
    CPU
    Pentium 2.0 gHZ Dual core E2160
    Memory
    2 gb
    Screen Resolution
    1440 x 900
    Hard Drives
    300 GB

Yard Dog

Vista Guru
Gold Member
Ya know, i was re reading your first post, when you went to the register, you used an admin account, try making a new admin account, i believe you can do this without keyboard , but, keep in mind you have a keyboard here. Start, all programs, accessories, ease of access, on screen keyboard. Use new admin account and see if this keyboard issue is on that account as well.
 

My Computer

System One

  • Manufacturer/Model
    Emachine ET 1161-05
    CPU
    AMD Athlon 64 LE-1640
    Motherboard
    eMachines MCP61PM-GM (Socket AM2 )
    Memory
    2.00 GB Dual-Channel DDR2 @ 387MHz (6-6-6-18)
    Graphics Card(s)
    Acer E181H ([email protected]) 128MB GeForce 6150SE nForce 430 (
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    Name Acer E181H on NVIDIA GeForce 6150SE nForce 430
    Screen Resolution
    1280x768 pixels
    Hard Drives
    ST316081 5AS SCSI Disk Device
    PSU
    MCP61PM-GM 9000 NVIDIA Chipset Model MCP61 Chipset Revisio
    Case
    Tower
    Cooling
    Fan Speed 1247 RPM
    Mouse
    PS/2 Compatible Mouse
    Keyboard
    Standard PS/2 Keyboard
    Internet Speed
    http://www.speedtest.net/result/1538974261.png
Couldn't sleep easy so hooked out of the sack and tried your last suggestion.

Very interesting result! If I open up a new admin account using the virtual keyboard, once established then the numeric lock is off but the keyboard stays the same, i.e. no space key no F keys and only certain keys upon the main qwerty.

If I log on to my old admin account and put up the virtual keyboard and hit the numeric lock it switches off the numeric lock on my old account but keyboard remains only partially operational as above.

This tells me that the problem is probably hardware rather than software! I think that whilst in my sons care (lack of!) the laptop has either been dropped and the ribbon connection to the main board has become partially disconnected, or more likely his daft wife has knocked a coffee across the keyboard and screwed it!!

Later this morning I will remove the keyboard (which is virtually new) and investigate: likely to find that everything has been thrown at it! The power pack for the machine came back screwed, and so nothing would surprise me!

Also if you think about it, the F2 key into the Bios is not working during boot up, so I do think that the keyboard problem is likely hardware!

Will advise when I have chance to investigate further.

Sherlock Holmes P.C. investigator! grins
 

My Computer

System One

  • Manufacturer/Model
    Advent 7113 Laptop
    CPU
    Celeron
    Motherboard
    Advent
    Memory
    2 M

tom982

٩(͡๏̯͡๏)۶
Vista Guru
Gold Member
Hello Ragamuffin and welcome to the forums :party:

Have you got a spare USB keyboard that you could use? If you do, then plug it in and see if it functions correctly :) This will establish whether the fault is caused by hardware or software

Tom
 

My Computer

System One

  • Manufacturer/Model
    Build #1
    CPU
    Intel Core i7 3770K @4.4GHz
    Motherboard
    ASUS P8Z77-V PRO
    Memory
    Corsair Vengeance 2x4GB DDR3 1600MHz Low Profile (White)
    Graphics Card(s)
    Gigabyte Radeon HD 7850 (2GB GDDR5)
    Sound Card
    Integrated on motherboard
    Monitor(s) Displays
    23" LG LCD/LED IPS
    Screen Resolution
    1920*1080
    Hard Drives
    Samsung EVO 128GB SSD
    Seagate Barracuda 2TB 7200rpm
    2x500GB Seagate FreeAgent 5400rpm
    PSU
    Corsair TX650W V2 (80+ Bronze)
    Case
    NZXT Phantom 410
    Cooling
    Corsair H100 Water Cooler, 1x140mm and 1x120mm stock fans
    Mouse
    Microsoft Desktop 2000 Wireless Mouse
    Keyboard
    Microsoft Desktop 2000 Wireless Keyboard
    Internet Speed
    95 Mb/s Download 70 Mb/s Upload
Hi Guys

Well it looks as I suspected! I have taken out the keyboard and removed the ribbon connection, then reconnected without success.

On the right hand side inner keyboard-well, of what was a brand new replacement keyboard, right across the ram memory; an ominous brown liquid stain, sticky to touch: looks like spilled coffee: you can see where the liquid has spread across the inner casing, and across the metal!!

We are hosting my son and his "worse half" for dinner today: 'an English Roast, and it won't be the only thing that will get roasted!!

Can I thank you guys and gals for your valued input on this: VERY MUCH APPRECIATED, but at the end of the day almost certainly sticky fingers have been at work here, and I'm certain who was responsible!

So its back to my trusty brand new Desk Top 3 Core I5 with tried and well tested XP Pro. At least some of us know the true value of careful computer usage, and respect for equipment.

Again, my grateful thanks to all.

Take care now.

Ragamuffin

P.S.

And on this day in the UK which is Remembrance Sunday can I point you to the following link which has a special place in my heart for both our lost British & American Boys and Girls!:_

In keeping the spirit of Remembrance week.

Something that I don't normally shout about.

I wrote, composed and recorded the following in 2002:-

"Northern Ireland, Iraqi, Afghanistan, Syria, Egypt, and now Libya!

Perhaps one day "Ol' Johnnie Blue might be allowed to sleep in peace"..... but I doubt it?"

http://ragamuffin.biz/film/johnnieblue.wmv

Take care now.

Ragamuffin
 

My Computer

System One

  • Manufacturer/Model
    Advent 7113 Laptop
    CPU
    Celeron
    Motherboard
    Advent
    Memory
    2 M

Yard Dog

Vista Guru
Gold Member
Morning, i just got my first cup of coffee and and reading your results , glad i was able to assist you in getting to the bottom of the issue, but, regret hearing of the news of coffee stains, ouch !!! Thanks also for the posting of Remembrance Week article you wrote, Good luck and hope you have a good day. Come back to read the tutorials posted by Brink in this forum or to join in assisting others.
 

My Computer

System One

  • Manufacturer/Model
    Emachine ET 1161-05
    CPU
    AMD Athlon 64 LE-1640
    Motherboard
    eMachines MCP61PM-GM (Socket AM2 )
    Memory
    2.00 GB Dual-Channel DDR2 @ 387MHz (6-6-6-18)
    Graphics Card(s)
    Acer E181H ([email protected]) 128MB GeForce 6150SE nForce 430 (
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    Name Acer E181H on NVIDIA GeForce 6150SE nForce 430
    Screen Resolution
    1280x768 pixels
    Hard Drives
    ST316081 5AS SCSI Disk Device
    PSU
    MCP61PM-GM 9000 NVIDIA Chipset Model MCP61 Chipset Revisio
    Case
    Tower
    Cooling
    Fan Speed 1247 RPM
    Mouse
    PS/2 Compatible Mouse
    Keyboard
    Standard PS/2 Keyboard
    Internet Speed
    http://www.speedtest.net/result/1538974261.png

townsbg

~~тσωηsвg~~
Vista Guru
Gold Member
Yeah that wasn't a good thing to do.
 

My Computers

System One System Two

  • Operating System
    Windows 7 Pro x64
    Manufacturer/Model
    Mid 2010 iMac
    CPU
    Quad core 3.2 Ghz Intel I3
    Memory
    8 gb
    Graphics Card(s)
    ATI Radeon HD 5670 512 mb ram
    Screen Resolution
    1920x1080 and 1440x900
    Hard Drives
    1 TB
    Other Info
    N/A
  • Operating System
    Windows 2008 R2 Enterprise
    Manufacturer/Model
    Compaq Presario SR5350F
    CPU
    Pentium 2.0 gHZ Dual core E2160
    Memory
    2 gb
    Screen Resolution
    1440 x 900
    Hard Drives
    300 GB
Top