Open Each folder in its own window Bug

G

GTS

FWIW I've been analyzing this problem - i.e. the fact that Vista ignores the
Open Each folder in its own window setting. I find this a major usability
aggravation. In case anyone is interested, when changing this option it
toggles the 5th byte in the Settings key below between 0a for open in same
window and 2a for open in own window. I tried some experimentation with the
values (looking at what XP uses) with no success. If nothing else, this
indicates that the problem is not in Folder Options failing to save a
setting, but in Vista failing to use it.

[HKEY_USERS\S-1-5-21-922192377-234827669-2519656814-1000\Software\Microsoft\Windows\CurrentVersion\Explorer\CabinetState]
"Settings"=hex:0c,00,02,00,2a,01,00,00,60,00,00,00

If anyone has any other info about this or any work around, please let us
know.
 

My Computer

R

Rich Bell

"GTS" <[email protected]> wrote in message
news:[email protected]
> FWIW I've been analyzing this problem - i.e. the fact that Vista ignores
> the Open Each folder in its own window setting. I find this a major
> usability aggravation. In case anyone is interested, when changing this
> option it toggles the 5th byte in the Settings key below between 0a for
> open in same window and 2a for open in own window. I tried some
> experimentation with the values (looking at what XP uses) with no success.
> If nothing else, this indicates that the problem is not in Folder Options
> failing to save a setting, but in Vista failing to use it.
>
> [HKEY_USERS\S-1-5-21-922192377-234827669-2519656814-1000\Software\Microsoft\Windows\CurrentVersion\Explorer\CabinetState]
> "Settings"=hex:0c,00,02,00,2a,01,00,00,60,00,00,00
>
> If anyone has any other info about this or any work around, please let us
> know.
>


If you right click on the folder and select "Open" it will open in a new
windows. If you select "Explore" it will open in the same window. Explore is
the default action. If you can change that it should fix it.
 

My Computer

G

GTS

"Rich Bell" <[email protected]> wrote in message
news:[email protected]
>
> "GTS" <[email protected]> wrote in message
> news:[email protected]
>> FWIW I've been analyzing this problem - i.e. the fact that Vista ignores
>> the Open Each folder in its own window setting. I find this a major
>> usability aggravation. In case anyone is interested, when changing this
>> option it toggles the 5th byte in the Settings key below between 0a for
>> open in same window and 2a for open in own window. I tried some
>> experimentation with the values (looking at what XP uses) with no
>> success. If nothing else, this indicates that the problem is not in
>> Folder Options failing to save a setting, but in Vista failing to use it.
>>
>> [HKEY_USERS\S-1-5-21-922192377-234827669-2519656814-1000\Software\Microsoft\Windows\CurrentVersion\Explorer\CabinetState]
>> "Settings"=hex:0c,00,02,00,2a,01,00,00,60,00,00,00
>>
>> If anyone has any other info about this or any work around, please let us
>> know.
>>

>
> If you right click on the folder and select "Open" it will open in a new
> windows. If you select "Explore" it will open in the same window. Explore
> is the default action. If you can change that it should fix it.


Thanks. That's a good point and a lead to some further research.
So far there doesn't seem to be any way to change that default action. (I'm
still researching that.) It's interesting that if you do right click to
Open, the folder always opens in it's own Window, regardless of the "Open
Each folder in its own window" setting. An option to Explore in own window
by double clicking would be acceptable, but doesn't exist either. (right
clicking and selecting Open folder location is the manual equivalent.) The
upshot seems to be that there's just no way to open or explore a folder by
double clicking it rather than having to right click and select menu
options.
I guess a lot of people wouldn't care, but I find it a major annoyance
inconvenience when I want open a number of folders to work with or organize
files.
 

My Computer

V

voyager

Hi,
i'm having the same problem. But no solution yet. The only thing that seems
to work (for now) is making a new account under Vista. My second (standard)
account works fine now and opens each folder in its own window.
But my admin account stays the same and does not get it right.
Sorry guys for my bad english.

I hope we can find a solution.




"Rich Bell" <[email protected]> schreef in bericht
news:[email protected]
>
> "GTS" <[email protected]> wrote in message
> news:[email protected]
>> FWIW I've been analyzing this problem - i.e. the fact that Vista ignores
>> the Open Each folder in its own window setting. I find this a major
>> usability aggravation. In case anyone is interested, when changing this
>> option it toggles the 5th byte in the Settings key below between 0a for
>> open in same window and 2a for open in own window. I tried some
>> experimentation with the values (looking at what XP uses) with no
>> success. If nothing else, this indicates that the problem is not in
>> Folder Options failing to save a setting, but in Vista failing to use it.
>>
>> [HKEY_USERS\S-1-5-21-922192377-234827669-2519656814-1000\Software\Microsoft\Windows\CurrentVersion\Explorer\CabinetState]
>> "Settings"=hex:0c,00,02,00,2a,01,00,00,60,00,00,00
>>
>> If anyone has any other info about this or any work around, please let us
>> know.
>>

>
> If you right click on the folder and select "Open" it will open in a new
> windows. If you select "Explore" it will open in the same window. Explore
> is the default action. If you can change that it should fix it.
 

My Computer

G

GTS

Interesting. I just created another account and it had the same problem.
Some others have commented on this in the thread below, one with a finding
like yours.
http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=1215422&SiteID=17

If you're comfortable with the registry, I would be interested in what
data the working account shows in the Setting key under
HKEY_USERS\S-1-5-21-2906963813-540635898-969211686-1009\Software\Microsoft\Windows\CurrentVersion\Explorer\CabinetState\


"voyager" <[email protected]> wrote in message
news:%[email protected]
> Hi,
> i'm having the same problem. But no solution yet. The only thing that
> seems to work (for now) is making a new account under Vista. My second
> (standard) account works fine now and opens each folder in its own window.
> But my admin account stays the same and does not get it right.
> Sorry guys for my bad english.
>
> I hope we can find a solution.
>
>
>
>
> "Rich Bell" <[email protected]> schreef in bericht
> news:[email protected]
>>
>> "GTS" <[email protected]> wrote in message
>> news:[email protected]
>>> FWIW I've been analyzing this problem - i.e. the fact that Vista ignores
>>> the Open Each folder in its own window setting. I find this a major
>>> usability aggravation. In case anyone is interested, when changing this
>>> option it toggles the 5th byte in the Settings key below between 0a for
>>> open in same window and 2a for open in own window. I tried some
>>> experimentation with the values (looking at what XP uses) with no
>>> success. If nothing else, this indicates that the problem is not in
>>> Folder Options failing to save a setting, but in Vista failing to use
>>> it.
>>>
>>> [HKEY_USERS\S-1-5-21-922192377-234827669-2519656814-1000\Software\Microsoft\Windows\CurrentVersion\Explorer\CabinetState]
>>> "Settings"=hex:0c,00,02,00,2a,01,00,00,60,00,00,00
>>>
>>> If anyone has any other info about this or any work around, please let
>>> us know.
>>>

>>
>> If you right click on the folder and select "Open" it will open in a new
>> windows. If you select "Explore" it will open in the same window. Explore
>> is the default action. If you can change that it should fix it.

>
 

My Computer

P

Peter W

My Computer

D

DanR

This does not work for me. And... ticking "open each folder in its own
window" from "Organize / Folder and search options has no effect. The only
way I can get multiple folder windows to open is to right click a folder and
left click "open".
Or turn off "Organize / layout /Navigation pane.
Seems like there was a time when I did not have this problem.


"Peter W" <[email protected]> wrote in message
news:[email protected]

>
> Go to Control Panel and double click Folder Options. Click View. Uncheck
> "display simple folder view in Navigation pane". Click OK. Then you can
> open multiple windows in "Computer" by double clicking as in previous
> Windows versions.
>
>
> --
> Peter W
> ------------------------------------------------------------------------
> Peter W's Profile: http://forums.techarena.in/member.php?userid=33613
> View this thread: http://forums.techarena.in/showthread.php?t=695736
>
> http://forums.techarena.in
>
 

My Computer

C

cuneyt

You can check the setting below in the registry:

HKEY_CLASSES_ROOT\Folder\shell

(Default) setting must be have a value of "(Value not set)

This makes windows to use the setting in the folder options.

If the default setting is open windows opens every folder in seperate
window; if the setting is expore windows opens every folder in same
window without regarding to the setting you specified in folder
options.


--
cuneyt
------------------------------------------------------------------------
cuneyt's Profile: http://forums.techarena.in/member.php?userid=48277
View this thread: http://forums.techarena.in/showthread.php?t=695736

http://forums.techarena.in
 

My Computer

N

Nou Bary

Hi, I have the same problem and resolve following these steps:

- copy the values data of
COMPUTER\HKEY_CLASSES_ROOT\Folder\shell\open\command : (Default) and
DelegateExecute to

COMPUTER\HKEY_CLASSES_ROOT\Folder\shell\explore\command respectively
but delete the word /separate from de default value and, in case,
DelegateExecute does not exists create and paste the value of
DelegateExecute from the Open Key.


At the end, You will have the following value in the key
COMPUTER\HKEY_CLASSES_ROOT\Folder\shell\explore\command :

(Default) -> "%SystemRoot%\Explorer.exe /idlist,%I,%L" .

DelegateExecute -> value of
"COMPUTER\HKEY_CLASSES_ROOT\Folder\shell\explore\command\DelegateExecute"

After that, the parameter works ok, means, if you select open each
folder in the same window or open in its own windows, works as should
be.


--
Nou Bary
------------------------------------------------------------------------
Nou Bary's Profile: http://forums.techarena.in/members/nou-bary.htm
View this thread: http://forums.techarena.in/vista-help/695736.htm

http://forums.techarena.in
 

My Computer

imekul

New Member
You can check the setting below in the registry:

HKEY_CLASSES_ROOT\Folder\shell

(Default) setting must be have a value of "(Value not set)

This makes windows to use the setting in the folder options.

If the default setting is open windows opens every folder in seperate
window; if the setting is expore windows opens every folder in same
window without regarding to the setting you specified in folder
options.


--
cuneyt
------------------------------------------------------------------------
cuneyt's Profile: cuneyt's profile on TechArena Computer Hardware Support Forums of India
View this thread: Open Each folder in its own window Bug - Vista Help

TechArena Community - Technology and Computer Hardware Support Forums of India
That fixed it for me!!

Wow. It's great to have this rather irritating problem taken care of. Thanks so much for sharing it!
 

My Computer

MilesAhead

Eclectician
Vista Guru
Gold Member
You can check the setting below in the registry:

HKEY_CLASSES_ROOT\Folder\shell

(Default) setting must be have a value of "(Value not set)

This makes windows to use the setting in the folder options.

If the default setting is open windows opens every folder in seperate
window; if the setting is expore windows opens every folder in same
window without regarding to the setting you specified in folder
options.


--
cuneyt
------------------------------------------------------------------------
cuneyt's Profile: cuneyt's profile on TechArena Computer Hardware Support Forums of India
View this thread: Open Each folder in its own window Bug - Vista Help

TechArena Community - Technology and Computer Hardware Support Forums of India
That fixed it for me!!

Wow. It's great to have this rather irritating problem taken care of. Thanks so much for sharing it!
An alternative is just to use my freeware
Half Shell. It has 2 hotkeys. Shift-Enter opens selections in a 32 bit shell so that many 32 bit shell extensions will work(64 bit OS only) but the other hotkey, Control-Enter opens selections in separate windows just like XP.

You can read the description and download from here:
Hotkeys
 

My Computer

System One

  • Manufacturer/Model
    HP Pavilion m9515y
    CPU
    Phenom X4 9850
    Memory
    8 GB
    Graphics Card(s)
    Some Radeon Cheapie with 512 MB Ram
    Monitor(s) Displays
    CRT
    Screen Resolution
    1280x1024
    Hard Drives
    750 GB SATA 3G
    2 SIIG Superspeed docks w/WD Caviar Black Sata II or III

VLaaD

New Member
Hi guys,

I just experienced this horrible misbehavior. Whatever I did, it was fruitless (trying to restore default settings, restart machine, repeat the sequence, in few iterations in different orders, etc.)

Then, I came up to the following links (you should note this only as the reference, I'll write exactly what helped me):

1. One site describes complete loss of folder view functionality; I saw this just once in my experience, some eight years ago, on Windows 2000.
JSI Tip 8321. Is your Windows Explorer folder pane blank?

2. The other one describes steps to fix Windows Explorer to be able (again) to open html/htm files.
Opening html/htm files from Windows Explorer

Second case inspired me to try to register mentioned dll's from the following batch file:

Code:
@echo off
REM Do not use this batch - just example of what I did
regsvr32.exe /s urlmon.dll 
regsvr32.exe /s shdocvw.dll 
regsvr32.exe /s oleaut32.dll
regsvr32.exe /s actxprxy.dll
regsvr32.exe /s mshtml.dll
After executing this (under elevated-privileges command prompt), all of a sudden my problem was gone for good!

However, you actually don't have to do all these registrations - just one is enough in order to enforce Windows Explorer obey "Open each folder in the same window":

Code:
@echo off
REM This is the right batch file for the Open each folder bug
regsvr32.exe /s actxprxy.dll
You can confirm that this is the right solution, if you intentionally unregister the mentioned file and start new instance of explorer.exe - the old buggy behavior is now returned - but it is an easy task to revert it.

*BUT* (!!#@*!$!)

a) New method to fetch updates from Microsoft for your Windows Vista and Windows 2008 Server (I suppose Windows Seven too, I didn't see it), called "Windows Update" sometimes get broken, somehow (you are unable to even start it) - I'm writing this because of the (lucky?) guys who didn't see Windows Vista and/or Windows 2008 server.

b) if you are developer using Microsoft Visual Studio (any recent edition, including Express), or Microsoft SQL Server Books Online, more precisely - you are utilising dexplore.exe to read all help files related to standard libraries, MSDN, etc. you have a chance (rare, to be honest) to experience impossibility of browsing the mentioned help files, under unknown circumstances (I didn't have chance to investigate further). The error message describes that the ms-help:// protocol handler is unable to open the documentation (or something like that).

The solution for both of these problems is to unregister
Code:
regsvr32.exe /u actxprxy.dll
the mentioned .dll and results are visible immediately - Windows Update will start to work and dexplore.exe will be able to open the documentation.

I can draw no conclusion on this

other that sometimes registering the actxprxy.dll (ActiveX Interface Marshalling Library) and sometimes (temporarily) unregistering it resolves some really, really annoying problems on modern operating systems (some people would say "sloppy tested and developed Frankenstein-looking and feeling OS sold at arrogantly high prices to the money-loundry companies and insane individuals" - but not me).

Think about this when you next time see the advertisements such as "More reliable than ever", "Completely rewritten code base", "100% Vertically Compatible", "Solid as a rock" and similar Goebbels-propaganda from any company.

I hope that anything from this helped. I've lost some life time for this, you know.

Cheers
VLaaD
 

My Computer

RPGash

New Member
DelegateExecute -> value of
"COMPUTER\HKEY_CLASSES_ROOT\Folder\shell\explore\command\DelegateExecute"
Thanks for this, it worked for me. But i had to put the exact contents of

"DelegateExecute"

from HKEY_CLASSES_ROOT\Folder\shell\open\command\

into the new explore\command KEY, which was {11dbb47c-a525-400b-9e80-a54615a090c0}

the above quote didnt work giving an error when i tried to open a directory in windows explorer.
 

My Computer

System One

  • Manufacturer/Model
    Self Built
    CPU
    Intel Core 2 CPU 6700 @ 2.66GHz (O/C @ 2.99Ghz)
    Motherboard
    IN9 32X MAX (680i-MCP55PXE)
    Memory
    3070 Mb RAM
    Graphics Card(s)
    nVidia GeForce 8800 GTS 640 Mb (x2)
    Sound Card
    Creative SB X-Fi
    Monitor(s) Displays
    BenQ FP241W 24"
    Screen Resolution
    1920 x 1200
    Hard Drives
    1 Tb WD
    500 Gb WD
    250 Gb WD
    Case
    Antec Nine Hundred
    Cooling
    Zalman CNPS9700 NT CPU Cooler
    Mouse
    Logitech MX1000
    Keyboard
    Eclipse

litlof42

New Member
Hi I'm having this same stupid problem. I did the basic check of checking the folder options but I had it set to "open in same window"
I then checked my registry (even if I am exceedingly hesitant to even mess with it) for that specified value and it was "Value not set"
I rebooted my computer many times to no avail.

Being the terrible OS noob that I am, please help me in my terrible plight! It's driving me nuts!

*Edit: I forgot to mention that all of this occurred promptly after I installed the recent MS Office 2007 patch/update (great job MS...)
 

My Computer

C

Chad Harris

"litlof42" <[email protected]> wrote in message
news:[email protected]

>
> Hi I'm having this same stupid problem. I did the basic check of
> checking the folder options but I had it set to "open in same window"
> I then checked my registry (even if I am exceedingly hesitant to even
> mess with it) for that specified value and it was "Value not set"
> I rebooted my computer many times to no avail.
>
> Being the terrible OS noob that I am, please help me in my terrible
> plight! It's driving me nuts!
>
> *Edit: I forgot to mention that all of this occurred promptly after I
> installed the recent MS Office 2007 patch/update (great job MS...)
>
>
> --
> litlof42
Hi--

Forgive me but what exactly is the problem you have now specifically that
you didn't have before? You say

"Hi I'm having this same stupid problem." Okay. And what is the problem?
Is it that the folders won't open in a new window and now they're opening in
the same window? When you type "control folders" (loose the quotes) in the
run box, and check either "show all folders" or automatically expand to
current folder" does a check in each or either help?

What can't you do that you now want to do?

Does this help you? It tells how to get the folder open in a new Window in
Vista?

http://www.vistax64.com/tutorials/91587-open-folder-same-separate-new-window.html

OR

BTW have you tried a restore point prior to when you had the problem that
you think is secondary to installing an Office SP of some type for some
version of Office?

Are these any help at all since I'm left guessing about what your problem
actually is with folders?

"Open Containing Folder" in Search for Files and Folders does not workWhen
you perform a file search, and then click the Open Containing Folder in the
context menu of the Search Results window, instead of opening the parent ...
www.winhelponline.com/articles/77/1/Open-Containing-Folder-in-Search-for-Files-and-Folders-does-not-work.html

How to Make Folders Appear as Cascading Menu in the Quick Launch ...Some
people would like to view the contents of the folder (cascaded as a list)
rather than opening the folder when clicked. Here is how to make folders in
....
www.winhelponline.com/blog/quicklaunch-toolbar-folders-appear-as-cascading-menu/

Best,

CH
 

My Computer

litlof42

New Member
Hi Chad Harris,

I apologize, I was not specific enough - the problem is that the folders ALWAYS open in a new window.
Like I said, I tried the fixes (going into the folder options and making sure the option to open it in the same window is checked, which it is/was) and checking my registry.
Despite this, it still opens in a new window.

I have not tried the restore point method, but as I go to look at the nearest restore point, it happens to be the day that this Office service pack was installed. It was apparently also installed with a bunch of other windows patches/updates, which I stand to lose if I restore...

What should I do?
 

My Computer

lemalin

New Member
Bonjour,
J'ai exactement le même problème : le "double clic" avec la souris ouvre systématiquement les répertoires de l'explorateur windows dans une nouvelle fenêtre ce qui est super gonflant ! Il faut que je fasse "clic droit > Explorer" pour rester dans la même fenêtre ...

J'ai fait ce qui était préconisé ; voilà un dump des valeurs du registre pour les clés concernées (voir après).

Le pb a semblé être réglé une fois, mais après avoir éteint/rallumé l'ordi le pb est réapparu et je n'arrive plus à revenir à la situation normale ou tous les dossiers s'ouvrent dans un même répertoire.

Merci pour ceux qui auraient une idée ? est-ce qu'on peut définir par hasard qqpart la fonction par défaut associée au double-clic ?

Gilles

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Folder\shell\]

[HKEY_CLASSES_ROOT\Folder\shell\\explore]
"MultiSelectModel"="Document"
"BrowserFlags"=dword:00000022
"ExplorerFlags"=dword:00000021

[HKEY_CLASSES_ROOT\Folder\shell\\explore\command]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\
65,00,20,00,2f,00,69,00,64,00,6c,00,69,00,73,00,74,00,2c,00,25,00,49,00,2c,\
00,25,00,4c,00,00,00
"DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"

[HKEY_CLASSES_ROOT\Folder\shell\\open]
"MultiSelectModel"="Document"
"BrowserFlags"=dword:00000010
"ExplorerFlags"=dword:00000012

[HKEY_CLASSES_ROOT\Folder\shell\\open\command]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\
65,00,20,00,2f,00,69,00,64,00,6c,00,69,00,73,00,74,00,2c,00,25,00,49,00,2c,\
00,25,00,4c,00,00,00
"DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"
 

My Computer

Top