• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

'Open With' - How to add and remove programs

I

Imageman

#1
Vista 64 / RC1 SP1

The programs I use, like Photoshop CS3, are not present in the right click
'Open With' dialog, and there are a bunch of things there that I never use.
How do I add and remove items? - Help appreciated - IM

--
USA - Washington State, Kitsap County "Replies welcomed as a sign of good
etiquette" Nostradamus 1560
 

My Computer

T

Timothy

#2
under the list of options should be "choose defualt" or something close
to it.
click that.
A window shows up with given options at the top, but browse button at
the bottom, with the browse you can pick any program.


--
Timothy
Posted via http://www.vistaheads.com
 

My Computer

I

Imageman

#3
Timothy, Thanks! - Yes, I've tried that, and I chose Photoshop.exe, then
selected OK. The image then pops open in "Windows Photo Gallery". In
addition, I don't want to change the default for the program that opens jpg
files, I just want Photoshop to appear in the 'Open With' dialog (instead of
all those programs I don't use)?

Vista leaves a lot to be desired . . especially considering I'm running the
SP1 release candidate and I thought all these 'things' had been fixed?

"Timothy" <Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com> wrote in message
news:Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com...

>
> under the list of options should be "choose defualt" or something close
> to it.
> click that.
> A window shows up with given options at the top, but browse button at
> the bottom, with the browse you can pick any program.
>
>
> --
> Timothy
> Posted via http://www.vistaheads.com
>
 

My Computer

T

Timothy

#4
ok, two things;
1: after selecting protoshop, uncheck "make this the defualt program
for this file type" that is right near the browse button.
2: did protoshop appear in the feild of other options? (to show the
feild click the little arrow at the right end of the line dubbed "other
options" under the defualts feild. If it did (after getting to it via
browse) then double click it there (after unselecting make this defualt)
without using the ok button, this ensures that it is the selection and
it doesn't mystriously act as if picture veiwer were selected.

If this doesn't work you could always just open photoshop then open the
file from there, but that doesn't really fix the problem, just go around
it, I try to avoid giving those answers.


--
Timothy
Posted via http://www.vistaheads.com
 

My Computer

C

Cameron Snyder

#5
If Photoshop doesn't appear in the dialog it is because it did not insert
itself there properly in the registry when installed. If other pgms appear
there that you don't like it isn't Vista that put them there. If you don't
use the pgrms, remove them. If their uninstall routines don't remove them
from dialog, again, it is not Vista that F'd up.

Find the registry entries that place them in the dialog and delete them
yourself. I have Half-life 2 that appears in my open with. It shouldn't be
there, but Vista isn't the culprit, and if I really cared it wouldn't be
there.


"Imageman" <Imageman@xxxxxx> wrote in message
news:HamdnUJsIPXXYj3anZ2dnUVZ_jCdnZ2d@xxxxxx

> Timothy, Thanks! - Yes, I've tried that, and I chose Photoshop.exe, then
> selected OK. The image then pops open in "Windows Photo Gallery". In
> addition, I don't want to change the default for the program that opens
> jpg files, I just want Photoshop to appear in the 'Open With' dialog
> (instead of all those programs I don't use)?
>
> Vista leaves a lot to be desired . . especially considering I'm running
> the SP1 release candidate and I thought all these 'things' had been fixed?
>
> "Timothy" <Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com> wrote in message
> news:Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com...

>>
>> under the list of options should be "choose defualt" or something close
>> to it.
>> click that.
>> A window shows up with given options at the top, but browse button at
>> the bottom, with the browse you can pick any program.
>>
>>
>> --
>> Timothy
>> Posted via http://www.vistaheads.com
>>
 

My Computer

I

Imageman

#6
I've spent all the time I'm willing to spend on this. I want productivity,
not nonsense. And I don't intend to become an expert. Don't get me wrong,
I'm moderately happy with Vista, but irritated by things in Vista that
should be easy to fix, but aren't. And I'm not alone . . .




"Cameron Snyder" <dntbther@xxxxxx> wrote in message
news:eFlFgP6YIHA.484@xxxxxx

> If Photoshop doesn't appear in the dialog it is because it did not insert
> itself there properly in the registry when installed. If other pgms appear
> there that you don't like it isn't Vista that put them there. If you don't
> use the pgrms, remove them. If their uninstall routines don't remove them
> from dialog, again, it is not Vista that F'd up.
>
> Find the registry entries that place them in the dialog and delete them
> yourself. I have Half-life 2 that appears in my open with. It shouldn't be
> there, but Vista isn't the culprit, and if I really cared it wouldn't be
> there.
>
>
> "Imageman" <Imageman@xxxxxx> wrote in message
> news:HamdnUJsIPXXYj3anZ2dnUVZ_jCdnZ2d@xxxxxx

>> Timothy, Thanks! - Yes, I've tried that, and I chose Photoshop.exe, then
>> selected OK. The image then pops open in "Windows Photo Gallery". In
>> addition, I don't want to change the default for the program that opens
>> jpg files, I just want Photoshop to appear in the 'Open With' dialog
>> (instead of all those programs I don't use)?
>>
>> Vista leaves a lot to be desired . . especially considering I'm running
>> the SP1 release candidate and I thought all these 'things' had been
>> fixed?
>>
>> "Timothy" <Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com> wrote in message
>> news:Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com...

>>>
>>> under the list of options should be "choose defualt" or something close
>>> to it.
>>> click that.
>>> A window shows up with given options at the top, but browse button at
>>> the bottom, with the browse you can pick any program.
>>>
>>>
>>> --
>>> Timothy
>>> Posted via http://www.vistaheads.com
>>>
>
 

My Computer

C

Cameron Snyder

#7
Well, you are on your own then. Good luck. I hope whining works for you,
having become an expert at that. Truly, you are not alone.

"Imageman" <Imageman@xxxxxx> wrote in message
news:Z6ednaWYGJrDtjzanZ2dnUVZ_sGvnZ2d@xxxxxx

> I've spent all the time I'm willing to spend on this. I want productivity,
> not nonsense. And I don't intend to become an expert. Don't get me wrong,
> I'm moderately happy with Vista, but irritated by things in Vista that
> should be easy to fix, but aren't. And I'm not alone . . .
>
> "Cameron Snyder" <dntbther@xxxxxx> wrote in message
> news:eFlFgP6YIHA.484@xxxxxx

>> If Photoshop doesn't appear in the dialog it is because it did not insert
>> itself there properly in the registry when installed. If other pgms
>> appear there that you don't like it isn't Vista that put them there. If
>> you don't use the pgrms, remove them. If their uninstall routines don't
>> remove them from dialog, again, it is not Vista that F'd up.
>>
>> Find the registry entries that place them in the dialog and delete them
>> yourself. I have Half-life 2 that appears in my open with. It shouldn't
>> be there, but Vista isn't the culprit, and if I really cared it wouldn't
>> be there.
>>
>>
>> "Imageman" <Imageman@xxxxxx> wrote in message
>> news:HamdnUJsIPXXYj3anZ2dnUVZ_jCdnZ2d@xxxxxx

>>> Timothy, Thanks! - Yes, I've tried that, and I chose Photoshop.exe,
>>> then selected OK. The image then pops open in "Windows Photo Gallery".
>>> In addition, I don't want to change the default for the program that
>>> opens jpg files, I just want Photoshop to appear in the 'Open With'
>>> dialog (instead of all those programs I don't use)?
>>>
>>> Vista leaves a lot to be desired . . especially considering I'm running
>>> the SP1 release candidate and I thought all these 'things' had been
>>> fixed?
>>>
>>> "Timothy" <Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com> wrote in message
>>> news:Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com...
>>>>
>>>> under the list of options should be "choose defualt" or something close
>>>> to it.
>>>> click that.
>>>> A window shows up with given options at the top, but browse button at
>>>> the bottom, with the browse you can pick any program.
>>>>
>>>>
>>>> --
>>>> Timothy
>>>> Posted via http://www.vistaheads.com
>>>>
>>
 

My Computer

K

Keith Miller \(MVP\)

#8
If you don't want to edit the registry, you could place a shortcut to
Photoshop in your 'Send to' folder. In the 'Start Search' box, type:

shell:sendto

to open the folder, then copy an existing shortcut into the folder or use
the new shortcut wizard.


Will post instructions for the reg edit if you're interested.


--
Good Luck,

Keith
Microsoft MVP [Windows Shell/User]



"Imageman" <Imageman@xxxxxx> wrote in message
news:Z6ednaWYGJrDtjzanZ2dnUVZ_sGvnZ2d@xxxxxx

> I've spent all the time I'm willing to spend on this. I want productivity,
> not nonsense. And I don't intend to become an expert. Don't get me wrong,
> I'm moderately happy with Vista, but irritated by things in Vista that
> should be easy to fix, but aren't. And I'm not alone . . .
>
>
>
>
> "Cameron Snyder" <dntbther@xxxxxx> wrote in message
> news:eFlFgP6YIHA.484@xxxxxx

>> If Photoshop doesn't appear in the dialog it is because it did not insert
>> itself there properly in the registry when installed. If other pgms
>> appear there that you don't like it isn't Vista that put them there. If
>> you don't use the pgrms, remove them. If their uninstall routines don't
>> remove them from dialog, again, it is not Vista that F'd up.
>>
>> Find the registry entries that place them in the dialog and delete them
>> yourself. I have Half-life 2 that appears in my open with. It shouldn't
>> be there, but Vista isn't the culprit, and if I really cared it wouldn't
>> be there.
>>
>>
>> "Imageman" <Imageman@xxxxxx> wrote in message
>> news:HamdnUJsIPXXYj3anZ2dnUVZ_jCdnZ2d@xxxxxx

>>> Timothy, Thanks! - Yes, I've tried that, and I chose Photoshop.exe,
>>> then selected OK. The image then pops open in "Windows Photo Gallery".
>>> In addition, I don't want to change the default for the program that
>>> opens jpg files, I just want Photoshop to appear in the 'Open With'
>>> dialog (instead of all those programs I don't use)?
>>>
>>> Vista leaves a lot to be desired . . especially considering I'm running
>>> the SP1 release candidate and I thought all these 'things' had been
>>> fixed?
>>>
>>> "Timothy" <Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com> wrote in message
>>> news:Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com...
>>>>
>>>> under the list of options should be "choose defualt" or something close
>>>> to it.
>>>> click that.
>>>> A window shows up with given options at the top, but browse button at
>>>> the bottom, with the browse you can pick any program.
>>>>
>>>>
>>>> --
>>>> Timothy
>>>> Posted via http://www.vistaheads.com
>>>>
>>
 

My Computer

I

Imageman

#9
Keith - Please post the reg edit instructions, and thanks for the positive
reply - Best, Bob

" Keith Miller (MVP)" <k.miller@xxxxxx> wrote in message
news:#HAIPp9YIHA.4272@xxxxxx

> If you don't want to edit the registry, you could place a shortcut to
> Photoshop in your 'Send to' folder. In the 'Start Search' box, type:
>
> shell:sendto
>
> to open the folder, then copy an existing shortcut into the folder or use
> the new shortcut wizard.
>
>
> Will post instructions for the reg edit if you're interested.
>
>
> --
> Good Luck,
>
> Keith
> Microsoft MVP [Windows Shell/User]
>
>
>
> "Imageman" <Imageman@xxxxxx> wrote in message
> news:Z6ednaWYGJrDtjzanZ2dnUVZ_sGvnZ2d@xxxxxx

>> I've spent all the time I'm willing to spend on this. I want
>> productivity, not nonsense. And I don't intend to become an expert. Don't
>> get me wrong, I'm moderately happy with Vista, but irritated by things in
>> Vista that should be easy to fix, but aren't. And I'm not alone . . .
>>
>>
>>
>>
>> "Cameron Snyder" <dntbther@xxxxxx> wrote in message
>> news:eFlFgP6YIHA.484@xxxxxx

>>> If Photoshop doesn't appear in the dialog it is because it did not
>>> insert itself there properly in the registry when installed. If other
>>> pgms appear there that you don't like it isn't Vista that put them
>>> there. If you don't use the pgrms, remove them. If their uninstall
>>> routines don't remove them from dialog, again, it is not Vista that F'd
>>> up.
>>>
>>> Find the registry entries that place them in the dialog and delete them
>>> yourself. I have Half-life 2 that appears in my open with. It shouldn't
>>> be there, but Vista isn't the culprit, and if I really cared it wouldn't
>>> be there.
>>>
>>>
>>> "Imageman" <Imageman@xxxxxx> wrote in message
>>> news:HamdnUJsIPXXYj3anZ2dnUVZ_jCdnZ2d@xxxxxx
>>>> Timothy, Thanks! - Yes, I've tried that, and I chose Photoshop.exe,
>>>> then selected OK. The image then pops open in "Windows Photo Gallery".
>>>> In addition, I don't want to change the default for the program that
>>>> opens jpg files, I just want Photoshop to appear in the 'Open With'
>>>> dialog (instead of all those programs I don't use)?
>>>>
>>>> Vista leaves a lot to be desired . . especially considering I'm running
>>>> the SP1 release candidate and I thought all these 'things' had been
>>>> fixed?
>>>>
>>>> "Timothy" <Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com> wrote in message
>>>> news:Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com...
>>>>>
>>>>> under the list of options should be "choose defualt" or something
>>>>> close
>>>>> to it.
>>>>> click that.
>>>>> A window shows up with given options at the top, but browse button at
>>>>> the bottom, with the browse you can pick any program.
>>>>>
>>>>>
>>>>> --
>>>>> Timothy
>>>>> Posted via http://www.vistaheads.com
>>>>>
>>>
>
 

My Computer

I

Imageman

#10
Timothy, Thanks for your help! IM

"Timothy" <Timothy.340vo6@xxxxxx-mx.forums.vistaheads.com> wrote in message
news:Timothy.340vo6@xxxxxx-mx.forums.vistaheads.com...

>
> ok, two things;
> 1: after selecting protoshop, uncheck "make this the defualt program
> for this file type" that is right near the browse button.
> 2: did protoshop appear in the feild of other options? (to show the
> feild click the little arrow at the right end of the line dubbed "other
> options" under the defualts feild. If it did (after getting to it via
> browse) then double click it there (after unselecting make this defualt)
> without using the ok button, this ensures that it is the selection and
> it doesn't mystriously act as if picture veiwer were selected.
>
> If this doesn't work you could always just open photoshop then open the
> file from there, but that doesn't really fix the problem, just go around
> it, I try to avoid giving those answers.
>
>
> --
> Timothy
> Posted via http://www.vistaheads.com
>
 

My Computer

R

Ramesh, MS-MVP

#11
Registering programs with the "Open With" dialog:
http://windowsxp.mvps.org/openwithadd.htm

--
Regards,

Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
Windows® Troubleshooting http://www.winhelponline.com


"Imageman" <Imageman@xxxxxx> wrote in message news:HamdnUJsIPXXYj3anZ2dnUVZ_jCdnZ2d@xxxxxx
Timothy, Thanks! - Yes, I've tried that, and I chose Photoshop.exe, then
selected OK. The image then pops open in "Windows Photo Gallery". In
addition, I don't want to change the default for the program that opens jpg
files, I just want Photoshop to appear in the 'Open With' dialog (instead of
all those programs I don't use)?

Vista leaves a lot to be desired . . especially considering I'm running the
SP1 release candidate and I thought all these 'things' had been fixed?

"Timothy" <Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com> wrote in message
news:Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com...

>
> under the list of options should be "choose defualt" or something close
> to it.
> click that.
> A window shows up with given options at the top, but browse button at
> the bottom, with the browse you can pick any program.
>
>
> --
> Timothy
> Posted via http://www.vistaheads.com
>
 

My Computer

Z

zachd [MSFT]

#12
It's a bug in Adobe's installer. It would take them a minimal amount of
time to fix. You should ask their support staff to add this feature to
their installer. ( HKEY_CLASSES_ROOT \ Applications registration .) It's
really simple. If they can't figure it out, have them use their Microsoft
contact, who should be able to straighten them out in minutes. Heck, the
Microsoft contact can head my way, I do this sort of thing all the time.

If Adobe wants to offer me a free product, I'll certainly take care of this
for them. ;-) But really, this is trivial, and it's just something that
their software could be adding.

--
Speaking for myself only.
See http://zachd.com/pss/pss.html for some helpful WMP info.
This posting is provided "AS IS" with no warranties, and confers no rights.
--

"Imageman" <Imageman@xxxxxx> wrote in message
news:Z6ednaWYGJrDtjzanZ2dnUVZ_sGvnZ2d@xxxxxx

> I've spent all the time I'm willing to spend on this. I want productivity,
> not nonsense. And I don't intend to become an expert. Don't get me wrong,
> I'm moderately happy with Vista, but irritated by things in Vista that
> should be easy to fix, but aren't. And I'm not alone . . .
>
>
>
>
> "Cameron Snyder" <dntbther@xxxxxx> wrote in message
> news:eFlFgP6YIHA.484@xxxxxx

>> If Photoshop doesn't appear in the dialog it is because it did not insert
>> itself there properly in the registry when installed. If other pgms
>> appear there that you don't like it isn't Vista that put them there. If
>> you don't use the pgrms, remove them. If their uninstall routines don't
>> remove them from dialog, again, it is not Vista that F'd up.
>>
>> Find the registry entries that place them in the dialog and delete them
>> yourself. I have Half-life 2 that appears in my open with. It shouldn't
>> be there, but Vista isn't the culprit, and if I really cared it wouldn't
>> be there.
>>
>>
>> "Imageman" <Imageman@xxxxxx> wrote in message
>> news:HamdnUJsIPXXYj3anZ2dnUVZ_jCdnZ2d@xxxxxx

>>> Timothy, Thanks! - Yes, I've tried that, and I chose Photoshop.exe,
>>> then selected OK. The image then pops open in "Windows Photo Gallery".
>>> In addition, I don't want to change the default for the program that
>>> opens jpg files, I just want Photoshop to appear in the 'Open With'
>>> dialog (instead of all those programs I don't use)?
>>>
>>> Vista leaves a lot to be desired . . especially considering I'm running
>>> the SP1 release candidate and I thought all these 'things' had been
>>> fixed?
>>>
>>> "Timothy" <Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com> wrote in message
>>> news:Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com...
>>>>
>>>> under the list of options should be "choose defualt" or something close
>>>> to it.
>>>> click that.
>>>> A window shows up with given options at the top, but browse button at
>>>> the bottom, with the browse you can pick any program.
>>>>
>>>>
>>>> --
>>>> Timothy
>>>> Posted via http://www.vistaheads.com
>>>>
>>
 

My Computer

I

Imageman

#13
Ramesh - Perfect! and thank you - IM

"Ramesh, MS-MVP" <ramesh@xxxxxx> wrote in message
news:#njHxtIZIHA.4808@xxxxxx

> Registering programs with the "Open With" dialog:
> http://windowsxp.mvps.org/openwithadd.htm
>
> --
> Regards,
>
> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
> Windows® Troubleshooting http://www.winhelponline.com
>
>
> "Imageman" <Imageman@xxxxxx> wrote in message
> news:HamdnUJsIPXXYj3anZ2dnUVZ_jCdnZ2d@xxxxxx
> Timothy, Thanks! - Yes, I've tried that, and I chose Photoshop.exe, then
> selected OK. The image then pops open in "Windows Photo Gallery". In
> addition, I don't want to change the default for the program that opens
> jpg
> files, I just want Photoshop to appear in the 'Open With' dialog (instead
> of
> all those programs I don't use)?
>
> Vista leaves a lot to be desired . . especially considering I'm running
> the
> SP1 release candidate and I thought all these 'things' had been fixed?
>
> "Timothy" <Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com> wrote in message
> news:Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com...

>>
>> under the list of options should be "choose defualt" or something close
>> to it.
>> click that.
>> A window shows up with given options at the top, but browse button at
>> the bottom, with the browse you can pick any program.
>>
>>
>> --
>> Timothy
>> Posted via http://www.vistaheads.com
>>
 

My Computer

X

Xenomorph

#14
You *could* try something like this:
http://xenomorph.net/?page_id=492

It lets you remove file associtions for the current user (cleaning out the
list).

You can then add the programs you want back easily.

Vista does not have the file association manager that 9x/2000/XP had.


"Imageman" <Imageman@xxxxxx> wrote in message
news:L4adnQ4tJf4dQj3anZ2dnUVZ_uevnZ2d@xxxxxx

> Vista 64 / RC1 SP1
>
> The programs I use, like Photoshop CS3, are not present in the right click
> 'Open With' dialog, and there are a bunch of things there that I never
> use. How do I add and remove items? - Help appreciated - IM
>
> --
> USA - Washington State, Kitsap County "Replies welcomed as a sign of
> good etiquette" Nostradamus 1560
>
>
>
 

My Computer

R

Ramesh, MS-MVP

#15
You're welcome IM.

--
Regards,

Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
Windows® Troubleshooting http://www.winhelponline.com


"Imageman" <Imageman@xxxxxx> wrote in message news:uqednTwsn_lmhT7anZ2dnUVZ_qKgnZ2d@xxxxxx
Ramesh - Perfect! and thank you - IM

"Ramesh, MS-MVP" <ramesh@xxxxxx> wrote in message
news:#njHxtIZIHA.4808@xxxxxx

> Registering programs with the "Open With" dialog:
> http://windowsxp.mvps.org/openwithadd.htm
>
> --
> Regards,
>
> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
> Windows® Troubleshooting http://www.winhelponline.com
>
>
> "Imageman" <Imageman@xxxxxx> wrote in message
> news:HamdnUJsIPXXYj3anZ2dnUVZ_jCdnZ2d@xxxxxx
> Timothy, Thanks! - Yes, I've tried that, and I chose Photoshop.exe, then
> selected OK. The image then pops open in "Windows Photo Gallery". In
> addition, I don't want to change the default for the program that opens
> jpg
> files, I just want Photoshop to appear in the 'Open With' dialog (instead
> of
> all those programs I don't use)?
>
> Vista leaves a lot to be desired . . especially considering I'm running
> the
> SP1 release candidate and I thought all these 'things' had been fixed?
>
> "Timothy" <Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com> wrote in message
> news:Timothy.340sw6@xxxxxx-mx.forums.vistaheads.com...

>>
>> under the list of options should be "choose defualt" or something close
>> to it.
>> click that.
>> A window shows up with given options at the top, but browse button at
>> the bottom, with the browse you can pick any program.
>>
>>
>> --
>> Timothy
>> Posted via http://www.vistaheads.com
>>
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)