• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

PDF's won't Associate with Acrobat

A

adamsr2

#1
I can’t get Windows Vista Professional to associate my .pdf files with my
Adobe Acrobat Standard 8.1. This became a problem after I had to completely
uninstall and re-install Adobe Acrobat. All my .pdf files are reachable if I
open Adobe Acrobat first and within Adobe Acrobat navigate to open the files.
I tried re-installing Adobe Acrobat but that didn’t help.

I worked with file association by right clicking a .pdf file and choosing
“Open With…†I get to the “Open With†window which doesn’t have Adobe
Acrobat listed among the “Recommended Programs†or “Other Programsâ€. So, I
click on “Browseâ€. This takes me to the “Open With†navigation tree window.
I navigate to the Adobe Acrobat exe file. I single click on the file.
“Adobe†is entered in the File Name field below. Then I click on “Open†(the
default choice). This takes me back to the “Open With†window. But Adobe
Acrobat is not added to this window as the “Recommended Program†or as an
“Other Program†for me to select. I checked to make sure in the navigation
window that I really have selected the Adobe Acrobat exe file. I double
click on it and Adobe Acrobat Standard 8.0 opens up.

I have gone into the Control Panel Default Programs settings, Associate a
file type, and done the same thing. But this eventually takes me to the
“Open With†windows and the result is the same. I tried doing “Start†then
“Default Programs†and still get the same result.

One thing which could be affecting this, but I don’t think it shouldn’t, is
I departed from the default install folder of Program Files/Adobe/Acrobat 8.0
to install the program. I installed it in Program Files/Adobe/Acrobat 810
because of some problems with uninstalling my previous version of Acrobat 8.

Pdf files on the internet are unaffected. I am logged on as administrator.
My HKey_Classes_Root registry for PDF has a sub-folder OpenWithList which as
a sub-folder Acrobat.exe. The key is a default REG_SZ.

How can I get Vista to associate my .pdf’s with Acrobat?
 

My Computer

D

dean-dean

#2
In the key

HKEY_CLASSES_ROOT\AcroExch.Document\Shell\Open\Command

what is the value? I have Adobe Reader, but it should look something like
this:

"C:\Program Files\Adobe\Reader 8.0\Reader\AcroRd32.exe" "%1"

Of course, the path and names will be different for Adobe Acrobat on your
computer. Note that the path is in quotes, followed by a space, followed by
%1 in quotes.


"adamsr2" <adamsr2@discussions.microsoft.com> wrote in message
news:DE9F76E0-531E-4F31-8AFB-275C1582DEF8@microsoft.com...
>I can’t get Windows Vista Professional to associate my .pdf files with my
> Adobe Acrobat Standard 8.1. This became a problem after I had to
> completely
> uninstall and re-install Adobe Acrobat. All my .pdf files are reachable
> if I
> open Adobe Acrobat first and within Adobe Acrobat navigate to open the
> files.
> I tried re-installing Adobe Acrobat but that didn’t help.
>
> I worked with file association by right clicking a .pdf file and choosing
> “Open With…†I get to the “Open With†window which doesn’t have Adobe
> Acrobat listed among the “Recommended Programs†or “Other Programsâ€. So,
> I
> click on “Browseâ€. This takes me to the “Open With†navigation tree
> window.
> I navigate to the Adobe Acrobat exe file. I single click on the file.
> “Adobe†is entered in the File Name field below. Then I click on “Openâ€
> (the
> default choice). This takes me back to the “Open With†window. But
> Adobe
> Acrobat is not added to this window as the “Recommended Program†or as an
> “Other Program†for me to select. I checked to make sure in the
> navigation
> window that I really have selected the Adobe Acrobat exe file. I double
> click on it and Adobe Acrobat Standard 8.0 opens up.
>
> I have gone into the Control Panel Default Programs settings, Associate a
> file type, and done the same thing. But this eventually takes me to the
> “Open With†windows and the result is the same. I tried doing “Startâ€
> then
> “Default Programs†and still get the same result.
>
> One thing which could be affecting this, but I don’t think it shouldn’t,
> is
> I departed from the default install folder of Program Files/Adobe/Acrobat
> 8.0
> to install the program. I installed it in Program Files/Adobe/Acrobat 810
> because of some problems with uninstalling my previous version of Acrobat
> 8.
>
> Pdf files on the internet are unaffected. I am logged on as administrator.
> My HKey_Classes_Root registry for PDF has a sub-folder OpenWithList which
> as
> a sub-folder Acrobat.exe. The key is a default REG_SZ.
>
> How can I get Vista to associate my .pdf’s with Acrobat?
>
 

My Computer

A

adamsr2

#3
Thanks for the information, but still no cigar.

In the HKEY_CLASSES_ROOT\AcroExch.Document\Shell\Open\Command key I had
"C:\Program Files\Adobe\Acrobat 8.0\Acrobat\Acrobat.exe" "%1" The Acrobat
8.0 folder does not have the Acrobat.exe. So, I changed the key to read:
"C:\Program Files\Adobe\Acrobat 810\Acrobat\Acrobat.exe" "%1" This is where
the Acrobat.exe is locate.

But that didn't change anything. Have you got any more suggestions?

Thanks....


"dean-dean" wrote:

> In the key
>
> HKEY_CLASSES_ROOT\AcroExch.Document\Shell\Open\Command
>
> what is the value? I have Adobe Reader, but it should look something like
> this:
>
> "C:\Program Files\Adobe\Reader 8.0\Reader\AcroRd32.exe" "%1"
>
> Of course, the path and names will be different for Adobe Acrobat on your
> computer. Note that the path is in quotes, followed by a space, followed by
> %1 in quotes.
>
>
> "adamsr2" <adamsr2@discussions.microsoft.com> wrote in message
> news:DE9F76E0-531E-4F31-8AFB-275C1582DEF8@microsoft.com...
> >I can’t get Windows Vista Professional to associate my .pdf files with my
> > Adobe Acrobat Standard 8.1. This became a problem after I had to
> > completely
> > uninstall and re-install Adobe Acrobat. All my .pdf files are reachable
> > if I
> > open Adobe Acrobat first and within Adobe Acrobat navigate to open the
> > files.
> > I tried re-installing Adobe Acrobat but that didn’t help.
> >
> > I worked with file association by right clicking a .pdf file and choosing
> > “Open With…†I get to the “Open With†window which doesn’t have Adobe
> > Acrobat listed among the “Recommended Programs†or “Other Programsâ€. So,
> > I
> > click on “Browseâ€. This takes me to the “Open With†navigation tree
> > window.
> > I navigate to the Adobe Acrobat exe file. I single click on the file.
> > “Adobe†is entered in the File Name field below. Then I click on “Openâ€
> > (the
> > default choice). This takes me back to the “Open With†window. But
> > Adobe
> > Acrobat is not added to this window as the “Recommended Program†or as an
> > “Other Program†for me to select. I checked to make sure in the
> > navigation
> > window that I really have selected the Adobe Acrobat exe file. I double
> > click on it and Adobe Acrobat Standard 8.0 opens up.
> >
> > I have gone into the Control Panel Default Programs settings, Associate a
> > file type, and done the same thing. But this eventually takes me to the
> > “Open With†windows and the result is the same. I tried doing “Startâ€
> > then
> > “Default Programs†and still get the same result.
> >
> > One thing which could be affecting this, but I don’t think it shouldn’t,
> > is
> > I departed from the default install folder of Program Files/Adobe/Acrobat
> > 8.0
> > to install the program. I installed it in Program Files/Adobe/Acrobat 810
> > because of some problems with uninstalling my previous version of Acrobat
> > 8.
> >
> > Pdf files on the internet are unaffected. I am logged on as administrator.
> > My HKey_Classes_Root registry for PDF has a sub-folder OpenWithList which
> > as
> > a sub-folder Acrobat.exe. The key is a default REG_SZ.
> >
> > How can I get Vista to associate my .pdf’s with Acrobat?
> >

>
>
 

My Computer

D

dean-dean

#4
I think I would do this. Adobe writes a slew of registry entries when it is
installed that have path referrals. The fact that that one key seems to be
written incorrectly may only be the tip of the iceburg. I would uninstall
Acrobat, delete any Acrobat folder under C:\Program Files\Adobe\ (e.g.,
Acrobat 8.0, Acrobat 810), and, in the Registry, delete these keys (on the
left-hand side of the pane) (if ithey still exist):

HKEY_CLASSES_ROOT\.pdf
and
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.pdf

Also delete these folders (if they still exist):
C:\Program Files\Common Files\Adobe\Acrobat
C:\ProgramData\Adobe\Acrobat
C:\Users\(Your Name)\AppData\Roaming\Adobe\Acrobat
C:\Users\(Your Name)\AppData\Local\Adobe\Acrobat

Download and install the Windows Installer CleanUp Utility, found here:

http://support.microsoft.com/kb/290301

Run Windows Install Clean Up (a shortcut should be
in the Start Menu). Highlight all references to Acrobat (only!), if they
exist, and click on Remove.

Now install Acrobat using the Installer's default settings, e.g., don't
change the path. Hopefully, things will work correctly after all that.

"adamsr2" <adamsr2@discussions.microsoft.com> wrote in message
news:03777BDD-BF9E-48EA-BB05-DE9D7E21D2D9@microsoft.com...
> Thanks for the information, but still no cigar.
>
> In the HKEY_CLASSES_ROOT\AcroExch.Document\Shell\Open\Command key I had
> "C:\Program Files\Adobe\Acrobat 8.0\Acrobat\Acrobat.exe" "%1" The Acrobat
> 8.0 folder does not have the Acrobat.exe. So, I changed the key to read:
> "C:\Program Files\Adobe\Acrobat 810\Acrobat\Acrobat.exe" "%1" This is
> where
> the Acrobat.exe is locate.
>
> But that didn't change anything. Have you got any more suggestions?
>
> Thanks....
>
>
> "dean-dean" wrote:
>
>> In the key
>>
>> HKEY_CLASSES_ROOT\AcroExch.Document\Shell\Open\Command
>>
>> what is the value? I have Adobe Reader, but it should look something
>> like
>> this:
>>
>> "C:\Program Files\Adobe\Reader 8.0\Reader\AcroRd32.exe" "%1"
>>
>> Of course, the path and names will be different for Adobe Acrobat on your
>> computer. Note that the path is in quotes, followed by a space, followed
>> by
>> %1 in quotes.
>>
>>
>> "adamsr2" <adamsr2@discussions.microsoft.com> wrote in message
>> news:DE9F76E0-531E-4F31-8AFB-275C1582DEF8@microsoft.com...
>> >I can’t get Windows Vista Professional to associate my .pdf files with
>> >my
>> > Adobe Acrobat Standard 8.1. This became a problem after I had to
>> > completely
>> > uninstall and re-install Adobe Acrobat. All my .pdf files are
>> > reachable
>> > if I
>> > open Adobe Acrobat first and within Adobe Acrobat navigate to open the
>> > files.
>> > I tried re-installing Adobe Acrobat but that didn’t help.
>> >
>> > I worked with file association by right clicking a .pdf file and
>> > choosing
>> > “Open With…†I get to the “Open With†window which doesn’t have Adobe
>> > Acrobat listed among the “Recommended Programs†or “Other Programsâ€.
>> > So,
>> > I
>> > click on “Browseâ€. This takes me to the “Open With†navigation tree
>> > window.
>> > I navigate to the Adobe Acrobat exe file. I single click on the file.
>> > “Adobe†is entered in the File Name field below. Then I click on
>> > “Openâ€
>> > (the
>> > default choice). This takes me back to the “Open With†window. But
>> > Adobe
>> > Acrobat is not added to this window as the “Recommended Program†or as
>> > an
>> > “Other Program†for me to select. I checked to make sure in the
>> > navigation
>> > window that I really have selected the Adobe Acrobat exe file. I
>> > double
>> > click on it and Adobe Acrobat Standard 8.0 opens up.
>> >
>> > I have gone into the Control Panel Default Programs settings, Associate
>> > a
>> > file type, and done the same thing. But this eventually takes me to
>> > the
>> > “Open With†windows and the result is the same. I tried doing “Startâ€
>> > then
>> > “Default Programs†and still get the same result.
>> >
>> > One thing which could be affecting this, but I don’t think it shouldn’t,
>> > is
>> > I departed from the default install folder of Program
>> > Files/Adobe/Acrobat
>> > 8.0
>> > to install the program. I installed it in Program Files/Adobe/Acrobat
>> > 810
>> > because of some problems with uninstalling my previous version of
>> > Acrobat
>> > 8.
>> >
>> > Pdf files on the internet are unaffected. I am logged on as
>> > administrator.
>> > My HKey_Classes_Root registry for PDF has a sub-folder OpenWithList
>> > which
>> > as
>> > a sub-folder Acrobat.exe. The key is a default REG_SZ.
>> >
>> > How can I get Vista to associate my .pdf’s with Acrobat?
>> >

>>
>>
 

My Computer

A

adamsr2

#5
I have success!

I took your strategy of Acrobat 8.0 references in my registry to the
extreme. I found I had over three dozen Acrobat 8.0 references in the
Classes_Root. So, I backed up my registry and created a new restore point
and changed seven more in addition to the one you suggested. It worked! I
went into default programs and found Adobe Acrobat 8.0 as one of the
recommended programs. I clicked on it and viola! I had the correct
association. I also opened a few pdf files to make sure it worked. It did!

Here are the keys I changed (al in classes_root):
Acrobat\defaultIcon
Acrobat\Shell\Open\Command
AcroExch.Document\Shell\Open\Command
AcroExch.Document\Shell\print\Command
AcroExcg.Document\Shell\printto\Command
AcroExch.Document.7\protocol\StdFileEditing\server
ArcoExch.Document.7\Shell\open\Command
ArcoExch.Document.7\Shell\Print\Command
ArchExch.Document.7\Shell\Printto\Command

I probably was overkill, but everything seems to work. Thanks so much!

"adamsr2" wrote:

> I can’t get Windows Vista Professional to associate my .pdf files with my
> Adobe Acrobat Standard 8.1. This became a problem after I had to completely
> uninstall and re-install Adobe Acrobat. All my .pdf files are reachable if I
> open Adobe Acrobat first and within Adobe Acrobat navigate to open the files.
> I tried re-installing Adobe Acrobat but that didn’t help.
>
> I worked with file association by right clicking a .pdf file and choosing
> “Open With…†I get to the “Open With†window which doesn’t have Adobe
> Acrobat listed among the “Recommended Programs†or “Other Programsâ€. So, I
> click on “Browseâ€. This takes me to the “Open With†navigation tree window.
> I navigate to the Adobe Acrobat exe file. I single click on the file.
> “Adobe†is entered in the File Name field below. Then I click on “Open†(the
> default choice). This takes me back to the “Open With†window. But Adobe
> Acrobat is not added to this window as the “Recommended Program†or as an
> “Other Program†for me to select. I checked to make sure in the navigation
> window that I really have selected the Adobe Acrobat exe file. I double
> click on it and Adobe Acrobat Standard 8.0 opens up.
>
> I have gone into the Control Panel Default Programs settings, Associate a
> file type, and done the same thing. But this eventually takes me to the
> “Open With†windows and the result is the same. I tried doing “Start†then
> “Default Programs†and still get the same result.
>
> One thing which could be affecting this, but I don’t think it shouldn’t, is
> I departed from the default install folder of Program Files/Adobe/Acrobat 8.0
> to install the program. I installed it in Program Files/Adobe/Acrobat 810
> because of some problems with uninstalling my previous version of Acrobat 8.
>
> Pdf files on the internet are unaffected. I am logged on as administrator.
> My HKey_Classes_Root registry for PDF has a sub-folder OpenWithList which as
> a sub-folder Acrobat.exe. The key is a default REG_SZ.
>
> How can I get Vista to associate my .pdf’s with Acrobat?
>
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)