• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Powershell Remoting in broken between CTP3 and RC1

B

Bob Landau

#1
For those which have both Vista/W2k8 and either Win7 or W2k8r2 could you try
this out is very simple.

PS-Vista> Enter-PSSession -Computer Win7Machine -Port 5985

At least this is what I've found note you must explicitly set the ports
since they've changed CTP3 (80) and Win7 (5985)

Here is what works for me

CTP3 <-> CTP3 for Vista-to-Vista W2k8-to-Vista, ...
RC1 <-> RC1 Here I only have a Win7 setup

Granted even if my findings are correct this can't be called a bug however
it would sure be nice if Microsoft gave us a updated release i.e CTP4



The error I get when going from CTP3 to RC1 are:

Enter-PSSession : Processing data from remote server failed with the
following error message: The WS-Management service
cannot process the request because the request contained invalid selectors
for the resource.

and going from RC1 to CTP3 I get:

Enter-PSSession : Processing data from remote server failed with the
following error message: Remoting data is missing
Version property. For more information, see the about_Remote_Troubleshooting
Help topic.


In all cases netowork connectivity has been established and I have been both
authenticated and authorized CreateShell succeeds but the ReceiveShellOutput
fails with the error code of 2152992672. I suspect this is just random
garbage on the stack though since WSManReceiveShellOutput returns nothing. In
either the netmon trace or eventlog I see WSMan Listener returnning the error
HTTP 500
 

My Computer

M

Marco Shaw [MVP]

#2
Yup, you need the same version of PowerShell and WinRM on both ends to
connect. Once PowerShell v2 and WinRM 2.0 are out (as final versions), I'd
expect any updates to remain compatible though, except maybe once v3 comes
along...

Not just the ports have changed, but also the applications themselves...
The same happened when trying CTP1 and CTP2, for example...

Marco

"Bob Landau" <BobLandau@xxxxxx> wrote in message
news:A1691DD2-0ED4-4114-BFD7-821A426B45B2@xxxxxx

> For those which have both Vista/W2k8 and either Win7 or W2k8r2 could you
> try
> this out is very simple.
>
> PS-Vista> Enter-PSSession -Computer Win7Machine -Port 5985
>
> At least this is what I've found note you must explicitly set the ports
> since they've changed CTP3 (80) and Win7 (5985)
>
> Here is what works for me
>
> CTP3 <-> CTP3 for Vista-to-Vista W2k8-to-Vista, ...
> RC1 <-> RC1 Here I only have a Win7 setup
>
> Granted even if my findings are correct this can't be called a bug however
> it would sure be nice if Microsoft gave us a updated release i.e CTP4
>
>
>
> The error I get when going from CTP3 to RC1 are:
>
> Enter-PSSession : Processing data from remote server failed with the
> following error message: The WS-Management service
> cannot process the request because the request contained invalid selectors
> for the resource.
>
> and going from RC1 to CTP3 I get:
>
> Enter-PSSession : Processing data from remote server failed with the
> following error message: Remoting data is missing
> Version property. For more information, see the
> about_Remote_Troubleshooting
> Help topic.
>
>
> In all cases netowork connectivity has been established and I have been
> both
> authenticated and authorized CreateShell succeeds but the
> ReceiveShellOutput
> fails with the error code of 2152992672. I suspect this is just random
> garbage on the stack though since WSManReceiveShellOutput returns nothing.
> In
> either the netmon trace or eventlog I see WSMan Listener returnning the
> error
> HTTP 500
>
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)