printer sharing via home network with Win7, WinXP, & Vista

G

Guest

With much stumbling, I have been able to configure, via Control Panel, the
printer settings on the WinXP desktop to print to the printer that is
physically connected via USB cable to the Win7 desktop. When I File/Print
and select the appropriate printer name from the dropdown list, the printing
is fully successful.

Attempting to apply the same steps with the Vista laptop fails.

The printer was at one time installed and connected via USB to the laptop,
and therefore an icon for it exists in Control Panel/Printers. I select the
printer name, right click, properties, Ports, Add Port, Local Port.

When I got to this point on the WinXP computer, I had only to enter
\\XPS9000\Canon Inkjet iP6700D as the port name, and all was good. But on
the Vista laptop, I get an Local Port error window "Access is denied"

Perhaps having three different operating systems adds complexity to
networking a printer. But someone can help me overcome it, I hope.

BTW, when I go to Control Panel/Printers on the XP computer, the port name
in properties is exactly as I specified above. A curious thing is that when
I go to the Sharing tab, the spelling for the Share name is "CanoniP"
 

My Computer

R

R.Q

On 3/1/2010 5:52 PM, [email protected] wrote:

> With much stumbling, I have been able to configure, via Control Panel, the
> printer settings on the WinXP desktop to print to the printer that is
> physically connected via USB cable to the Win7 desktop. When I File/Print
> and select the appropriate printer name from the dropdown list, the printing
> is fully successful.
>
> Attempting to apply the same steps with the Vista laptop fails.
>
> The printer was at one time installed and connected via USB to the laptop,
> and therefore an icon for it exists in Control Panel/Printers. I select the
> printer name, right click, properties, Ports, Add Port, Local Port.
>
> When I got to this point on the WinXP computer, I had only to enter
> \\XPS9000\Canon Inkjet iP6700D as the port name, and all was good. But on
> the Vista laptop, I get an Local Port error window "Access is denied"
>
> Perhaps having three different operating systems adds complexity to
> networking a printer. But someone can help me overcome it, I hope.
>
> BTW, when I go to Control Panel/Printers on the XP computer, the port name
> in properties is exactly as I specified above. A curious thing is that when
> I go to the Sharing tab, the spelling for the Share name is "CanoniP"
>
>
Try the fix mentioned here:

http://social.technet.microsoft.com.../thread/8c3c3d97-9d85-4ab0-9fc8-4b7aba202fb2/
 

My Computer

G

Guest

I went to the post showing the Melonhead "solution." I am at this time
failing to see how what I did differs essentially from Melonhead.'s steps.
BTW, the Win7 computername is XPS9000, where XPS has nothing to do with OS
WinXP. Unlike theshadow6 and patchman10, I have not set up filesharing, as
far as I know. My home network is three computers in the same room. An XP
computer and a Win7 computer connected by ethernet cables to my Actiontec
modem/router gateway, and the Vista laptop wirelessly connected. Up to now,
the only sharing that I have achieved is that I can print to the inkjet
connected to the Win7 by USB cable.

Is what I did different from the Melonhead reference? Is the "Share name"
of significance? Are there instructions for "dummies" on how to access
printers hard-USB-cabled to Win7 and XP printers which are on the same
modem/router/gateway?


"R.Q" <[email protected]> wrote in message
news:[email protected]

> On 3/1/2010 5:52 PM, [email protected] wrote:

>> With much stumbling, I have been able to configure, via Control Panel,
>> the
>> printer settings on the WinXP desktop to print to the printer that is
>> physically connected via USB cable to the Win7 desktop. When I File/Print
>> and select the appropriate printer name from the dropdown list, the
>> printing
>> is fully successful.
>>
>> Attempting to apply the same steps with the Vista laptop fails.
>>
>> The printer was at one time installed and connected via USB to the
>> laptop,
>> and therefore an icon for it exists in Control Panel/Printers. I select
>> the
>> printer name, right click, properties, Ports, Add Port, Local Port.
>>
>> When I got to this point on the WinXP computer, I had only to enter
>> \\XPS9000\Canon Inkjet iP6700D as the port name, and all was good. But
>> on
>> the Vista laptop, I get an Local Port error window "Access is denied"
>>
>> Perhaps having three different operating systems adds complexity to
>> networking a printer. But someone can help me overcome it, I hope.
>>
>> BTW, when I go to Control Panel/Printers on the XP computer, the port
>> name
>> in properties is exactly as I specified above. A curious thing is that
>> when
>> I go to the Sharing tab, the spelling for the Share name is "CanoniP"
>>
>>
> Try the fix mentioned here:
>
> http://social.technet.microsoft.com.../thread/8c3c3d97-9d85-4ab0-9fc8-4b7aba202fb2/
 

My Computer

G

Guest

Perhaps I should have mentioned that the laptop runs Vista Home Premium SP2,
the XP desktop is on XP Pro SP3, and the new computer is Win7 Pro 64bit.

"R.Q" <[email protected]> wrote in message
news:[email protected]

> On 3/1/2010 5:52 PM, [email protected] wrote:

>> With much stumbling, I have been able to configure, via Control Panel,
>> the
>> printer settings on the WinXP desktop to print to the printer that is
>> physically connected via USB cable to the Win7 desktop. When I File/Print
>> and select the appropriate printer name from the dropdown list, the
>> printing
>> is fully successful.
>>
>> Attempting to apply the same steps with the Vista laptop fails.
>>
>> The printer was at one time installed and connected via USB to the
>> laptop,
>> and therefore an icon for it exists in Control Panel/Printers. I select
>> the
>> printer name, right click, properties, Ports, Add Port, Local Port.
>>
>> When I got to this point on the WinXP computer, I had only to enter
>> \\XPS9000\Canon Inkjet iP6700D as the port name, and all was good. But
>> on
>> the Vista laptop, I get an Local Port error window "Access is denied"
>>
>> Perhaps having three different operating systems adds complexity to
>> networking a printer. But someone can help me overcome it, I hope.
>>
>> BTW, when I go to Control Panel/Printers on the XP computer, the port
>> name
>> in properties is exactly as I specified above. A curious thing is that
>> when
>> I go to the Sharing tab, the spelling for the Share name is "CanoniP"
>>
>>
> Try the fix mentioned here:
>
> http://social.technet.microsoft.com.../thread/8c3c3d97-9d85-4ab0-9fc8-4b7aba202fb2/
 

My Computer

R

R.Q

On 3/2/2010 7:57 PM, [email protected] wrote:

> Perhaps I should have mentioned that the laptop runs Vista Home Premium SP2,
> the XP desktop is on XP Pro SP3, and the new computer is Win7 Pro 64bit.
>
> "R.Q"<[email protected]> wrote in message
> news:[email protected]

>> On 3/1/2010 5:52 PM, [email protected] wrote:

>>> With much stumbling, I have been able to configure, via Control Panel,
>>> the
>>> printer settings on the WinXP desktop to print to the printer that is
>>> physically connected via USB cable to the Win7 desktop. When I File/Print
>>> and select the appropriate printer name from the dropdown list, the
>>> printing
>>> is fully successful.
>>>
>>> Attempting to apply the same steps with the Vista laptop fails.
>>>
>>> The printer was at one time installed and connected via USB to the
>>> laptop,
>>> and therefore an icon for it exists in Control Panel/Printers. I select
>>> the
>>> printer name, right click, properties, Ports, Add Port, Local Port.
>>>
>>> When I got to this point on the WinXP computer, I had only to enter
>>> \\XPS9000\Canon Inkjet iP6700D as the port name, and all was good. But
>>> on
>>> the Vista laptop, I get an Local Port error window "Access is denied"
>>>
>>> Perhaps having three different operating systems adds complexity to
>>> networking a printer. But someone can help me overcome it, I hope.
>>>
>>> BTW, when I go to Control Panel/Printers on the XP computer, the port
>>> name
>>> in properties is exactly as I specified above. A curious thing is that
>>> when
>>> I go to the Sharing tab, the spelling for the Share name is "CanoniP"
>>>
>>>
>> Try the fix mentioned here:
>>
>> http://social.technet.microsoft.com.../thread/8c3c3d97-9d85-4ab0-9fc8-4b7aba202fb2/
>
>
All I can suggest is keeping the computer names and share names
consistent. Check that the share names are correct on the printer you
are trying to share.I assume it is the wired printer that you trying to
share. Also I had a similar error with a WinXp computer that
necessitated a change of a value in my registry to fix. It can be very
frustrating indeed.Good luck.
 

My Computer

R

R.Q

On 3/2/2010 7:57 PM, [email protected] wrote:

> Perhaps I should have mentioned that the laptop runs Vista Home Premium SP2,
> the XP desktop is on XP Pro SP3, and the new computer is Win7 Pro 64bit.
>
> "R.Q"<[email protected]> wrote in message
> news:[email protected]

>> On 3/1/2010 5:52 PM, [email protected] wrote:

>>> With much stumbling, I have been able to configure, via Control Panel,
>>> the
>>> printer settings on the WinXP desktop to print to the printer that is
>>> physically connected via USB cable to the Win7 desktop. When I File/Print
>>> and select the appropriate printer name from the dropdown list, the
>>> printing
>>> is fully successful.
>>>
>>> Attempting to apply the same steps with the Vista laptop fails.
>>>
>>> The printer was at one time installed and connected via USB to the
>>> laptop,
>>> and therefore an icon for it exists in Control Panel/Printers. I select
>>> the
>>> printer name, right click, properties, Ports, Add Port, Local Port.
>>>
>>> When I got to this point on the WinXP computer, I had only to enter
>>> \\XPS9000\Canon Inkjet iP6700D as the port name, and all was good. But
>>> on
>>> the Vista laptop, I get an Local Port error window "Access is denied"
>>>
>>> Perhaps having three different operating systems adds complexity to
>>> networking a printer. But someone can help me overcome it, I hope.
>>>
>>> BTW, when I go to Control Panel/Printers on the XP computer, the port
>>> name
>>> in properties is exactly as I specified above. A curious thing is that
>>> when
>>> I go to the Sharing tab, the spelling for the Share name is "CanoniP"
>>>
>>>
>> Try the fix mentioned here:
>>
>> http://social.technet.microsoft.com.../thread/8c3c3d97-9d85-4ab0-9fc8-4b7aba202fb2/
>
>
Here are some google links:


http://forums.cnet.com/5208-7589_102-0.html?threadID=232132

http://windows.microsoft.com/en-US/windows-vista/Troubleshoot-network-printer-problems


http://forum.soft32.com/win4/Add-Network-er-Access-Deniedftopic-172653-days0-orderasc-45.html
 

My Computer

Top