PSHED.dll 0xc000009e Error on startup

Calde

New Member
As said in the title, i'm getting a PSHED.dll error, PSHED.dll is missing/corrupt not everytime I startup, but the majority of the time I do in the last 2 days.

And the error code 0xc000009e. Sometimes a simple restart sorts it out and windows boots up. sometimes it doesnt. Lots of sites have said to use a registry cleaner, i've got ccleaner and just feel like using that. I don't really feel safe trying random registry cleaners so i've been avoiding them.

Any help would be great! gotta run to work now, so I will be able to provide more info tonight.

Nearly forgot, Vista home premium 64bit system.
 

My Computer

System One

  • CPU
    Intel Core 2 Duo CPU E7300 2.66GHZ
    Motherboard
    Gigabyte EP45-DS4P
    Memory
    4gb Kingston HyperX
    Graphics Card(s)
    ATI Radeon HD 4850
    Sound Card
    N/A
    Monitor(s) Displays
    ASUS 19" Widescreen
    Screen Resolution
    1440x900
    Hard Drives
    610GB Samsung

Calde

New Member
Anyone got any ideas that would help me out yet? :)
 

My Computer

System One

  • CPU
    Intel Core 2 Duo CPU E7300 2.66GHZ
    Motherboard
    Gigabyte EP45-DS4P
    Memory
    4gb Kingston HyperX
    Graphics Card(s)
    ATI Radeon HD 4850
    Sound Card
    N/A
    Monitor(s) Displays
    ASUS 19" Widescreen
    Screen Resolution
    1440x900
    Hard Drives
    610GB Samsung

stoneys-nutz

Gamerholic
Vista Guru
Gold Member
Hello Calde,
Try this, it may repair the damaged file.​

Go to Start / All Programs / Accessories.
Right click Command Prompt and select the 'Run As Administrator' option.
Click Continue on the UAC prompt.​

In the Command Window, type the following command.​

SFC /SCANNOW​

Press ENTER.​

Good luck and post your results.​
 

My Computer

System One

  • Manufacturer/Model
    Self Build
    CPU
    QX9650 (black box) [email protected]
    Motherboard
    Asus P5Q Premium
    Memory
    8GB-4x2GB Corsair Dominator DDR 2-1066
    Graphics Card(s)
    2 x ASUS EAH 4870 X 2 (Quad)
    Sound Card
    Supreme FX 2
    Monitor(s) Displays
    Fujitsu Siemens 22inch flat screen
    Screen Resolution
    1680x1050
    Hard Drives
    150 Gig WD Raptor
    300 Gig Maxtor
    300 Gig Maxtor, (External)
    PSU
    CoolerMaster 1000
    Case
    CoolerMaster N-Vidia stacker 830
    Cooling
    Noctua NH-U12P x 1x120mm fan, 6x120mm case fans
    Mouse
    Logitech G5
    Keyboard
    Logitech G15
    Internet Speed
    20Mbps
    Other Info
    Audio FX Pro 5+1 gaming head set

Calde

New Member
do want the results of the log created?, it said it found some corrupt files, but was unalbe to fix all. Theres no info in the log that i shouldnt let onto the internet if i attach it to show you?
 

My Computer

System One

  • CPU
    Intel Core 2 Duo CPU E7300 2.66GHZ
    Motherboard
    Gigabyte EP45-DS4P
    Memory
    4gb Kingston HyperX
    Graphics Card(s)
    ATI Radeon HD 4850
    Sound Card
    N/A
    Monitor(s) Displays
    ASUS 19" Widescreen
    Screen Resolution
    1440x900
    Hard Drives
    610GB Samsung

roy69

47,65,65,6B
Vista Guru
Gold Member
If it is unable to fix the problems then do a repair install.
 

My Computer

System One

  • Manufacturer/Model
    Self Built
    CPU
    I5 3570K
    Motherboard
    Gigabyte Z77-DS3H
    Memory
    4 x 4GB corsair ballistix sport DDR3 1600 Mhz
    Graphics Card(s)
    Gigabyte Geforce GTX 660 TI
    Sound Card
    creative x-fi
    Monitor(s) Displays
    Primary CiBox 22" Widescreen LCD ,Secondary Dell 22" Widescreen
    Screen Resolution
    Both 1680 x 1050
    Hard Drives
    2 x 500G HD (SATA) 1 x 2TB USB
    PSU
    Corsair HX 620W ATX2.2 Modular SLI Complient PSU
    Case
    Antec 900 Ultimate Gaming Case
    Cooling
    3 x 80mm tri led front, 120mm side 120mm back, 200mm top
    Mouse
    Technika TKOPTM2
    Keyboard
    Logik
    Internet Speed
    288 / 4000
    Other Info
    Creative Inspire 7.1 T7900 Speakers
    Trust Graphics Tablet

jonny321321

Banned
insert ur recovery disk and boot from it then click ur language and then click repair!
 

My Computer

System One

  • Manufacturer/Model
    Custom Built
    CPU
    Intel Pentium Dual Core E5200 Overclocked @ 2.90
    Motherboard
    ASUStek
    Memory
    OCZ DDR2 PC2-6400 Vista Performance Gold 4GB Dual Channel
    Graphics Card(s)
    ASUStek ENGTX275 PCI-E x 1
    Monitor(s) Displays
    19inch benq
    Screen Resolution
    1400x900
    Hard Drives
    400 gb
    PSU
    700 Watt artic power
    Cooling
    Artic cooler
    Internet Speed
    4.70 mb/s download, 0.37 mb/s upload

Calde

New Member
insert ur recovery disk and boot from it then click ur language and then click repair!
every time i try doing this it refuses to boot from my vista dvd...I thought it would do so automatically like it does tell me to do when it doesnt boot. it says insert vista disk, restart, and repair..but the vista never starts itself to boot from the disk to do a repair install.
 

My Computer

System One

  • CPU
    Intel Core 2 Duo CPU E7300 2.66GHZ
    Motherboard
    Gigabyte EP45-DS4P
    Memory
    4gb Kingston HyperX
    Graphics Card(s)
    ATI Radeon HD 4850
    Sound Card
    N/A
    Monitor(s) Displays
    ASUS 19" Widescreen
    Screen Resolution
    1440x900
    Hard Drives
    610GB Samsung

stoneys-nutz

Gamerholic
Vista Guru
Gold Member
Have you changed the Bios to boot from DVD/CD first in the boot order ?.
 

My Computer

System One

  • Manufacturer/Model
    Self Build
    CPU
    QX9650 (black box) [email protected]
    Motherboard
    Asus P5Q Premium
    Memory
    8GB-4x2GB Corsair Dominator DDR 2-1066
    Graphics Card(s)
    2 x ASUS EAH 4870 X 2 (Quad)
    Sound Card
    Supreme FX 2
    Monitor(s) Displays
    Fujitsu Siemens 22inch flat screen
    Screen Resolution
    1680x1050
    Hard Drives
    150 Gig WD Raptor
    300 Gig Maxtor
    300 Gig Maxtor, (External)
    PSU
    CoolerMaster 1000
    Case
    CoolerMaster N-Vidia stacker 830
    Cooling
    Noctua NH-U12P x 1x120mm fan, 6x120mm case fans
    Mouse
    Logitech G5
    Keyboard
    Logitech G15
    Internet Speed
    20Mbps
    Other Info
    Audio FX Pro 5+1 gaming head set

Calde

New Member
Have you changed the Bios to boot from DVD/CD first in the boot order ?.
will now :), Thought that would be what I had to do, wasnt to keen to play around with it though.
 

My Computer

System One

  • CPU
    Intel Core 2 Duo CPU E7300 2.66GHZ
    Motherboard
    Gigabyte EP45-DS4P
    Memory
    4gb Kingston HyperX
    Graphics Card(s)
    ATI Radeon HD 4850
    Sound Card
    N/A
    Monitor(s) Displays
    ASUS 19" Widescreen
    Screen Resolution
    1440x900
    Hard Drives
    610GB Samsung

stoneys-nutz

Gamerholic
Vista Guru
Gold Member
It's quite easy to do, just remember to change it back afterwards. ;)
 

My Computer

System One

  • Manufacturer/Model
    Self Build
    CPU
    QX9650 (black box) [email protected]
    Motherboard
    Asus P5Q Premium
    Memory
    8GB-4x2GB Corsair Dominator DDR 2-1066
    Graphics Card(s)
    2 x ASUS EAH 4870 X 2 (Quad)
    Sound Card
    Supreme FX 2
    Monitor(s) Displays
    Fujitsu Siemens 22inch flat screen
    Screen Resolution
    1680x1050
    Hard Drives
    150 Gig WD Raptor
    300 Gig Maxtor
    300 Gig Maxtor, (External)
    PSU
    CoolerMaster 1000
    Case
    CoolerMaster N-Vidia stacker 830
    Cooling
    Noctua NH-U12P x 1x120mm fan, 6x120mm case fans
    Mouse
    Logitech G5
    Keyboard
    Logitech G15
    Internet Speed
    20Mbps
    Other Info
    Audio FX Pro 5+1 gaming head set

Frostmourne

Banned
What programs do you have installed? What runs on startup? Have you checked msconfig?
 

My Computer

System One

  • Manufacturer/Model
    Sony Vaio Z46GDU
    CPU
    [email protected] w/6MB L2 cache 1066MHz FSB
    Memory
    6GB DDR3 1066MHz SDRAM
    Graphics Card(s)
    9300M GS 256MB + Intel Integrated 4500MHD
    Monitor(s) Displays
    13.1" WXGA True Colour Tough
    Screen Resolution
    1600x900
    Hard Drives
    320GB SATA 7200RPM
    Internet Speed
    1MB/s

Calde

New Member
Ok, time for an update.

PC is working, as far as I'm aware the problem should be fixed. Although there were some hiccups in the repair. The first time I ran the 'repair my pc' option it did so, and said all was well. Restarted PC as it said, same PSHED.dll error pops up. So I restart and boot from DVD again.

This time after attempting to repair it says 'repair failed would you like to notify microsft with error report'. So I did so, Then it did its 'windows is searching for a solution' which seemed to turn up nothing. So I restarted once more, to recieve the PSHED.dll error again.

So, another restart, 3rd boot from DVD, run the repair again, and it says this time it has fixed it. So i restart again, hoping that it won't lie to me like it did the first time. And amazingly it did indeed boot up after I changed it to boot from the HDD again.

So, hopefully it is fixed for real this time. We'll see next time I end up turning it off. If I ever do :O, thanks the help. Watch this thread!, I could possibly be back very soon if it continues to play up.
 

My Computer

System One

  • CPU
    Intel Core 2 Duo CPU E7300 2.66GHZ
    Motherboard
    Gigabyte EP45-DS4P
    Memory
    4gb Kingston HyperX
    Graphics Card(s)
    ATI Radeon HD 4850
    Sound Card
    N/A
    Monitor(s) Displays
    ASUS 19" Widescreen
    Screen Resolution
    1440x900
    Hard Drives
    610GB Samsung

Calde

New Member
What programs do you have installed? What runs on startup? Have you checked msconfig?
Anything in particular i should be looking for when checking msconfig?

Just basic things on startup, anti-virus, Spybot S&D, java, logitech desktop manager, webcam programs, skype, windows live.
 

My Computer

System One

  • CPU
    Intel Core 2 Duo CPU E7300 2.66GHZ
    Motherboard
    Gigabyte EP45-DS4P
    Memory
    4gb Kingston HyperX
    Graphics Card(s)
    ATI Radeon HD 4850
    Sound Card
    N/A
    Monitor(s) Displays
    ASUS 19" Widescreen
    Screen Resolution
    1440x900
    Hard Drives
    610GB Samsung

stoneys-nutz

Gamerholic
Vista Guru
Gold Member
Most of the programs that are on startup can be started manually, so i would go through them one at a time and see which ones you can do without, remember they can always be started manually when you need them, it just saves a load of programs running in the background doing nothing.
Java, windows live, are just two you can do without.
Give it a go and post your results.
 

My Computer

System One

  • Manufacturer/Model
    Self Build
    CPU
    QX9650 (black box) [email protected]
    Motherboard
    Asus P5Q Premium
    Memory
    8GB-4x2GB Corsair Dominator DDR 2-1066
    Graphics Card(s)
    2 x ASUS EAH 4870 X 2 (Quad)
    Sound Card
    Supreme FX 2
    Monitor(s) Displays
    Fujitsu Siemens 22inch flat screen
    Screen Resolution
    1680x1050
    Hard Drives
    150 Gig WD Raptor
    300 Gig Maxtor
    300 Gig Maxtor, (External)
    PSU
    CoolerMaster 1000
    Case
    CoolerMaster N-Vidia stacker 830
    Cooling
    Noctua NH-U12P x 1x120mm fan, 6x120mm case fans
    Mouse
    Logitech G5
    Keyboard
    Logitech G15
    Internet Speed
    20Mbps
    Other Info
    Audio FX Pro 5+1 gaming head set

Calde

New Member
would they really affect the occurence of the PSHED.dll error when my machine is attempting to boot up? Maybe I should have made the title bootup instead of startup. :o
 

My Computer

System One

  • CPU
    Intel Core 2 Duo CPU E7300 2.66GHZ
    Motherboard
    Gigabyte EP45-DS4P
    Memory
    4gb Kingston HyperX
    Graphics Card(s)
    ATI Radeon HD 4850
    Sound Card
    N/A
    Monitor(s) Displays
    ASUS 19" Widescreen
    Screen Resolution
    1440x900
    Hard Drives
    610GB Samsung

stoneys-nutz

Gamerholic
Vista Guru
Gold Member
Maybe not, but why have them running in the background using resources when there is no need.
You need to look through your startup programs and see if there is anything that is out of place, if you don't think there is anything wrong then leave them as they are.
 

My Computer

System One

  • Manufacturer/Model
    Self Build
    CPU
    QX9650 (black box) [email protected]
    Motherboard
    Asus P5Q Premium
    Memory
    8GB-4x2GB Corsair Dominator DDR 2-1066
    Graphics Card(s)
    2 x ASUS EAH 4870 X 2 (Quad)
    Sound Card
    Supreme FX 2
    Monitor(s) Displays
    Fujitsu Siemens 22inch flat screen
    Screen Resolution
    1680x1050
    Hard Drives
    150 Gig WD Raptor
    300 Gig Maxtor
    300 Gig Maxtor, (External)
    PSU
    CoolerMaster 1000
    Case
    CoolerMaster N-Vidia stacker 830
    Cooling
    Noctua NH-U12P x 1x120mm fan, 6x120mm case fans
    Mouse
    Logitech G5
    Keyboard
    Logitech G15
    Internet Speed
    20Mbps
    Other Info
    Audio FX Pro 5+1 gaming head set
Top