• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Re: Word 2007 Send as Email greyed out

  • Thread starter Doug Robbins - Word MVP
  • Start date
D

Doug Robbins - Word MVP

#1
Here is some information posted by Peter Jamieson. It may not be applicable
to your operating system and mail program, for which it might be better to
ask your question in the microsoft.public.windows.vista.mail newsgroup, to
which I have cross-posted this response.

First, make sure that the e-mail program you want to use is set up to be the
default e-mail program (e.g. via Internet Explorer|Tools|Internet
Options|Programs, and send at least one message using it.

Then Word needs some stuff in WIN.INI and/or in the Windows registry
before it will show you the E-mail option. I believe that for Word 2003 it
needs to be in the Windows registry, but that may depend also on the version
of Windows so it is probably better to put the information in both places.

For WIN.INI,
a. find the WIN.INI file in your Windows folder (typically c:\WINDOWS),
make a backup copy of it, and open it in Notepad.
b. ensure that the following text is in there, and add it if not

[Mail]
MAPI=1
CMCDLLNAME32=mapi32.dll
CMCDLLNAME=mapi.dll
CMC=1
MAPIX=1
MAPIXVER=1.0.0.1
OLEMessaging=1

You will need to close all copies of Word before this change has a chance of
taking effect. It is probably safest to restart Windows to be completely
sure.

If that isn't enough, you will need to edit the registry. Proceed with
caution!

c. In your Windows folder, locate and run regedit.exe. If you're on an
older version of Windows you might need to use regedt32.exe.

Look for a key called

HKEY_LOCAL_MACHINE\SOFTWARE\Mi­crosoft\Windows Messaging Subsystem

I would be surprised if it was not there in recent versions of Windows, but
if it is not, add it.

If it is there, I would expect to see
d. a subkey claled MSMapiApps
e. a number of "values" with the same names as are in the above list -
MAPI, MAPIX etc.
f. an additional value called InstallCmd

If you cannot see the (e) values, you need to add them. For each of the
values in the above list
g. right click "Windows Messaging Subsystem" and select New|String Value.
Note that although some of these items have numeric values, they should all
be entered as String Values.
h. enter the name, as above
i. double click on the name. A dialog box appears. Enter the value (e.g.
for the name CMCDLLNAME, enter mapi.dll) and click OK
j. You may also need to create the InstallCmd value, although I rather
doubt it. I am less sure about this and about what should go in there. On my
system, the value is:
rundll32 setupapi,InstallHinfSection MSMAIL 132 msmail.inf

When you have done them all, press F5. Then close all copies of Word and
restart it - or restart Windows, then restart Word and see if the e-mail
option has appeared.


--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Ben Coyle" <frenz_of_rom@hotmail.com> wrote in message
news:013B92BE-6DAA-46F0-8030-DC1DE1027EDB@microsoft.com...
> Hi
> I have just bought MS Office 2007 Home and Student edition. When I try to
> send a document as an email attachment in Word (or any other Office
> program for that matter) all the email options are greyed out, with no
> explanation as to why I can't send. Sending from Wordpad works fine.
> My default mail client is Windows Mail. I am running Vista Home Premium
> OS. Is this problem occuring because I am not using Outlook? Or is there
> some other issue?
> THanks
 

My Computer

W

Walter Blanchard

#2
Not allowed to save edited win.ini with Vista.

--

______________________________

Walter B
waltblanch[at]tampabay[dot]rr[dot]com
______________________________


"Doug Robbins - Word MVP" <dkr@REMOVECAPSmvps.org> wrote in message
news:e%23ZV6qCaHHA.5032@TK2MSFTNGP02.phx.gbl...
> Here is some information posted by Peter Jamieson. It may not be
> applicable to your operating system and mail program, for which it might
> be better to ask your question in the microsoft.public.windows.vista.mail
> newsgroup, to which I have cross-posted this response.
>
> First, make sure that the e-mail program you want to use is set up to be
> the
> default e-mail program (e.g. via Internet Explorer|Tools|Internet
> Options|Programs, and send at least one message using it.
>
> Then Word needs some stuff in WIN.INI and/or in the Windows registry
> before it will show you the E-mail option. I believe that for Word 2003 it
> needs to be in the Windows registry, but that may depend also on the
> version
> of Windows so it is probably better to put the information in both places.
>
> For WIN.INI,
> a. find the WIN.INI file in your Windows folder (typically c:\WINDOWS),
> make a backup copy of it, and open it in Notepad.
> b. ensure that the following text is in there, and add it if not
>
> [Mail]
> MAPI=1
> CMCDLLNAME32=mapi32.dll
> CMCDLLNAME=mapi.dll
> CMC=1
> MAPIX=1
> MAPIXVER=1.0.0.1
> OLEMessaging=1
>
> You will need to close all copies of Word before this change has a chance
> of
> taking effect. It is probably safest to restart Windows to be completely
> sure.
>
> If that isn't enough, you will need to edit the registry. Proceed with
> caution!
>
> c. In your Windows folder, locate and run regedit.exe. If you're on an
> older version of Windows you might need to use regedt32.exe.
>
> Look for a key called
>
> HKEY_LOCAL_MACHINE\SOFTWARE\Mi­crosoft\Windows Messaging Subsystem
>
> I would be surprised if it was not there in recent versions of Windows,
> but
> if it is not, add it.
>
> If it is there, I would expect to see
> d. a subkey claled MSMapiApps
> e. a number of "values" with the same names as are in the above list -
> MAPI, MAPIX etc.
> f. an additional value called InstallCmd
>
> If you cannot see the (e) values, you need to add them. For each of the
> values in the above list
> g. right click "Windows Messaging Subsystem" and select New|String Value.
> Note that although some of these items have numeric values, they should
> all
> be entered as String Values.
> h. enter the name, as above
> i. double click on the name. A dialog box appears. Enter the value (e.g.
> for the name CMCDLLNAME, enter mapi.dll) and click OK
> j. You may also need to create the InstallCmd value, although I rather
> doubt it. I am less sure about this and about what should go in there. On
> my
> system, the value is:
> rundll32 setupapi,InstallHinfSection MSMAIL 132 msmail.inf
>
> When you have done them all, press F5. Then close all copies of Word and
> restart it - or restart Windows, then restart Word and see if the e-mail
> option has appeared.
>
>
> --
> Hope this helps.
>
> Please reply to the newsgroup unless you wish to avail yourself of my
> services on a paid consulting basis.
>
> Doug Robbins - Word MVP
>
> "Ben Coyle" <frenz_of_rom@hotmail.com> wrote in message
> news:013B92BE-6DAA-46F0-8030-DC1DE1027EDB@microsoft.com...
>> Hi
>> I have just bought MS Office 2007 Home and Student edition. When I try to
>> send a document as an email attachment in Word (or any other Office
>> program for that matter) all the email options are greyed out, with no
>> explanation as to why I can't send. Sending from Wordpad works fine.
>> My default mail client is Windows Mail. I am running Vista Home Premium
>> OS. Is this problem occuring because I am not using Outlook? Or is there
>> some other issue?
>> THanks

>
>
 

My Computer

#3
I am having the same problem. Outlook 2003 is my default mail program
(check), I looked in the Registry and all values are present (check), I added
the PDF and XPS attachments. I added "Send to mail recipient" to the Quick
Task bar where it remains "gray."

I got all that info from the Help section on Word 2007. Their last
alternative is to send the document as an attachment which seems to me to
defeat the purpose and is not a viable workaround for my project (an email
Newsletter).

Any other thoughts on this?

Thanks

"Doug Robbins - Word MVP" wrote:

> Here is some information posted by Peter Jamieson. It may not be applicable
> to your operating system and mail program, for which it might be better to
> ask your question in the microsoft.public.windows.vista.mail newsgroup, to
> which I have cross-posted this response.
>
> First, make sure that the e-mail program you want to use is set up to be the
> default e-mail program (e.g. via Internet Explorer|Tools|Internet
> Options|Programs, and send at least one message using it.
>
> Then Word needs some stuff in WIN.INI and/or in the Windows registry
> before it will show you the E-mail option. I believe that for Word 2003 it
> needs to be in the Windows registry, but that may depend also on the version
> of Windows so it is probably better to put the information in both places.
>
> For WIN.INI,
> a. find the WIN.INI file in your Windows folder (typically c:\WINDOWS),
> make a backup copy of it, and open it in Notepad.
> b. ensure that the following text is in there, and add it if not
>
> [Mail]
> MAPI=1
> CMCDLLNAME32=mapi32.dll
> CMCDLLNAME=mapi.dll
> CMC=1
> MAPIX=1
> MAPIXVER=1.0.0.1
> OLEMessaging=1
>
> You will need to close all copies of Word before this change has a chance of
> taking effect. It is probably safest to restart Windows to be completely
> sure.
>
> If that isn't enough, you will need to edit the registry. Proceed with
> caution!
>
> c. In your Windows folder, locate and run regedit.exe. If you're on an
> older version of Windows you might need to use regedt32.exe.
>
> Look for a key called
>
> HKEY_LOCAL_MACHINE\SOFTWARE\Mi­crosoft\Windows Messaging Subsystem
>
> I would be surprised if it was not there in recent versions of Windows, but
> if it is not, add it.
>
> If it is there, I would expect to see
> d. a subkey claled MSMapiApps
> e. a number of "values" with the same names as are in the above list -
> MAPI, MAPIX etc.
> f. an additional value called InstallCmd
>
> If you cannot see the (e) values, you need to add them. For each of the
> values in the above list
> g. right click "Windows Messaging Subsystem" and select New|String Value.
> Note that although some of these items have numeric values, they should all
> be entered as String Values.
> h. enter the name, as above
> i. double click on the name. A dialog box appears. Enter the value (e.g.
> for the name CMCDLLNAME, enter mapi.dll) and click OK
> j. You may also need to create the InstallCmd value, although I rather
> doubt it. I am less sure about this and about what should go in there. On my
> system, the value is:
> rundll32 setupapi,InstallHinfSection MSMAIL 132 msmail.inf
>
> When you have done them all, press F5. Then close all copies of Word and
> restart it - or restart Windows, then restart Word and see if the e-mail
> option has appeared.
>
>
> --
> Hope this helps.
>
> Please reply to the newsgroup unless you wish to avail yourself of my
> services on a paid consulting basis.
>
> Doug Robbins - Word MVP
>
> "Ben Coyle" <frenz_of_rom@hotmail.com> wrote in message
> news:013B92BE-6DAA-46F0-8030-DC1DE1027EDB@microsoft.com...
> > Hi
> > I have just bought MS Office 2007 Home and Student edition. When I try to
> > send a document as an email attachment in Word (or any other Office
> > program for that matter) all the email options are greyed out, with no
> > explanation as to why I can't send. Sending from Wordpad works fine.
> > My default mail client is Windows Mail. I am running Vista Home Premium
> > OS. Is this problem occuring because I am not using Outlook? Or is there
> > some other issue?
> > THanks

>
>
>
 

My Computer

D

Doug Robbins - Word MVP

#4
I think that the issue may be one of Compatability between Word 2007 and
Outlook 2003.

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Art" <Art@discussions.microsoft.com> wrote in message
news:409A3502-3DBA-47A2-8D3C-758BFB335E92@microsoft.com...
>I am having the same problem. Outlook 2003 is my default mail program
> (check), I looked in the Registry and all values are present (check), I
> added
> the PDF and XPS attachments. I added "Send to mail recipient" to the Quick
> Task bar where it remains "gray."
>
> I got all that info from the Help section on Word 2007. Their last
> alternative is to send the document as an attachment which seems to me to
> defeat the purpose and is not a viable workaround for my project (an email
> Newsletter).
>
> Any other thoughts on this?
>
> Thanks
>
> "Doug Robbins - Word MVP" wrote:
>
>> Here is some information posted by Peter Jamieson. It may not be
>> applicable
>> to your operating system and mail program, for which it might be better
>> to
>> ask your question in the microsoft.public.windows.vista.mail newsgroup,
>> to
>> which I have cross-posted this response.
>>
>> First, make sure that the e-mail program you want to use is set up to be
>> the
>> default e-mail program (e.g. via Internet Explorer|Tools|Internet
>> Options|Programs, and send at least one message using it.
>>
>> Then Word needs some stuff in WIN.INI and/or in the Windows registry
>> before it will show you the E-mail option. I believe that for Word 2003
>> it
>> needs to be in the Windows registry, but that may depend also on the
>> version
>> of Windows so it is probably better to put the information in both
>> places.
>>
>> For WIN.INI,
>> a. find the WIN.INI file in your Windows folder (typically c:\WINDOWS),
>> make a backup copy of it, and open it in Notepad.
>> b. ensure that the following text is in there, and add it if not
>>
>> [Mail]
>> MAPI=1
>> CMCDLLNAME32=mapi32.dll
>> CMCDLLNAME=mapi.dll
>> CMC=1
>> MAPIX=1
>> MAPIXVER=1.0.0.1
>> OLEMessaging=1
>>
>> You will need to close all copies of Word before this change has a chance
>> of
>> taking effect. It is probably safest to restart Windows to be completely
>> sure.
>>
>> If that isn't enough, you will need to edit the registry. Proceed with
>> caution!
>>
>> c. In your Windows folder, locate and run regedit.exe. If you're on an
>> older version of Windows you might need to use regedt32.exe.
>>
>> Look for a key called
>>
>> HKEY_LOCAL_MACHINE\SOFTWARE\Mi­crosoft\Windows Messaging Subsystem
>>
>> I would be surprised if it was not there in recent versions of Windows,
>> but
>> if it is not, add it.
>>
>> If it is there, I would expect to see
>> d. a subkey claled MSMapiApps
>> e. a number of "values" with the same names as are in the above list -
>> MAPI, MAPIX etc.
>> f. an additional value called InstallCmd
>>
>> If you cannot see the (e) values, you need to add them. For each of the
>> values in the above list
>> g. right click "Windows Messaging Subsystem" and select New|String
>> Value.
>> Note that although some of these items have numeric values, they should
>> all
>> be entered as String Values.
>> h. enter the name, as above
>> i. double click on the name. A dialog box appears. Enter the value (e.g.
>> for the name CMCDLLNAME, enter mapi.dll) and click OK
>> j. You may also need to create the InstallCmd value, although I rather
>> doubt it. I am less sure about this and about what should go in there. On
>> my
>> system, the value is:
>> rundll32 setupapi,InstallHinfSection MSMAIL 132 msmail.inf
>>
>> When you have done them all, press F5. Then close all copies of Word and
>> restart it - or restart Windows, then restart Word and see if the e-mail
>> option has appeared.
>>
>>
>> --
>> Hope this helps.
>>
>> Please reply to the newsgroup unless you wish to avail yourself of my
>> services on a paid consulting basis.
>>
>> Doug Robbins - Word MVP
>>
>> "Ben Coyle" <frenz_of_rom@hotmail.com> wrote in message
>> news:013B92BE-6DAA-46F0-8030-DC1DE1027EDB@microsoft.com...
>> > Hi
>> > I have just bought MS Office 2007 Home and Student edition. When I try
>> > to
>> > send a document as an email attachment in Word (or any other Office
>> > program for that matter) all the email options are greyed out, with no
>> > explanation as to why I can't send. Sending from Wordpad works fine.
>> > My default mail client is Windows Mail. I am running Vista Home Premium
>> > OS. Is this problem occuring because I am not using Outlook? Or is
>> > there
>> > some other issue?
>> > THanks

>>
>>
>>
 

My Computer

#5
Compatability may well be a problem, I know I can not use word as my email
editor but from reading other posts here I get the feeling that MS has
disabled the "Send to Email recipient" function in the 2007 Home and Student
program. The rational seems to be that that function is a "commercial"
function. I disagree with that logic because a lot of people just wont open
ANY email attachments so the need to send a document as an email is fully
justified, IMHO, for use in the Home & Student version. I hope that someone
can get through to MS and that they will activate the function in the H & S
version. (Well I can dream can't I? <grin>)

"Doug Robbins - Word MVP" wrote:

> I think that the issue may be one of Compatability between Word 2007 and
> Outlook 2003.
>
> --
> Hope this helps.
>
> Please reply to the newsgroup unless you wish to avail yourself of my
> services on a paid consulting basis.
>
> Doug Robbins - Word MVP
>
> "Art" <Art@discussions.microsoft.com> wrote in message
> news:409A3502-3DBA-47A2-8D3C-758BFB335E92@microsoft.com...
> >I am having the same problem. Outlook 2003 is my default mail program
> > (check), I looked in the Registry and all values are present (check), I
> > added
> > the PDF and XPS attachments. I added "Send to mail recipient" to the Quick
> > Task bar where it remains "gray."
> >
> > I got all that info from the Help section on Word 2007. Their last
> > alternative is to send the document as an attachment which seems to me to
> > defeat the purpose and is not a viable workaround for my project (an email
> > Newsletter).
> >
> > Any other thoughts on this?
> >
> > Thanks
> >
> > "Doug Robbins - Word MVP" wrote:
> >
> >> Here is some information posted by Peter Jamieson. It may not be
> >> applicable
> >> to your operating system and mail program, for which it might be better
> >> to
> >> ask your question in the microsoft.public.windows.vista.mail newsgroup,
> >> to
> >> which I have cross-posted this response.
> >>
> >> First, make sure that the e-mail program you want to use is set up to be
> >> the
> >> default e-mail program (e.g. via Internet Explorer|Tools|Internet
> >> Options|Programs, and send at least one message using it.
> >>
> >> Then Word needs some stuff in WIN.INI and/or in the Windows registry
> >> before it will show you the E-mail option. I believe that for Word 2003
> >> it
> >> needs to be in the Windows registry, but that may depend also on the
> >> version
> >> of Windows so it is probably better to put the information in both
> >> places.
> >>
> >> For WIN.INI,
> >> a. find the WIN.INI file in your Windows folder (typically c:\WINDOWS),
> >> make a backup copy of it, and open it in Notepad.
> >> b. ensure that the following text is in there, and add it if not
> >>
> >> [Mail]
> >> MAPI=1
> >> CMCDLLNAME32=mapi32.dll
> >> CMCDLLNAME=mapi.dll
> >> CMC=1
> >> MAPIX=1
> >> MAPIXVER=1.0.0.1
> >> OLEMessaging=1
> >>
> >> You will need to close all copies of Word before this change has a chance
> >> of
> >> taking effect. It is probably safest to restart Windows to be completely
> >> sure.
> >>
> >> If that isn't enough, you will need to edit the registry. Proceed with
> >> caution!
> >>
> >> c. In your Windows folder, locate and run regedit.exe. If you're on an
> >> older version of Windows you might need to use regedt32.exe.
> >>
> >> Look for a key called
> >>
> >> HKEY_LOCAL_MACHINE\SOFTWARE\Mi­crosoft\Windows Messaging Subsystem
> >>
> >> I would be surprised if it was not there in recent versions of Windows,
> >> but
> >> if it is not, add it.
> >>
> >> If it is there, I would expect to see
> >> d. a subkey claled MSMapiApps
> >> e. a number of "values" with the same names as are in the above list -
> >> MAPI, MAPIX etc.
> >> f. an additional value called InstallCmd
> >>
> >> If you cannot see the (e) values, you need to add them. For each of the
> >> values in the above list
> >> g. right click "Windows Messaging Subsystem" and select New|String
> >> Value.
> >> Note that although some of these items have numeric values, they should
> >> all
> >> be entered as String Values.
> >> h. enter the name, as above
> >> i. double click on the name. A dialog box appears. Enter the value (e.g.
> >> for the name CMCDLLNAME, enter mapi.dll) and click OK
> >> j. You may also need to create the InstallCmd value, although I rather
> >> doubt it. I am less sure about this and about what should go in there. On
> >> my
> >> system, the value is:
> >> rundll32 setupapi,InstallHinfSection MSMAIL 132 msmail.inf
> >>
> >> When you have done them all, press F5. Then close all copies of Word and
> >> restart it - or restart Windows, then restart Word and see if the e-mail
> >> option has appeared.
> >>
> >>
> >> --
> >> Hope this helps.
> >>
> >> Please reply to the newsgroup unless you wish to avail yourself of my
> >> services on a paid consulting basis.
> >>
> >> Doug Robbins - Word MVP
> >>
> >> "Ben Coyle" <frenz_of_rom@hotmail.com> wrote in message
> >> news:013B92BE-6DAA-46F0-8030-DC1DE1027EDB@microsoft.com...
> >> > Hi
> >> > I have just bought MS Office 2007 Home and Student edition. When I try
> >> > to
> >> > send a document as an email attachment in Word (or any other Office
> >> > program for that matter) all the email options are greyed out, with no
> >> > explanation as to why I can't send. Sending from Wordpad works fine.
> >> > My default mail client is Windows Mail. I am running Vista Home Premium
> >> > OS. Is this problem occuring because I am not using Outlook? Or is
> >> > there
> >> > some other issue?
> >> > THanks
> >>
> >>
> >>

>
>
>
 

My Computer

D

Doug Robbins - Word MVP

#6
If you set Outlook Express as the default mail program, you should then be
able to use it for the purpose.

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Art" <Art@discussions.microsoft.com> wrote in message
news:F205EBB4-1E6A-4AC9-9304-01B8407640BD@microsoft.com...
> Compatability may well be a problem, I know I can not use word as my email
> editor but from reading other posts here I get the feeling that MS has
> disabled the "Send to Email recipient" function in the 2007 Home and
> Student
> program. The rational seems to be that that function is a "commercial"
> function. I disagree with that logic because a lot of people just wont
> open
> ANY email attachments so the need to send a document as an email is fully
> justified, IMHO, for use in the Home & Student version. I hope that
> someone
> can get through to MS and that they will activate the function in the H &
> S
> version. (Well I can dream can't I? <grin>)
>
> "Doug Robbins - Word MVP" wrote:
>
>> I think that the issue may be one of Compatability between Word 2007 and
>> Outlook 2003.
>>
>> --
>> Hope this helps.
>>
>> Please reply to the newsgroup unless you wish to avail yourself of my
>> services on a paid consulting basis.
>>
>> Doug Robbins - Word MVP
>>
>> "Art" <Art@discussions.microsoft.com> wrote in message
>> news:409A3502-3DBA-47A2-8D3C-758BFB335E92@microsoft.com...
>> >I am having the same problem. Outlook 2003 is my default mail program
>> > (check), I looked in the Registry and all values are present (check), I
>> > added
>> > the PDF and XPS attachments. I added "Send to mail recipient" to the
>> > Quick
>> > Task bar where it remains "gray."
>> >
>> > I got all that info from the Help section on Word 2007. Their last
>> > alternative is to send the document as an attachment which seems to me
>> > to
>> > defeat the purpose and is not a viable workaround for my project (an
>> > email
>> > Newsletter).
>> >
>> > Any other thoughts on this?
>> >
>> > Thanks
>> >
>> > "Doug Robbins - Word MVP" wrote:
>> >
>> >> Here is some information posted by Peter Jamieson. It may not be
>> >> applicable
>> >> to your operating system and mail program, for which it might be
>> >> better
>> >> to
>> >> ask your question in the microsoft.public.windows.vista.mail
>> >> newsgroup,
>> >> to
>> >> which I have cross-posted this response.
>> >>
>> >> First, make sure that the e-mail program you want to use is set up to
>> >> be
>> >> the
>> >> default e-mail program (e.g. via Internet Explorer|Tools|Internet
>> >> Options|Programs, and send at least one message using it.
>> >>
>> >> Then Word needs some stuff in WIN.INI and/or in the Windows registry
>> >> before it will show you the E-mail option. I believe that for Word
>> >> 2003
>> >> it
>> >> needs to be in the Windows registry, but that may depend also on the
>> >> version
>> >> of Windows so it is probably better to put the information in both
>> >> places.
>> >>
>> >> For WIN.INI,
>> >> a. find the WIN.INI file in your Windows folder (typically
>> >> c:\WINDOWS),
>> >> make a backup copy of it, and open it in Notepad.
>> >> b. ensure that the following text is in there, and add it if not
>> >>
>> >> [Mail]
>> >> MAPI=1
>> >> CMCDLLNAME32=mapi32.dll
>> >> CMCDLLNAME=mapi.dll
>> >> CMC=1
>> >> MAPIX=1
>> >> MAPIXVER=1.0.0.1
>> >> OLEMessaging=1
>> >>
>> >> You will need to close all copies of Word before this change has a
>> >> chance
>> >> of
>> >> taking effect. It is probably safest to restart Windows to be
>> >> completely
>> >> sure.
>> >>
>> >> If that isn't enough, you will need to edit the registry. Proceed with
>> >> caution!
>> >>
>> >> c. In your Windows folder, locate and run regedit.exe. If you're on
>> >> an
>> >> older version of Windows you might need to use regedt32.exe.
>> >>
>> >> Look for a key called
>> >>
>> >> HKEY_LOCAL_MACHINE\SOFTWARE\Mi­crosoft\Windows Messaging Subsystem
>> >>
>> >> I would be surprised if it was not there in recent versions of
>> >> Windows,
>> >> but
>> >> if it is not, add it.
>> >>
>> >> If it is there, I would expect to see
>> >> d. a subkey claled MSMapiApps
>> >> e. a number of "values" with the same names as are in the above
>> >> list -
>> >> MAPI, MAPIX etc.
>> >> f. an additional value called InstallCmd
>> >>
>> >> If you cannot see the (e) values, you need to add them. For each of
>> >> the
>> >> values in the above list
>> >> g. right click "Windows Messaging Subsystem" and select New|String
>> >> Value.
>> >> Note that although some of these items have numeric values, they
>> >> should
>> >> all
>> >> be entered as String Values.
>> >> h. enter the name, as above
>> >> i. double click on the name. A dialog box appears. Enter the value
>> >> (e.g.
>> >> for the name CMCDLLNAME, enter mapi.dll) and click OK
>> >> j. You may also need to create the InstallCmd value, although I
>> >> rather
>> >> doubt it. I am less sure about this and about what should go in there.
>> >> On
>> >> my
>> >> system, the value is:
>> >> rundll32 setupapi,InstallHinfSection MSMAIL 132 msmail.inf
>> >>
>> >> When you have done them all, press F5. Then close all copies of Word
>> >> and
>> >> restart it - or restart Windows, then restart Word and see if the
>> >> e-mail
>> >> option has appeared.
>> >>
>> >>
>> >> --
>> >> Hope this helps.
>> >>
>> >> Please reply to the newsgroup unless you wish to avail yourself of my
>> >> services on a paid consulting basis.
>> >>
>> >> Doug Robbins - Word MVP
>> >>
>> >> "Ben Coyle" <frenz_of_rom@hotmail.com> wrote in message
>> >> news:013B92BE-6DAA-46F0-8030-DC1DE1027EDB@microsoft.com...
>> >> > Hi
>> >> > I have just bought MS Office 2007 Home and Student edition. When I
>> >> > try
>> >> > to
>> >> > send a document as an email attachment in Word (or any other Office
>> >> > program for that matter) all the email options are greyed out, with
>> >> > no
>> >> > explanation as to why I can't send. Sending from Wordpad works fine.
>> >> > My default mail client is Windows Mail. I am running Vista Home
>> >> > Premium
>> >> > OS. Is this problem occuring because I am not using Outlook? Or is
>> >> > there
>> >> > some other issue?
>> >> > THanks
>> >>
>> >>
>> >>

>>
>>
>>
 

My Computer

J

Julian

#7
"Doug Robbins - Word MVP" <dkr@REMOVECAPSmvps.org> wrote in message
news:e6tRb7$0HHA.728@TK2MSFTNGP05.phx.gbl...
> If you set Outlook Express as the default mail program, you should then be
> able to use it for the purpose.


Outlook Express on Vista?


>
> --
> Hope this helps.
>
> Please reply to the newsgroup unless you wish to avail yourself of my
> services on a paid consulting basis.
>
> Doug Robbins - Word MVP
>
> "Art" <Art@discussions.microsoft.com> wrote in message
> news:F205EBB4-1E6A-4AC9-9304-01B8407640BD@microsoft.com...
>> Compatability may well be a problem, I know I can not use word as my
>> email
>> editor but from reading other posts here I get the feeling that MS has
>> disabled the "Send to Email recipient" function in the 2007 Home and
>> Student
>> program. The rational seems to be that that function is a "commercial"
>> function. I disagree with that logic because a lot of people just wont
>> open
>> ANY email attachments so the need to send a document as an email is fully
>> justified, IMHO, for use in the Home & Student version. I hope that
>> someone
>> can get through to MS and that they will activate the function in the H &
>> S
>> version. (Well I can dream can't I? <grin>)
>>
>> "Doug Robbins - Word MVP" wrote:
>>
>>> I think that the issue may be one of Compatability between Word 2007 and
>>> Outlook 2003.
>>>
>>> --
>>> Hope this helps.
>>>
>>> Please reply to the newsgroup unless you wish to avail yourself of my
>>> services on a paid consulting basis.
>>>
>>> Doug Robbins - Word MVP
>>>
>>> "Art" <Art@discussions.microsoft.com> wrote in message
>>> news:409A3502-3DBA-47A2-8D3C-758BFB335E92@microsoft.com...
>>> >I am having the same problem. Outlook 2003 is my default mail program
>>> > (check), I looked in the Registry and all values are present (check),
>>> > I
>>> > added
>>> > the PDF and XPS attachments. I added "Send to mail recipient" to the
>>> > Quick
>>> > Task bar where it remains "gray."
>>> >
>>> > I got all that info from the Help section on Word 2007. Their last
>>> > alternative is to send the document as an attachment which seems to me
>>> > to
>>> > defeat the purpose and is not a viable workaround for my project (an
>>> > email
>>> > Newsletter).
>>> >
>>> > Any other thoughts on this?
>>> >
>>> > Thanks
>>> >
>>> > "Doug Robbins - Word MVP" wrote:
>>> >
>>> >> Here is some information posted by Peter Jamieson. It may not be
>>> >> applicable
>>> >> to your operating system and mail program, for which it might be
>>> >> better
>>> >> to
>>> >> ask your question in the microsoft.public.windows.vista.mail
>>> >> newsgroup,
>>> >> to
>>> >> which I have cross-posted this response.
>>> >>
>>> >> First, make sure that the e-mail program you want to use is set up to
>>> >> be
>>> >> the
>>> >> default e-mail program (e.g. via Internet Explorer|Tools|Internet
>>> >> Options|Programs, and send at least one message using it.
>>> >>
>>> >> Then Word needs some stuff in WIN.INI and/or in the Windows registry
>>> >> before it will show you the E-mail option. I believe that for Word
>>> >> 2003
>>> >> it
>>> >> needs to be in the Windows registry, but that may depend also on the
>>> >> version
>>> >> of Windows so it is probably better to put the information in both
>>> >> places.
>>> >>
>>> >> For WIN.INI,
>>> >> a. find the WIN.INI file in your Windows folder (typically
>>> >> c:\WINDOWS),
>>> >> make a backup copy of it, and open it in Notepad.
>>> >> b. ensure that the following text is in there, and add it if not
>>> >>
>>> >> [Mail]
>>> >> MAPI=1
>>> >> CMCDLLNAME32=mapi32.dll
>>> >> CMCDLLNAME=mapi.dll
>>> >> CMC=1
>>> >> MAPIX=1
>>> >> MAPIXVER=1.0.0.1
>>> >> OLEMessaging=1
>>> >>
>>> >> You will need to close all copies of Word before this change has a
>>> >> chance
>>> >> of
>>> >> taking effect. It is probably safest to restart Windows to be
>>> >> completely
>>> >> sure.
>>> >>
>>> >> If that isn't enough, you will need to edit the registry. Proceed
>>> >> with
>>> >> caution!
>>> >>
>>> >> c. In your Windows folder, locate and run regedit.exe. If you're on
>>> >> an
>>> >> older version of Windows you might need to use regedt32.exe.
>>> >>
>>> >> Look for a key called
>>> >>
>>> >> HKEY_LOCAL_MACHINE\SOFTWARE\Mi­crosoft\Windows Messaging Subsystem
>>> >>
>>> >> I would be surprised if it was not there in recent versions of
>>> >> Windows,
>>> >> but
>>> >> if it is not, add it.
>>> >>
>>> >> If it is there, I would expect to see
>>> >> d. a subkey claled MSMapiApps
>>> >> e. a number of "values" with the same names as are in the above
>>> >> list -
>>> >> MAPI, MAPIX etc.
>>> >> f. an additional value called InstallCmd
>>> >>
>>> >> If you cannot see the (e) values, you need to add them. For each of
>>> >> the
>>> >> values in the above list
>>> >> g. right click "Windows Messaging Subsystem" and select New|String
>>> >> Value.
>>> >> Note that although some of these items have numeric values, they
>>> >> should
>>> >> all
>>> >> be entered as String Values.
>>> >> h. enter the name, as above
>>> >> i. double click on the name. A dialog box appears. Enter the value
>>> >> (e.g.
>>> >> for the name CMCDLLNAME, enter mapi.dll) and click OK
>>> >> j. You may also need to create the InstallCmd value, although I
>>> >> rather
>>> >> doubt it. I am less sure about this and about what should go in
>>> >> there. On
>>> >> my
>>> >> system, the value is:
>>> >> rundll32 setupapi,InstallHinfSection MSMAIL 132 msmail.inf
>>> >>
>>> >> When you have done them all, press F5. Then close all copies of Word
>>> >> and
>>> >> restart it - or restart Windows, then restart Word and see if the
>>> >> e-mail
>>> >> option has appeared.
>>> >>
>>> >>
>>> >> --
>>> >> Hope this helps.
>>> >>
>>> >> Please reply to the newsgroup unless you wish to avail yourself of my
>>> >> services on a paid consulting basis.
>>> >>
>>> >> Doug Robbins - Word MVP
>>> >>
>>> >> "Ben Coyle" <frenz_of_rom@hotmail.com> wrote in message
>>> >> news:013B92BE-6DAA-46F0-8030-DC1DE1027EDB@microsoft.com...
>>> >> > Hi
>>> >> > I have just bought MS Office 2007 Home and Student edition. When I
>>> >> > try
>>> >> > to
>>> >> > send a document as an email attachment in Word (or any other Office
>>> >> > program for that matter) all the email options are greyed out, with
>>> >> > no
>>> >> > explanation as to why I can't send. Sending from Wordpad works
>>> >> > fine.
>>> >> > My default mail client is Windows Mail. I am running Vista Home
>>> >> > Premium
>>> >> > OS. Is this problem occuring because I am not using Outlook? Or is
>>> >> > there
>>> >> > some other issue?
>>> >> > THanks
>>> >>
>>> >>
>>> >>
>>>
>>>
>>>

>
>
 

My Computer

D

Doug Robbins - Word MVP

#8
I don't see where Vista was mentioned anywhere in the posts to which I was
responding.

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Julian" <Julianlzb87@gmail.com> wrote in message
news:471FA87B-929D-42E2-93CD-478E63556F97@microsoft.com...
>
>
> "Doug Robbins - Word MVP" <dkr@REMOVECAPSmvps.org> wrote in message
> news:e6tRb7$0HHA.728@TK2MSFTNGP05.phx.gbl...
>> If you set Outlook Express as the default mail program, you should then
>> be able to use it for the purpose.

>
> Outlook Express on Vista?
>
>
>>
>> --
>> Hope this helps.
>>
>> Please reply to the newsgroup unless you wish to avail yourself of my
>> services on a paid consulting basis.
>>
>> Doug Robbins - Word MVP
>>
>> "Art" <Art@discussions.microsoft.com> wrote in message
>> news:F205EBB4-1E6A-4AC9-9304-01B8407640BD@microsoft.com...
>>> Compatability may well be a problem, I know I can not use word as my
>>> email
>>> editor but from reading other posts here I get the feeling that MS has
>>> disabled the "Send to Email recipient" function in the 2007 Home and
>>> Student
>>> program. The rational seems to be that that function is a "commercial"
>>> function. I disagree with that logic because a lot of people just wont
>>> open
>>> ANY email attachments so the need to send a document as an email is
>>> fully
>>> justified, IMHO, for use in the Home & Student version. I hope that
>>> someone
>>> can get through to MS and that they will activate the function in the H
>>> & S
>>> version. (Well I can dream can't I? <grin>)
>>>
>>> "Doug Robbins - Word MVP" wrote:
>>>
>>>> I think that the issue may be one of Compatability between Word 2007
>>>> and
>>>> Outlook 2003.
>>>>
>>>> --
>>>> Hope this helps.
>>>>
>>>> Please reply to the newsgroup unless you wish to avail yourself of my
>>>> services on a paid consulting basis.
>>>>
>>>> Doug Robbins - Word MVP
>>>>
>>>> "Art" <Art@discussions.microsoft.com> wrote in message
>>>> news:409A3502-3DBA-47A2-8D3C-758BFB335E92@microsoft.com...
>>>> >I am having the same problem. Outlook 2003 is my default mail program
>>>> > (check), I looked in the Registry and all values are present (check),
>>>> > I
>>>> > added
>>>> > the PDF and XPS attachments. I added "Send to mail recipient" to the
>>>> > Quick
>>>> > Task bar where it remains "gray."
>>>> >
>>>> > I got all that info from the Help section on Word 2007. Their last
>>>> > alternative is to send the document as an attachment which seems to
>>>> > me to
>>>> > defeat the purpose and is not a viable workaround for my project (an
>>>> > email
>>>> > Newsletter).
>>>> >
>>>> > Any other thoughts on this?
>>>> >
>>>> > Thanks
>>>> >
>>>> > "Doug Robbins - Word MVP" wrote:
>>>> >
>>>> >> Here is some information posted by Peter Jamieson. It may not be
>>>> >> applicable
>>>> >> to your operating system and mail program, for which it might be
>>>> >> better
>>>> >> to
>>>> >> ask your question in the microsoft.public.windows.vista.mail
>>>> >> newsgroup,
>>>> >> to
>>>> >> which I have cross-posted this response.
>>>> >>
>>>> >> First, make sure that the e-mail program you want to use is set up
>>>> >> to be
>>>> >> the
>>>> >> default e-mail program (e.g. via Internet Explorer|Tools|Internet
>>>> >> Options|Programs, and send at least one message using it.
>>>> >>
>>>> >> Then Word needs some stuff in WIN.INI and/or in the Windows registry
>>>> >> before it will show you the E-mail option. I believe that for Word
>>>> >> 2003
>>>> >> it
>>>> >> needs to be in the Windows registry, but that may depend also on the
>>>> >> version
>>>> >> of Windows so it is probably better to put the information in both
>>>> >> places.
>>>> >>
>>>> >> For WIN.INI,
>>>> >> a. find the WIN.INI file in your Windows folder (typically
>>>> >> c:\WINDOWS),
>>>> >> make a backup copy of it, and open it in Notepad.
>>>> >> b. ensure that the following text is in there, and add it if not
>>>> >>
>>>> >> [Mail]
>>>> >> MAPI=1
>>>> >> CMCDLLNAME32=mapi32.dll
>>>> >> CMCDLLNAME=mapi.dll
>>>> >> CMC=1
>>>> >> MAPIX=1
>>>> >> MAPIXVER=1.0.0.1
>>>> >> OLEMessaging=1
>>>> >>
>>>> >> You will need to close all copies of Word before this change has a
>>>> >> chance
>>>> >> of
>>>> >> taking effect. It is probably safest to restart Windows to be
>>>> >> completely
>>>> >> sure.
>>>> >>
>>>> >> If that isn't enough, you will need to edit the registry. Proceed
>>>> >> with
>>>> >> caution!
>>>> >>
>>>> >> c. In your Windows folder, locate and run regedit.exe. If you're on
>>>> >> an
>>>> >> older version of Windows you might need to use regedt32.exe.
>>>> >>
>>>> >> Look for a key called
>>>> >>
>>>> >> HKEY_LOCAL_MACHINE\SOFTWARE\Mi­crosoft\Windows Messaging Subsystem
>>>> >>
>>>> >> I would be surprised if it was not there in recent versions of
>>>> >> Windows,
>>>> >> but
>>>> >> if it is not, add it.
>>>> >>
>>>> >> If it is there, I would expect to see
>>>> >> d. a subkey claled MSMapiApps
>>>> >> e. a number of "values" with the same names as are in the above
>>>> >> list -
>>>> >> MAPI, MAPIX etc.
>>>> >> f. an additional value called InstallCmd
>>>> >>
>>>> >> If you cannot see the (e) values, you need to add them. For each of
>>>> >> the
>>>> >> values in the above list
>>>> >> g. right click "Windows Messaging Subsystem" and select New|String
>>>> >> Value.
>>>> >> Note that although some of these items have numeric values, they
>>>> >> should
>>>> >> all
>>>> >> be entered as String Values.
>>>> >> h. enter the name, as above
>>>> >> i. double click on the name. A dialog box appears. Enter the value
>>>> >> (e.g.
>>>> >> for the name CMCDLLNAME, enter mapi.dll) and click OK
>>>> >> j. You may also need to create the InstallCmd value, although I
>>>> >> rather
>>>> >> doubt it. I am less sure about this and about what should go in
>>>> >> there. On
>>>> >> my
>>>> >> system, the value is:
>>>> >> rundll32 setupapi,InstallHinfSection MSMAIL 132 msmail.inf
>>>> >>
>>>> >> When you have done them all, press F5. Then close all copies of Word
>>>> >> and
>>>> >> restart it - or restart Windows, then restart Word and see if the
>>>> >> e-mail
>>>> >> option has appeared.
>>>> >>
>>>> >>
>>>> >> --
>>>> >> Hope this helps.
>>>> >>
>>>> >> Please reply to the newsgroup unless you wish to avail yourself of
>>>> >> my
>>>> >> services on a paid consulting basis.
>>>> >>
>>>> >> Doug Robbins - Word MVP
>>>> >>
>>>> >> "Ben Coyle" <frenz_of_rom@hotmail.com> wrote in message
>>>> >> news:013B92BE-6DAA-46F0-8030-DC1DE1027EDB@microsoft.com...
>>>> >> > Hi
>>>> >> > I have just bought MS Office 2007 Home and Student edition. When I
>>>> >> > try
>>>> >> > to
>>>> >> > send a document as an email attachment in Word (or any other
>>>> >> > Office
>>>> >> > program for that matter) all the email options are greyed out,
>>>> >> > with no
>>>> >> > explanation as to why I can't send. Sending from Wordpad works
>>>> >> > fine.
>>>> >> > My default mail client is Windows Mail. I am running Vista Home
>>>> >> > Premium
>>>> >> > OS. Is this problem occuring because I am not using Outlook? Or is
>>>> >> > there
>>>> >> > some other issue?
>>>> >> > THanks
>>>> >>
>>>> >>
>>>> >>
>>>>
>>>>
>>>>

>>
>>
 

My Computer

J

Julian

#9
"Doug Robbins - Word MVP" <dkr@REMOVECAPSmvps.org> wrote in message
news:#81dlLA1HHA.2484@TK2MSFTNGP06.phx.gbl...
>I don't see where Vista was mentioned anywhere in the posts to which I was
>responding.


The OP is running Vista and this is a Vista Forum.

> --
> Hope this helps.
>
> Please reply to the newsgroup unless you wish to avail yourself of my
> services on a paid consulting basis.
>
> Doug Robbins - Word MVP
>
> "Julian" <Julianlzb87@gmail.com> wrote in message
> news:471FA87B-929D-42E2-93CD-478E63556F97@microsoft.com...
>>
>>
>> "Doug Robbins - Word MVP" <dkr@REMOVECAPSmvps.org> wrote in message
>> news:e6tRb7$0HHA.728@TK2MSFTNGP05.phx.gbl...
>>> If you set Outlook Express as the default mail program, you should then
>>> be able to use it for the purpose.

>>
>> Outlook Express on Vista?
>>
>>
>>>
>>> --
>>> Hope this helps.
>>>
>>> Please reply to the newsgroup unless you wish to avail yourself of my
>>> services on a paid consulting basis.
>>>
>>> Doug Robbins - Word MVP
>>>
>>> "Art" <Art@discussions.microsoft.com> wrote in message
>>> news:F205EBB4-1E6A-4AC9-9304-01B8407640BD@microsoft.com...
>>>> Compatability may well be a problem, I know I can not use word as my
>>>> email
>>>> editor but from reading other posts here I get the feeling that MS has
>>>> disabled the "Send to Email recipient" function in the 2007 Home and
>>>> Student
>>>> program. The rational seems to be that that function is a "commercial"
>>>> function. I disagree with that logic because a lot of people just wont
>>>> open
>>>> ANY email attachments so the need to send a document as an email is
>>>> fully
>>>> justified, IMHO, for use in the Home & Student version. I hope that
>>>> someone
>>>> can get through to MS and that they will activate the function in the H
>>>> & S
>>>> version. (Well I can dream can't I? <grin>)
>>>>
>>>> "Doug Robbins - Word MVP" wrote:
>>>>
>>>>> I think that the issue may be one of Compatability between Word 2007
>>>>> and
>>>>> Outlook 2003.
>>>>>
>>>>> --
>>>>> Hope this helps.
>>>>>
>>>>> Please reply to the newsgroup unless you wish to avail yourself of my
>>>>> services on a paid consulting basis.
>>>>>
>>>>> Doug Robbins - Word MVP
>>>>>
>>>>> "Art" <Art@discussions.microsoft.com> wrote in message
>>>>> news:409A3502-3DBA-47A2-8D3C-758BFB335E92@microsoft.com...
>>>>> >I am having the same problem. Outlook 2003 is my default mail program
>>>>> > (check), I looked in the Registry and all values are present
>>>>> > (check), I
>>>>> > added
>>>>> > the PDF and XPS attachments. I added "Send to mail recipient" to the
>>>>> > Quick
>>>>> > Task bar where it remains "gray."
>>>>> >
>>>>> > I got all that info from the Help section on Word 2007. Their last
>>>>> > alternative is to send the document as an attachment which seems to
>>>>> > me to
>>>>> > defeat the purpose and is not a viable workaround for my project (an
>>>>> > email
>>>>> > Newsletter).
>>>>> >
>>>>> > Any other thoughts on this?
>>>>> >
>>>>> > Thanks
>>>>> >
>>>>> > "Doug Robbins - Word MVP" wrote:
>>>>> >
>>>>> >> Here is some information posted by Peter Jamieson. It may not be
>>>>> >> applicable
>>>>> >> to your operating system and mail program, for which it might be
>>>>> >> better
>>>>> >> to
>>>>> >> ask your question in the microsoft.public.windows.vista.mail
>>>>> >> newsgroup,
>>>>> >> to
>>>>> >> which I have cross-posted this response.
>>>>> >>
>>>>> >> First, make sure that the e-mail program you want to use is set up
>>>>> >> to be
>>>>> >> the
>>>>> >> default e-mail program (e.g. via Internet Explorer|Tools|Internet
>>>>> >> Options|Programs, and send at least one message using it.
>>>>> >>
>>>>> >> Then Word needs some stuff in WIN.INI and/or in the Windows
>>>>> >> registry
>>>>> >> before it will show you the E-mail option. I believe that for Word
>>>>> >> 2003
>>>>> >> it
>>>>> >> needs to be in the Windows registry, but that may depend also on
>>>>> >> the
>>>>> >> version
>>>>> >> of Windows so it is probably better to put the information in both
>>>>> >> places.
>>>>> >>
>>>>> >> For WIN.INI,
>>>>> >> a. find the WIN.INI file in your Windows folder (typically
>>>>> >> c:\WINDOWS),
>>>>> >> make a backup copy of it, and open it in Notepad.
>>>>> >> b. ensure that the following text is in there, and add it if not
>>>>> >>
>>>>> >> [Mail]
>>>>> >> MAPI=1
>>>>> >> CMCDLLNAME32=mapi32.dll
>>>>> >> CMCDLLNAME=mapi.dll
>>>>> >> CMC=1
>>>>> >> MAPIX=1
>>>>> >> MAPIXVER=1.0.0.1
>>>>> >> OLEMessaging=1
>>>>> >>
>>>>> >> You will need to close all copies of Word before this change has a
>>>>> >> chance
>>>>> >> of
>>>>> >> taking effect. It is probably safest to restart Windows to be
>>>>> >> completely
>>>>> >> sure.
>>>>> >>
>>>>> >> If that isn't enough, you will need to edit the registry. Proceed
>>>>> >> with
>>>>> >> caution!
>>>>> >>
>>>>> >> c. In your Windows folder, locate and run regedit.exe. If you're
>>>>> >> on an
>>>>> >> older version of Windows you might need to use regedt32.exe.
>>>>> >>
>>>>> >> Look for a key called
>>>>> >>
>>>>> >> HKEY_LOCAL_MACHINE\SOFTWARE\Mi­crosoft\Windows Messaging Subsystem
>>>>> >>
>>>>> >> I would be surprised if it was not there in recent versions of
>>>>> >> Windows,
>>>>> >> but
>>>>> >> if it is not, add it.
>>>>> >>
>>>>> >> If it is there, I would expect to see
>>>>> >> d. a subkey claled MSMapiApps
>>>>> >> e. a number of "values" with the same names as are in the above
>>>>> >> list -
>>>>> >> MAPI, MAPIX etc.
>>>>> >> f. an additional value called InstallCmd
>>>>> >>
>>>>> >> If you cannot see the (e) values, you need to add them. For each of
>>>>> >> the
>>>>> >> values in the above list
>>>>> >> g. right click "Windows Messaging Subsystem" and select New|String
>>>>> >> Value.
>>>>> >> Note that although some of these items have numeric values, they
>>>>> >> should
>>>>> >> all
>>>>> >> be entered as String Values.
>>>>> >> h. enter the name, as above
>>>>> >> i. double click on the name. A dialog box appears. Enter the value
>>>>> >> (e.g.
>>>>> >> for the name CMCDLLNAME, enter mapi.dll) and click OK
>>>>> >> j. You may also need to create the InstallCmd value, although I
>>>>> >> rather
>>>>> >> doubt it. I am less sure about this and about what should go in
>>>>> >> there. On
>>>>> >> my
>>>>> >> system, the value is:
>>>>> >> rundll32 setupapi,InstallHinfSection MSMAIL 132 msmail.inf
>>>>> >>
>>>>> >> When you have done them all, press F5. Then close all copies of
>>>>> >> Word and
>>>>> >> restart it - or restart Windows, then restart Word and see if the
>>>>> >> e-mail
>>>>> >> option has appeared.
>>>>> >>
>>>>> >>
>>>>> >> --
>>>>> >> Hope this helps.
>>>>> >>
>>>>> >> Please reply to the newsgroup unless you wish to avail yourself of
>>>>> >> my
>>>>> >> services on a paid consulting basis.
>>>>> >>
>>>>> >> Doug Robbins - Word MVP
>>>>> >>
>>>>> >> "Ben Coyle" <frenz_of_rom@hotmail.com> wrote in message
>>>>> >> news:013B92BE-6DAA-46F0-8030-DC1DE1027EDB@microsoft.com...
>>>>> >> > Hi
>>>>> >> > I have just bought MS Office 2007 Home and Student edition. When
>>>>> >> > I try
>>>>> >> > to
>>>>> >> > send a document as an email attachment in Word (or any other
>>>>> >> > Office
>>>>> >> > program for that matter) all the email options are greyed out,
>>>>> >> > with no
>>>>> >> > explanation as to why I can't send. Sending from Wordpad works
>>>>> >> > fine.
>>>>> >> > My default mail client is Windows Mail. I am running Vista Home
>>>>> >> > Premium
>>>>> >> > OS. Is this problem occuring because I am not using Outlook? Or
>>>>> >> > is
>>>>> >> > there
>>>>> >> > some other issue?
>>>>> >> > THanks
>>>>> >>
>>>>> >>
>>>>> >>
>>>>>
>>>>>
>>>>>
>>>
>>>

>
>
 

My Computer

G

Gary VanderMolen

#10
Try this:
Run your 2007 Home and Student edition CD and choose the option
to add specific components. Although there is no option to install Outlook,
you should have an option to install MAPI handlers. The MAPI handler
needs to be present before Word can "send to Email recipient".

Gary VanderMolen

"Art" <Art@discussions.microsoft.com> wrote in message news:F205EBB4-1E6A-4AC9-9304-01B8407640BD@microsoft.com...
> Compatability may well be a problem, I know I can not use word as my email
> editor but from reading other posts here I get the feeling that MS has
> disabled the "Send to Email recipient" function in the 2007 Home and Student
> program. The rational seems to be that that function is a "commercial"
> function. I disagree with that logic because a lot of people just wont open
> ANY email attachments so the need to send a document as an email is fully
> justified, IMHO, for use in the Home & Student version. I hope that someone
> can get through to MS and that they will activate the function in the H & S
> version. (Well I can dream can't I? <grin>)
>
> "Doug Robbins - Word MVP" wrote:
>
>> I think that the issue may be one of Compatability between Word 2007 and
>> Outlook 2003.
>>
>> --
>> Hope this helps.
>>
>> Please reply to the newsgroup unless you wish to avail yourself of my
>> services on a paid consulting basis.
>>
>> Doug Robbins - Word MVP
>>
>> "Art" <Art@discussions.microsoft.com> wrote in message
>> news:409A3502-3DBA-47A2-8D3C-758BFB335E92@microsoft.com...
>> >I am having the same problem. Outlook 2003 is my default mail program
>> > (check), I looked in the Registry and all values are present (check), I
>> > added
>> > the PDF and XPS attachments. I added "Send to mail recipient" to the Quick
>> > Task bar where it remains "gray."
>> >
>> > I got all that info from the Help section on Word 2007. Their last
>> > alternative is to send the document as an attachment which seems to me to
>> > defeat the purpose and is not a viable workaround for my project (an email
>> > Newsletter).
>> >
>> > Any other thoughts on this?
>> >
>> > Thanks
>> >
>> > "Doug Robbins - Word MVP" wrote:
>> >
>> >> Here is some information posted by Peter Jamieson. It may not be
>> >> applicable
>> >> to your operating system and mail program, for which it might be better
>> >> to
>> >> ask your question in the microsoft.public.windows.vista.mail newsgroup,
>> >> to
>> >> which I have cross-posted this response.
>> >>
>> >> First, make sure that the e-mail program you want to use is set up to be
>> >> the
>> >> default e-mail program (e.g. via Internet Explorer|Tools|Internet
>> >> Options|Programs, and send at least one message using it.
>> >>
>> >> Then Word needs some stuff in WIN.INI and/or in the Windows registry
>> >> before it will show you the E-mail option. I believe that for Word 2003
>> >> it
>> >> needs to be in the Windows registry, but that may depend also on the
>> >> version
>> >> of Windows so it is probably better to put the information in both
>> >> places.
>> >>
>> >> For WIN.INI,
>> >> a. find the WIN.INI file in your Windows folder (typically c:\WINDOWS),
>> >> make a backup copy of it, and open it in Notepad.
>> >> b. ensure that the following text is in there, and add it if not
>> >>
>> >> [Mail]
>> >> MAPI=1
>> >> CMCDLLNAME32=mapi32.dll
>> >> CMCDLLNAME=mapi.dll
>> >> CMC=1
>> >> MAPIX=1
>> >> MAPIXVER=1.0.0.1
>> >> OLEMessaging=1
>> >>
>> >> You will need to close all copies of Word before this change has a chance
>> >> of
>> >> taking effect. It is probably safest to restart Windows to be completely
>> >> sure.
>> >>
>> >> If that isn't enough, you will need to edit the registry. Proceed with
>> >> caution!
>> >>
>> >> c. In your Windows folder, locate and run regedit.exe. If you're on an
>> >> older version of Windows you might need to use regedt32.exe.
>> >>
>> >> Look for a key called
>> >>
>> >> HKEY_LOCAL_MACHINE\SOFTWARE\Mi­crosoft\Windows Messaging Subsystem
>> >>
>> >> I would be surprised if it was not there in recent versions of Windows,
>> >> but
>> >> if it is not, add it.
>> >>
>> >> If it is there, I would expect to see
>> >> d. a subkey claled MSMapiApps
>> >> e. a number of "values" with the same names as are in the above list -
>> >> MAPI, MAPIX etc.
>> >> f. an additional value called InstallCmd
>> >>
>> >> If you cannot see the (e) values, you need to add them. For each of the
>> >> values in the above list
>> >> g. right click "Windows Messaging Subsystem" and select New|String
>> >> Value.
>> >> Note that although some of these items have numeric values, they should
>> >> all
>> >> be entered as String Values.
>> >> h. enter the name, as above
>> >> i. double click on the name. A dialog box appears. Enter the value (e.g.
>> >> for the name CMCDLLNAME, enter mapi.dll) and click OK
>> >> j. You may also need to create the InstallCmd value, although I rather
>> >> doubt it. I am less sure about this and about what should go in there. On
>> >> my
>> >> system, the value is:
>> >> rundll32 setupapi,InstallHinfSection MSMAIL 132 msmail.inf
>> >>
>> >> When you have done them all, press F5. Then close all copies of Word and
>> >> restart it - or restart Windows, then restart Word and see if the e-mail
>> >> option has appeared.
>> >>
>> >>
>> >> --
>> >> Hope this helps.
>> >>
>> >> Please reply to the newsgroup unless you wish to avail yourself of my
>> >> services on a paid consulting basis.
>> >>
>> >> Doug Robbins - Word MVP
>> >>
>> >> "Ben Coyle" <frenz_of_rom@hotmail.com> wrote in message
>> >> news:013B92BE-6DAA-46F0-8030-DC1DE1027EDB@microsoft.com...
>> >> > Hi
>> >> > I have just bought MS Office 2007 Home and Student edition. When I try
>> >> > to
>> >> > send a document as an email attachment in Word (or any other Office
>> >> > program for that matter) all the email options are greyed out, with no
>> >> > explanation as to why I can't send. Sending from Wordpad works fine.
>> >> > My default mail client is Windows Mail. I am running Vista Home Premium
>> >> > OS. Is this problem occuring because I am not using Outlook? Or is
>> >> > there
>> >> > some other issue?
>> >> > THanks
>> >>
>> >>
>> >>

>>
>>
>>
 

My Computer

D

Doug Robbins - Word MVP

#11
Not where I am seeing it - microsoft.public.word.mail

--
Hope this helps.

Please reply to the newsgroup unless you wish to avail yourself of my
services on a paid consulting basis.

Doug Robbins - Word MVP

"Julian" <Julianlzb87@gmail.com> wrote in message
news:4EDE15BE-95CB-490D-A7AF-B42D34B3AD4D@microsoft.com...
>
>
> "Doug Robbins - Word MVP" <dkr@REMOVECAPSmvps.org> wrote in message
> news:#81dlLA1HHA.2484@TK2MSFTNGP06.phx.gbl...
>>I don't see where Vista was mentioned anywhere in the posts to which I was
>>responding.

>
> The OP is running Vista and this is a Vista Forum.
>
>> --
>> Hope this helps.
>>
>> Please reply to the newsgroup unless you wish to avail yourself of my
>> services on a paid consulting basis.
>>
>> Doug Robbins - Word MVP
>>
>> "Julian" <Julianlzb87@gmail.com> wrote in message
>> news:471FA87B-929D-42E2-93CD-478E63556F97@microsoft.com...
>>>
>>>
>>> "Doug Robbins - Word MVP" <dkr@REMOVECAPSmvps.org> wrote in message
>>> news:e6tRb7$0HHA.728@TK2MSFTNGP05.phx.gbl...
>>>> If you set Outlook Express as the default mail program, you should then
>>>> be able to use it for the purpose.
>>>
>>> Outlook Express on Vista?
>>>
>>>
>>>>
>>>> --
>>>> Hope this helps.
>>>>
>>>> Please reply to the newsgroup unless you wish to avail yourself of my
>>>> services on a paid consulting basis.
>>>>
>>>> Doug Robbins - Word MVP
>>>>
>>>> "Art" <Art@discussions.microsoft.com> wrote in message
>>>> news:F205EBB4-1E6A-4AC9-9304-01B8407640BD@microsoft.com...
>>>>> Compatability may well be a problem, I know I can not use word as my
>>>>> email
>>>>> editor but from reading other posts here I get the feeling that MS has
>>>>> disabled the "Send to Email recipient" function in the 2007 Home and
>>>>> Student
>>>>> program. The rational seems to be that that function is a "commercial"
>>>>> function. I disagree with that logic because a lot of people just wont
>>>>> open
>>>>> ANY email attachments so the need to send a document as an email is
>>>>> fully
>>>>> justified, IMHO, for use in the Home & Student version. I hope that
>>>>> someone
>>>>> can get through to MS and that they will activate the function in the
>>>>> H & S
>>>>> version. (Well I can dream can't I? <grin>)
>>>>>
>>>>> "Doug Robbins - Word MVP" wrote:
>>>>>
>>>>>> I think that the issue may be one of Compatability between Word 2007
>>>>>> and
>>>>>> Outlook 2003.
>>>>>>
>>>>>> --
>>>>>> Hope this helps.
>>>>>>
>>>>>> Please reply to the newsgroup unless you wish to avail yourself of my
>>>>>> services on a paid consulting basis.
>>>>>>
>>>>>> Doug Robbins - Word MVP
>>>>>>
>>>>>> "Art" <Art@discussions.microsoft.com> wrote in message
>>>>>> news:409A3502-3DBA-47A2-8D3C-758BFB335E92@microsoft.com...
>>>>>> >I am having the same problem. Outlook 2003 is my default mail
>>>>>> >program
>>>>>> > (check), I looked in the Registry and all values are present
>>>>>> > (check), I
>>>>>> > added
>>>>>> > the PDF and XPS attachments. I added "Send to mail recipient" to
>>>>>> > the Quick
>>>>>> > Task bar where it remains "gray."
>>>>>> >
>>>>>> > I got all that info from the Help section on Word 2007. Their last
>>>>>> > alternative is to send the document as an attachment which seems to
>>>>>> > me to
>>>>>> > defeat the purpose and is not a viable workaround for my project
>>>>>> > (an email
>>>>>> > Newsletter).
>>>>>> >
>>>>>> > Any other thoughts on this?
>>>>>> >
>>>>>> > Thanks
>>>>>> >
>>>>>> > "Doug Robbins - Word MVP" wrote:
>>>>>> >
>>>>>> >> Here is some information posted by Peter Jamieson. It may not be
>>>>>> >> applicable
>>>>>> >> to your operating system and mail program, for which it might be
>>>>>> >> better
>>>>>> >> to
>>>>>> >> ask your question in the microsoft.public.windows.vista.mail
>>>>>> >> newsgroup,
>>>>>> >> to
>>>>>> >> which I have cross-posted this response.
>>>>>> >>
>>>>>> >> First, make sure that the e-mail program you want to use is set up
>>>>>> >> to be
>>>>>> >> the
>>>>>> >> default e-mail program (e.g. via Internet Explorer|Tools|Internet
>>>>>> >> Options|Programs, and send at least one message using it.
>>>>>> >>
>>>>>> >> Then Word needs some stuff in WIN.INI and/or in the Windows
>>>>>> >> registry
>>>>>> >> before it will show you the E-mail option. I believe that for Word
>>>>>> >> 2003
>>>>>> >> it
>>>>>> >> needs to be in the Windows registry, but that may depend also on
>>>>>> >> the
>>>>>> >> version
>>>>>> >> of Windows so it is probably better to put the information in both
>>>>>> >> places.
>>>>>> >>
>>>>>> >> For WIN.INI,
>>>>>> >> a. find the WIN.INI file in your Windows folder (typically
>>>>>> >> c:\WINDOWS),
>>>>>> >> make a backup copy of it, and open it in Notepad.
>>>>>> >> b. ensure that the following text is in there, and add it if not
>>>>>> >>
>>>>>> >> [Mail]
>>>>>> >> MAPI=1
>>>>>> >> CMCDLLNAME32=mapi32.dll
>>>>>> >> CMCDLLNAME=mapi.dll
>>>>>> >> CMC=1
>>>>>> >> MAPIX=1
>>>>>> >> MAPIXVER=1.0.0.1
>>>>>> >> OLEMessaging=1
>>>>>> >>
>>>>>> >> You will need to close all copies of Word before this change has a
>>>>>> >> chance
>>>>>> >> of
>>>>>> >> taking effect. It is probably safest to restart Windows to be
>>>>>> >> completely
>>>>>> >> sure.
>>>>>> >>
>>>>>> >> If that isn't enough, you will need to edit the registry. Proceed
>>>>>> >> with
>>>>>> >> caution!
>>>>>> >>
>>>>>> >> c. In your Windows folder, locate and run regedit.exe. If you're
>>>>>> >> on an
>>>>>> >> older version of Windows you might need to use regedt32.exe.
>>>>>> >>
>>>>>> >> Look for a key called
>>>>>> >>
>>>>>> >> HKEY_LOCAL_MACHINE\SOFTWARE\Mi­crosoft\Windows Messaging Subsystem
>>>>>> >>
>>>>>> >> I would be surprised if it was not there in recent versions of
>>>>>> >> Windows,
>>>>>> >> but
>>>>>> >> if it is not, add it.
>>>>>> >>
>>>>>> >> If it is there, I would expect to see
>>>>>> >> d. a subkey claled MSMapiApps
>>>>>> >> e. a number of "values" with the same names as are in the above
>>>>>> >> list -
>>>>>> >> MAPI, MAPIX etc.
>>>>>> >> f. an additional value called InstallCmd
>>>>>> >>
>>>>>> >> If you cannot see the (e) values, you need to add them. For each
>>>>>> >> of the
>>>>>> >> values in the above list
>>>>>> >> g. right click "Windows Messaging Subsystem" and select
>>>>>> >> New|String
>>>>>> >> Value.
>>>>>> >> Note that although some of these items have numeric values, they
>>>>>> >> should
>>>>>> >> all
>>>>>> >> be entered as String Values.
>>>>>> >> h. enter the name, as above
>>>>>> >> i. double click on the name. A dialog box appears. Enter the
>>>>>> >> value (e.g.
>>>>>> >> for the name CMCDLLNAME, enter mapi.dll) and click OK
>>>>>> >> j. You may also need to create the InstallCmd value, although I
>>>>>> >> rather
>>>>>> >> doubt it. I am less sure about this and about what should go in
>>>>>> >> there. On
>>>>>> >> my
>>>>>> >> system, the value is:
>>>>>> >> rundll32 setupapi,InstallHinfSection MSMAIL 132 msmail.inf
>>>>>> >>
>>>>>> >> When you have done them all, press F5. Then close all copies of
>>>>>> >> Word and
>>>>>> >> restart it - or restart Windows, then restart Word and see if the
>>>>>> >> e-mail
>>>>>> >> option has appeared.
>>>>>> >>
>>>>>> >>
>>>>>> >> --
>>>>>> >> Hope this helps.
>>>>>> >>
>>>>>> >> Please reply to the newsgroup unless you wish to avail yourself of
>>>>>> >> my
>>>>>> >> services on a paid consulting basis.
>>>>>> >>
>>>>>> >> Doug Robbins - Word MVP
>>>>>> >>
>>>>>> >> "Ben Coyle" <frenz_of_rom@hotmail.com> wrote in message
>>>>>> >> news:013B92BE-6DAA-46F0-8030-DC1DE1027EDB@microsoft.com...
>>>>>> >> > Hi
>>>>>> >> > I have just bought MS Office 2007 Home and Student edition. When
>>>>>> >> > I try
>>>>>> >> > to
>>>>>> >> > send a document as an email attachment in Word (or any other
>>>>>> >> > Office
>>>>>> >> > program for that matter) all the email options are greyed out,
>>>>>> >> > with no
>>>>>> >> > explanation as to why I can't send. Sending from Wordpad works
>>>>>> >> > fine.
>>>>>> >> > My default mail client is Windows Mail. I am running Vista Home
>>>>>> >> > Premium
>>>>>> >> > OS. Is this problem occuring because I am not using Outlook? Or
>>>>>> >> > is
>>>>>> >> > there
>>>>>> >> > some other issue?
>>>>>> >> > THanks
>>>>>> >>
>>>>>> >>
>>>>>> >>
>>>>>>
>>>>>>
>>>>>>
>>>>
>>>>

>>
>>
 

My Computer

J

Julian

#12
"Doug Robbins - Word MVP" <dkr@REMOVECAPSmvps.org> wrote in message
news:uA1m#lB1HHA.5884@TK2MSFTNGP02.phx.gbl...
> Not where I am seeing it - microsoft.public.word.mail


OK... it must have been crossposted at some point after the OP sent it.

I quote from the bottom of this post...

"My default mail client is Windows Mail. I am running Vista Home Premium OS.
Is this problem occuring because I am not using Outlook?"

>
> --
> Hope this helps.
>
> Please reply to the newsgroup unless you wish to avail yourself of my
> services on a paid consulting basis.
>
> Doug Robbins - Word MVP
>
> "Julian" <Julianlzb87@gmail.com> wrote in message
> news:4EDE15BE-95CB-490D-A7AF-B42D34B3AD4D@microsoft.com...
>>
>>
>> "Doug Robbins - Word MVP" <dkr@REMOVECAPSmvps.org> wrote in message
>> news:#81dlLA1HHA.2484@TK2MSFTNGP06.phx.gbl...
>>>I don't see where Vista was mentioned anywhere in the posts to which I
>>>was responding.

>>
>> The OP is running Vista and this is a Vista Forum.
>>
>>> --
>>> Hope this helps.
>>>
>>> Please reply to the newsgroup unless you wish to avail yourself of my
>>> services on a paid consulting basis.
>>>
>>> Doug Robbins - Word MVP
>>>
>>> "Julian" <Julianlzb87@gmail.com> wrote in message
>>> news:471FA87B-929D-42E2-93CD-478E63556F97@microsoft.com...
>>>>
>>>>
>>>> "Doug Robbins - Word MVP" <dkr@REMOVECAPSmvps.org> wrote in message
>>>> news:e6tRb7$0HHA.728@TK2MSFTNGP05.phx.gbl...
>>>>> If you set Outlook Express as the default mail program, you should
>>>>> then be able to use it for the purpose.
>>>>
>>>> Outlook Express on Vista?
>>>>
>>>>
>>>>>
>>>>> --
>>>>> Hope this helps.
>>>>>
>>>>> Please reply to the newsgroup unless you wish to avail yourself of my
>>>>> services on a paid consulting basis.
>>>>>
>>>>> Doug Robbins - Word MVP
>>>>>
>>>>> "Art" <Art@discussions.microsoft.com> wrote in message
>>>>> news:F205EBB4-1E6A-4AC9-9304-01B8407640BD@microsoft.com...
>>>>>> Compatability may well be a problem, I know I can not use word as my
>>>>>> email
>>>>>> editor but from reading other posts here I get the feeling that MS
>>>>>> has
>>>>>> disabled the "Send to Email recipient" function in the 2007 Home and
>>>>>> Student
>>>>>> program. The rational seems to be that that function is a
>>>>>> "commercial"
>>>>>> function. I disagree with that logic because a lot of people just
>>>>>> wont open
>>>>>> ANY email attachments so the need to send a document as an email is
>>>>>> fully
>>>>>> justified, IMHO, for use in the Home & Student version. I hope that
>>>>>> someone
>>>>>> can get through to MS and that they will activate the function in the
>>>>>> H & S
>>>>>> version. (Well I can dream can't I? <grin>)
>>>>>>
>>>>>> "Doug Robbins - Word MVP" wrote:
>>>>>>
>>>>>>> I think that the issue may be one of Compatability between Word 2007
>>>>>>> and
>>>>>>> Outlook 2003.
>>>>>>>
>>>>>>> --
>>>>>>> Hope this helps.
>>>>>>>
>>>>>>> Please reply to the newsgroup unless you wish to avail yourself of
>>>>>>> my
>>>>>>> services on a paid consulting basis.
>>>>>>>
>>>>>>> Doug Robbins - Word MVP
>>>>>>>
>>>>>>> "Art" <Art@discussions.microsoft.com> wrote in message
>>>>>>> news:409A3502-3DBA-47A2-8D3C-758BFB335E92@microsoft.com...
>>>>>>> >I am having the same problem. Outlook 2003 is my default mail
>>>>>>> >program
>>>>>>> > (check), I looked in the Registry and all values are present
>>>>>>> > (check), I
>>>>>>> > added
>>>>>>> > the PDF and XPS attachments. I added "Send to mail recipient" to
>>>>>>> > the Quick
>>>>>>> > Task bar where it remains "gray."
>>>>>>> >
>>>>>>> > I got all that info from the Help section on Word 2007. Their last
>>>>>>> > alternative is to send the document as an attachment which seems
>>>>>>> > to me to
>>>>>>> > defeat the purpose and is not a viable workaround for my project
>>>>>>> > (an email
>>>>>>> > Newsletter).
>>>>>>> >
>>>>>>> > Any other thoughts on this?
>>>>>>> >
>>>>>>> > Thanks
>>>>>>> >
>>>>>>> > "Doug Robbins - Word MVP" wrote:
>>>>>>> >
>>>>>>> >> Here is some information posted by Peter Jamieson. It may not be
>>>>>>> >> applicable
>>>>>>> >> to your operating system and mail program, for which it might be
>>>>>>> >> better
>>>>>>> >> to
>>>>>>> >> ask your question in the microsoft.public.windows.vista.mail
>>>>>>> >> newsgroup,
>>>>>>> >> to
>>>>>>> >> which I have cross-posted this response.
>>>>>>> >>
>>>>>>> >> First, make sure that the e-mail program you want to use is set
>>>>>>> >> up to be
>>>>>>> >> the
>>>>>>> >> default e-mail program (e.g. via Internet Explorer|Tools|Internet
>>>>>>> >> Options|Programs, and send at least one message using it.
>>>>>>> >>
>>>>>>> >> Then Word needs some stuff in WIN.INI and/or in the Windows
>>>>>>> >> registry
>>>>>>> >> before it will show you the E-mail option. I believe that for
>>>>>>> >> Word 2003
>>>>>>> >> it
>>>>>>> >> needs to be in the Windows registry, but that may depend also on
>>>>>>> >> the
>>>>>>> >> version
>>>>>>> >> of Windows so it is probably better to put the information in
>>>>>>> >> both
>>>>>>> >> places.
>>>>>>> >>
>>>>>>> >> For WIN.INI,
>>>>>>> >> a. find the WIN.INI file in your Windows folder (typically
>>>>>>> >> c:\WINDOWS),
>>>>>>> >> make a backup copy of it, and open it in Notepad.
>>>>>>> >> b. ensure that the following text is in there, and add it if not
>>>>>>> >>
>>>>>>> >> [Mail]
>>>>>>> >> MAPI=1
>>>>>>> >> CMCDLLNAME32=mapi32.dll
>>>>>>> >> CMCDLLNAME=mapi.dll
>>>>>>> >> CMC=1
>>>>>>> >> MAPIX=1
>>>>>>> >> MAPIXVER=1.0.0.1
>>>>>>> >> OLEMessaging=1
>>>>>>> >>
>>>>>>> >> You will need to close all copies of Word before this change has
>>>>>>> >> a chance
>>>>>>> >> of
>>>>>>> >> taking effect. It is probably safest to restart Windows to be
>>>>>>> >> completely
>>>>>>> >> sure.
>>>>>>> >>
>>>>>>> >> If that isn't enough, you will need to edit the registry. Proceed
>>>>>>> >> with
>>>>>>> >> caution!
>>>>>>> >>
>>>>>>> >> c. In your Windows folder, locate and run regedit.exe. If you're
>>>>>>> >> on an
>>>>>>> >> older version of Windows you might need to use regedt32.exe.
>>>>>>> >>
>>>>>>> >> Look for a key called
>>>>>>> >>
>>>>>>> >> HKEY_LOCAL_MACHINE\SOFTWARE\Mi­crosoft\Windows Messaging
>>>>>>> >> Subsystem
>>>>>>> >>
>>>>>>> >> I would be surprised if it was not there in recent versions of
>>>>>>> >> Windows,
>>>>>>> >> but
>>>>>>> >> if it is not, add it.
>>>>>>> >>
>>>>>>> >> If it is there, I would expect to see
>>>>>>> >> d. a subkey claled MSMapiApps
>>>>>>> >> e. a number of "values" with the same names as are in the above
>>>>>>> >> list -
>>>>>>> >> MAPI, MAPIX etc.
>>>>>>> >> f. an additional value called InstallCmd
>>>>>>> >>
>>>>>>> >> If you cannot see the (e) values, you need to add them. For each
>>>>>>> >> of the
>>>>>>> >> values in the above list
>>>>>>> >> g. right click "Windows Messaging Subsystem" and select
>>>>>>> >> New|String
>>>>>>> >> Value.
>>>>>>> >> Note that although some of these items have numeric values, they
>>>>>>> >> should
>>>>>>> >> all
>>>>>>> >> be entered as String Values.
>>>>>>> >> h. enter the name, as above
>>>>>>> >> i. double click on the name. A dialog box appears. Enter the
>>>>>>> >> value (e.g.
>>>>>>> >> for the name CMCDLLNAME, enter mapi.dll) and click OK
>>>>>>> >> j. You may also need to create the InstallCmd value, although I
>>>>>>> >> rather
>>>>>>> >> doubt it. I am less sure about this and about what should go in
>>>>>>> >> there. On
>>>>>>> >> my
>>>>>>> >> system, the value is:
>>>>>>> >> rundll32 setupapi,InstallHinfSection MSMAIL 132 msmail.inf
>>>>>>> >>
>>>>>>> >> When you have done them all, press F5. Then close all copies of
>>>>>>> >> Word and
>>>>>>> >> restart it - or restart Windows, then restart Word and see if the
>>>>>>> >> e-mail
>>>>>>> >> option has appeared.
>>>>>>> >>
>>>>>>> >>
>>>>>>> >> --
>>>>>>> >> Hope this helps.
>>>>>>> >>
>>>>>>> >> Please reply to the newsgroup unless you wish to avail yourself
>>>>>>> >> of my
>>>>>>> >> services on a paid consulting basis.
>>>>>>> >>
>>>>>>> >> Doug Robbins - Word MVP
>>>>>>> >>
>>>>>>> >> "Ben Coyle" <frenz_of_rom@hotmail.com> wrote in message
>>>>>>> >> news:013B92BE-6DAA-46F0-8030-DC1DE1027EDB@microsoft.com...
>>>>>>> >> > Hi
>>>>>>> >> > I have just bought MS Office 2007 Home and Student edition.
>>>>>>> >> > When I try
>>>>>>> >> > to
>>>>>>> >> > send a document as an email attachment in Word (or any other
>>>>>>> >> > Office
>>>>>>> >> > program for that matter) all the email options are greyed out,
>>>>>>> >> > with no
>>>>>>> >> > explanation as to why I can't send. Sending from Wordpad works
>>>>>>> >> > fine.
>>>>>>> >> > My default mail client is Windows Mail. I am running Vista Home
>>>>>>> >> > Premium
>>>>>>> >> > OS. Is this problem occuring because I am not using Outlook? Or
>>>>>>> >> > is
>>>>>>> >> > there
>>>>>>> >> > some other issue?
>>>>>>> >> > THanks
>>>>>>> >>
>>>>>>> >>
>>>>>>> >>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>
>>>>>
>>>
>>>

>
>
 

My Computer

H

Herb Tyson [MVP]

#13
....and make sure that Windows Mail is set as the default mail program
(assuming the user doesn't have some other MAPI mail client installed).

--
Herb Tyson MS MVP
Author of the Word 2007 Bible
Blog: http://word2007bible.herbtyson.com
Web: http://www.herbtyson.com


"Gary VanderMolen" <gary@NoMail.invalid> wrote in message
news:OMh1ppA1HHA.728@TK2MSFTNGP05.phx.gbl...
> Try this:
> Run your 2007 Home and Student edition CD and choose the option
> to add specific components. Although there is no option to install
> Outlook,
> you should have an option to install MAPI handlers. The MAPI handler
> needs to be present before Word can "send to Email recipient".
>
> Gary VanderMolen
>
> "Art" <Art@discussions.microsoft.com> wrote in message
> news:F205EBB4-1E6A-4AC9-9304-01B8407640BD@microsoft.com...
>> Compatability may well be a problem, I know I can not use word as my
>> email
>> editor but from reading other posts here I get the feeling that MS has
>> disabled the "Send to Email recipient" function in the 2007 Home and
>> Student
>> program. The rational seems to be that that function is a "commercial"
>> function. I disagree with that logic because a lot of people just wont
>> open
>> ANY email attachments so the need to send a document as an email is fully
>> justified, IMHO, for use in the Home & Student version. I hope that
>> someone
>> can get through to MS and that they will activate the function in the H &
>> S
>> version. (Well I can dream can't I? <grin>)
>>
>> "Doug Robbins - Word MVP" wrote:
>>
>>> I think that the issue may be one of Compatability between Word 2007 and
>>> Outlook 2003.
>>>
>>> --
>>> Hope this helps.
>>>
>>> Please reply to the newsgroup unless you wish to avail yourself of my
>>> services on a paid consulting basis.
>>>
>>> Doug Robbins - Word MVP
>>>
>>> "Art" <Art@discussions.microsoft.com> wrote in message
>>> news:409A3502-3DBA-47A2-8D3C-758BFB335E92@microsoft.com...
>>> >I am having the same problem. Outlook 2003 is my default mail program
>>> > (check), I looked in the Registry and all values are present (check),
>>> > I
>>> > added
>>> > the PDF and XPS attachments. I added "Send to mail recipient" to the
>>> > Quick
>>> > Task bar where it remains "gray."
>>> >
>>> > I got all that info from the Help section on Word 2007. Their last
>>> > alternative is to send the document as an attachment which seems to me
>>> > to
>>> > defeat the purpose and is not a viable workaround for my project (an
>>> > email
>>> > Newsletter).
>>> >
>>> > Any other thoughts on this?
>>> >
>>> > Thanks
>>> >
>>> > "Doug Robbins - Word MVP" wrote:
>>> >
>>> >> Here is some information posted by Peter Jamieson. It may not be
>>> >> applicable
>>> >> to your operating system and mail program, for which it might be
>>> >> better
>>> >> to
>>> >> ask your question in the microsoft.public.windows.vista.mail
>>> >> newsgroup,
>>> >> to
>>> >> which I have cross-posted this response.
>>> >>
>>> >> First, make sure that the e-mail program you want to use is set up to
>>> >> be
>>> >> the
>>> >> default e-mail program (e.g. via Internet Explorer|Tools|Internet
>>> >> Options|Programs, and send at least one message using it.
>>> >>
>>> >> Then Word needs some stuff in WIN.INI and/or in the Windows registry
>>> >> before it will show you the E-mail option. I believe that for Word
>>> >> 2003
>>> >> it
>>> >> needs to be in the Windows registry, but that may depend also on the
>>> >> version
>>> >> of Windows so it is probably better to put the information in both
>>> >> places.
>>> >>
>>> >> For WIN.INI,
>>> >> a. find the WIN.INI file in your Windows folder (typically
>>> >> c:\WINDOWS),
>>> >> make a backup copy of it, and open it in Notepad.
>>> >> b. ensure that the following text is in there, and add it if not
>>> >>
>>> >> [Mail]
>>> >> MAPI=1
>>> >> CMCDLLNAME32=mapi32.dll
>>> >> CMCDLLNAME=mapi.dll
>>> >> CMC=1
>>> >> MAPIX=1
>>> >> MAPIXVER=1.0.0.1
>>> >> OLEMessaging=1
>>> >>
>>> >> You will need to close all copies of Word before this change has a
>>> >> chance
>>> >> of
>>> >> taking effect. It is probably safest to restart Windows to be
>>> >> completely
>>> >> sure.
>>> >>
>>> >> If that isn't enough, you will need to edit the registry. Proceed
>>> >> with
>>> >> caution!
>>> >>
>>> >> c. In your Windows folder, locate and run regedit.exe. If you're on
>>> >> an
>>> >> older version of Windows you might need to use regedt32.exe.
>>> >>
>>> >> Look for a key called
>>> >>
>>> >> HKEY_LOCAL_MACHINE\SOFTWARE\Mi­crosoft\Windows Messaging Subsystem
>>> >>
>>> >> I would be surprised if it was not there in recent versions of
>>> >> Windows,
>>> >> but
>>> >> if it is not, add it.
>>> >>
>>> >> If it is there, I would expect to see
>>> >> d. a subkey claled MSMapiApps
>>> >> e. a number of "values" with the same names as are in the above
>>> >> list -
>>> >> MAPI, MAPIX etc.
>>> >> f. an additional value called InstallCmd
>>> >>
>>> >> If you cannot see the (e) values, you need to add them. For each of
>>> >> the
>>> >> values in the above list
>>> >> g. right click "Windows Messaging Subsystem" and select New|String
>>> >> Value.
>>> >> Note that although some of these items have numeric values, they
>>> >> should
>>> >> all
>>> >> be entered as String Values.
>>> >> h. enter the name, as above
>>> >> i. double click on the name. A dialog box appears. Enter the value
>>> >> (e.g.
>>> >> for the name CMCDLLNAME, enter mapi.dll) and click OK
>>> >> j. You may also need to create the InstallCmd value, although I
>>> >> rather
>>> >> doubt it. I am less sure about this and about what should go in
>>> >> there. On
>>> >> my
>>> >> system, the value is:
>>> >> rundll32 setupapi,InstallHinfSection MSMAIL 132 msmail.inf
>>> >>
>>> >> When you have done them all, press F5. Then close all copies of Word
>>> >> and
>>> >> restart it - or restart Windows, then restart Word and see if the
>>> >> e-mail
>>> >> option has appeared.
>>> >>
>>> >>
>>> >> --
>>> >> Hope this helps.
>>> >>
>>> >> Please reply to the newsgroup unless you wish to avail yourself of my
>>> >> services on a paid consulting basis.
>>> >>
>>> >> Doug Robbins - Word MVP
>>> >>
>>> >> "Ben Coyle" <frenz_of_rom@hotmail.com> wrote in message
>>> >> news:013B92BE-6DAA-46F0-8030-DC1DE1027EDB@microsoft.com...
>>> >> > Hi
>>> >> > I have just bought MS Office 2007 Home and Student edition. When I
>>> >> > try
>>> >> > to
>>> >> > send a document as an email attachment in Word (or any other Office
>>> >> > program for that matter) all the email options are greyed out, with
>>> >> > no
>>> >> > explanation as to why I can't send. Sending from Wordpad works
>>> >> > fine.
>>> >> > My default mail client is Windows Mail. I am running Vista Home
>>> >> > Premium
>>> >> > OS. Is this problem occuring because I am not using Outlook? Or is
>>> >> > there
>>> >> > some other issue?
>>> >> > THanks
>>> >>
>>> >>
>>> >>
>>>
>>>
>>>

>
 

My Computer

J

Julian

#14
"Herb Tyson [MVP]" <herb@1x2y3z.xnw> wrote in message
news:CAE929BE-2D7F-42D3-9B44-240ACD8DE25F@microsoft.com...
> ...and make sure that Windows Mail is set as the default mail program



Tools >
Options >
General >
Default Messaging Programs >
This application is the default Mail handler > Make Default
 

My Computer

P

Peter Jamieson

#15
There are so many diferent possible configurations in this area...

> Run your 2007 Home and Student edition CD and choose the option
> to add specific components. Although there is no option to install
> Outlook,
> you should have an option to install MAPI handlers. The MAPI handler
> needs to be present before Word can "send to Email recipient".


FWIW,
a. when I run the Home and Student CD and/or when I used the Control
Panel|"Programs and features" options to do the same thing, I saw no MAPI
option of any kind. If it's there in your version, can you provide really
specific pointers?
b. I would expect the necessary MAPI stuff to be installed with Outlook
2003, if anything. Here, I installed OL2003 first, then Office Home and
Student 2007. I can certainly use Word|Office button|Send|E-mail|As an
attachment (and I didn't really expect to be able to do that, given that
previous versions of Word/Outlook generally had to be the same to achieve
that kind of interoperability). However, here, I happen to be working with
Microsoft Exchange Server and that might also have a bearing on the
issue(s).

Peter Jamieson

"Gary VanderMolen" <gary@NoMail.invalid> wrote in message
news:OMh1ppA1HHA.728@TK2MSFTNGP05.phx.gbl...
> Try this:
> Run your 2007 Home and Student edition CD and choose the option
> to add specific components. Although there is no option to install
> Outlook,
> you should have an option to install MAPI handlers. The MAPI handler
> needs to be present before Word can "send to Email recipient".
>
> Gary VanderMolen
>
> "Art" <Art@discussions.microsoft.com> wrote in message
> news:F205EBB4-1E6A-4AC9-9304-01B8407640BD@microsoft.com...
>> Compatability may well be a problem, I know I can not use word as my
>> email
>> editor but from reading other posts here I get the feeling that MS has
>> disabled the "Send to Email recipient" function in the 2007 Home and
>> Student
>> program. The rational seems to be that that function is a "commercial"
>> function. I disagree with that logic because a lot of people just wont
>> open
>> ANY email attachments so the need to send a document as an email is fully
>> justified, IMHO, for use in the Home & Student version. I hope that
>> someone
>> can get through to MS and that they will activate the function in the H &
>> S
>> version. (Well I can dream can't I? <grin>)
>>
>> "Doug Robbins - Word MVP" wrote:
>>
>>> I think that the issue may be one of Compatability between Word 2007 and
>>> Outlook 2003.
>>>
>>> --
>>> Hope this helps.
>>>
>>> Please reply to the newsgroup unless you wish to avail yourself of my
>>> services on a paid consulting basis.
>>>
>>> Doug Robbins - Word MVP
>>>
>>> "Art" <Art@discussions.microsoft.com> wrote in message
>>> news:409A3502-3DBA-47A2-8D3C-758BFB335E92@microsoft.com...
>>> >I am having the same problem. Outlook 2003 is my default mail program
>>> > (check), I looked in the Registry and all values are present (check),
>>> > I
>>> > added
>>> > the PDF and XPS attachments. I added "Send to mail recipient" to the
>>> > Quick
>>> > Task bar where it remains "gray."
>>> >
>>> > I got all that info from the Help section on Word 2007. Their last
>>> > alternative is to send the document as an attachment which seems to me
>>> > to
>>> > defeat the purpose and is not a viable workaround for my project (an
>>> > email
>>> > Newsletter).
>>> >
>>> > Any other thoughts on this?
>>> >
>>> > Thanks
>>> >
>>> > "Doug Robbins - Word MVP" wrote:
>>> >
>>> >> Here is some information posted by Peter Jamieson. It may not be
>>> >> applicable
>>> >> to your operating system and mail program, for which it might be
>>> >> better
>>> >> to
>>> >> ask your question in the microsoft.public.windows.vista.mail
>>> >> newsgroup,
>>> >> to
>>> >> which I have cross-posted this response.
>>> >>
>>> >> First, make sure that the e-mail program you want to use is set up to
>>> >> be
>>> >> the
>>> >> default e-mail program (e.g. via Internet Explorer|Tools|Internet
>>> >> Options|Programs, and send at least one message using it.
>>> >>
>>> >> Then Word needs some stuff in WIN.INI and/or in the Windows registry
>>> >> before it will show you the E-mail option. I believe that for Word
>>> >> 2003
>>> >> it
>>> >> needs to be in the Windows registry, but that may depend also on the
>>> >> version
>>> >> of Windows so it is probably better to put the information in both
>>> >> places.
>>> >>
>>> >> For WIN.INI,
>>> >> a. find the WIN.INI file in your Windows folder (typically
>>> >> c:\WINDOWS),
>>> >> make a backup copy of it, and open it in Notepad.
>>> >> b. ensure that the following text is in there, and add it if not
>>> >>
>>> >> [Mail]
>>> >> MAPI=1
>>> >> CMCDLLNAME32=mapi32.dll
>>> >> CMCDLLNAME=mapi.dll
>>> >> CMC=1
>>> >> MAPIX=1
>>> >> MAPIXVER=1.0.0.1
>>> >> OLEMessaging=1
>>> >>
>>> >> You will need to close all copies of Word before this change has a
>>> >> chance
>>> >> of
>>> >> taking effect. It is probably safest to restart Windows to be
>>> >> completely
>>> >> sure.
>>> >>
>>> >> If that isn't enough, you will need to edit the registry. Proceed
>>> >> with
>>> >> caution!
>>> >>
>>> >> c. In your Windows folder, locate and run regedit.exe. If you're on
>>> >> an
>>> >> older version of Windows you might need to use regedt32.exe.
>>> >>
>>> >> Look for a key called
>>> >>
>>> >> HKEY_LOCAL_MACHINE\SOFTWARE\Mi­crosoft\Windows Messaging Subsystem
>>> >>
>>> >> I would be surprised if it was not there in recent versions of
>>> >> Windows,
>>> >> but
>>> >> if it is not, add it.
>>> >>
>>> >> If it is there, I would expect to see
>>> >> d. a subkey claled MSMapiApps
>>> >> e. a number of "values" with the same names as are in the above
>>> >> list -
>>> >> MAPI, MAPIX etc.
>>> >> f. an additional value called InstallCmd
>>> >>
>>> >> If you cannot see the (e) values, you need to add them. For each of
>>> >> the
>>> >> values in the above list
>>> >> g. right click "Windows Messaging Subsystem" and select New|String
>>> >> Value.
>>> >> Note that although some of these items have numeric values, they
>>> >> should
>>> >> all
>>> >> be entered as String Values.
>>> >> h. enter the name, as above
>>> >> i. double click on the name. A dialog box appears. Enter the value
>>> >> (e.g.
>>> >> for the name CMCDLLNAME, enter mapi.dll) and click OK
>>> >> j. You may also need to create the InstallCmd value, although I
>>> >> rather
>>> >> doubt it. I am less sure about this and about what should go in
>>> >> there. On
>>> >> my
>>> >> system, the value is:
>>> >> rundll32 setupapi,InstallHinfSection MSMAIL 132 msmail.inf
>>> >>
>>> >> When you have done them all, press F5. Then close all copies of Word
>>> >> and
>>> >> restart it - or restart Windows, then restart Word and see if the
>>> >> e-mail
>>> >> option has appeared.
>>> >>
>>> >>
>>> >> --
>>> >> Hope this helps.
>>> >>
>>> >> Please reply to the newsgroup unless you wish to avail yourself of my
>>> >> services on a paid consulting basis.
>>> >>
>>> >> Doug Robbins - Word MVP
>>> >>
>>> >> "Ben Coyle" <frenz_of_rom@hotmail.com> wrote in message
>>> >> news:013B92BE-6DAA-46F0-8030-DC1DE1027EDB@microsoft.com...
>>> >> > Hi
>>> >> > I have just bought MS Office 2007 Home and Student edition. When I
>>> >> > try
>>> >> > to
>>> >> > send a document as an email attachment in Word (or any other Office
>>> >> > program for that matter) all the email options are greyed out, with
>>> >> > no
>>> >> > explanation as to why I can't send. Sending from Wordpad works
>>> >> > fine.
>>> >> > My default mail client is Windows Mail. I am running Vista Home
>>> >> > Premium
>>> >> > OS. Is this problem occuring because I am not using Outlook? Or is
>>> >> > there
>>> >> > some other issue?
>>> >> > THanks
>>> >>
>>> >>
>>> >>
>>>
>>>
>>>

>
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)