• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Reinstalling fonts

R

reneegade

#1
Seems I might have deleted a few of the essential fonts and am now getting
the following error:

"Error 1907: Could not register font. Verify that you have sufficient
permissions to install fonts, and that the system supports this font".

This error happens each time a new email arrives and at various other times
(such as launching MS Word 2007) and I have to click the IGNORE button 12
times.

I know I'm missing Aharoni, Calibri, Cambria, Consolas and Cordia - this
might be the problem. Anyone know where I can download these fonts from? I
can't do a reinstall from the disc as my PC was shipped with Home Premium.

Thanks in advance.
 

My Computer

Brink

Staff member
mvp
Messages
32,205
Location
Oklahoma, USA
#2

My Computers

System One System Two

  • Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    PSU
    Seasonic Prime Titanium 850W
    Case
    Corsair Air 740
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master
    Keyboard
    Logitech wireless K800
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Creative F200 webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD
R

reneegade

#3
Hi Brink,

Just tried that - did the scannow - it found and corrected problems. I've
just restarted but it hasn't finxed anything.

Any more ideas?
Hopeful

"brink" wrote:

>
> Hi reneegade,
>
> Go here for details and do the sfc /SCANNOW one. Hopefully it will
> restore the fonts for you.
>
> http://www.vistax64.com/tutorials/66978-system-files.html?ltr=S
>
> Hope this helps,
> Shawn
>
>
> --
> brink
>
> *There are no dumb questions, just the people that don't ask them.*
> '_www.Vistax64.com_' (http://www.vistax64.com/www.Vistax64.com)
> Please post feedback to help others.
>
 

My Computer

Brink

Staff member
mvp
Messages
32,205
Location
Oklahoma, USA
#4
Hi Brink,

Just tried that - did the scannow - it found and corrected problems. I've
just restarted but it hasn't finxed anything.

Any more ideas?
Hopeful
Ok reneegade,

At least it fixed some other problems for you. ;)

You can do a System restore to a date that you still had the fonts.

If you know which Vista fonts you want, I can e-mail them to you. I have 283 MB of Fonts, so please narrow it down or it'll be a long download.



Regards,
Shawn
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    PSU
    Seasonic Prime Titanium 850W
    Case
    Corsair Air 740
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master
    Keyboard
    Logitech wireless K800
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Creative F200 webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD

geopgeop

New Member
Messages
1
#5
I realize that this post is about 6 months late, but I had to come to reply:

After running SFC /SCANNOW, the second thing to do is go to Control Panel\Fonts. The fonts have been restored, but are technically unregistered, which is why if you deleted verdana.ttf, it doesn't show up even though it has been restored.

Right click anywhere in the folder, and click Install Font.

Select C:\Windows\Fonts (or the equivalent) as the folder. Click Select All, then click Install. All the fonts will be copied back onto themselves and be registered in the process.

Hope that helps.
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)