• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Remote Desktop Connection Runs Like Turtle

G

gsilvan

#1
I have used Remote Desktop Connection in Windows XP to connect to my work
network running Windows Server 2003 Standard Edition with RSA SecurID without
problem. Recently I purchased a laptop running Windows Vista. Now when I
connect everything starts out fine. The program connects to the server and
the login and verification proceed without a hitch. As soon as the
connection is complete, however, it runs like a slow turtle. It takes
forever for the remot workspace to load and several miniutes for it to
respond to even a simple mouse click. Eventually, all communications just
cease. Task manager says remote Desktop Connection is running normally and
the window can be moved, resized, etc., but the workspace doesn't respond and
there is no communication on the network. The problem isn't in either my
network or my work network as my XP machine still works fine.

How can I fix this problem?
 

My Computer

S

Stanley Feng \(MSFT\)

#2
Can you try to follow the instructions listed in the article here:
http://blog.tmcnet.com/blog/tom-keating/microsoft/remote-desktop-slow-problem-solved.asp,
specifically, these instructions from that article may help:

Here is what you need to do if you have the same issue:

- Run a command prompt (cmd.exe) as an Administrator
- Type: netsh interface tcp set global autotuninglevel=disabled

If you want to to re-enable it:
- Type: netsh interface tcp set global autotuninglevel=normal

In some cases you may need to use this command in addition to the above,
but I didn't have to:
- Type: netsh interface tcp set global rss=disabled

Please write back to let us know if it works or not.

--
This posting is provided "AS IS" with no warranties, and confers no rights.
Use of included script samples (if any) are subject to the terms specified
at http://www.microsoft.com/info/cpyright.htm"

"gsilvan" <gsilvan@discussions.microsoft.com> wrote in message
news:AC877CBA-6399-40A8-8C18-273C94160976@microsoft.com...
>I have used Remote Desktop Connection in Windows XP to connect to my work
> network running Windows Server 2003 Standard Edition with RSA SecurID
> without
> problem. Recently I purchased a laptop running Windows Vista. Now when I
> connect everything starts out fine. The program connects to the server
> and
> the login and verification proceed without a hitch. As soon as the
> connection is complete, however, it runs like a slow turtle. It takes
> forever for the remot workspace to load and several miniutes for it to
> respond to even a simple mouse click. Eventually, all communications just
> cease. Task manager says remote Desktop Connection is running normally
> and
> the window can be moved, resized, etc., but the workspace doesn't respond
> and
> there is no communication on the network. The problem isn't in either my
> network or my work network as my XP machine still works fine.
>
> How can I fix this problem?
 

My Computer

G

gsilvan

#3
It worked beautifully. Thanks!

"Stanley Feng (MSFT)" wrote:

> Can you try to follow the instructions listed in the article here:
> http://blog.tmcnet.com/blog/tom-keating/microsoft/remote-desktop-slow-problem-solved.asp,
> specifically, these instructions from that article may help:
>
> Here is what you need to do if you have the same issue:
>
> - Run a command prompt (cmd.exe) as an Administrator
> - Type: netsh interface tcp set global autotuninglevel=disabled
>
> If you want to to re-enable it:
> - Type: netsh interface tcp set global autotuninglevel=normal
>
> In some cases you may need to use this command in addition to the above,
> but I didn't have to:
> - Type: netsh interface tcp set global rss=disabled
>
> Please write back to let us know if it works or not.
>
> --
> This posting is provided "AS IS" with no warranties, and confers no rights.
> Use of included script samples (if any) are subject to the terms specified
> at http://www.microsoft.com/info/cpyright.htm"
>
> "gsilvan" <gsilvan@discussions.microsoft.com> wrote in message
> news:AC877CBA-6399-40A8-8C18-273C94160976@microsoft.com...
> >I have used Remote Desktop Connection in Windows XP to connect to my work
> > network running Windows Server 2003 Standard Edition with RSA SecurID
> > without
> > problem. Recently I purchased a laptop running Windows Vista. Now when I
> > connect everything starts out fine. The program connects to the server
> > and
> > the login and verification proceed without a hitch. As soon as the
> > connection is complete, however, it runs like a slow turtle. It takes
> > forever for the remot workspace to load and several miniutes for it to
> > respond to even a simple mouse click. Eventually, all communications just
> > cease. Task manager says remote Desktop Connection is running normally
> > and
> > the window can be moved, resized, etc., but the workspace doesn't respond
> > and
> > there is no communication on the network. The problem isn't in either my
> > network or my work network as my XP machine still works fine.
> >
> > How can I fix this problem?

>
>
>
 

My Computer

S

Stanley Feng \(MSFT\)

#4
gsilvan,

Glad to know this solved (worked-around) your problem. We would like to know
more about this issue, can you please email me offline at:

sfeng (at) microsoft.com?

Thanks!

--
This posting is provided "AS IS" with no warranties, and confers no rights.
Use of included script samples (if any) are subject to the terms specified
at http://www.microsoft.com/info/cpyright.htm"

"gsilvan" <gsilvan@discussions.microsoft.com> wrote in message
news:921D276F-F339-42EC-9A53-B993CFB683E3@microsoft.com...
> It worked beautifully. Thanks!
>
> "Stanley Feng (MSFT)" wrote:
>
>> Can you try to follow the instructions listed in the article here:
>> http://blog.tmcnet.com/blog/tom-keating/microsoft/remote-desktop-slow-problem-solved.asp,
>> specifically, these instructions from that article may help:
>>
>> Here is what you need to do if you have the same issue:
>>
>> - Run a command prompt (cmd.exe) as an Administrator
>> - Type: netsh interface tcp set global autotuninglevel=disabled
>>
>> If you want to to re-enable it:
>> - Type: netsh interface tcp set global autotuninglevel=normal
>>
>> In some cases you may need to use this command in addition to the
>> above,
>> but I didn't have to:
>> - Type: netsh interface tcp set global rss=disabled
>>
>> Please write back to let us know if it works or not.
>>
>> --
>> This posting is provided "AS IS" with no warranties, and confers no
>> rights.
>> Use of included script samples (if any) are subject to the terms
>> specified
>> at http://www.microsoft.com/info/cpyright.htm"
>>
>> "gsilvan" <gsilvan@discussions.microsoft.com> wrote in message
>> news:AC877CBA-6399-40A8-8C18-273C94160976@microsoft.com...
>> >I have used Remote Desktop Connection in Windows XP to connect to my
>> >work
>> > network running Windows Server 2003 Standard Edition with RSA SecurID
>> > without
>> > problem. Recently I purchased a laptop running Windows Vista. Now
>> > when I
>> > connect everything starts out fine. The program connects to the server
>> > and
>> > the login and verification proceed without a hitch. As soon as the
>> > connection is complete, however, it runs like a slow turtle. It takes
>> > forever for the remot workspace to load and several miniutes for it to
>> > respond to even a simple mouse click. Eventually, all communications
>> > just
>> > cease. Task manager says remote Desktop Connection is running normally
>> > and
>> > the window can be moved, resized, etc., but the workspace doesn't
>> > respond
>> > and
>> > there is no communication on the network. The problem isn't in either
>> > my
>> > network or my work network as my XP machine still works fine.
>> >
>> > How can I fix this problem?

>>
>>
>>
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)