• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Right-Click EDIT menu. How to change it?

A

Andre Da Costa[ActiveWin]

#2
Right click > Open With > Choose Default Program. See the application you
want to use, and click OK. "Always use the selected program to open this
kind of file" should already be preselected. If you don't see the
application you want to use, click Browse to find the appropriate program.
--
Andre
Blog: http://adacosta.spaces.live.com
My Vista Quickstart Guide:
http://adacosta.spaces.live.com/blog/cns!E8E5CC039D51E3DB!9709.entry
"Paul" <Paul@discussions.microsoft.com> wrote in message
news:66DBE552-5591-48B1-9F77-2708E56FC840@microsoft.com...
> How do I change paint.exe from opening each time I click EDIT from the
> Windows Explorer right-click menu?
 

My Computer

P
#3
I have done that.

I have it set to open jpg and gif files with Windows Gallery.

It does that OK but when I click EDIT it opens paint.exe and I want to use
fireworks.

"Andre Da Costa[ActiveWin]" wrote:

> Right click > Open With > Choose Default Program. See the application you
> want to use, and click OK. "Always use the selected program to open this
> kind of file" should already be preselected. If you don't see the
> application you want to use, click Browse to find the appropriate program.
> --
> Andre
> Blog: http://adacosta.spaces.live.com
> My Vista Quickstart Guide:
> http://adacosta.spaces.live.com/blog/cns!E8E5CC039D51E3DB!9709.entry
> "Paul" <Paul@discussions.microsoft.com> wrote in message
> news:66DBE552-5591-48B1-9F77-2708E56FC840@microsoft.com...
> > How do I change paint.exe from opening each time I click EDIT from the
> > Windows Explorer right-click menu?

>
>
>
 

My Computer

P
#4
Ok. Currently that shows "%systemroot%\system32\mspaint.exe" "%1"

How do i chnage it to open fireworks.exe which is in c:\program
files\macromedia\fireworks 8\fireworks.exe



"." wrote:

> Verb editing was removed from Vista.
>
> You have to dit here in the registry
>
> HKEY_CLASSES_ROOT\Paint.Picture\shell\edit\command
>
> "Paul" <Paul@discussions.microsoft.com> wrote in message
> news:677D71BD-1548-431F-9C72-FD39883D9DF1@microsoft.com...
> >I have done that.
> >
> > I have it set to open jpg and gif files with Windows Gallery.
> >
> > It does that OK but when I click EDIT it opens paint.exe and I want to use
> > fireworks.
> >
> > "Andre Da Costa[ActiveWin]" wrote:
> >
> >> Right click > Open With > Choose Default Program. See the application you
> >> want to use, and click OK. "Always use the selected program to open this
> >> kind of file" should already be preselected. If you don't see the
> >> application you want to use, click Browse to find the appropriate
> >> program.
> >> --
> >> Andre
> >> Blog: http://adacosta.spaces.live.com
> >> My Vista Quickstart Guide:
> >> http://adacosta.spaces.live.com/blog/cns!E8E5CC039D51E3DB!9709.entry
> >> "Paul" <Paul@discussions.microsoft.com> wrote in message
> >> news:66DBE552-5591-48B1-9F77-2708E56FC840@microsoft.com...
> >> > How do I change paint.exe from opening each time I click EDIT from the
> >> > Windows Explorer right-click menu?
> >>
> >>
> >>

>
>
 

My Computer

G

Guest

#5
"c:\program files\macromedia\fireworks 8\fireworks.exe" "%1"

%1 gets replaced with the file you click.

Paul" <Paul@discussions.microsoft.com> wrote in message
news:98D44440-EB07-4A61-B8AC-4CC7075D182C@microsoft.com...
> Ok. Currently that shows "%systemroot%\system32\mspaint.exe" "%1"
>
> How do i chnage it to open fireworks.exe which is in c:\program
> files\macromedia\fireworks 8\fireworks.exe
>
>
>
> "." wrote:
>
>> Verb editing was removed from Vista.
>>
>> You have to dit here in the registry
>>
>> HKEY_CLASSES_ROOT\Paint.Picture\shell\edit\command
>>
>> "Paul" <Paul@discussions.microsoft.com> wrote in message
>> news:677D71BD-1548-431F-9C72-FD39883D9DF1@microsoft.com...
>> >I have done that.
>> >
>> > I have it set to open jpg and gif files with Windows Gallery.
>> >
>> > It does that OK but when I click EDIT it opens paint.exe and I want to
>> > use
>> > fireworks.
>> >
>> > "Andre Da Costa[ActiveWin]" wrote:
>> >
>> >> Right click > Open With > Choose Default Program. See the application
>> >> you
>> >> want to use, and click OK. "Always use the selected program to open
>> >> this
>> >> kind of file" should already be preselected. If you don't see the
>> >> application you want to use, click Browse to find the appropriate
>> >> program.
>> >> --
>> >> Andre
>> >> Blog: http://adacosta.spaces.live.com
>> >> My Vista Quickstart Guide:
>> >> http://adacosta.spaces.live.com/blog/cns!E8E5CC039D51E3DB!9709.entry
>> >> "Paul" <Paul@discussions.microsoft.com> wrote in message
>> >> news:66DBE552-5591-48B1-9F77-2708E56FC840@microsoft.com...
>> >> > How do I change paint.exe from opening each time I click EDIT from
>> >> > the
>> >> > Windows Explorer right-click menu?
>> >>
>> >>
>> >>

>>
>>
 

My Computer

P
#6
just tried that and re-booted but still paint opens all graphic files.

"." wrote:

> "c:\program files\macromedia\fireworks 8\fireworks.exe" "%1"
>
> %1 gets replaced with the file you click.
>
> Paul" <Paul@discussions.microsoft.com> wrote in message
> news:98D44440-EB07-4A61-B8AC-4CC7075D182C@microsoft.com...
> > Ok. Currently that shows "%systemroot%\system32\mspaint.exe" "%1"
> >
> > How do i chnage it to open fireworks.exe which is in c:\program
> > files\macromedia\fireworks 8\fireworks.exe
> >
> >
> >
> > "." wrote:
> >
> >> Verb editing was removed from Vista.
> >>
> >> You have to dit here in the registry
> >>
> >> HKEY_CLASSES_ROOT\Paint.Picture\shell\edit\command
> >>
> >> "Paul" <Paul@discussions.microsoft.com> wrote in message
> >> news:677D71BD-1548-431F-9C72-FD39883D9DF1@microsoft.com...
> >> >I have done that.
> >> >
> >> > I have it set to open jpg and gif files with Windows Gallery.
> >> >
> >> > It does that OK but when I click EDIT it opens paint.exe and I want to
> >> > use
> >> > fireworks.
> >> >
> >> > "Andre Da Costa[ActiveWin]" wrote:
> >> >
> >> >> Right click > Open With > Choose Default Program. See the application
> >> >> you
> >> >> want to use, and click OK. "Always use the selected program to open
> >> >> this
> >> >> kind of file" should already be preselected. If you don't see the
> >> >> application you want to use, click Browse to find the appropriate
> >> >> program.
> >> >> --
> >> >> Andre
> >> >> Blog: http://adacosta.spaces.live.com
> >> >> My Vista Quickstart Guide:
> >> >> http://adacosta.spaces.live.com/blog/cns!E8E5CC039D51E3DB!9709.entry
> >> >> "Paul" <Paul@discussions.microsoft.com> wrote in message
> >> >> news:66DBE552-5591-48B1-9F77-2708E56FC840@microsoft.com...
> >> >> > How do I change paint.exe from opening each time I click EDIT from
> >> >> > the
> >> >> > Windows Explorer right-click menu?
> >> >>
> >> >>
> >> >>
> >>
> >>

>
>
 

My Computer

G

Guest

#7
HKEY_CLASSES_ROOT\.bmp

It default value should be Paint.Picture

"Paul" <Paul@discussions.microsoft.com> wrote in message
news:66DBE552-5591-48B1-9F77-2708E56FC840@microsoft.com...
> How do I change paint.exe from opening each time I click EDIT from the
> Windows Explorer right-click menu?
 

My Computer

P
#8
It is fireworks.bmp

Basically, all I want to do is edit jpg, png and gif in fireworks. At the
moment they edit in Paint by default if i right click and select EDIT.

When i just click on them i want then to open in windows gallery which they
do now.



"." wrote:

> HKEY_CLASSES_ROOT\.bmp
>
> It default value should be Paint.Picture
>
> "Paul" <Paul@discussions.microsoft.com> wrote in message
> news:66DBE552-5591-48B1-9F77-2708E56FC840@microsoft.com...
> > How do I change paint.exe from opening each time I click EDIT from the
> > Windows Explorer right-click menu?

>
>
 

My Computer

G

Guest

#9
Change it to paint.picture
"Paul" <Paul@discussions.microsoft.com> wrote in message
news:3CBFE421-DC25-408F-9CB9-85F5CEBBFF30@microsoft.com...
> It is fireworks.bmp
>
> Basically, all I want to do is edit jpg, png and gif in fireworks. At the
> moment they edit in Paint by default if i right click and select EDIT.
>
> When i just click on them i want then to open in windows gallery which
> they
> do now.
>
>
>
> "." wrote:
>
>> HKEY_CLASSES_ROOT\.bmp
>>
>> It default value should be Paint.Picture
>>
>> "Paul" <Paul@discussions.microsoft.com> wrote in message
>> news:66DBE552-5591-48B1-9F77-2708E56FC840@microsoft.com...
>> > How do I change paint.exe from opening each time I click EDIT from the
>> > Windows Explorer right-click menu?

>>
>>
 

My Computer

P
#10
Sorry. Paint is still the default editor for bmp, jpg, png.

"." wrote:

> Change it to paint.picture
> "Paul" <Paul@discussions.microsoft.com> wrote in message
> news:3CBFE421-DC25-408F-9CB9-85F5CEBBFF30@microsoft.com...
> > It is fireworks.bmp
> >
> > Basically, all I want to do is edit jpg, png and gif in fireworks. At the
> > moment they edit in Paint by default if i right click and select EDIT.
> >
> > When i just click on them i want then to open in windows gallery which
> > they
> > do now.
> >
> >
> >
> > "." wrote:
> >
> >> HKEY_CLASSES_ROOT\.bmp
> >>
> >> It default value should be Paint.Picture
> >>
> >> "Paul" <Paul@discussions.microsoft.com> wrote in message
> >> news:66DBE552-5591-48B1-9F77-2708E56FC840@microsoft.com...
> >> > How do I change paint.exe from opening each time I click EDIT from the
> >> > Windows Explorer right-click menu?
> >>
> >>

>
>
 

My Computer

G

Guest

#11
HKEY_CURRENT_USER\Software\Classes\Paint.Picture\shell\edit\command
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Paint.Picture\shell\edit\command

HKCR is a amalgam of the above two. See what they say it is, also for .bmp.

Also look here.
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SystemFileAssociations\image\shell\edit\command
"Paul" <Paul@discussions.microsoft.com> wrote in message
news:EE15F802-A9D7-4B70-B374-3727AC4D7026@microsoft.com...
> just tried that and re-booted but still paint opens all graphic files.
>
> "." wrote:
>
>> "c:\program files\macromedia\fireworks 8\fireworks.exe" "%1"
>>
>> %1 gets replaced with the file you click.
>>
>> Paul" <Paul@discussions.microsoft.com> wrote in message
>> news:98D44440-EB07-4A61-B8AC-4CC7075D182C@microsoft.com...
>> > Ok. Currently that shows "%systemroot%\system32\mspaint.exe" "%1"
>> >
>> > How do i chnage it to open fireworks.exe which is in c:\program
>> > files\macromedia\fireworks 8\fireworks.exe
>> >
>> >
>> >
>> > "." wrote:
>> >
>> >> Verb editing was removed from Vista.
>> >>
>> >> You have to dit here in the registry
>> >>
>> >> HKEY_CLASSES_ROOT\Paint.Picture\shell\edit\command
>> >>
>> >> "Paul" <Paul@discussions.microsoft.com> wrote in message
>> >> news:677D71BD-1548-431F-9C72-FD39883D9DF1@microsoft.com...
>> >> >I have done that.
>> >> >
>> >> > I have it set to open jpg and gif files with Windows Gallery.
>> >> >
>> >> > It does that OK but when I click EDIT it opens paint.exe and I want
>> >> > to
>> >> > use
>> >> > fireworks.
>> >> >
>> >> > "Andre Da Costa[ActiveWin]" wrote:
>> >> >
>> >> >> Right click > Open With > Choose Default Program. See the
>> >> >> application
>> >> >> you
>> >> >> want to use, and click OK. "Always use the selected program to open
>> >> >> this
>> >> >> kind of file" should already be preselected. If you don't see the
>> >> >> application you want to use, click Browse to find the appropriate
>> >> >> program.
>> >> >> --
>> >> >> Andre
>> >> >> Blog: http://adacosta.spaces.live.com
>> >> >> My Vista Quickstart Guide:
>> >> >> http://adacosta.spaces.live.com/blog/cns!E8E5CC039D51E3DB!9709.entry
>> >> >> "Paul" <Paul@discussions.microsoft.com> wrote in message
>> >> >> news:66DBE552-5591-48B1-9F77-2708E56FC840@microsoft.com...
>> >> >> > How do I change paint.exe from opening each time I click EDIT
>> >> >> > from
>> >> >> > the
>> >> >> > Windows Explorer right-click menu?
>> >> >>
>> >> >>
>> >> >>
>> >>
>> >>

>>
>>
 

My Computer

R

Ramesh, MS-MVP

#12
Perhaps a .bmp file association report would help.

FileExtInfo - http://windowsxp.mvps.org/fileextinfo.htm

--
Regards,

Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
Windows® Troubleshooting http://www.winhelponline.com


"Paul" <Paul@discussions.microsoft.com> wrote in message news:DB6F9470-CD2B-4540-86DE-03EF548EBE7E@microsoft.com...
Sorry. Paint is still the default editor for bmp, jpg, png.

"." wrote:

> Change it to paint.picture
> "Paul" <Paul@discussions.microsoft.com> wrote in message
> news:3CBFE421-DC25-408F-9CB9-85F5CEBBFF30@microsoft.com...
> > It is fireworks.bmp
> >
> > Basically, all I want to do is edit jpg, png and gif in fireworks. At the
> > moment they edit in Paint by default if i right click and select EDIT.
> >
> > When i just click on them i want then to open in windows gallery which
> > they
> > do now.
> >
> >
> >
> > "." wrote:
> >
> >> HKEY_CLASSES_ROOT\.bmp
> >>
> >> It default value should be Paint.Picture
> >>
> >> "Paul" <Paul@discussions.microsoft.com> wrote in message
> >> news:66DBE552-5591-48B1-9F77-2708E56FC840@microsoft.com...
> >> > How do I change paint.exe from opening each time I click EDIT from the
> >> > Windows Explorer right-click menu?
> >>
> >>

>
>
 

My Computer

R

Ramesh, MS-MVP

#13
Paul,

Go to this registry key:

[HKEY_CLASSES_ROOT\Fireworks.bmp\shell]

Rename "Edit with Fireworks" as just "Edit"

"Edit" verb defined under the ProgId takes precedence over SystemFileAssociations...Edit.

Close Regedit.exe


--
Regards,

Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
Windows® Troubleshooting http://www.winhelponline.com


"Paul" <Paul@discussions.microsoft.com> wrote in message news:E539CE3B-EFFB-460F-8780-9AADE07AD64E@microsoft.com...
report below.....But just to confirm what i want to do...

Left click on a gif/jpg/bmp/png file and it opens in windows gallery.
Right click on the same file and if the EDIT option is chosen the file opens
in Fireworks.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
FileExtInfo v1.0 - Log file
10/04/2007 08:38:49

Complete File association information for ---> .BMP
Useful for troubleshooting File association and other problems
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


[HKEY_CLASSES_ROOT\.BMP]
"Content Type"="image/bmp"
@="Fireworks.bmp"
"PerceivedType"="image"

[HKEY_CLASSES_ROOT\.BMP\OpenWithList]

[HKEY_CLASSES_ROOT\.BMP\OpenWithList\MSPaint.exe]
@=""

[HKEY_CLASSES_ROOT\.BMP\OpenWithList\ois.exe]
@=""

[HKEY_CLASSES_ROOT\.BMP\OpenWithProgids]
"Paint.Picture"=""

[HKEY_CLASSES_ROOT\.BMP\PersistentHandler]
@="{098f2470-bae0-11cd-b579-08002b30bfeb}"

[HKEY_CLASSES_ROOT\.BMP\ShellNew]
"ItemName"=hex(2):40,00,25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,6f,00,\
6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,\
00,6d,00,73,00,70,00,61,00,69,00,6e,00,74,00,2e,00,65,00,78,00,65,00,2c,00,\
2d,00,35,00,39,00,34,00,31,00,34,00,00,00
"NullFile"=""


[HKEY_CLASSES_ROOT\Fireworks.bmp]

[HKEY_CLASSES_ROOT\Fireworks.bmp\DefaultIcon]
@="\"C:\\Program Files\\Macromedia\\Fireworks 8\\Fireworks.exe\",1"

[HKEY_CLASSES_ROOT\Fireworks.bmp\shell]

[HKEY_CLASSES_ROOT\Fireworks.bmp\shell\Edit with Fireworks]
@=""

[HKEY_CLASSES_ROOT\Fireworks.bmp\shell\Edit with Fireworks\Command]
@="\"C:\\Program Files\\Macromedia\\Fireworks 8\\Fireworks.exe\" \"%1\""

[HKEY_CLASSES_ROOT\Fireworks.bmp\shell\Open]

[HKEY_CLASSES_ROOT\Fireworks.bmp\shell\Open\command]
@="\"C:\\Program Files\\Macromedia\\Fireworks 8\\Fireworks.exe\" \"%1\""

[HKEY_CLASSES_ROOT\Fireworks.bmp\shell\Preview]

[HKEY_CLASSES_ROOT\Fireworks.bmp\shell\Preview\command]
@="\"C:\\Program Files\\Macromedia\\Fireworks 8\\Fireworks.exe\" \"%1\""


[HKEY_CLASSES_ROOT\SystemFileAssociations\.BMP]
"PreviewDetails"="prop:*System.DateModified;*System.Image.Dimensions;*System.Size;*System.OfflineAvailability;*System.OfflineStatus;*System.DateCreated;*System.SharedWith"
"FullDetails"="prop:System.PropGroup.Image;System.Image.Dimensions;System.Image.HorizontalSize;System.Image.VerticalSize;System.Image.BitDepth;System.PropGroup.FileSystem;System.ItemNameDisplay;System.ItemType;System.ItemFolderPathDisplay;System.DateCreated;System.DateModified;System.Size;System.FileAttributes;System.OfflineAvailability;System.OfflineStatus;System.SharedWith;System.FileOwner;System.ComputerName"
"InfoTip"="prop:System.ItemType;*System.DateModified;*System.Image.Dimensions;*System.Size"
"ExtendedTileInfo"="prop:System.ItemType;*System.DateModified;*System.Image.Dimensions"

[HKEY_CLASSES_ROOT\SystemFileAssociations\.BMP\OpenWithList]

[HKEY_CLASSES_ROOT\SystemFileAssociations\.BMP\OpenWithList\PhotoViewer.dll]

[HKEY_CLASSES_ROOT\SystemFileAssociations\.BMP\ShellEx]

[HKEY_CLASSES_ROOT\SystemFileAssociations\.BMP\ShellEx\ContextMenuHandlers]

[HKEY_CLASSES_ROOT\SystemFileAssociations\.BMP\ShellEx\ContextMenuHandlers\ShellImagePreview]
@="{FFE2A43C-56B9-4bf5-9A79-CC6D4285608A}"


[HKEY_CLASSES_ROOT\SystemFileAssociations\image]
"Treatment"=dword:00000002
"TypeOverlay"=""

[HKEY_CLASSES_ROOT\SystemFileAssociations\image\OpenWithList]

[HKEY_CLASSES_ROOT\SystemFileAssociations\image\OpenWithList\MSPaint.exe]
@=""

[HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell]

[HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\edit]

[HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\edit\command]
@=hex(2):22,00,25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,6f,00,6f,00,74,\
00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,6d,00,\
73,00,70,00,61,00,69,00,6e,00,74,00,2e,00,65,00,78,00,65,00,22,00,20,00,22,\
00,25,00,31,00,22,00,00,00

[HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\print]

[HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\print\command]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,72,00,75,00,\
6e,00,64,00,6c,00,6c,00,33,00,32,00,2e,00,65,00,78,00,65,00,20,00,22,00,25,\
00,50,00,72,00,6f,00,67,00,72,00,61,00,6d,00,46,00,69,00,6c,00,65,00,73,00,\
25,00,5c,00,57,00,69,00,6e,00,64,00,6f,00,77,00,73,00,20,00,50,00,68,00,6f,\
00,74,00,6f,00,20,00,47,00,61,00,6c,00,6c,00,65,00,72,00,79,00,5c,00,50,00,\
68,00,6f,00,74,00,6f,00,56,00,69,00,65,00,77,00,65,00,72,00,2e,00,64,00,6c,\
00,6c,00,22,00,2c,00,20,00,49,00,6d,00,61,00,67,00,65,00,56,00,69,00,65,00,\
77,00,5f,00,46,00,75,00,6c,00,6c,00,73,00,63,00,72,00,65,00,65,00,6e,00,20,\
00,25,00,31,00,00,00

[HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\print\DropTarget]
"Clsid"="{60fd46de-f830-4894-a628-6fa81bc0190d}"

[HKEY_CLASSES_ROOT\SystemFileAssociations\image\ShellEx]

[HKEY_CLASSES_ROOT\SystemFileAssociations\image\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}]
@="{3F30C968-480A-4C6C-862D-EFC0897BB84B}"

[HKEY_CLASSES_ROOT\SystemFileAssociations\image\ShellEx\{e357fccd-a995-4576-b01f-234630154e96}]
@="{C7657C4A-9F68-40fa-A4DF-96BC08EB3551}"


[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.BMP]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.BMP\OpenWithList]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.BMP\OpenWithProgids]
"Paint.Picture"=hex(0):
"Fireworks.bmp"=hex(0):

"Ramesh, MS-MVP" wrote:

> Perhaps a .bmp file association report would help.
>
> FileExtInfo - http://windowsxp.mvps.org/fileextinfo.htm
>
> --
> Regards,
>
> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
> Windows® Troubleshooting http://www.winhelponline.com
>
>
> "Paul" <Paul@discussions.microsoft.com> wrote in message news:DB6F9470-CD2B-4540-86DE-03EF548EBE7E@microsoft.com...
> Sorry. Paint is still the default editor for bmp, jpg, png.
>
> "." wrote:
>
> > Change it to paint.picture
> > "Paul" <Paul@discussions.microsoft.com> wrote in message
> > news:3CBFE421-DC25-408F-9CB9-85F5CEBBFF30@microsoft.com...
> > > It is fireworks.bmp
> > >
> > > Basically, all I want to do is edit jpg, png and gif in fireworks. At the
> > > moment they edit in Paint by default if i right click and select EDIT.
> > >
> > > When i just click on them i want then to open in windows gallery which
> > > they
> > > do now.
> > >
> > >
> > >
> > > "." wrote:
> > >
> > >> HKEY_CLASSES_ROOT\.bmp
> > >>
> > >> It default value should be Paint.Picture
> > >>
> > >> "Paul" <Paul@discussions.microsoft.com> wrote in message
> > >> news:66DBE552-5591-48B1-9F77-2708E56FC840@microsoft.com...
> > >> > How do I change paint.exe from opening each time I click EDIT from the
> > >> > Windows Explorer right-click menu?
> > >>
> > >>

> >
> >

>
 

My Computer

R

Ramesh, MS-MVP

#14
Paul,

It's better to go the other way, as you want "open" to launch Photo Gallery. Do the changes that David mentioned (about Paint.Picture). To reiterate his comments:

Click Start, type Regedit.exe and go to:

HKEY_CLASSES_ROOT\.bmp

Double-click (default) and set it to Paint.Picture
(The log says you did not perform the above step.)

If the above is done correctly, then go to this location:

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Paint.Picture\shell\edit\command

Alter the (default) and point it to Fireworks executable (pass %1 as well).

--
Regards,

Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
Windows® Troubleshooting http://www.winhelponline.com


"Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message news:OPdYct0eHHA.4772@TK2MSFTNGP05.phx.gbl...
Paul,

Go to this registry key:

[HKEY_CLASSES_ROOT\Fireworks.bmp\shell]

Rename "Edit with Fireworks" as just "Edit"

"Edit" verb defined under the ProgId takes precedence over SystemFileAssociations...Edit.

Close Regedit.exe


--
Regards,

Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
Windows® Troubleshooting http://www.winhelponline.com
 

My Computer

P
#15
hi

I have now done everything you say and re-booted.

BMP's now open in Gallery and edit in Fireworks. Great....but

GIF/PNG/JPG open in Gallery (great) but still edit in Paint (bad).

How can I make thse file types edit in Fireworks?

"Ramesh, MS-MVP" wrote:

> Paul,
>
> It's better to go the other way, as you want "open" to launch Photo Gallery. Do the changes that David mentioned (about Paint.Picture). To reiterate his comments:
>
> Click Start, type Regedit.exe and go to:
>
> HKEY_CLASSES_ROOT\.bmp
>
> Double-click (default) and set it to Paint.Picture
> (The log says you did not perform the above step.)
>
> If the above is done correctly, then go to this location:
>
> HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Paint.Picture\shell\edit\command
>
> Alter the (default) and point it to Fireworks executable (pass %1 as well).
>
> --
> Regards,
>
> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
> Windows® Troubleshooting http://www.winhelponline.com
>
>
> "Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message news:OPdYct0eHHA.4772@TK2MSFTNGP05.phx.gbl...
> Paul,
>
> Go to this registry key:
>
> [HKEY_CLASSES_ROOT\Fireworks.bmp\shell]
>
> Rename "Edit with Fireworks" as just "Edit"
>
> "Edit" verb defined under the ProgId takes precedence over SystemFileAssociations...Edit.
>
> Close Regedit.exe
>
>
> --
> Regards,
>
> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
> Windows® Troubleshooting http://www.winhelponline.com
>
>
>
 

My Computer

C

Cal Bear '66

#16
Why don't you just use the Open With right click option?
So much easier to set up.
Choose Default Program..., unclick always use this program and
once you do this fireworks will show up on the list of programs.

"Paul" <Paul@discussions.microsoft.com> wrote in message news:26090AA0-AC8F-4199-8244-8E45537FA2E2@microsoft.com...
> hi
>
> I have now done everything you say and re-booted.
>
> BMP's now open in Gallery and edit in Fireworks. Great....but
>
> GIF/PNG/JPG open in Gallery (great) but still edit in Paint (bad).
>
> How can I make thse file types edit in Fireworks?
>
> "Ramesh, MS-MVP" wrote:
>
>> Paul,
>>
>> It's better to go the other way, as you want "open" to launch Photo Gallery. Do the changes that David mentioned (about Paint.Picture). To reiterate his comments:
>>
>> Click Start, type Regedit.exe and go to:
>>
>> HKEY_CLASSES_ROOT\.bmp
>>
>> Double-click (default) and set it to Paint.Picture
>> (The log says you did not perform the above step.)
>>
>> If the above is done correctly, then go to this location:
>>
>> HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Paint.Picture\shell\edit\command
>>
>> Alter the (default) and point it to Fireworks executable (pass %1 as well).
>>
>> --
>> Regards,
>>
>> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
>> Windows® Troubleshooting http://www.winhelponline.com
>>
>>
>> "Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message news:OPdYct0eHHA.4772@TK2MSFTNGP05.phx.gbl...
>> Paul,
>>
>> Go to this registry key:
>>
>> [HKEY_CLASSES_ROOT\Fireworks.bmp\shell]
>>
>> Rename "Edit with Fireworks" as just "Edit"
>>
>> "Edit" verb defined under the ProgId takes precedence over SystemFileAssociations...Edit.
>>
>> Close Regedit.exe
>>
>>
>> --
>> Regards,
>>
>> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
>> Windows® Troubleshooting http://www.winhelponline.com
>>
>>
>>
 

My Computer

P
#17
Just tried that and if I do that, as soon as I click on the file Fireworks
opens the file instead of gallery.

I am amased how fiddly this is to do. All I want to do is this....

Click on a graphics file and it opens in Gallery.
Right click on the file and select EDIT and it edits in Fireworks.




"Cal Bear '66" wrote:

> Why don't you just use the Open With right click option?
> So much easier to set up.
> Choose Default Program..., unclick always use this program and
> once you do this fireworks will show up on the list of programs.
>
> "Paul" <Paul@discussions.microsoft.com> wrote in message
> news:26090AA0-AC8F-4199-8244-8E45537FA2E2@microsoft.com...
> > hi
> >
> > I have now done everything you say and re-booted.
> >
> > BMP's now open in Gallery and edit in Fireworks. Great....but
> >
> > GIF/PNG/JPG open in Gallery (great) but still edit in Paint (bad).
> >
> > How can I make thse file types edit in Fireworks?
> >
> > "Ramesh, MS-MVP" wrote:
> >
> >> Paul,
> >>
> >> It's better to go the other way, as you want "open" to launch Photo

> Gallery. Do the changes that David mentioned (about Paint.Picture). To
> reiterate his comments:
> >>
> >> Click Start, type Regedit.exe and go to:
> >>
> >> HKEY_CLASSES_ROOT\.bmp
> >>
> >> Double-click (default) and set it to Paint.Picture
> >> (The log says you did not perform the above step.)
> >>
> >> If the above is done correctly, then go to this location:
> >>
> >> HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Paint.Picture\shell\edit\command
> >>
> >> Alter the (default) and point it to Fireworks executable (pass %1 as

> well).
> >>
> >> --
> >> Regards,
> >>
> >> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
> >> Windows® Troubleshooting http://www.winhelponline.com
> >>
> >>
> >> "Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message

> news:OPdYct0eHHA.4772@TK2MSFTNGP05.phx.gbl...
> >> Paul,
> >>
> >> Go to this registry key:
> >>
> >> [HKEY_CLASSES_ROOT\Fireworks.bmp\shell]
> >>
> >> Rename "Edit with Fireworks" as just "Edit"
> >>
> >> "Edit" verb defined under the ProgId takes precedence over

> SystemFileAssociations...Edit.
> >>
> >> Close Regedit.exe
> >>
> >>
> >> --
> >> Regards,
> >>
> >> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
> >> Windows® Troubleshooting http://www.winhelponline.com
> >>
> >>
> >>

>
 

My Computer

C

Cal Bear '66

#18
When you chose Fireworks, did you UNTICK the always use this program check box?

If you untick the box, and open the file in Fireworks once, then an icon to open that type
of file will appear in the list when you click Open With, but the default association will
not be changed and when you double click on a file of that type it will open in the
original program.


"Paul" <Paul@discussions.microsoft.com> wrote in message news:2BEDEDED-AF80-43C8-8529-DF9D4F5F6709@microsoft.com...
> Just tried that and if I do that, as soon as I click on the file Fireworks
> opens the file instead of gallery.
>
> I am amased how fiddly this is to do. All I want to do is this....
>
> Click on a graphics file and it opens in Gallery.
> Right click on the file and select EDIT and it edits in Fireworks.
>
>
>
>
> "Cal Bear '66" wrote:
>
>> Why don't you just use the Open With right click option?
>> So much easier to set up.
>> Choose Default Program..., unclick always use this program and
>> once you do this fireworks will show up on the list of programs.
>>
>> "Paul" <Paul@discussions.microsoft.com> wrote in message
>> news:26090AA0-AC8F-4199-8244-8E45537FA2E2@microsoft.com...
>> > hi
>> >
>> > I have now done everything you say and re-booted.
>> >
>> > BMP's now open in Gallery and edit in Fireworks. Great....but
>> >
>> > GIF/PNG/JPG open in Gallery (great) but still edit in Paint (bad).
>> >
>> > How can I make thse file types edit in Fireworks?
>> >
>> > "Ramesh, MS-MVP" wrote:
>> >
>> >> Paul,
>> >>
>> >> It's better to go the other way, as you want "open" to launch Photo

>> Gallery. Do the changes that David mentioned (about Paint.Picture). To
>> reiterate his comments:
>> >>
>> >> Click Start, type Regedit.exe and go to:
>> >>
>> >> HKEY_CLASSES_ROOT\.bmp
>> >>
>> >> Double-click (default) and set it to Paint.Picture
>> >> (The log says you did not perform the above step.)
>> >>
>> >> If the above is done correctly, then go to this location:
>> >>
>> >> HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Paint.Picture\shell\edit\command
>> >>
>> >> Alter the (default) and point it to Fireworks executable (pass %1 as

>> well).
>> >>
>> >> --
>> >> Regards,
>> >>
>> >> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
>> >> Windows® Troubleshooting http://www.winhelponline.com
>> >>
>> >>
>> >> "Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message

>> news:OPdYct0eHHA.4772@TK2MSFTNGP05.phx.gbl...
>> >> Paul,
>> >>
>> >> Go to this registry key:
>> >>
>> >> [HKEY_CLASSES_ROOT\Fireworks.bmp\shell]
>> >>
>> >> Rename "Edit with Fireworks" as just "Edit"
>> >>
>> >> "Edit" verb defined under the ProgId takes precedence over

>> SystemFileAssociations...Edit.
>> >>
>> >> Close Regedit.exe
>> >>
>> >>
>> >> --
>> >> Regards,
>> >>
>> >> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
>> >> Windows® Troubleshooting http://www.winhelponline.com
>> >>
>> >>
>> >>

>>
 

My Computer

A

Adam Albright

#19
On Fri, 13 Apr 2007 10:06:03 -0700, Paul
<Paul@discussions.microsoft.com> wrote:

>Just tried that and if I do that, as soon as I click on the file Fireworks
>opens the file instead of gallery.
>
>I am amased how fiddly this is to do. All I want to do is this....
>Click on a graphics file and it opens in Gallery.
>Right click on the file and select EDIT and it edits in Fireworks.


Vista is still badly broken with several right click options. For
example I can go to a folder where I have nothing but video files. For
some, if I right click, I have the option to "open with" and I can
pick any application on my system.

Others, I only get presented with a short list and the mindnumbingly
stupid choice of 'choose default program'. Well damn it, I don't want
to change my default or pick a new one, I simply want to be able to
select WHICH application I want to use NOW, this time, for THIS file,
not be limted by what Vista sometimes says I can use.

Example, I have 10 different applications that can edit a MPEG file.
Often Vista only shows the last five applications I used for editing a
MEPG, then demand I pick one of those as a default totally preventing
me from seeing the other applications from this context menu unless I
first make whatever I pick the default which I surely don't want to
change.

Stupid, but typical Microsoft dumb bug riddled programming. That's
what happens when the OS is so bloated is is comprised of millions and
millions of lines of untested code.
 

My Computer

P
#20
Thanks for stickling with me here.....

I have done that and it works fine for GIFs but JPG open in Gallery and now
edit in Gallery. Fireworks does not open at all and it has made no
difference to PNG. they open and edit in Paint.

How easy would it be to have like XP did and option to open and an option to
edit. Another thing Vista bumbles along with :(

"Cal Bear '66" wrote:

> When you chose Fireworks, did you UNTICK the always use this program check
> box?
>
> If you untick the box, and open the file in Fireworks once, then an icon
> to open that type
> of file will appear in the list when you click Open With, but the default
> association will
> not be changed and when you double click on a file of that type it will
> open in the
> original program.
>
>
> "Paul" <Paul@discussions.microsoft.com> wrote in message
> news:2BEDEDED-AF80-43C8-8529-DF9D4F5F6709@microsoft.com...
> > Just tried that and if I do that, as soon as I click on the file

> Fireworks
> > opens the file instead of gallery.
> >
> > I am amased how fiddly this is to do. All I want to do is this....
> >
> > Click on a graphics file and it opens in Gallery.
> > Right click on the file and select EDIT and it edits in Fireworks.
> >
> >
> >
> >
> > "Cal Bear '66" wrote:
> >
> >> Why don't you just use the Open With right click option?
> >> So much easier to set up.
> >> Choose Default Program..., unclick always use this program and
> >> once you do this fireworks will show up on the list of programs.
> >>
> >> "Paul" <Paul@discussions.microsoft.com> wrote in message
> >> news:26090AA0-AC8F-4199-8244-8E45537FA2E2@microsoft.com...
> >> > hi
> >> >
> >> > I have now done everything you say and re-booted.
> >> >
> >> > BMP's now open in Gallery and edit in Fireworks. Great....but
> >> >
> >> > GIF/PNG/JPG open in Gallery (great) but still edit in Paint (bad).
> >> >
> >> > How can I make thse file types edit in Fireworks?
> >> >
> >> > "Ramesh, MS-MVP" wrote:
> >> >
> >> >> Paul,
> >> >>
> >> >> It's better to go the other way, as you want "open" to launch Photo
> >> Gallery. Do the changes that David mentioned (about Paint.Picture). To
> >> reiterate his comments:
> >> >>
> >> >> Click Start, type Regedit.exe and go to:
> >> >>
> >> >> HKEY_CLASSES_ROOT\.bmp
> >> >>
> >> >> Double-click (default) and set it to Paint.Picture
> >> >> (The log says you did not perform the above step.)
> >> >>
> >> >> If the above is done correctly, then go to this location:
> >> >>
> >> >> HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Paint.Picture\shell\edit\command
> >> >>
> >> >> Alter the (default) and point it to Fireworks executable (pass %1 as
> >> well).
> >> >>
> >> >> --
> >> >> Regards,
> >> >>
> >> >> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
> >> >> Windows® Troubleshooting http://www.winhelponline.com
> >> >>
> >> >>
> >> >> "Ramesh, MS-MVP" <ramesh@XOX.mvps.org> wrote in message
> >> news:OPdYct0eHHA.4772@TK2MSFTNGP05.phx.gbl...
> >> >> Paul,
> >> >>
> >> >> Go to this registry key:
> >> >>
> >> >> [HKEY_CLASSES_ROOT\Fireworks.bmp\shell]
> >> >>
> >> >> Rename "Edit with Fireworks" as just "Edit"
> >> >>
> >> >> "Edit" verb defined under the ProgId takes precedence over
> >> SystemFileAssociations...Edit.
> >> >>
> >> >> Close Regedit.exe
> >> >>
> >> >>
> >> >> --
> >> >> Regards,
> >> >>
> >> >> Ramesh Srinivasan, Microsoft MVP [Windows Shell/User]
> >> >> Windows® Troubleshooting http://www.winhelponline.com
> >> >>
> >> >>
> >> >>
> >>

>
 

My Computer