• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Running a Windows Service with Interactive Mode in Vista ?

P

Polaris

#1
Hi Experts:

I have an existing Windows service which is configured to run in
"Interactive with Desktop" mode; it has been working fine on older Windows
platform but not in Vista. Under Vista, the application runs all right but
its UIs are not shown.

How to make it work in Vista so that the UI shows up the same way as in XP?
Any help link is appreciated.

Thanks in advance!
Polaris
 

My Computer

A

Alexander Suhovey

#2
"Polaris" <etpolaris@hotmail.com> wrote in message
news:%23JJsXINRHHA.1016@TK2MSFTNGP04.phx.gbl...
> I have an existing Windows service which is configured to run in
> "Interactive with Desktop" mode; it has been working fine on older Windows
> platform but not in Vista. Under Vista, the application runs all right but
> its UIs are not shown.
>
> How to make it work in Vista so that the UI shows up the same way as in
> XP? Any help link is appreciated.
>


Polaris,

Session 0 isolation in Vista prevents services from interacting with user
sessions in the way it was possible in previous versions of Windows. For
more information refer to documents below:

Impact of Session 0 Isolation on Services and Drivers in Windows Vista
http://www.microsoft.com/whdc/system/vista/services.mspx

Session 0 Changes and Vista Compatibility for Services running as
Interactive with Desktop
http://channel9.msdn.com/ShowPost.aspx?PostID=263925

--
Alexander Suhovey
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)