• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

sbs2003,exchange OWA and iphone

O

ok103

#1
hello all
I have a problem and i really need your help , i'm trying to sync my
iphone with my exchange and i have a lot of problems.
first i'll say that i have an iphone 3G F/M 3.0
i have anSBS2003 with Exchange and the OWA is working when i log on
to:
http://servername/exchange and http://serverip/exchange -from external
computer
i know that port 443 is open but i can't use ssl beacuse i don't have a
certificate . (can't log on to https://servername/exchange or
https://sedrverip/exchange) for external computer

my questions are:
1. can i make a self certificte on the sbs2003 and will it harm in
anyway my other servers on my network ( FTP, TERMINAL )?
2.i know that the iphone don't need ssl to work .. why doesn't it work
as is .
3. do i need to change something in my IIS or EXCHANGE?

by the way :
i can't log on to : http://owa.servername.com or mail.severname.com or
oma.servername.com --just the 2 i wrote before ...

please help me out
and please be open-minded with me i have a lot questions about this
problem with the exchange and iphone

thanks a lot
ok103


--
ok103
------------------------------------------------------------------------
ok103's Profile: http://forums.techarena.in/members/167717.htm
View this thread: http://forums.techarena.in/small-business-server/1286443.htm

http://forums.techarena.in
 

My Computer

O

ok103

#2
ok ..
now i made a self certificate and i can see my exchange when i log on
to :
https://servername/exchange and https://serverip/exchange
but i can't sync my iphone yet .... from external ( meaning from the
iphone that gets ip from my home network ...

and anoter question :
when i have wireless network on my iphone -from my network at the
office... ( from lan ) will i be able to get my e mails?
what kind of setting do i need to define to be able to get my mail from
any where ( LAN and WAN )

i hope you can help me out ...
thanks a lot
ok103


--
ok103
------------------------------------------------------------------------
ok103's Profile: http://forums.techarena.in/members/167717.htm
View this thread: http://forums.techarena.in/small-business-server/1286443.htm

http://forums.techarena.in
 

My Computer

A

Ace Fekay [MCT]

#3
"ok103" <ok103.43urbb@newsgroup> wrote in message
news:ok103.43urbb@newsgroup

>
> ok ..
> now i made a self certificate and i can see my exchange when i log on
> to :
> https://servername/exchange and https://serverip/exchange
> but i can't sync my iphone yet .... from external ( meaning from the
> iphone that gets ip from my home network ...
>
> and anoter question :
> when i have wireless network on my iphone -from my network at the
> office... ( from lan ) will i be able to get my e mails?
> what kind of setting do i need to define to be able to get my mail from
> any where ( LAN and WAN )
>
> i hope you can help me out ...
> thanks a lot
> ok103

From external, can you you connect to
https://owa.yourdomainName.com/exchange?

Earlier you stated you cannot log in to http://owa.servername.com. The name
"servername" makes me think you do not have an external domain name. Do you
have an external domain name with a record called "owa" created that points
to your firewall's WAN IP? Or was this just a typo?

Also, go to the following Exchange test site to test connectivity. It's from
Microsoft and was designed to help folks test Exchange.

Microsoft Exchange Server Remote Connectivity Analyzer
https://www.testexchangeconnectivity.com/

--
Ace

This posting is provided "AS-IS" with no warranties or guarantees and
confers no rights.

Please reply back to the newsgroup or forum for collaboration benefit among
responding engineers, and to help others benefit from your resolution.

Ace Fekay, MCT, MCITP EA, MCTS Windows 2008 & Exchange 2007, MCSE & MCSA
2003/2000, MCSA Messaging 2003
Microsoft Certified Trainer

For urgent issues, please contact Microsoft PSS directly. Please check
http://support.microsoft.com for regional support phone numbers.
 

My Computer

O

ok103

#4
hey there ...
i don't understand ... what do mean by :

Earlier you stated you cannot log in to http://owa.servername.com. The
name
"servername" makes me think you do not have an external domain name. Do
you
have an external domain name with a record called "owa" created that
points
to your firewall's WAN IP?

i can't log on to http://owa.servername.com --- i don't have the "owa"
when i try to log on to my OWA ( http://SeverName/exchange or
https:/servername/echange ... and http:/serverIP/exchange
https://serverIP/exchange )
i cheacked the A records .. and added that servername = server ip but i
didn't call it under owa.servername/exchange ...

i know that SSL is working , and i made a self certificate... and when
i try to work on my OWA at home it's working great . bt when i put it
onthe iphone i can't get mails from the server ... ( i got a masage that
the certificate id not trusted or something like that ... and press
acsept ..

please help me ...
by the way i have firewall called Fortigate .. where can i see the logs
there to see if the iphone is trying to accsess the exchange ....

i'm sorry about my english and thati'm bugging about this iphone and
exchange but it's driving me crazy !!

can you tell me what i need to have in my DNS and my A records - maybe
the problem is there.....

thanks for all your help...
i really appreciate the time and your effort for all your help ...
ok103


--
ok103
------------------------------------------------------------------------
ok103's Profile: http://forums.techarena.in/members/167717.htm
View this thread: http://forums.techarena.in/small-business-server/1286443.htm

http://forums.techarena.in
 

My Computer

A

Ace Fekay [MCT]

#5
"ok103" <ok103.43vgba@newsgroup> wrote in message
news:ok103.43vgba@newsgroup

>
> hey there ...
> i don't understand ... what do mean by :
>
> Earlier you stated you cannot log in to http://owa.servername.com. The
> name
> "servername" makes me think you do not have an external domain name. Do
> you
> have an external domain name with a record called "owa" created that
> points
> to your firewall's WAN IP?
>
> i can't log on to http://owa.servername.com --- i don't have the "owa"
> when i try to log on to my OWA ( http://SeverName/exchange or
> https:/servername/echange ... and http:/serverIP/exchange
> https://serverIP/exchange )
> i cheacked the A records .. and added that servername = server ip but i
> didn't call it under owa.servername/exchange ...
>
> i know that SSL is working , and i made a self certificate... and when
> i try to work on my OWA at home it's working great . bt when i put it
> onthe iphone i can't get mails from the server ... ( i got a masage that
> the certificate id not trusted or something like that ... and press
> acsept ..
>
> please help me ...
> by the way i have firewall called Fortigate .. where can i see the logs
> there to see if the iphone is trying to accsess the exchange ....
>
> i'm sorry about my english and thati'm bugging about this iphone and
> exchange but it's driving me crazy !!
>
> can you tell me what i need to have in my DNS and my A records - maybe
> the problem is there.....
>
> thanks for all your help...
> i really appreciate the time and your effort for all your help ...
> ok103

1. To better help you, we need to have you run some tests. Have you tried
the Exchange Connectivity Test site as I had suggested in my previous post?
I didn't see in your response if you had tried it or not. Please run the
test. Once again, it is at the following link:

Microsoft Exchange Server Remote Connectivity Analyzer
https://www.testexchangeconnectivity.com/

2. Follow Russ' step-by-step instructions to setup the iPhone.

3. To access OWA with SBS 2003\Exchange 2003, you need to access it by the
following format:
http://owa.YourPublicDomainName.com/exchange

4. Do you have a public domain name setup, such as YourPublicDomainName.com?
It may be easier for us to help if you can please let us know the actual
name that you connect to your OWA site from the Internet.

Ace
 

My Computer

O

ok103

#6
hey there :
this is what i get when i try to test exchange active sync

Testing Exchange ActiveSync
Exchange ActiveSync test Failed
Test Steps
Attempting AutoDiscover and Exchange ActiveSync Test (if requested)
Failed to test AutoDiscover for Exchange ActiveSync
Test Steps
Attempting each method of contacting the AutoDiscover Service
Failed to contact the AutoDiscover service successfully by any method
Test Steps
Attempting to test potential AutoDiscover URL
https://rrsystems.co.il/AutoDiscover/AutoDiscover.xml
Failed testing this potential AutoDiscover URL
Test Steps
Attempting to resolve the host name rrsystems.co.il in DNS.
Host successfully resolved
Additional Details
IP(s) returned: 212.179.114.51

Testing TCP Port 443 on host rrsystems.co.il to ensure it is listening
and open.
The port was opened successfully.
Testing SSL Certificate for validity.
The SSL Certificate failed one or more certificate validation checks.
Tell me more about this issue and how to resolve it
Additional Details
A network error occurred while communicating with remote host
Exception Details:
Message: Authentication failed because the remote party has closed the
transport stream.
Type: System.IO.IOException
Stack Trace:
at System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32
readBytes, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer,
AsyncProtocolRequest asyncRequest)
at
System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken
message, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32
count, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ForceAuthentication(Boolean
receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult
lazyResult)
at System.Net.Security.SslStream.AuthenticateAsClient(String
targetHost, X509CertificateCollection clientCertificates, SslProtocols
enabledSslProtocols, Boolean checkCertificateRevocation)
at System.Net.Security.SslStream.AuthenticateAsClient(String
targetHost)
at
Microsoft.Exchange.Tools.ExRca.Tests.SSLCertificateTest.PerformTestReally()




Attempting to test potential AutoDiscover URL
https://autodiscover.rrsystems.co.il/AutoDiscover/AutoDiscover.xml
Failed testing this potential AutoDiscover URL
Test Steps
Attempting to resolve the host name autodiscover.rrsystems.co.il in
DNS.
The Host could not be resolved.
Tell me more about this issue and how to resolve it
Additional Details
Host autodiscover.rrsystems.co.il could not be resolved in DNS
Exception Details:
Message: No such host is known
Type: System.Net.Sockets.SocketException
Stack Trace:
at System.Net.Dns.GetAddrInfo(String name)
at System.Net.Dns.InternalGetHostByName(String hostName, Boolean
includeIPv6)
at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
at
Microsoft.Exchange.Tools.ExRca.Tests.ResolveHostTest.PerformTestReally()




Attempting to contact the AutoDiscover service using the HTTP redirect
method.
Failed to contact AutoDiscover using the HTTP Redirect method
Test Steps
Attempting to resolve the host name autodiscover.rrsystems.co.il in
DNS.
The Host could not be resolved.
Tell me more about this issue and how to resolve it
Additional Details
Host autodiscover.rrsystems.co.il could not be resolved in DNS
Exception Details:
Message: No such host is known
Type: System.Net.Sockets.SocketException
Stack Trace:
at System.Net.Dns.GetAddrInfo(String name)
at System.Net.Dns.InternalGetHostByName(String hostName, Boolean
includeIPv6)
at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
at
Microsoft.Exchange.Tools.ExRca.Tests.ResolveHostTest.PerformTestReally()




Attempting to contact the AutoDiscover service using the DNS SRV
redirect method.
Failed to contact AutoDiscover using the DNS SRV redirect method.
Test Steps
Attempting to locate SRV record _autodiscover._tcp.rrsystems.co.il in
DNS.
Failed to find AutoDiscover SRV record in DNS.
Tell me more about this issue and how to resolve it

ok103
p.s i'll post more test in a few min


--
ok103
------------------------------------------------------------------------
ok103's Profile: http://forums.techarena.in/members/167717.htm
View this thread: http://forums.techarena.in/small-business-server/1286443.htm

http://forums.techarena.in
 

My Computer

O

ok103

#7
hey there : Testing RPC/HTTP connectivity BY THE WAY is SBS2003 does
it have autodoscover???

Testing RPC/HTTP connectivity
RPC/HTTP test failed
Test Steps
Attempting to test Autodiscover for amir@newsgroup
Testing Autodiscover failed
Test Steps
Attempting each method of contacting the AutoDiscover Service
Failed to contact the AutoDiscover service successfully by any method
Test Steps
Attempting to test potential AutoDiscover URL
https://rrsystems.co.il/AutoDiscover/AutoDiscover.xml
Failed testing this potential AutoDiscover URL
Test Steps
Attempting to resolve the host name rrsystems.co.il in DNS.
Host successfully resolved
Additional Details
IP(s) returned: 212.179.114.51

Testing TCP Port 443 on host rrsystems.co.il to ensure it is listening
and open.
The port was opened successfully.
Testing SSL Certificate for validity.
The SSL Certificate failed one or more certificate validation checks.
Tell me more about this issue and how to resolve it
Additional Details
A network error occurred while communicating with remote host
Exception Details:
Message: Authentication failed because the remote party has closed the
transport stream.
Type: System.IO.IOException
Stack Trace:
at System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32
readBytes, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer,
AsyncProtocolRequest asyncRequest)
at
System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken
message, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32
count, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ForceAuthentication(Boolean
receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult
lazyResult)
at System.Net.Security.SslStream.AuthenticateAsClient(String
targetHost, X509CertificateCollection clientCertificates, SslProtocols
enabledSslProtocols, Boolean checkCertificateRevocation)
at System.Net.Security.SslStream.AuthenticateAsClient(String
targetHost)
at
Microsoft.Exchange.Tools.ExRca.Tests.SSLCertificateTest.PerformTestReally()




Attempting to test potential AutoDiscover URL
https://autodiscover.rrsystems.co.il/AutoDiscover/AutoDiscover.xml
Failed testing this potential AutoDiscover URL
Test Steps
Attempting to resolve the host name autodiscover.rrsystems.co.il in
DNS.
The Host could not be resolved.
Tell me more about this issue and how to resolve it
Additional Details
Host autodiscover.rrsystems.co.il could not be resolved in DNS
Exception Details:
Message: No such host is known
Type: System.Net.Sockets.SocketException
Stack Trace:
at System.Net.Dns.GetAddrInfo(String name)
at System.Net.Dns.InternalGetHostByName(String hostName, Boolean
includeIPv6)
at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
at
Microsoft.Exchange.Tools.ExRca.Tests.ResolveHostTest.PerformTestReally()




Attempting to contact the AutoDiscover service using the HTTP redirect
method.
Failed to contact AutoDiscover using the HTTP Redirect method
Test Steps
Attempting to resolve the host name autodiscover.rrsystems.co.il in
DNS.
The Host could not be resolved.
Tell me more about this issue and how to resolve it
Additional Details
Host autodiscover.rrsystems.co.il could not be resolved in DNS
Exception Details:
Message: No such host is known
Type: System.Net.Sockets.SocketException
Stack Trace:
at System.Net.Dns.GetAddrInfo(String name)
at System.Net.Dns.InternalGetHostByName(String hostName, Boolean
includeIPv6)
at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
at
Microsoft.Exchange.Tools.ExRca.Tests.ResolveHostTest.PerformTestReally()




Attempting to contact the AutoDiscover service using the DNS SRV
redirect method.
Failed to contact AutoDiscover using the DNS SRV redirect method.
Test Steps
Attempting to locate SRV record _autodiscover._tcp.rrsystems.co.il in
DNS.
Failed to find AutoDiscover SRV record in DNS.
Tell me more about this issue and how to resolve it


--
ok103
------------------------------------------------------------------------
ok103's Profile: http://forums.techarena.in/members/167717.htm
View this thread: http://forums.techarena.in/small-business-server/1286443.htm

http://forums.techarena.in
 

My Computer

O

ok103

#8
hey there :

It almost appears that you are using the POP3 connector to your SBS
-I'm using POP3 connector!
or using a gateway to filter your emailand i think that my isp is
filtering my mail.

What is the External A record you created? it is
servername.rrsystems.co.il and it reffers to my serverexternal ip
Usually servername.rrsystems.co.il
but it could be anything.rrsystems.co.il
and was it the same as the certificate you created. -on my certificate
i can see : Issued to:SBS-2003 isssued by:rrsystems
(Hopefully the same name)

is there something that is not configured right?
about this lines :
Attempting to resolve the host name rrsystems.co.il in DNS.

> Host successfully resolved
> Additional Details
> IP(s) returned: 212.179.114.51
the 212.179.114.51 ip is not my server external ip (that i'm using
while trying to sync my iphone to my exhange ) .
maybe i have a problem with my A records? or DNS ?
(when i do nslookup to my servername i get a diffrent ip )

thanks again for all your help
ok103


--
ok103
------------------------------------------------------------------------
ok103's Profile: http://forums.techarena.in/members/167717.htm
View this thread: http://forums.techarena.in/small-business-server/1286443.htm

http://forums.techarena.in
 

My Computer

A

Ace Fekay [MCT]

#9
"ok103" <ok103.43wj7g@newsgroup> wrote in message
news:ok103.43wj7g@newsgroup

>
> hey there :
>
> It almost appears that you are using the POP3 connector to your SBS
> -I'm using POP3 connector!
> or using a gateway to filter your emailand i think that my isp is
> filtering my mail.
>
> What is the External A record you created? it is
> servername.rrsystems.co.il and it reffers to my serverexternal ip
> Usually servername.rrsystems.co.il
> but it could be anything.rrsystems.co.il
> and was it the same as the certificate you created. -on my certificate
> i can see : Issued to:SBS-2003 isssued by:rrsystems
> (Hopefully the same name)
>
> is there something that is not configured right?
> about this lines :
> Attempting to resolve the host name rrsystems.co.il in DNS.

>> Host successfully resolved
>> Additional Details
>> IP(s) returned: 212.179.114.51
> the 212.179.114.51 ip is not my server external ip (that i'm using
> while trying to sync my iphone to my exhange ) .
> maybe i have a problem with my A records? or DNS ?
> (when i do nslookup to my servername i get a diffrent ip )
>
> thanks again for all your help
> ok103

Hello ok103,

1. The test indicates that connecting to http://www.rrsystems.co.il/ on port
443 is being shutdown when trying to connect using the Exchange tests. It
appears to indicate that port 443 is open, but there is no Exxhange services
running on it. I went to that site, and it is a web page in a different
language, Hebrew I assume? So that doesn't appear to be your Exchange OWA
IP.

2. What URL do you use to connect to access OWA when you are at home?

3. For the autodiscover record, you can simply create an "A" record called
autodiscover under the rrsystems.co.il public zone name and give it
212.179.114.51, that is IF that IP is your WAN IP.

4. What is your external WAN IP?

And I agree with Russ that techarena is not the best to help you out with
these issues. If you can use a regular news reader to access the Microsoft
SBS group directly, it would be to your benefit.

Ace
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)